Informix error

Hi,

I have Informix 7.71 UC5 installed on SCO Unix. When I try to initialize it
I get the gollowing error. Any idea what it means and how to solve?


mt_shm_remove: WARNING: may not have removed all/correct segments


Thanks,

Vasilis
0
vasilis
9/9/2004 10:21:11 AM
comp.databases.informix 16056 articles. 0 followers. Post Follow

3 Replies
102 Views

Similar Articles

[PageSpeed] 47
On Thu, 09 Sep 2004 06:21:11 -0400, Vasilis Economides wrote:

> Hi,
> 
> I have Informix 7.71 UC5 installed on SCO Unix. When I try to initialize it
> I get the gollowing error. Any idea what it means and how to solve?
> 
> 
> mt_shm_remove: WARNING: may not have removed all/correct segments
> 
> 
> Thanks,
> 
> Vasilis

It means that the engine crashed/exited on startup for some reason (try
adding the -v option to the oninit to see the step that failed) and the
engine was not sure if it successfully removed all shared memory segments
that had already been allocated to that point.  You need to check for
yourself: 'ipcs -a|fgrep informix' to find any left over segments and use
ipcrm to get rid of them.  I assume the version above is a typo and should be
7.31UC5?

Art S. Kagel
0
Art
9/9/2004 1:16:05 PM
On 9 Sep 2004 03:21:11 -0700, vasilis.economides@ctl.com (Vasilis Economides)
wrote:

>Hi,
>
>I have Informix 7.71 UC5 installed on SCO Unix. When I try to initialize it
>I get the gollowing error. Any idea what it means and how to solve?
>
>
>mt_shm_remove: WARNING: may not have removed all/correct segments
>
>
>Thanks,
>
>Vasilis
Did Informix ever run on that system?
If yes than do the following:
If you have startup and stop scripts (in /etc/rc2.d and /etc/rc0.d) then edit
startup script (in /etc/rc2.d) to avoid starting up Informix during system
startup. Then reboot the system and try to start Informix "manually" - like Art
wrote - with:
	oninit -v

Send the messages to the group.

nebojsa
------------------------------------
Remove spam block (DELETE_) to reply
0
Nebojsa
9/9/2004 2:03:03 PM
7.71????

Anyway, your engine hasn't cleaned up tidily

Not familiar with SCO but I think the ipcs command should show you
what is left hanging around.

You can remove the bits that are left using ipcrm

or you can reboot the whole UNIX machine.




vasilis.economides@ctl.com (Vasilis Economides) wrote in message news:<adefb3eb.0409090221.a6d4364@posting.google.com>...
> Hi,
> 
> I have Informix 7.71 UC5 installed on SCO Unix. When I try to initialize it
> I get the gollowing error. Any idea what it means and how to solve?
> 
> 
> mt_shm_remove: WARNING: may not have removed all/correct segments
> 
> 
> Thanks,
> 
> Vasilis
0
dryburghj
9/9/2004 4:24:27 PM
Reply:
Similar Artilces:

SCO OpenServer 6v
Dear all, I am getting some issues on my new installation of SCO Openserver 6v, and do not know how to repair that. I have this on boot: mount.svr5: not privileged user Failed to mount /system/processor filesystem UX: msmfs mount.svr5: ERROR: permission denied failed to mount /var/tmp filesystem So, I cannot understand what is exactly the problem with permission and where is the problem. Have you guys seem something like this before? Thanks all to help me. Aldren Moraes Sorry guys,=20 The problem was about some permission used before changing the owners of fi= le...

Internal error: 30002
I am writing a vb.net autoprocess using Sybase ASE 12.5.2. Therough the program i am trying to insert certain data into a sybase table through a stored procedure. The problem is when i execute the stored procedure from back end with same values thats getting passed through parameters from the vb.net autoprocess, it gets executed without any error. But through vb.net autoprocess for the same stored procedure execution i get the following error Message "Internal Error: 30002" Source "Sybase.Data.AseClient" StackTrace " at Sybase.Data.AseClient.AseCommand.C...

modprobe error on bootup?
Sure this is a newbie question so i apologise but I'm seeing the following in boot.msg on a Dell PE2300 with a PERC 3/DC running Suse 9.0 with all current updates from YOU. <3>kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2 <6>scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.36 <4> <Adaptec aic7890/91 Ultra2 SCSI adapter> <4> aic7890/91: Ultra2 Wide Channel A, SCSI Id=7, 32/253 SCBs <4> <6>scsi1 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.36 <4> <Adaptec aic7860 Ultra S...

Re: Can't find the Informix 2.81 UC2 CSDK #2
Sorry, Ronald. > > Prpbably, if you get the PA(Pasport Advantage), you can get PA site. > >Passport Advantage only had UC1 as of yesterday. How about contact your IBM sales ? Actualy, Japanese customer uses 2.81.UC2. Regards. -- Tsutomu Ogiwara from Tokyo Japan. ICQ#:168106592 _________________________________________________________________ Protect your PC - get McAfee.com VirusScan Online http://clinic.mcafee.com/clinic/ibuy/campaign.asp?cid=3963 sending to informix-list ...

Automatic Error Cancel
Hi I am in the process of writing an application to be used on an un-attended machine. However I remember a utility which allowed RISC OS to 'click ok' on any errors. Can anyone remember what this was / know where to get it. Cheers in advance Michael In message of 20 Jan, Michaek Emerton <MichaelREmerton@hotmial.com> wrote: > I am in the process of writing an application to be used on an > un-attended machine. > > However I remember a utility which allowed RISC OS to 'click ok' on > any errors. > > Can anyone remember what this was / know ...

Why did PHP remove Informix support?
I just installed 5.2.4 and found that the developers have removed Informix support! Informix and PHP are great stuff. Why pull something that works fine? http://us.php.net/manual/en/ref.ifx.php >From devzone: In other CVS news, Tony moved ext/informix out of the core in PHP_5_2 branch and CVS HEAD. The extension now resides in PECL CVS, but has no maintainer at the time of writing. The actively maintained pecl/ pdo_informix extension should be used in new code. On Wed, 19 Sep 2007 12:46:03 -0700, gquiring@gmail.com wrote: > I just installed 5.2.4 and found that the developers have...

Why do I have this error message?
I am using eclipse to compile a java application.It works fine if I right click the class that contains main. But If I run it in dos window, I get this error message,Exception in Thread "main" java.lang.NoClassDefFoundError:I had this error message a few days ago, then I fixed it, and then I havn't gone back to command line util today I finished everything and it works fine if I just right click and Run As..Java application.When finally I returned to command prompt, the error message came back.I tried previous version of my application and the same error message. It doesn't s...

IMAQ Find Circles Error
An exception occrred within the extermal code called by a Call Library Function Node. This might have corrupted LabVIEW's memory. Save any work to a new location and restart LabVIEW. VI "eyes track.vi" was stopped at node 0x0 of subVI "IMAQ Find Circles". &nbsp; This my error. I don't how to answer it ,please help me. Thanks. Hi hddblue, &nbsp; What's your error code and error message? Can you please use printscreen to copy your screen when error occur and&nbsp;attach&nbsp;it? I believe it will be helpful for us to check what's wrong in your...

Error with any output procedures ???
Hi !!! I recently ungraded my SAS from ver 8.2 to 9.1. Now for any output procedure that i run i am getting the following error. Is this due to the 9.1 upgrade. Any clues of how to fix this. I tried to compare my outputs. However, there seems to be no error in the output. Please advise. ERROR: Expecting page 3, got page -1 instead. ERROR: Page validation error while reading WORK._tf0002.ITEMSTOR. ERROR: File WORK._tf0002.ITEMSTOR is damaged. I/O processing did not complete. Thanks, Take a look at: http://listserv.uga.edu/cgi-bin/wa?A2=ind0509b&L=sas-l&D=0&P=47692 Art ------...

IMAGE DataBase Error (FSERR 72)
Today, when I used Query to access a database, I received the following error message, which I've never seen before : CANNOT ATTACH ROOT FILE TO MPE XL XM : FILE SYSTEM ERROR 72 Here's the Query and surprisingly, I can still get info via Dbutil. Any suggestions, as always, are GREATLY appreciated.... XL:query HP32216N.03.18 QUERY/NM THU, NOV 18, 2004, 7:08 PM COPYRIGHT HEWLETT-PACKARD CO. 1976 >xeq qdefver.data DEFINE DATA-BASE = VERDB.IMAGE PASSWORD = ********** MODE = 5 TurboIMAGE Error Message: CANNOT ATTACH ROOT FILE TO MPE XL XM : FILE SYSTEM ERROR 72...

Error recovery
Hi, when I wrote a method skipto(int tokenKind) that skip all tokens until finding a token of the kind that I asked for. Very well, but what can I do if I want to get it in my parsing anyway ? In fact is it possible go back with the tokenmanager ? Kupee wrote: > Hi, when I wrote a method skipto(int tokenKind) > that skip all tokens until finding a token of the kind > that I asked for. > Very well, but what can I do if I want to get it > in my parsing anyway ? > In fact is it possible go back with the tokenmanager ? Hi Kupee I hope I understood your question...

Almost there...but I have an error!
I know I have posted similar programs before, but I took the while loop out of digital.vi and made a couple other changes. When I run voltagecontrol.vi, and press the stop button to move beyond the while loop,&nbsp;an erro pops up and it tells me that I need to either increase the amount of time before it times out or increase the sampling rate. The error occurs at the DAQmx Write.vi in digital.vi. I tried using the timing control in DAQmx, but it wasn't working (as well as trying a number of other things to fix the problem. After the error occurs, I press continue, and what I want to ...

Informix Rocks
http://www.informixcity.com/downloads/Informix%20case%20study%20SWC10011-DEEN-00.pdf IDS 11 delivers!!!!! ...

Error when trying to open AVI video
I wrote a few lines of code that read an AVI video. It works on some AVIs but not on others and I don't know why. In both instances number of frames is always a large #, so they're there, they just aren't being read. Code: mmrx = mmreader('movie.avi', 'tag', 'mrxx'); numframes = get(mmrx, 'NumberOfFrames'); vrxx = read(mmrx, [1 10]]; For the problem file, the error I get is numframes = 1196718 Warning: The end of file was reached before the requested frames were read completely. Frames 1 through 1 were returned. Why is this happening, when it se...

NIS passwd error
I have NIS running on Solaris 8 and when I run "passwd -r nis -e <user>" on the NIS master to change a user's shell, I get "permission denied" (even though I'm root). Does anyone know why? I can accomplish the same thing by changing the user's shell in /var/yp/etc/passwd and then running "cd /var/yp; make passwd" but I'm curious why the first method is not working. In article <4G_Pb.17464$cQ6.700334@news20.bellglobal.com>, "gusmeister" <gusmeister_NOSPAM_@sympatico.ca> wrote: > I have NIS running on Solaris 8 ...

%s_i_mc error message
Hi, When running a function i recieve this error message: undefined variable : %s_i_mc when assigning a value to an object: cheat.Sv=Sv I put a pause command immediately before this line and then copy and paste it (and all the other lines from then on in the function) to Scilab's command line and it evaluates everything as it should. I'm terribly confused. Can anyone shed any light on what %s_i_mc means? Mike Dewar help overloading HTH Francois ...

xBScript error
Hi to all, I have the following error, using xBScript. This error is obtain at IE, when running test.asp: >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>> HTTP 500.100. Error interno del servidor: error de ASP Servicios de Internet Information Server ----------------------------------------------------------------------------= ---- Informaci=F3n t=E9cnica (para personal de soporte t=E9cnico) Tipo de error: dbU...

Errpt error
Hi!! I am having a problem with errpt command, when executed it throws an error:- logread: unexpected end of file Unable to process the error log file /var/adm/ras/errlog. The supplied error log file is not valid: /var/adm/ras/errlog. I cleared the error log file, two days back with "errclear 0" Now interesting thing is, the size of /var/adm/ras/errlog right now is zero while it is mentioned in manual pages of errclear that Note: The errclear command clears the specified entries, but does not decrease the error log file size. Now I dont know what to do.... Any suggestions?????...

Compiler error during logfile creation.
Sir/mam, i am trying to make logfile using mpich2's mpicc binary as given below. mpicc -mpilog -profile=temp -o sim sim.c temp is my profiling library. This commands gives following error. cc1: error: Unrecognized command line option "-mpilog". And its not getting compiled. Please help me out. I want clog2 files for jumpshot to trace my code. Thank you. In article <388ff992-d840-477c-945c-9386d9131383@g20g2000prb.googlegroups.com>, Panny <pranavkulkarni30@gmail.com> wrote: > Sir/mam, > i am trying to make logfile using mpich2's mpicc binary as given >...

Weird access error: Access/OLE/Active-X communication
Hi! I have a problem with an access database. The database which I designed and made using MS access works perfectly OK on my computer however it is not working at all on computers for which it was done :) When the client tries to open first form the access shows information about error connected to the communication between Access and OLE or Active-X control. The problem is that I cannot go to the client's computer and test it because the client is rather far away.. I don't know if that's important but it may be - I am using polish version of access (tested on english vers...

proc CALIS error
Dear SAS-listers, I am trying to use a path analysis approach to study the relationship between previous breeding success, site fidelity and mate fidelity. The dataset includes a list of individuals which bred in two consecutive years. The structure is as follows: ID BreedSuc(0/1) SameSite(0/1) SameMate(0/1) And I would like to compare the following models: 1. Breeding success is exogenous, leading to site and mate fidelity; 2. both breeding success and site fidelity are exogenous and lead to mate fidelity. For model 1, I use SAS code: proc calis data=fidelity cov corr residual; v...

On Informix Virtual Segments
Can anyone help shedding some light on the following issue. Informix IBM tech is saying one thing while IBM AIX tech contradicts its counterpart. I have one IDS instance on AIX 5.2 and the Informix ver is 7.31.UD7 , 32bit SHMVIRTSISE set to 1100000 SHMADD set to 100000 BUFFERS set to 200000 SHMTOTAL set to 0 Physical Memory of Box is 8GB The total instance size is about 2GB or 1.94GB (1944016) One day the instance try to add segments to support the workload. It added one successfully and about 1 hour later it hung and finally went down while trying to add another ...

[OdbcException: ERROR [HY000] [Informix][Informix ODBC Driver][Informix]Transaction not available.]
I 've connected to informix database. i want to begin an odbc transaction in my C# code. then the error occured. ERROR [HY000] [Informix][Informix ODBC Driver][Informix]Transaction not available. pls help me, How can i solve this problem? is it needed to especial setting in the informix db? thanks alot, for the problem, i set the informix : no log--> log and the problem 's solved. Mahta On 31 Dec 2006 23:05:58 -0800, Mahta <mahbahj@gmail.com> wrote: > I 've connected to informix database. i want to begin an odbc > transaction in my C# code. t...

Special Informix Day on May 16 in The Hague
This is a multi-part message in MIME format. ------_=_NextPart_001_01C674E3.871104F9 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: quoted-printable I subscribed for this event, but yesterday I got a mail that this day is cancelled because of the low number of enrolments. Is no one of the European users is interested in this event? http://www-304.ibm.com/jct03001c/services/learning/ites.wss/xx/en?pageTy pe=3Dpage&c=3Da0009740 ------_=_NextPart_001_01C674E3.871104F9 Content-Type: text/html; charset="us-ascii" Content-Transf...

Epson C2000 Error Messages
Hi all, anyone know what the service message error code C1700 refers to on my Epson C2000 Aculaser please? Seems very difficult to locate any list of codes on the web ...