f



"Method 'Controls' of ojbect 'CommandBarPopup' failed" ?

I get this error every so often.  Some bogus error number (such as
-2147467259), too.

Google searches imply that it can be caused by manually
adding/deleting menu items on the fly, but it happens to me when a
modal form is active and a timer function fires.  Some of the code it
runs (not sure what exactly) breaks it.  Part of the menus are then
hosed (i.e., you click and it doesn't "drop down", even if there are
items in there).

The only "solution" I've found is to resort to a backup and re-code
everything since that point.

Can anyone help me find a better solution than this?
0
none77 (68)
11/7/2003 6:55:36 PM
comp.databases.ms-access 42670 articles. 0 followers. Post Follow

1 Replies
818 Views

Similar Articles

[PageSpeed] 54

It might help to see the relevant code.

"Jon" <None@hotmail.com> wrote in message
news:kbqnqv0d8g7spes9f839vb9nkb4ipf6jlh@4ax.com...
> I get this error every so often.  Some bogus error number (such as
> -2147467259), too.
>
> Google searches imply that it can be caused by manually
> adding/deleting menu items on the fly, but it happens to me when a
> modal form is active and a timer function fires.  Some of the code it
> runs (not sure what exactly) breaks it.  Part of the menus are then
> hosed (i.e., you click and it doesn't "drop down", even if there are
> items in there).
>
> The only "solution" I've found is to resort to a backup and re-code
> everything since that point.
>
> Can anyone help me find a better solution than this?


0
macdermott1 (571)
11/8/2003 2:05:23 AM
Reply:

Similar Artilces:

ERROR: "Method 'Connection' of object '_Current Project' failed."
I have created a front-end application and back-end database. Everytime that I opened the program in the past, it open just fine with no errors when linking to the back-end tables. lately, I get the following error message whenever I open my application: ERROR: "Method 'Connection' of object '_Current Project' failed. Check to see if you installed the tables used for storing data is in the default directory. -2147024769 After clicking, "OK", my application continues on to open anyway. I have checked the application to determine if the intended location for the link tables where in view and relinked them to be sure. Each of the forms continue to show data from the backend. But, I continue to get the above error message. Any clues? John ...

'quote' to `quote'
Hi, what is the way to change 'shocking,' said Sally into `shocking', said Sally automatically as Tex read the author.txt file? Does this method also change "whatever happens," he said into ``whatever happens.'' he said. David R David R <angel_ov_north@tiscali.co.uk> wrote: > what is the way to change 'shocking,' said Sally > into `shocking', said Sally > automatically as Tex read the > author.txt file? It is possible (e.g. via an active '). But I suspect, this is a lot easier using a script language or similar. Also you should consider ['s] coming from genitive and other uses of the apostrophe. Yours sincerely Heiko <oberdiek@uni-freiburg.de> David R wrote: > what is the way to change 'shocking,' said Sally > into `shocking', said Sally > automatically as Tex read the > author.txt file? Tricky thing to do on the TeX level because you can't tell a quote from an apostrophe in a reliable and efficient way. This will probably require pre-processing of author.txt (it's no big deal with regular expressions). > Does this method also change "whatever happens," he said > into ``whatever happens.'' he said. Assuming you're using Latex: try the csquotes package. See \MakeOuterQuote{"} in the tutorial. -- Sender address blackholed; do not reply to From: address. You can still reach me by email at: plehman gmx net. On Wed, 10 Ja...

ERROR: "Method 'Connection' of object '_Current Project' failed. -2147024769"
I have created a front-end application and back-end database. I have code that automatically links the front-end application to the back-end database for whenever I provide a patch or upgrade. Everytime that I opened the program in the past using either Access 2002 and 2003, it open just fine with no errors when linking to the back-end tables. Lately, I get the following error message whenever I open my application: ERROR: "Method 'Connection' of object '_Current Project' failed. Check to see if you installed the tables used for storing data is in the default directory. -2147024769" After clicking, "OK", my application continues to open and re-links to the back-end tables anyway. Yes, all the data displays in the application front-end data fields. I removed all the links to the back-end tables; re-imported the back-end tables; same problem. This was then followed by with creating a new application re-combining the front and back-ends (no problems occurred in loading and using the application) and preceded to re-split the application again. I continue to receive the above error. I went to backups and earlier versions of my application, up to 12 months, and now, they give out the same above error message. Could this be an Access problem? Any ideas on what is going on? John I've seen this problem when there are hidden table objects confusing my re-linker. Have the re-linker print out the name of each table as it loops, a...

ERROR: "Method 'Connection' of object '_Current Project' failed. -2147024769"
Continue to get error message. Here is an update of my problem and everything that I have done to correct it. I have created a front-end application and back-end database. I have code that automatically links the front-end application to the back-end database for whenever I provide a patch or upgrade. Everytime that I opened the program in the past using either Access 2002 and 2003, it open just fine with no errors when linking to the back-end tables. Lately, I get the following error message whenever I open my application: ERROR: "Method 'Connection' of object '_Current Project' failed. Check to see if you installed the tables used for storing data is in the default directory. -2147024769" After clicking, "OK", my application continues to open and re-links to the back-end tables anyway. Yes, all the data displays in the application front-end data fields. I removed all the links to the back-end tables; re-imported the back-end tables; same problem. This was then followed by with creating a new application re-combining the front and back-ends (no problems occurred in loading and using the application) and preceded to re-split the application again. I continue to receive the above error. I went to backups and earlier versions of my application, up to 12 months, and now, they give out the same above error message. Could this be an Access problem? John John Phelan wrote: > Continue to get error message. > > Here is an update...

'is not' or '!='
A newbie question to you; what is the difference between statements like: if x is not None: and if x != None: Without any context, which one should be preferred? IMHO, the latter is more readable. On 2014-08-18 21:35, ElChino wrote: > A newbie question to you; what is the difference between statements > like: > if x is not None: > and > if x != None: > > Without any context, which one should be preferred? > IMHO, the latter is more readable. > "x == y" tells you whether x and y refer to objects that are equal. "x is y" tells you whether x and y actually refer to the same object. In the case of singletons like None (there's only one None object), it's better to use "is". "ElChino" <elchino@cnn.cn>: > A newbie question to you; what is the difference between statements > like: > if x is not None: > and > if x != None: Do the following: take two $10 bills. Hold one bill in the left hand, hold the other bill in the right hand. Now, the bill in the left hand "is not" the bill in the right hand. However, the bill in the left hand "==" the bill in the right hand. > Without any context, which one should be preferred? > IMHO, the latter is more readable. In almost all cases, both tests would result in the same behavior. However, the "is not" test is conceptually the correct one since you want...

'^=' and '~='?
Hello, What is the difference between '^=' and '~='? Thanks, Duckhye ...

VB6 & Jet 4 & MDAC 2.7 RTM challenge
VB6 & Jet 4 & MDAC 2.7 RTM challenge - "Method '~' of object '~' failed" I've spent more than three full days trying to get a VB6 program to talk to my Access 2002 database, and gives error -2147024769 while refusing to connect to the local database. The program works on a development machine and used to also work on a WinXP clean install. However, now, it won't work no matter what I do even though the program is unchanged. In an attempt to solve this problem, I created versions using different MDACs using Microsoft's Visual Studio 6 deploymen...

VB6 & Jet 4 & MDAC 2.7 RTM challenge
VB6 & Jet 4 & MDAC 2.7 RTM challenge - "Method '~' of object '~' failed" I've spent more than three full days trying to get a VB6 program to talk to my Access 2002 database, and gives error -2147024769 while refusing to connect to the local database. The program works on a development machine and used to also work on a WinXP clean install. However, now, it won't work no matter what I do even though the program is unchanged. In an attempt to solve this problem, I created versions using different MDACs using Microsoft's Visual Studio ...

Unable to identify an operator '*=' for types 'character varying[]' and '"unknown"'
Okay.I'm following the documentation that came with the PostgreSQL source code (located in /usr/doc/postgresql-7.3.4-2/html/arrays.hmtl in my cygwin root). I created have a table with a varchar array in it, kind of like the following: CREATE TABLE tbl_db_usuario_detalles (NOMBRE varchar(50), COD_USE varchar(6)[]); I've added a single record that has two values. It is imported from a tab-separated text file that has one line, like the following: Username {xxxxxx,yyyyyy} The import seems to work fine (if I put quotes around the string values in the array it fails). ...

Quotes from the 'tolerant', 'liberal', 'progressive' Left
"I hope his wife feeds him lots of eggs and butter and he dies early like many black men do, of heart disease. ... He is an absolutely reprehensible person." --USA Today Columnist Julianne Malveaux on Justice Clarence Thomas "If there is...justice, he'll get AIDS, or one of his grandchildren will get it." --National Public Radio's (NPR) Nina Totenberg on Sen. Jesse Helms "[I]t may take the destruction of Western Civilization to allow the rest of the world to really emerge as a free and brotherly society." --Newly elected president of that hot-bed of co...

ERROR: "Method 'Connection' of object '_Current Project' failed.
I have created a front-end application and back-end database. Everytime that I opened the program in the past, it open just fine with no errors when linking to the back-end tables. Lately, I get the following error message whenever I open my application: ERROR: "Method 'Connection' of object '_Current Project' failed. Check to see if you installed the tables used for storing data is in the default directory. -2147024769 After clicking, "OK", my application continues on to open anyway. I have checked the application to determine if the intended location for the link tables where in view and relinked them to be sure. Each of the forms continue to show data from the backend. But, I continue to get the above error message. Any clues? John *** Sent via Devdex http://www.devdex.com *** Don't just participate in USENET...get rewarded for it! ...

Re: Unable to identify an operator '*=' for types 'character varying[]' and '"unknown"'
Okay...I answered my own question. I didn't understand from the directions that I had to compile and install the dll in contrib/array and run the array_iterator.sql. It works like a charm now. Mike -----Original Message----- From: Mike Leahy [mailto:mgleahy@fes.uwaterloo.ca] Sent: October 10, 2003 3:41 PM To: 'pgsql-general@postgresql.org' Subject: Unable to identify an operator '*=' for types 'character varying[]' and '"unknown"' Okay.I'm following the documentation that came with the PostgreSQL source code (located in /u...

'''''''''''''The Running Update/Append Queries Using VBA code Ordeal''''''''''''''
Hello fellow programmers, I am trying to run an append/update query from code, a command button on a form initiates the queries. the format i am using is; _____________________________________________________ SELECT "criteria" FROM "criteria" WHERE "criteria" UPDATE/APPEND "field selections" RecordSource "qryExample" = above text strings" _______________________________________________________________________ When i am running a SELECT query in this manner it works fine with no problems, and accepts the values of specified linked form fields. This never works when doing an APPEND/UPDATE query. It can never find the values of linked form fields, Access always asks for the parameter value of the field(s) in question, or Access comes up with an error 3323 - No recordset. I am sure there are other people that have had this problem. What is the difference between Select queries and append/update queries? the append/update queries never seem to be able to find values in linked form fields. Can anyone shed any light on this or point to a knowledgebase Item, or even recommend a book focusing on this subject, I will go and buy it now. I have been for up 2 nights trying to acomplish this and now considering suicide, please help. Thanks In advance, Aaron. I know of two ways you can accomplish this. 1. You can create the SQL script for you append or update query and run the script with DoCmd.RunSQL. 2. You can create a...

"cannot convert parameter from 'short **' to 'void **'"
int func(void**); { short* p = NULL; func(&p); //<<< here } Could somebody remind me why is this not allowed ? error message: "cannot convert parameter from 'short **' to 'void **'" Thanks, Igor On 2005-11-22, Igor Okulist <igor@remove_this_okulist.com> wrote: > int func(void**); > > { > short* p = NULL; > func(&p); //<<< here > } > > Could somebody remind me why is this not allowed ? error > message: "cannot convert parameter from 'short **' to 'void > **'" ...

expect script : "expect 'X', send 'Y'" until expect "Z".
Hi. I am having some difficulties with an expect script, and was hoping someone could help me out here. I am running a scripted telnet session to some 'black box' appliance, and would like to retrieve the output of a particular command. However, the output of the command is longer than a single screen full. Since it was designed for interactive use, you get the magic string "[=More (xx%)=]" after each screenfull of output, at which point the command expects you to hit the spacebar in order to get another screenfull of output. Of course, I could just "send <space>" a few times, but since I have no idea how long the output will be in advance, this does not appear to be such a good approach. It looks like I would have to do something were I keep sending a space as long as I keep getting/expecting the string "[=More (xx%)=]", and stop doing that after I have gotten/expected the prompt again. (which is "% "). Does anyone have any idea on how to do such a thing in expect ? Of course, other suggestions to tackle the same problem are welcome as well of course. Sincerely, John Smith. "J.Smith" <lbalbalba@hotmail.com> wrote in message news:737da4e2.0410200305.1f12696f@posting.google.com... > Hi. > > > I am having some difficulties with an expect script, and was hoping > someone could help me out here. > > > I am running a scripted telnet session to some 'black box' applianc...

Re: Mandis Quotes (aka retiring """ and ''')
Russell Nelson wrote: > If you need to put a single quote in, then you put > an arbitrary string in-between the single quotes which does NOT > appear in the string. For example, "Bill's house" becomes > 'x'Bill's house'x'. So possible examples might be: 'xx'somebody's mother'xx' 'xy'somebody's father'xy' 'wink'somebody's uncle'wink' 'quote'somebody's body'quote' not terrible easy on the eyes, and why use the single quote at all? Why no= t use a similar pattern li...

'''''''''''''The Running Update/Append Queries Using VBA code Ordeal'''''''''''''' #2
Hi, Thanks for ur help there HJ. I know how to do the tasks you specified there. I would like for the update query to use field values from some of the fields on the form (frmInvoices) such as InvoiceNumber, DateFrom, DateTo. My problem is that an append/update query can't find the values in the open Form (frmInvoices) when I specify them as; [Forms]![frmInvoices]![InvoiceNumber] a select query has no problem finding the field values on a form. please help. Aaron Hi Aaron, Could you post the entire code that you are having trouble with? Now it is not possible to see what goes wrong. HJ "Aaron" <aaron@rapid-motion.co.uk> wrote in message news:260d7f40.0408120245.2f3d01f8@posting.google.com... > Hi, > > Thanks for ur help there HJ. > > I know how to do the tasks you specified there. > > I would like for the update query to use field values from some of the > fields on the form (frmInvoices) such as InvoiceNumber, DateFrom, > DateTo. My problem is that an append/update query can't find the > values in the open Form (frmInvoices) when I specify them as; > > [Forms]![frmInvoices]![InvoiceNumber] > > a select query has no problem finding the field values on a form. > > please help. > > Aaron First off, if you are not always using all the parameters specified in your form, then you have to add parameters to your query on the fly. Also, you can't just do something like qdf.SQL = "SE...

if str_mo not in ('','.') and str_da not in ('','.') and str_yy not in ('','.') Any shorter ?
Hi, there. =20 I'm just curious if it ever dawned on anybody how to abbreviate this line : if str_mo not in ('','.') and str_da not in ('','.') and str_yy not in ('','.')=20 =20 Igor Kurbeko Clinical Programmer Analyst 678 336 4328 ikurbeko@atherogenics.com =20 no brain no pain =20 how about: if not (str_mo in ('','.') or str_da in ('','.') or str_yy in ('','.')) OR if not (missing(str_mo) or missing(str_da) or missing(str_yy)) Eric On 22 Oct 03 21:13:37 GMT, ikurbeko@ATHER...

MNRFIT Error "Undefined function or method 'mnrfit' for input arguments of type 'double'"
My data looks like this: Y=[4;4;5;13.....]; (n by 1) X= 1.3 6.9 2.0 3.2 4.2 6.9048 ..... (n by 2) when i used: [B,dev,stats]=mnrfit(x,y,'interactions','off'); The error message appeared : ??? Undefined function or method 'mnrfit' for input arguments of type 'double'. What caused that problem? Also, shall I convert the y into a format of 1,2,3,4,...k, rather than the code number originally assigned for each choice (starting from 4, to 500+. with irregular numbering) Thanks! "Yiyi Wang" <yiyiwang@mail.ute...

fminsearch error: "Undefined function or method 'L' for input arguments of type 'double'"
Hi, I am trying to minimizing the function 'L' below but I keep getting the error: ?? Undefined function or method 'L' for input arguments of type 'double' My code is the following: ---------------------------------------------------------------- %seastate = 2000 x 1 vector %pings = 2000 x 1 vector %entang = 2000 x 1 vector x0 = [-1.5 0.3 -0.1 0.001]; %my initial parameters exponent = @(x0) x0(1) + x0(2).*seastate + x0(3).*pings + x0(4).*pings.^2; pi = @(x0) exp(exponent)./(1 + exp(exponent); oneminuspi = @(x0) 1 - pi(x0); L = @(x0) -1*log(prod(pi(x0).^(entang).*(oneminuspi(x0)).^(1- entang))); params = fminsearch('L', x0) ------------------------------------------------------------------ Can anyone help me? Thanks "Marlene" <brito.nen@gmail.com> wrote in message news:7efd7b9b-f704-49dd-867f-7f413953fb54@i39g2000prd.googlegroups.com... > Hi, > > I am trying to minimizing the function 'L' below but I keep getting > the error: > > ?? Undefined function or method 'L' for input arguments of type > 'double' > > My code is the following: > ---------------------------------------------------------------- > %seastate = 2000 x 1 vector > %pings = 2000 x 1 vector > %entang = 2000 x 1 vector > > x0 = [-1.5 0.3 -0.1 0.001]; %my initial parameters > > exponent = @(x0) x0(1) + x0(2).*seastate + x0(3).*pin...

ABF "error: expected identifier or '(' before '=' token"
When trying to compile an ABF application on a Red Hat Enterprise Linux Server release 5.4,Intel(R) Xeon(R) and II 9.1.2 (int.lnx/ 100)NPTL, I get the following errors : "Processing form 'ylxo60701p' . . . Forcing compilation to create object file. Compiling '218688.c' . . . 218688.c:1420: error: expected identifier or '(' before '=' token E_AB001E Compilation failed" I've found out that the form in question (218688.c) is missing the global FRAME identifier here : FRAME * = { &_form0 }; which should be replaced wi...

Re: Mandis Quotes (aka retiring """ and ''') #2
Russell Nelson notes: > = > Choose poor examples, and then criticize them as poor choices? > = true enough, but the suggested scheme introduces another variable into the = language syntax; I might always make good choices <wink> on what delimiter = I choose, but I might also end up working on code written by someone else w= ho makes less good choices. Or vice versa. = > Exactly. It really would be better to have one(1) string literal > which can quote anything without reverting to backslashing. Why one? > Simpler parsing, simpler learning of the language, fewe...

A function with 'and' , 'not' , 'null' , 'car' and 'cdr'
What's this ? (defun enigma (x) (and (not (null x)) (or (null (car x)) (enigma (cdr x))))) "I suppose I should learn Lisp, but it seems so foreign." - Paul Graham, Nov 1983 On Wed, Oct 07 2015, CAI GENGYANG wrote: > What's this ? > > > (defun enigma (x) > (and (not (null x)) > (or (null (car x)) > (enigma (cdr x))))) Bad taste? It returns T if the list X contains nil as an element. It would be clearer to write (some #'null x). Helmut CAI GENGYANG ...

error: expected '=', ',', ';', 'asm' or '__attrib
Hi I'm trying to compile an ADC Driver & come acrosss the following error. I've no experience writing drivers before, and hence have no clue how to fix it. Hope someone out there has encountered the problem & suggesst a fix for the same. The Error is I get is : qadc.c: At top level: qadc.c:97: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'qadc_read' make: *** [qadc.o] Error 1 [root@localhost qadc]# ########################################################################### ADC Driver Code ########################################################################### #define MODULE #define __KERNEL__ #include <linux/config.h> #include <linux/module.h> #include <linux/kernel.h> /* printk */ #include <linux/fs.h> / #include <linux/errno.h> /* error codes */ #include <linux/types.h> /* size_t */ #include <linux/proc_fs.h> /* proc file system */ #include <linux/fcntl.h> #include <asm/system.h> /* cli, flags */ #include <asm/uaccess.h> /* copy from/to user */ /*Registers to get qadc access*/ volatile unsigned short * qadcmcr = (unsigned short *)0x40190000; volatile unsigned short * qacr0 = (unsigned short *)0x4019000a; volatile unsigned short * qacr1 = (unsigned short *)0x4019000c; volatile unsigned short * qacr2 = (unsigned short *)0x4019000e; volatile unsigned short * qasr0 = (unsigned short *)0x40190010; volatile unsigned short * qasr1...

Web resources about - "Method 'Controls' of ojbect 'CommandBarPopup' failed" ? - comp.databases.ms-access

Resources last updated: 3/21/2016 9:07:18 PM