f



Total row problem

Access 2013.  I have a main form with a datasheet subform.  In the subform,=
 I added a Totals row (an Access built in option).  3 columns have a calcul=
ation.  2 are a sum of values, the 3rd a count of records. =20

I display records based on selecting a value from a combo box.  The values/=
recordset change fine in the subform.  The issues is sometimes all 3 calcs =
display, I move to another recordset and 2 calcs display, move again, only =
1 calc displays, move again and all calcs display.  Any idea why the total =
calcs don't display all the time in my subform?
0
Patrick
12/6/2016 10:07:17 PM
comp.databases.ms-access 42670 articles. 0 followers. Post Follow

3 Replies
437 Views

Similar Articles

[PageSpeed] 6

On Tuesday, December 6, 2016 at 5:07:20 PM UTC-5, Patrick Finucane wrote:
> Access 2013.  I have a main form with a datasheet subform.  In the subfor=
m, I added a Totals row (an Access built in option).  3 columns have a calc=
ulation.  2 are a sum of values, the 3rd a count of records. =20
>=20
> I display records based on selecting a value from a combo box.  The value=
s/recordset change fine in the subform.  The issues is sometimes all 3 calc=
s display, I move to another recordset and 2 calcs display, move again, onl=
y 1 calc displays, move again and all calcs display.  Any idea why the tota=
l calcs don't display all the time in my subform?

What's odd is that if I click on the column that has the hidden values they=
 appear.  Not sure why the values aren't visible all the time.
0
Patrick
12/7/2016 2:08:04 PM
On Tuesday, 6 December 2016 22:07:20 UTC, Patrick Finucane  wrote:
> Access 2013.  I have a main form with a datasheet subform.  In the subfor=
m, I added a Totals row (an Access built in option).  3 columns have a calc=
ulation.  2 are a sum of values, the 3rd a count of records. =20
>=20
> I display records based on selecting a value from a combo box.  The value=
s/recordset change fine in the subform.  The issues is sometimes all 3 calc=
s display, I move to another recordset and 2 calcs display, move again, onl=
y 1 calc displays, move again and all calcs display.  Any idea why the tota=
l calcs don't display all the time in my subform?

Hi Patrick.
I am having similar problems.
It looks as if this person is as well. https://bytes.com/topic/access/answe=
rs/967835-i-split-database-now-i-have-sneaky-issue-subform-not-displaying-d=
ata

Phil
0
pstanton54
12/7/2016 11:58:04 PM
On Tuesday, 6 December 2016 22:07:20 UTC, Patrick Finucane  wrote:
> Access 2013.  I have a main form with a datasheet subform.  In the subfor=
m, I added a Totals row (an Access built in option).  3 columns have a calc=
ulation.  2 are a sum of values, the 3rd a count of records. =20
>=20
> I display records based on selecting a value from a combo box.  The value=
s/recordset change fine in the subform.  The issues is sometimes all 3 calc=
s display, I move to another recordset and 2 calcs display, move again, onl=
y 1 calc displays, move again and all calcs display.  Any idea why the tota=
l calcs don't display all the time in my subform?

Have you tried to Requery the subform after the selection in the combo box?

Should be unnecessary but you never know, it may kick the system into life

Jim

0
internet
12/8/2016 2:13:54 PM
Reply: