f



"Ora-01000 maximum open cursors exceeded" after update from 10.2.0.1 to 10.2.0.3

Hi all!

After updating our Database from 10.2.0.1 to 10.2.0.3 I get the error
Ora-01000 in our application (we use the proC precompiler).

When I look at the v$open_cursor, I see the number of cursors
increasing all the time.
In our application we have a lot of select statements and every
statement is a cursor. But the cursor is always closed after the
statement. And we also have a lot of transactions. And after a
rollback the cursors should be closed automatic (am I right?).

It seams that neither a "EXEC SQL CLOSE ..." nor a "rollback" close
the cursors any more!

The parameter session_cached_cursors is 20, the parameter open_cursors
is set to 300.

With 10.2.0.1 we have no problems.
Has anyone an idea whats running wrong? Is there a new parameter?

Thanks in advance

0
martin_p (8)
6/4/2007 6:25:09 AM
comp.databases.oracle.server 22978 articles. 1 followers. Post Follow

6 Replies
871 Views

Similar Articles

[PageSpeed] 35

On Jun 4, 10:25 am, poschma <marti...@utanet.at> wrote:
> Hi all!
>
> After updating our Database from 10.2.0.1 to 10.2.0.3 I get the error
> Ora-01000 in our application (we use the proC precompiler).
>
> When I look at the v$open_cursor, I see the number of cursors
> increasing all the time.
> In our application we have a lot of select statements and every
> statement is a cursor. But the cursor is always closed after the
> statement. And we also have a lot of transactions. And after a
> rollback the cursors should be closed automatic (am I right?).
>
> It seams that neither a "EXEC SQL CLOSE ..." nor a "rollback" close
> the cursors any more!
>
> The parameter session_cached_cursors is 20, the parameter open_cursors
> is set to 300.
>
> With 10.2.0.1 we have no problems.
> Has anyone an idea whats running wrong? Is there a new parameter?
>
> Thanks in advance

Afaik, ROLLBACK doesn't close any cursors, it just rolls back current
transaction (and COMMIT doesn't close cursors either.) Try closing
unneeded cursors explicitly after rollback. Why you started hitting
the issue only after patching I can't say. Maybe there's some
regression in the patchset that causes cursor leakage, but I couldn't
find any similarly looking bugs on MetaLink except your very own forum
post...

Hth,
   Vladimir M. Zakharychev
   N-Networks, makers of Dynamic PSP(tm)
   http://www.dynamicpsp.com

0
6/4/2007 1:14:48 PM
>From my (OCI) experience, closing a cursor doesn't release the cursor.
Releasing the handle of the statement releases the cursor. Though I'm
not %100 sure why you would be seeing the change if you haven't
changed your code.

On Jun 4, 6:14 am, "Vladimir M. Zakharychev"
<vladimir.zakharyc...@gmail.com> wrote:
> On Jun 4, 10:25 am, poschma <marti...@utanet.at> wrote:
>
>
>
>
>
> > Hi all!
>
> > After updating our Database from 10.2.0.1 to 10.2.0.3 I get the error
> > Ora-01000 in our application (we use the proC precompiler).
>
> > When I look at the v$open_cursor, I see the number of cursors
> > increasing all the time.
> > In our application we have a lot of select statements and every
> > statement is a cursor. But the cursor is always closed after the
> > statement. And we also have a lot of transactions. And after a
> > rollback the cursors should be closed automatic (am I right?).
>
> > It seams that neither a "EXEC SQL CLOSE ..." nor a "rollback" close
> > the cursors any more!
>
> > The parameter session_cached_cursors is 20, the parameter open_cursors
> > is set to 300.
>
> > With 10.2.0.1 we have no problems.
> > Has anyone an idea whats running wrong? Is there a new parameter?
>
> > Thanks in advance
>
> Afaik, ROLLBACK doesn't close any cursors, it just rolls back current
> transaction (and COMMIT doesn't close cursors either.) Try closing
> unneeded cursors explicitly after rollback. Why you started hitting
> the issue only after patching I can't say. Maybe there's some
> regression in the patchset that causes cursor leakage, but I couldn't
> find any similarly looking bugs on MetaLink except your very own forum
> post...
>
> Hth,
>    Vladimir M. Zakharychev
>    N-Networks, makers of Dynamic PSP(tm)
>    http://www.dynamicpsp.com- Hide quoted text -
>
> - Show quoted text -


0
peter3282 (11)
6/4/2007 5:30:10 PM
On Jun 4, 2:25 am, poschma <marti...@utanet.at> wrote:
> Hi all!
>
> After updating our Database from 10.2.0.1 to 10.2.0.3 I get the error
> Ora-01000 in our application (we use the proC precompiler).
>
> When I look at the v$open_cursor, I see the number of cursors
> increasing all the time.
> In our application we have a lot of select statements and every
> statement is a cursor. But the cursor is always closed after the
> statement. And we also have a lot of transactions. And after a
> rollback the cursors should be closed automatic (am I right?).
>
> It seams that neither a "EXEC SQL CLOSE ..." nor a "rollback" close
> the cursors any more!
>
> The parameter session_cached_cursors is 20, the parameter open_cursors
> is set to 300.
>
> With 10.2.0.1 we have no problems.
> Has anyone an idea whats running wrong? Is there a new parameter?
>
> Thanks in advance

Although it can vary for each application, in general 300 is a very
low value for that parameter.  Lots of places have open_cursors set
between 500 and 1000 or more.

Do some googling around.  I think Tom Kyte recommends considering
setting it to 1000?

Perhaps you were very close to the limit previously in your app and
some minor change in oracle maintenace pushed you over?


0
johnbhurley (2707)
6/4/2007 5:54:00 PM
On Jun 3, 11:25 pm, poschma <marti...@utanet.at> wrote:
> Hi all!
>
> After updating our Database from 10.2.0.1 to 10.2.0.3 I get the error
> Ora-01000 in our application (we use the proC precompiler).
>
> When I look at the v$open_cursor, I see the number of cursors
> increasing all the time.
> In our application we have a lot of select statements and every
> statement is a cursor. But the cursor is always closed after the
> statement. And we also have a lot of transactions. And after a
> rollback the cursors should be closed automatic (am I right?).
>
> It seams that neither a "EXEC SQL CLOSE ..." nor a "rollback" close
> the cursors any more!
>
> The parameter session_cached_cursors is 20, the parameter open_cursors
> is set to 300.
>
> With 10.2.0.1 we have no problems.
> Has anyone an idea whats running wrong? Is there a new parameter?
>
> Thanks in advance

There has been work done on error handling of cursors, for example,
see metalink Note:3091541.8 which references a non-published bug, and
bug 5053820.  Hard to tell what is going on, of course, but I'm
speculating your app has some invalid cursors which were handled
differently before some fix.  Also see Note:2055810.6 , I don't see
how internal changes in cursor handling _wouldn't_ affect this stuff.

If you have the test environments available, you might try running in
both environments and watching the cursors.  Also see Note:296377.1,
it's possible you are running into an optimizer change that
necessitates more child cursors.

Nothing really wrong with setting the cursors way up, anyways.  My
particular environment (cursor-profligate vendor OCI code) runs well
with session_cached_cursors 250, open_cursors 2500.  It's been quite a
while since I've even thought about them.

jg
--
@home.com is bogus.
http://www.informationweek.com/shared/printableArticle.jhtml?articleID=199900170

0
joel-garry (4553)
6/4/2007 6:29:11 PM
I tried to set open_cursors to 30.000 (!). After that our application
runs for 10 minutes befor I got the ora-01000!
I will try the Metalink Note and Bug.

Thanks,
Martin

0
martin_p (8)
6/5/2007 4:42:28 AM
I found the problem ... we used (because of some customers) an Oracle7
precompiler. With the new precompiler the error is gone.

Thanks a lot

0
martin_p (8)
6/5/2007 2:10:08 PM
Reply:

Similar Artilces:

Copy Database From Ora 10.1.0.5 to 10.2.0.2
Hi, We have a database named, say, DB1 running on a Win2003 server with Ora 10.1.0.5. We need to copy DB1 to another server running on Win2003 with Ora 10.2.0.2. (Neither are production databases). I know how to copy the database, recreate the control file, etc.. My question is what subsequent steps I need to take after the database has been copied, the control file created, and the database opened, given that I am copying a database from an Ora 10.1.0.5 server to an Ora 10.2.0.2 one. Thanks, DF copy all db file... datafile, controlfile, redo and upgrade.... (read the manual...) I don't athink you need to recreate controlfile if_investor@yahoo.com ha scritto: > Hi, > > We have a database named, say, DB1 running on a Win2003 server with > Ora 10.1.0.5. > We need to copy DB1 to another server running on Win2003 with Ora > 10.2.0.2. > (Neither are production databases). > > I know how to copy the database, recreate the control file, etc.. > > My question is what subsequent steps I need to take after the database > has been copied, > the control file created, and the database opened, given that I am > copying a database from > an Ora 10.1.0.5 server to an Ora 10.2.0.2 one. > > > > Thanks, > DF "if_investor@yahoo.com" <basis_consultant@hotmail.com> wrote in news:97ca144b-9c19-4cf5-9c07-d5089b0a4954@d1g2000hsg.googlegroups.com: > Hi, > > We have a database named, say, DB1 runn...

New Option Packs after Update from 10.2.0.1 to 10.2.0.2 ???
Hello, i have a little understanding problem how Oracle handles his Patch Sets. First i have installed a Oracle 10.1.0.1 Enterprise Edition Database on my Solaris 9 Sparc Server. Explicitly i have selected only one Option Pack: The Partitioning Option. Then i istalled the actually Patch Set 10.2.0.2. At next i begin create a database. After creation the new database works fine. But when i get a Database-Report in the Enterprise Manager, it says i have installed the following options: * Data Mining * Intermedia * OLAP * Spatial * Text * XML DB The Install overview in the Oracle Installer says, basicly i have installed only the partitioning option. In the Patchset-Installation i can't see what exactly is patched. But from my understanding - Patch sets should only patch installed Programs/Features - not Features where are not installed. Did anyone see the same effects while patching Oracle? What can i do to solve that little problem? Many thanks for helping and solly my bad english. Karl Karl Bach wrote: > Hello, > > i have a little understanding problem how Oracle handles his Patch Sets. > > First i have installed a Oracle 10.1.0.1 Enterprise Edition Database on my > Solaris 9 Sparc Server. Explicitly i have selected only one Option Pack: > The Partitioning Option. > > Then i istalled the actually Patch Set 10.2.0.2. > > At next i begin create a database. After creation the new database works > fine. > But when i get a D...

Problems installing 10.2.0.2 patchset to a 10.2.0.1 database
I am trying to install the latest patchset to my 10gR2 database. When i double click on setup.exe nothing visable happens. The process is launched and according to Windows Task manager is taking up 50% of my CPU. The process just sits there spinning away and nothing happens. I have shutdown, using Service Control Manager, all Oracle services including databases, listeners and DBConsoles Any ideas? <kevin.aide@intergraph.com> schreef in bericht news:1159977988.501508.164590@b28g2000cwb.googlegroups.com... >I am trying to install the latest patchset to my 10gR2 database. When > i double click on setup.exe nothing visable happens. The process is > launched and according to Windows Task manager is taking up 50% of my > CPU. The process just sits there spinning away and nothing happens. > > I have shutdown, using Service Control Manager, all Oracle services > including databases, listeners and DBConsoles > > Any ideas? > Sometimes it helps when you do not use the setup.exe in the root of your installation, but the one in the install directory. Reboot before patching might help too. Has to do with conflicting javaw.exe versions or something like that. You're not on VMWare, are you? Robbert van der Hoorn OSA it BV The Netherlands Robbert, I only have one setup.exe and there is no install directory. At the top level I have a stage directory and three html files and the setup.exe. I am not using VMWare and I have tried reb...

ERROR OUI-10091:Updation from oracle10gR2(10.2.0.1)xe to oracle10gR2(10.2.0.3) in linux 4
Hello everone, I am using patch p53370104_10203_Linux.zip to update my oracle 10gR2(10.2.01) Express Edition into Oracle 10gR2(10.2.0.3). In installation i got the following error: OUI-10091:There are no patches that need to be applied from the patchset Oracle Database 10g Release 2 Patch Set 2 10.2.0.3.0 . And its log file i find : INFO: Unable to read /usr/lib/oracle/xe/app/oracle/product/10.2.0/ server/inventory/ContentsXML/comps.xml. Some inventory information may be lost. INFO: OUI-10070:The patch oracle.ons 10.2.0.3.0, which is part of patch set Oracle Database 10g Release 2 Patch Set 2 10.2.0.3.0 , has not been selected for installation. please help me .. Thanks in Advance! On Aug 6, 8:43=A0am, sagar.maheshw...@daffodilsw.com wrote: > Hello everone, > I am using patch p53370104_10203_Linux.zip to update my oracle > 10gR2(10.2.01) Express Edition into Oracle 10gR2(10.2.0.3). > In installation =A0i got the following error: > OUI-10091:There are no patches that need to be applied from the > patchset Oracle Database 10g Release 2 Patch Set 2 10.2.0.3.0 . > > =A0And its log file i find : > > INFO: Unable to read /usr/lib/oracle/xe/app/oracle/product/10.2.0/ > server/inventory/ContentsXML/comps.xml. Some inventory information may > be lost. > INFO: OUI-10070:The patch oracle.ons 10.2.0.3.0, which is part of > patch set Oracle Database 10g Release 2 Patch Set 2 10.2.0.3.0 , has > not been selected for installation. > =A0pl...

after upgrade 10.2.0.1 to 10.2.0.2
I had 10.2.0.1 RAC installation in Redhat EL4. Everything run fine. I did upgrade from 10.2.0.1 to 10.2.0.2 today. I did clusterware first and RAC second. Both are successful. After that, I run catupgrd.sql in my database. Afterward, my database won't start. If I used srvctl start database -d name, then I got CRS-0215: Could not start resource 'ora.....inst' error. If I use sqlplus, I can do startup mount, but not open. Please help! Happy On Mar 22, 1:32 pm, "Happy" <Haibin.T...@gmail.com> wrote: > I had 10.2.0.1 RAC installation in Redhat EL4. Everything run fine. I > did upgrade from 10.2.0.1 to 10.2.0.2 today. I did clusterware first > and RAC second. Both are successful. After that, I run catupgrd.sql in > my database. Afterward, my database won't start. If I used srvctl > start database -d name, then I got CRS-0215: Could not start resource > 'ora.....inst' error. If I use sqlplus, I can do startup mount, but > not open. Please help! > > Happy You should not have tried to 'upgrade' from 10.2.0.1 to 10.2.0.2 as an upgrade changes the *base* release and you did nothing of the sort. You should have run catpatch.sql, as that is all you accomplished, *patching* your 10.2 database to the latest patch level. I hope you have a backup as you'll need it. David Fitzjarrell On Mar 22, 2:38 pm, "fitzjarr...@cox.net" <fitzjarr...@cox.net> wrote: > On Mar 22, 1:32 pm, "Happy...

Oracle server 9.2.0.1.0, Client 9.2.0.4.0, Red Hat Linux enterprise advanced server 2.1
Hi Everybody, My Database server is running on Red Hat Linux enterprise advanced server 2.1, And my Oracle version is 9.2.0.1.0. My Client mechine also Red Hat Linux enterprise advanced server 2.1 , Oracle client version is 9.2.0.4.0. I am running a web application. Our application is in Magic edeveloper. I connect to Oracle using oracle gateway to my application. My Problem is my application is is becoming slow. I am not able to trace where the problem is. Before our application was running fine. recently i upgraded Oracle client version to 9.2.0.4.0. My Oracle client & server versions are different. I am getting error on my client mechine, it showing all memory address on the screen and the part of error is, arg register addr=83498cc .... Dump of memory from 0x83988c to 0x83499cc .... -- End of Call stack trace -- I am not able to trace where the problem is.Any insight please... Thanks, Ssreddy. ...

Upgrading oracle db 10.1.0.5 to 10.2.0.2 java issues
Hi all, We are upgrading our oracle database from 10.1.0.5 to 10.2.0.2. has anyone had previous experience with this that they can point out potential pitfalls? I am talking more on the java side than actually the installation. We have a java system talking to the oracle database. One system is using hibernate, the other is using a DAO pattern with direct JDBC calls. Does anyone know if this change will effect the application and what changes we must do to accomadate? For example I know that oracle 10.2.0.2 has a different timestamp (oracle.timestamp) than that of it predecesor (sql.timestam...

how to "(1-3*x^2)/(1-3*x+x^2+2*x^3) => 1/(1-2*x) + x/(1-x-x^2)"?
hi normal(1/(1-2*x) + x/ (1-x-x^2),expanded); 1/(1-2*x) + x/(1-x-x^2) => (1-3*x^2)/(1-3*x+x^2+2*x^3) how to do the reverse? dillogimp@gmail.com writes: > normal(1/(1-2*x) + x/ (1-x-x^2),expanded); > 1/(1-2*x) + x/(1-x-x^2) => (1-3*x^2)/(1-3*x+x^2+2*x^3) > how to do the reverse? convert(%,parfrac,x); -- Joe Riel ...

Upgrading to 10.2.0.4 from 10.2.0.3
My Oracle Database Server is running 10.2.0.3.0. I would like to upgrade to 10.2.0.4.x When I check metalink the patch sets for 10.2.0.4 says it must be applied to a database already running 10.2.0.4. Am I reading this correctly? Which patch set do I use? On Nov 6, 3:41=A0pm, jhavero <jhav...@gmail.com> wrote: > My Oracle Database Server is running =A010.2.0.3.0. I would like to > upgrade to 10.2.0.4.x When I check metalink the patch sets for > 10.2.0.4 says it must be applied to a database already running > 10.2.0.4. Am I reading this correctly? Which patch set do I use? What are you looking at, exactly? The patch set depends. For me it's 6810189 Personally, I found issues with TZ (as the fix extends beyond Oracle) and dbconsole components. YMMV. jg -- @home.com is bogus. From the people who make spam palatable: http://googleblog.blogspot.com/2009/11/transparency-choice-and-control-now.= html On Nov 6, 6:41=A0pm, jhavero <jhav...@gmail.com> wrote: > My Oracle Database Server is running =A010.2.0.3.0. I would like to > upgrade to 10.2.0.4.x When I check metalink the patchsets for > 10.2.0.4 says it must be applied to a database already running > 10.2.0.4. Am I reading this correctly? Which patchset do I use? One that is almost 1 Gigabyte. Seriously. Its like 986 MB. Apply the 10.2.0.4 patchset using OUI (p6810189 for MS Win 32). After that has been completed, apply the one off patch using opatch. I'm guessing that you'...

Connection from Oracle Developer Suite 10g 9.0.4.0.1 to Oracle DB 10g Release 10.1.0.2.0
Hi, I have installed Oracle DB 10g Release 10.1.0.2.0 on Windows XP. START->ALL PROGS->oracle-OraDb10g_home3 Location of TNSNAMES FILE: C:\oracle\product\10.1.0\db_3\NETWORK\ADMIN\TNSNAMES.ORA with two alias: 1)ORCL3 2) EXTPROC_CONNECTION_DATA I can logon to database via SQL*PLUS and I can log on to EM on the web as well using ORCL3. After that I installed Oracle Developer Suite 10g 9.0.4.0.1 to my the same computer. During installation it was not allowing me to install this suite to the same ORACLE home. I installed this in the following home: START->ALL PROGS->...

"ORA-27300: OS system dependent operation:GetThreadTimes failed" Causes Instance Crash 10.2.0.2
Just curious to see if anyone has seen this problem before - I could not find anything on Metalink. One of my Oracle instances crashed at 34 seconds past midnight on Saturday - no known jobs run at that time. The server is running Windows 2003 x64, database is Oracle 10.2.0.2. The instance has been extremely stable since put in production in April 2006. The alert log shows this: --------------------------------- Sat Oct 28 00:00:34 2006 Process startup failed, error stack: Sat Oct 28 00:00:34 2006 Errors in file d:\oracle\product\10.2.0\admin\DB\bdump\vmfg_psp0_2196.trc: ORA-27300: OS system dependent operation:GetThreadTimes failed with status: 6 ORA-27301: OS failure message: The handle is invalid. ORA-27302: failure occurred at: skgpspawn Sat Oct 28 00:00:34 2006 Errors in file d:\oracle\product\10.2.0\admin\DB\bdump\vmfg_psp0_2196.trc: ORA-00600: internal error code, arguments: [784], [0x1A0AB9EE0], [0x195106208], [0], [], [], [], [] Sat Oct 28 00:00:35 2006 Errors in file d:\oracle\product\10.2.0\admin\DB\bdump\vmfg_psp0_2196.trc: ORA-00600: internal error code, arguments: [784], [0x1A0AB9EE0], [0x195106208], [0], [], [], [], [] PSP0: terminating instance due to error 490 Sat Oct 28 00:00:35 2006 Errors in file d:\oracle\product\10.2.0\admin\DB\bdump\vmfg_lgwr_1296.trc: ORA-00490: PSP process terminated with error Sat Oct 28 00:00:35 2006 Errors in file d:\oracle\product\10.2.0\admin\DB\bdump\vmfg_ckpt_888.trc: ORA-00490: PSP process terminated with error Sat Oct ...

OEM Upgrade from 10.2.0.1 to 10.2.0.5
Hi all, I am doing a fresh install of Oracle Enterprise manager on Linux 32 bit using OLE5.3 using How to Install Grid Control 10.2.0.5.0 on Enterprise Linux 5 Using the Existing Database (11g) Option Doc ID: 784963.1 As per the Metalink note I am doing software only install of 10.2.0.1 and then 10.2.0.5 with no config. Then I manually run the follwoing ConfigureGC.pl script: where I get this error ..../oms10g/perl/bin/perl .../oms10g/sysman/install/ConfigureGC.pl /u01/app/gc Any ideas/suggestions to solve this ? This is not related to sys/ sysman password I think Oc4jDeploy tool completed, but with errors. ' INFO: oracle.sysman.top.oms:PerformSecureCommand:runCmd:Command Output stderr: 'java.lang.reflect.InvocationTargetException at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke (NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke (DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:324) at oracle.j2ee.tools.deploy.Oc4jDeploy.doDeploy(Unknown Source) at oracle.j2ee.tools.deploy.Oc4jDeploy.execute(Unknown Source) at oracle.j2ee.tools.deploy.Oc4jDeploy.deploy(Unknown Source) at oracle.j2ee.tools.deploy.Oc4jDeploy.main(Unknown Source) Caused by: java.lang.NoClassDefFoundError at com.evermind.server.rmi.RMIConnection.EXCEPTION_ORIGINATES_FROM_TH...

SW: Firefox 10.0.12ESR, SeaMonkey 2.7.2 10.0.12ESR, Thunderbird 10.0.12ESR
++ From the VOICE OS/2-eCS News Service http://www.os2voice.org ++ From: madodelDESPAM@DESPAMptdprolog.net Firefox 10.0.12esr, SeaMonkey 2.7.2 based on 10.0.12ESR and Thunderbird 10.0.12ESR have been uploaded to Netlabs by Dave Yeo. Firefox is the Web Browser based on the open source Mozilla project. SeaMonkey is the Web Browser/Mail reader/News reader based on the open source Mozilla project. ESR stands for Extended Support. Thunderbird is the Mail reader/News reader based on the open source Mozilla project. If anyone is interested in continuing to see development of the Mozi...

Any way to install a later "build" of 10.5.2 over 10.5.2 "GM"?
Hi all... My 10.5.2 load set is based on the 10.5.2 GM -- 9C31. We got a new MacBook Pro that has 10.5.2 9C2028 -- a later build of 10.5.2 (containing the CD/DVD Sharing among other stuff...) When "later" builds of the same version of 10.4.x came out, we were able to use Carbon Copy Cloner to copy over the GM version load set of 10.4.x (any version), then boot from the "later build but same version number" DVD and do an "upgrade" install over the GM version of 10.4.x 10.5 is not letting me do this. The installer is reporting that the hard...

Firefox 2.0.0.2, 1.5.0.10 contrib. builds on Solaris10, Solaris8/9 are available #2
Please do NOT reply to this address. If you have any problems, feel free to send email to desktop dash discuss at opensolaris dot org Firefox 2.0.0.2, 1.5.0.10 contrib. builds on Solaris10, Solaris8/9 are now available on www.mozilla.com It's now much easier to get the latest contributed build on Solaris, just go to http://www.mozilla.com and click "Free Download" which would point you to the download page. Download Page ============== Firefox 2.0.0.2 http://www.mozilla.com (Click "Free Download") http://www.mozilla.com/en-US/firefox/2.0.0.2/releasenotes/#contribute...

int((9.2-9.0)*10) is 1, int((9.21-9.0)*10) is 2, why?
Python 2.5.2 (r252:60911, Feb 21 2008, 13:11:45) [MSC v.1310 32 bit (Intel)] on win32 The following line of code describes an funny question・3校 >>> int((9.2-9.0)*10) 1 >>> int((9.21-9.0)*10) 2 >>> int((9.1-9.0)*10) 0 >>> int((9.11-9.0)*10) 1 >>> int((8.2-8.0)*10) 1 >>> int((8.23-8.0)*10) 2 why? anybody can explain it? On Sep 5, 11:12 pm, bcm <bluecrysta...@gmail.com> wrote: > Python 2.5.2 (r252:60911, Feb 21 2008, 13:11:45) [MSC v.1310 32 bit > (Intel)] on win32 > The following line of code describes an funny que...

Rolling upgrade from oracle RAC 10.2.0.4 to 11.2.0.1
Has anyone done a rolling upgrade of oracle RAC 10.2.0.4 to 11.2.0.1. Recently I was trying to upgrade a 2 node RAC using logical standby database and evertime it is failing at upgrade of cluster. Hven't found any useful doc in metalink or internet. Will be very helpful if someone who has done this can provide a direction to me. Thanks ...

TNS-12537 after starting listener after upgrade from 10.2.0.2. 10.2.0.4
Hello, I have upgraded 7 Unix Solaris 5.10 Boxes from 10.2.0.2 to 10.2.0.4 and applied recommend patches. All upgrades worked with the exception of one server. One server won't start the listener. I get the following: 35% lsnrctl start LSNRCTL for Solaris: Version 10.2.0.4.0 - Production on 11-AUG-2008 10:17:31 Copyright (c) 1991, 2007, Oracle. All rights reserved. Starting /oracle/BWD/102_64/bin/tnslsnr: please wait... TNS-12537: TNS:connection closed TNS-12560: TNS:protocol adapter error TNS-00507: Connection closed Solaris Error: 29: Illegal seek I have searched google.com and the only thing I can find is related to Oracle 8 and Windows: add 127.0.0.1 localhost.(domain) localhost to /etc/hosts. I did this with no luck. I have two instances of Oracle on this one machine. One listener works, the other doesn't. I have done the following : cd $ORACLE_HOME/bin ../relink all then: cd $ORACLE_HOME/network/lib make -f ins_network.mk install make: Fatal error: Can't find `ins_network.mk': No such file or directory The port used by the listener is 1521 and netstat -an |grep 1521 reports port not in use. I've changed listener.ora with tracing and nothing seems obvious. trace_level_listener = 16 trace_file_listener = listener trace_timestamp_listener = on trace_filelen_listener = 100 trace_fileno_listener = 2 log_file_listener=listener -- Steve Comments embedded. On Aug 11, 9:34=A0am, sfa...@gmail.com wrote: > Hello, I have upgraded 7 ...

Error building GCL-2.6.2 Win XP/ MINGW GCC 3.2.3 / MSYS 1.0.10
Hi fellow lispers, I am trying to build GCL-2.6.2 on Win XP, with MINGW/GCC 3.2.3, and MSYS 1.0.10. Building GCL-2.5.3 was a piece of cake, but I have no luck with GCL-2.6.2. Running the configure script is OK, but a non recognised option: -fno-zero-initialized-in-bss So I remove this option from the makedefs file and run make. You also have to define cc as a synony for gcc, so the make works. Everything runs then fine for a (very long) while... then make crashes while building the info doc: make[1]: Entering directory `/home/gcl-2.6.2/info' makeinfo gcl-tk.texi Values'..texi:594:...

Upgrade from Oracle 9.2.0.1 to Oracle 9.2.0.3
Hello All, I am trying to upgrade oracle 9.2.0.1 to new patchset 9.2.0.3 or 9.2.0.4. Please recommend which is better 9.2.0.3 or 9.2.0.4? Also I had a bad experience with my development server when applying 9.2.0.3 patchset. Is there anything you recommend before I start again? Thanks Kumu Hello Kumu, What is the reason for upgrade? Any specific bugs or issues you experience? You can open TAR as well to get support recommendations for your situation. New patches can introduce new problems as you can see, Regards, Ron DBA Infopower http://www.dbainfopower.com Standard disclaimer: http://www.dbainfopower.com/dbaip_advice_disclaimer.html "kumu" <forlist2001@yahoo.com> wrote in message news:a44abd39.0402161837.6badb9ed@posting.google.com... > Hello All, > I am trying to upgrade oracle 9.2.0.1 to new patchset 9.2.0.3 or > 9.2.0.4. Please recommend which is better 9.2.0.3 or 9.2.0.4? > > Also I had a bad experience with my development server when applying > 9.2.0.3 patchset. Is there anything you recommend before I start > again? > > Thanks > Kumu "Ron" <support@dbainfopower.com> wrote in message news:<QqWdnRM_cMiwWqzdRVn-vg@comcast.com>... > Hello Kumu, > > What is the reason for upgrade? Any specific bugs or issues you > experience? > > You can open TAR as well to get support recommendations for your > situation. > > New patches can introduce new...

LaTex equation numbering like 2.1, 2.2, also 2.0.1, 2.0,2, 2.1.1, etc
David Roach wrote: > Is there a simple command to have latex number > the equations by the section numbers automatically. > > David From the LaTeX Companion (what a wonderful book!) %%%%%%%%%%%%%%%%%%%%%% % number equations within sections % In preamble \makeatletter \@addtoreset{equation}{section} \makeatother \renewcommand{\theequation}{\thesection.\arabic{equation}} %%%%%%%%%%%%%%%%%%%%%% Numbers within sections...I use this all the time in articles. Even works with ******************* ******************* Brilliant. And then I got numbering within subsections by repeating and editing (not replacing), so I now have:- (Just after the documentClass command) \makeatletter \@addtoreset{equation}{section} \makeatother \renewcommand{\theequation}{\thesection.\arabic{equation}} \makeatletter \@addtoreset{equation}{subsection} \makeatother \renewcommand{\theequation}{\thesubsection.\arabic{equation}} Bob Bob Marlow schrieb: > David Roach wrote: > >> Is there a simple command to have latex number >> the equations by the section numbers automatically. >> >> David > > From the LaTeX Companion (what a wonderful book!) > > %%%%%%%%%%%%%%%%%%%%%% > > % number equations within sections > % In preamble > > \makeatletter > \@addtoreset{equation}{section} > \makeatother > \renewcommand{\theequation}{\thesection.\arabic{equation}} > > %%%%%%%%%%%%%%%%%%%%%% [more code] > Hi! I th...

Best Way to Access remote Oracle 10.2.0.1.0 DB from a Linux server
I want to use a perl or unix script running on a linux server to access an Oracle v. 10.2.0.1.0 database on a remote machine, and process the output with the script. What is the best way to do this? I'm thinking some possible options are: install Oracle 11 cllient (assume it is backwards compatible), install the entire Oracle database v.11, or install Oracle express. Appreciate your comments. Johan Johan <johango99@yahoo.com> wrote in news:db01b8d1-577b-4310-89af- 97465a3623c3@w28g2000hsf.googlegroups.com: > I want to use a perl or unix script running on a linux server to > access an Oracle v. 10.2.0.1.0 database on a remote machine, and > process the output with the script. What is the best way to do this? > I'm thinking some possible options are: install Oracle 11 cllient > (assume it is backwards compatible), install the entire Oracle > database v.11, or install Oracle express. Appreciate your comments. > > Johan > I vote for Oracle client & PERL On Nov 17, 3:13 pm, "Ana C. Dent" <anaced...@hotmail.com> wrote: > Johan <johang...@yahoo.com> wrote in news:db01b8d1-577b-4310-89af- > 97465a362...@w28g2000hsf.googlegroups.com: > > > I want to use a perl or unix script running on a linux server to > > access an Oracle v. 10.2.0.1.0 database on a remote machine, and > > process the output with the script. What is the best way to do this? > > I'm thinking some possib...

wave.setparams((2, 2, 44100, 44100 * 2 * 10, "NONE", "not compressed")) became more than 30secs
thanx to rob .. who gave me an example of how to use the WAVE lib now am on my way to use it as simple as i can i wrote an oil.py the instance of which will behave like an oscillator which constantly generates 7 different wave forms (non fixed) i thought this code might produce 10secs of wave file but the result was longer than 30secs was testing if i could use the WAVE lib withount taking advantage of StringIO nor struct but maybe am doing totally wrong? --8<--- import oil import wave a = oil.Sa() w = wave.open("current.wav", "w") w.setparams((2, 2, 44100, 44100 * ...

OS X 10.6.2 / Eudora 6.2.4
Hi, I have never done this before and I am just about desperate to get eudora functioning again. I have used eudora for @15 years and it suits my needs perfectly. Although I have had issues in the past something occurred in mid-November which I have not been able to resolve and, in the process, messed up some settings. No one that I know knows how to correct this so I am hoping one of you might. So, around mid-November I suddenly was not able to send an e-mail using eudora. One of the error messages I keep getting is "Server not responding. 706". Another is "...

Web resources about - "Ora-01000 maximum open cursors exceeded" after update from 10.2.0.1 to 10.2.0.3 - comp.databases.oracle.server

Resources last updated: 3/19/2016 11:51:27 PM