f



pgnuplot 4.0 can't get 'with labels' feature to work

Hi,

  I can plot the curve just fine unless I try to add labels to the data
points.
I have seen this labels technique working on several gnuplot tutorials.
I cannot find a reason why mine doesn't work.

Thanks in advance,

Ed
WinXP SP2
pgnuplot 4.0

(works)
 plot '3509120199_APV_dataPointsPruned.csv'using 2:3 with linespoints

(doesn't work)
 plot '3509120199_APV_dataPointsPruned.csv'using 2:3 with
linespoints,''
 using 2:3:2 with labels

                        ^
         expecting 'lines', 'points', 'linespoints', 'dots',
'impulses',
        'yerrorbars', 'xerrorbars', 'xyerrorbars', 'steps', 'fsteps',
        'histeps', 'filledcurves', 'boxes', 'boxerrorbars',
'boxxyerrorbars',
        'vectors', 'financebars', 'candlesticks', 'errorlines',
'xerrorlines',
        'yerrorlines', 'xyerrorlines', 'pm3d'

My data file:

#cost & gamma pair, FPR, TPR, cost & gamma pair,  FNR, TNR
12_-11 0.125 0.833333 12_-11 0.166667 0.875
0_-5 0.25 0.916667 0_-5 0.0833333 0.75
18_-24 0.375 0.916667 18_-24 0.0833333 0.625
25_-30 0.5 1 25_-30 0 0.5
23_-29 0.625 1 23_-29 0 0.375
24_-29 0.75 0.833333 24_-29 0.166667 0.25
-1_-5 0.875 0.916667 -1_-5 0.0833333 0.125

0
Ed
5/23/2005 10:32:31 PM
comp.graphics.apps.gnuplot 5008 articles. 0 followers. Post Follow

4 Replies
653 Views

Similar Articles

[PageSpeed] 22

In article <1116887551.666580.135440@g14g2000cwa.googlegroups.com>,
Ed <edwardotis@gmail.com> wrote:
>Hi,
>
>  I can plot the curve just fine unless I try to add labels to the data points.
>I have seen this labels technique working on several gnuplot tutorials.
>I cannot find a reason why mine doesn't work.

At the time of the version 4.0 release, "plot ... with labels" was available
only as an add-on patch to the source code.  You could rebuild version 4.0
source with the patch added, but it's almost certainly not worth it since
you can get this feature plus a lot of newer ones by building version 4.1
from unpatched source instead.

Or possibly someone may offer a copy of a post-version-4 pgnuplot binary.

-- 
Ethan A Merritt
0
merritt
5/23/2005 11:23:15 PM
Thanks, Ethan.

Is there a workaround that would produce the same effect as the 'with
labels' feature? I'm new to gnuplot, but I assume people have been
adding labels to their datapoints in previous versions?

I am creating a script that other people will need to use, so I'd
rather not use the development version of gnuplot at the moment. I
don't expect my users to have it installed.

Thanks,

Ed

0
Ed
5/23/2005 11:37:48 PM
Sorry, for asking without doing another google search first. Now I see
all the posts about the workaround where you create your own "set
label" cmd for each data point.

Since, I happen to be plotting with a xrange and yrange of [0:1], it
looks like I can generate my own label coordinates too. Otherwise, I
assume that I would be SOL.

http://groups-beta.google.com/group/comp.graphics.apps.gnuplot/browse_thread/thread/1c89ab955f891/abe1df8dbdd890e9?q=data+point+labels&rnum=2&hl=en#abe1df8dbdd890e9
http://groups-beta.google.com/group/comp.graphics.apps.gnuplot/browse_thread/thread/e6786f063ce299ef/80f403b3e7014f9f?q=data+points+labels&rnum=1#80f403b3e7014f9f

0
Ed
5/23/2005 11:49:19 PM
Ed <edwardotis@gmail.com> wrote:

> Since, I happen to be plotting with a xrange and yrange of [0:1], it
> looks like I can generate my own label coordinates too. Otherwise, I
> assume that I would be SOL.

No you wouldn't.  Read "help set label" and "help coordinate" a bit
more carefully.

-- 
Hans-Bernhard Broeker (broeker@physik.rwth-aachen.de)
Even if all the snow were burnt, ashes would remain.
0
Hans
5/24/2005 8:03:52 AM
Reply:

Similar Artilces:

Can't get 'require' to work
I just started tinkering with Ruby. From "The Poignant Ruby Programmer" or whatever it's called (you know what I mean) I tried running the small example but get an error. This is the first file called m2.rb: require '/usr/home/me.rb' # Get evil idea and swap in code words print "Enter your new idea: " idea = gets code_words.each do |real, code| idea.gsub!( real, code ) end # Save the jibberish to a new file print "File encoded. Please enter a name for this idea: " idea_name = gets.strip File::open( "idea-" + idea_name + "...

OS X
after a bit of reading, it looks like I did a veeeeery shtupid thing... (I'm copying my post to this newsgroup, as the alt.sys.mac.newuser-help group didn't look quite as highly-trafficked...) anyways, here's what I did... ----------------------------------- in an effort to help the owner of a nice shiny new eMac 'clean up' their personal folder, I moved a few items... including the Library folder! it appears.... correct me if I'm wrong... that Mac OS X then created a NEW library... so we restarted it, and all the Quicken data, dialup info, (etc.) was gone... so we ...

Getting Error can't find '__main__' module in 'X'
Hey I am newbie in python.I have installed python 2.7.5 correctly.It is working fine but I am having some issues.I have set windows Enviroment variables. The problem is when I try to save my program in a folder(C:\Users\John\X)it shows that module error but when I save it outside this X folder ( C:\Users\John ) It runs successfully.How to fix it? On 06/02/2013 07:04 AM, meakaakka wrote: > Hey I am newbie in python.I have installed python 2.7.5 correctly.It is working fine but I am having some issues.I have set windows Enviroment variables. Please be a lot more specific. Do you have ...

'^=' and '~='?
Hello, What is the difference between '^=' and '~='? Thanks, Duckhye ...

'is not' or '!='
A newbie question to you; what is the difference between statements like: if x is not None: and if x != None: Without any context, which one should be preferred? IMHO, the latter is more readable. On 2014-08-18 21:35, ElChino wrote: > A newbie question to you; what is the difference between statements > like: > if x is not None: > and > if x != None: > > Without any context, which one should be preferred? > IMHO, the latter is more readable. > "x == y" tells you whether x and y refer to objects that are equal. "x is y" tells you whether x and y actually refer to the same object. In the case of singletons like None (there's only one None object), it's better to use "is". "ElChino" <elchino@cnn.cn>: > A newbie question to you; what is the difference between statements > like: > if x is not None: > and > if x != None: Do the following: take two $10 bills. Hold one bill in the left hand, hold the other bill in the right hand. Now, the bill in the left hand "is not" the bill in the right hand. However, the bill in the left hand "==" the bill in the right hand. > Without any context, which one should be preferred? > IMHO, the latter is more readable. In almost all cases, both tests would result in the same behavior. However, the "is not" test is conceptually the correct one since you want...

converting 1944 to '1','9','4','4'
converting 1944 to '1','9','4','4' how can I convert a number such as 1944 to a character array? thanks! x wrote: > converting 1944 to '1','9','4','4' > > how can I convert a number such as 1944 to a character array? Corvert it to string, then convert string into character array, if string is not good enough for you. See faq: [38.1] How do I convert a value (a number, for example) to a std::string? http://www.parashift.com/c++-faq-lite/misc-technical-issues.html#faq-38.1 On 13 Apr 2004 08:08:24 -0700, aotemp@hotma...

Can't even get 'Hello World' to work in Oracle!
Maybe I'm a moron. I don't know, but I can't even get Hello World to work in Oracle. I have the following SQL file: BEGIN DBMS_OUTPUT.put_line ('Hello World'); END; I am using SQL developer and connecting to an Oracle Server instance (not sure what version). I run the above file and it just says anonymous block completed in the script output window. In the DBMS output window, it says nothing. In the OWA Output window, it says nothing. What are all of those windows anyway? Thanks in advance for your help. Kramer314 <johnlkramer@gmail.com> wrote in ne...

Can't get '--coverage-html' switch to work in PHPUnit2
hi, how do I use code coverage and test skeleton generators to work in PHPUnit2. I used following commands 1) phpunit --coverage-html SomeTest 2) phpunit --skeleton SomeClass as described at http://www.phpunit.de/en/phpunit2_codecoverage.php and http://www.phpunit.de/en/phpunit2_skeleton.php, but it is not working. Please Help. Thanks ...

can't get the $_GET['id'] after the header is sent but page doesn't redirect
In the first if, the page is displayed without any company cars selected. If there is a company selected, then the id value is posted and captured by the redirect (1st elseif). Then one of two things can happen. The final else the selected company/id cars get displayed in the browser, or in the case of a post to a form for excel, the a header gets sent to the to the current_sightingsXL.php page. The current_sightingsXL.php and current_sightings.php pages test out. The second elseif works with one minor problem. I have to type in the url with the id to get it to download to excel. i...

Why can't we 'tformfwd' a cp2tform(..., 'polynomial')
Hi, Just as an example: This is allowed xybase = reshape(randn(12,1),6,2); t_affine = cp2tform(xybase,xybase,'affine'); [x,y] = tformfwd(t_affine,xybase,xybase); but this t_poly = cp2tform(xybase,xybase,'polynomial',2); [x,y] = tformfwd(t_poly,xybase,xybase); gives an error "Function TFORMFWD expected T's forward_fcn field to be non- empty." I checked the code a bit and indeed, with the 'polynomial' case, the findPolynomialTransform() function has at its end trans = maketform('custom',2,2,[],@inv_polynomial,[A B]); wher...

Re: if str_mo not in ('','.') and str_da not in ('','.') and str_ yy not in ('','.') Any shorter ? #4
Igor, Without robust error checking: %macro check ( vars , values , op = in /* not in */, con = and /* or */ ) ; %local i w ; %let i = 1 ; %let w = %scan(&vars,&i) ; %do %while ( %length ( &w ) > 0 ) ; %if &i > 1 %then &con ; &w &op &values %let i = %eval ( &i + 1 ) ; %let w = %scan(&vars,&i) ; %end ; %mend check ; option mprint ; data w ; retain x y z "a" r " " s t "a" a b 99 c . ; if %check( x y z , ('','.'), op = not in ) then put &qu...

if lisp can add any feature, then why doesn't it get used? I don't get it..
I really don't and for some odd reason I have this fascination with forth lisp smalltalk io haskell aggghhh!! On 2008-09-06 11:46:32 +0100, gavino <gavcomedy@gmail.com> said: > I really don't > > and for some odd reason I have this fascination with forth lisp > smalltalk io haskell > > aggghhh!! Isn't the answer *precisely* in your asking the question? Lisp is not used by "people who don't get it". Not because those that do are any smarter or born geniuses, but surely *because* they decided to put in *the effort* to learn and see "...

Can't get sqlite3.Row working: keyword lookup doesn't work
Hello, using Python 2.7.6 I try to access a sqlite database using keyword lookup instead of position (much more easy to maintain code), but it always fail, with the error: Index must be int or string I have created the database, populated it, and here is the code that tries to retrieve the information: with sqlite3.connect(mydbPath) as db: # open the database db.row_factory = sqlite3.Row cursor = db.cursor() cursor.execute("SELECT * FROM files") for row in cursor.fetchall(): print(row.keys()) print(row["filename&qu...

Can't get XP's Drag and Drop Feature to work
I uninstalled Nero, set the drive to be writable and still, it just doesn't allow me to drag and drop anything to that RW or CD-R. T On my home machine I just replaced my CD-R drive with a DVD-R drive. It didn't work before and it still doesn't work. I can burn with Nero but I want to be able to use the drag and drop function. I know alot of people don't likeit, but at work there is a general insistence that I get it working. .. -------------------------------------- Mike Richter, were you born with "Scam Artist" emblaz...

Can't get XP's Drag and Drop Feature to work
I uninstalled Nero, set the drive to be writable and still, it just doesn't allow me to drag and drop anything to that RW or CD-R. This is different from my last issue with the 2G file... On my home machine I just replaced my CD-R drive with a DVD-R drive. It didn't work before and it still doesn't work. I can burn with Nero but I want to be able to use the drag and drop function. I know alot of people don't likeit, but at work there is a general insistence that I get it working. .. -------------------------------------- Mike Richter, wer...

Removing the letters 't' 'i' 'x' and 'y'
Im having trouble with figuring out how to write a function which will remove the letters 't' 'i' 'x' and 'y' from any input string in matlab. for example modstr(pixy) should result in ans = 'p' or modstr(picture) should result in ans = 'pcure' if anyone could offer any help or hints i would really appreciate it. Thank You >> modstr=@(s) s(~ismember(s,'tixy')) modstr = @(s)s(~ismember(s,'tixy')) >> modstr('picture') ans = pcure % Bruno ...

Perl/Tk: can't get -command=> \&function to work 'on-the-fly'!!
Please Help! I am trying to define buttons 'on-the-fly' mostly because their number is determined in a config file - I don't know how many I will need. It's ROYALLY NOT WORKING. I think Tk.pm is having issues. And it's all driving me very... verrrryyy... batty. *** I WANT THIS TO WORK *** (pseudo-code) for i=1;i<100,i++ { $handle[i] = menubar->command(-label => "test_i", %somecolors, -command => Move2Folder(i)); *** IS THIS TOO MUCH TO ASK??? *** 1) If I 'unroll it' (see end of this message) AND wrap the Move2Folder function...

I don't get why '>' doesn't get printed in the following example
When I do a here-document, the '>' character shows up to indicate the start of a newline. [cdalten@localhost ~]$ cat << EOF > My current directory is dir $PWD > EOF My current directory is dir /home/cdalten [cdalten@localhost ~]$ What prevents the '>' characters from showing up in the final output? On Jul 3, 10:35 am, Chad <cdal...@gmail.com> wrote: > When I do a here-document, the '>' character shows up to indicate the > start of a newline. > > [cdalten@localhost ~]$ cat << EOF> My current directory is dir $PWD > &...

I don't work for IBM and I don't make promises I can't deliver on
I wish I could afford an advertising campaign to compete with what they have on the Internet now. I promise to go totally ballistic at the next LLLNL contract. Robert. On 8/12/2011 11:24 PM, Robert Myers wrote: > I wish I could afford an advertising campaign to compete with what they > have on the Internet now. > > I promise to go totally ballistic at the next LLLNL contract. > > Robert. I don't work for IBM (anymore) either. If you are talking about the death of Blue Waters, I don't believe they said they couldn't deliver. They said they chose not to because they would lose a bunch of money on the project since it turned out to cost a lot more than the initial guess. And I guess Ben chose not to print some more to pay for it. On Aug 24, 11:17=A0pm, Del Cecchi <delcec...@gmail.com> wrote: > On 8/12/2011 11:24 PM, Robert Myers wrote: > > > I wish I could afford an advertising campaign to compete with what they > > have on the Internet now. > > > I promise to go totally ballistic at the next LLLNL contract. > > > Robert. > > I don't work for IBM (anymore) either. =A0If you are talking about the > death of Blue Waters, I don't believe they said they couldn't deliver. > They said they chose not to because they would lose a bunch of money on > the project since it turned out to cost a lot more than the initial guess= .. > > And I guess Ben chose not to print some mor...

How come I can't use 'sqrt' and 'fabs'?
Hi, group, When I compile my code, the error message are: "error C2668: 'fabs' : ambiguous call to overloaded function" "error C2668: 'sqrt' : ambiguous call to overloaded function" I already add the math library, what does this error mean? Thanks. Vol. Vol wrote: > Hi, group, > When I compile my code, the error message are: > "error C2668: 'fabs' : ambiguous call to overloaded function" > "error C2668: 'sqrt' : ambiguous call to overloaded function" > > I already add the math library, what does this...

Why f=figure('visible','off') doens't work?!!!!!
Hi matlabers, stangre behaviour that I can't understand: I am developping a code that creates figures and save them, but as it is in a loop over thousands of steps, I don't want to see the figures, just save them. I knpw this is a very common question and I have made some research before posting this message, but I can't understand why, when I write in my loop f=figure('visible','off') and then I define my plot, and I use saveas or print, the figure appears on my screen!!!! How can I solve this problem?! Thanks in advance for your help, Camille. "...

i can't insert 'a''a' in a field with size 3
hi, i run INSERT INTO test (FIELD1) VALUES ('a''a') but DBMS oracle returns this error: ORA-01401: inserted value too large for column (FIELD1 size is 3!) what's the error? Fici wrote: > hi, > i run > INSERT INTO test (FIELD1) VALUES ('a''a') > but DBMS oracle returns this error: > ORA-01401: inserted value too large for column > (FIELD1 size is 3!) > what's the error? SQL> create table test ( 2 field1 VARCHAR2(3)); Table created. SQL> INSERT INTO test 2 (field1) 3 VALUES 4 ('a''a'); 1 row created. SQL> SELECT * FROM test; FIE --- a'a SQL> try the following in SQL*Plus: show define Post the result If you are not using SQL*Plus then your front-end tool is defective or needs to be reconfigured. -- Daniel A. Morgan Oracle Ace Director & Instructor University of Washington damorgan@x.washington.edu (replace x with u to respond) Puget Sound Oracle Users Group www.psoug.org On Mar 10, 6:38 pm, Fici <moretto.feder...@gmail.com> wrote: > hi, > i run > INSERT INTO test (FIELD1) VALUES ('a''a') > but DBMS oracle returns this error: > ORA-01401: inserted value too large for column > (FIELD1 size is 3!) > what's the error? Might be one of unicode charsets having each symbol more than one byte and column size defined in bytes not chars. Check DB charset and...

'''''''''''''The Running Update/Append Queries Using VBA code Ordeal''''''''''''''
Hello fellow programmers, I am trying to run an append/update query from code, a command button on a form initiates the queries. the format i am using is; _____________________________________________________ SELECT "criteria" FROM "criteria" WHERE "criteria" UPDATE/APPEND "field selections" RecordSource "qryExample" = above text strings" _______________________________________________________________________ When i am running a SELECT query in this manner it works fine with no problems, and accepts the values of specified linked for...

``awk '!a[$0]++' file'' and ``awk '{if(!($0 in rec)) {rec[$0]=1; print $0;}}' file ''
Hi all, Currently, I'm reading the book on awk programming language, but meet the following two examples which I cann't understand so well: awk '!a[$0]++' file and awk '{if(!($0 in rec)) {rec[$0]=1; print $0;}}' file Could someone here please give me some hints or explanations on the logic of above codes? Regards -- ..: Hongyi Zhao [ hongyi.zhao AT gmail.com ] Free as in Freedom :. In article <meuejm$gsf$1@aspen.stu.neva.ru>, Hongyi Zhao <hongyi.zhao@gmail.com> wrote: > Hi all, > > Currently, I'm reading the bo...

Web resources about - pgnuplot 4.0 can't get 'with labels' feature to work - comp.graphics.apps.gnuplot

Resources last updated: 3/2/2016 9:01:36 PM