f



[Apache+PHP] Error building PHP

Hi,

I am building php 4.3.10 on slackware 10.1.0 and I got an error.
More in details:

I've successfully installed apache_1.3.33.

In php-4.3.10 directory, I typed
# ./configure --with-mysql --with-apxs=/usr/local/apache/bin/apxs 
--enable-module=so

and i got the following error:

# ----------------------------------------
Configuring SAPI modules
checking for AOLserver support... no
checking for Apache 1.x module support via DSO through APXS...

Sorry, I was not able to successfully run APXS.  Possible reasons:

1.  Perl is not installed;
2.  Apache was not compiled with DSO support (--enable-module=so);
3.  'apxs' is not in your path.  Try to use --with-apxs=/path/to/apxs
The output of /usr/local/apache/bin/apxs follows
apxs:Error: Sorry, no DSO support for Apache available
apxs:Error: under your platform. Make sure the Apache
apxs:Error: module mod_so is compiled into your server
apxs:Error: binary `/usr/local/apache/bin/httpd'.
configure: error: Aborting
# ----------------------------------------

So, in /usr/sbin, I typed:

# ./httpd -l
Compiled-in modules:
   http_core.c
   mod_so.c
suexec: disabled; invalid wrapper /usr/sbin/suexec

which sounds good, ...but if i try again to do ./configure ...
i get the same error ( ... Configuring SAPI modules ...)

Any suggestions?

Thanks a lot!
Marzia
0
Marzia
3/22/2005 1:19:07 PM
comp.infosystems.servers.unix 3274 articles. 0 followers. Post Follow

2 Replies
1105 Views

Similar Articles

[PageSpeed] 29

Marzia Corvaglia schrieb:

> In php-4.3.10 directory, I typed
> # ./configure --with-mysql --with-apxs=/usr/local/apache/bin/apxs 
> --enable-module=so
   ^^^^^^^^^^^^^^^^^^^

This is for apache, not for php!

> # ./httpd -l
> Compiled-in modules:
>   http_core.c
>   mod_so.c
> suexec: disabled; invalid wrapper /usr/sbin/suexec
> 
> which sounds good, 

Yes it does.

> Any suggestions?

Try to run /usr/local/apache/bin/apxs from the command line first. Any 
errors?

B.


-- 
BM Computer-Services, Bergmannstr. 66, 10961 Berlin
Webdesign, Internet, Layout und Grafik
Tel.: 030/20649400, mobil 0175/7419517, Fax: 030/20649401
Web: http://www.bmservices.de, eMail: kontakt@bmservices.de
0
Bernd
3/23/2005 10:21:24 AM
Hi! Thanks a lot.

 >
 > This is for apache, not for php!
 >

Indeed, i should have used the option --enable-module=so
in apache configuration, not in php one!!!
So, now i reinstalled apache with that option, and then php
.... and each step successfully finished!!! :-)

Thanks again and bye,
Marzia
0
Marzia
3/23/2005 1:51:15 PM
Reply: