f



Apache 2.0.4.6 (Win) PHP 4.3.4.4

Hello there,

We have PHP ver 4.3.4.4 working off Apache server version 2.0.4.6.

My developer has developed a bunch of basic web pages which interact
with the SQL Server 2000.

We exposed the web application to the outside world though port 80 and
the server crashed all of a sudden the very next day.

Are there any security vulneribities with PHP ver 4.3.4.4  and Apache
server version 2.0.4.6.which I need to be aware off.

My developer is reluctant to upgrade the server to new version of
apache and php.

Any suggestion, help or pointer in the right direction will be
appreciated.

Thanks,
anups

0
anups_10 (1)
3/16/2005 5:05:12 AM
comp.infosystems.ms-windows 1722 articles. 0 followers. amosw01 (46) is leader. Post Follow

1 Replies
2572 Views

Similar Articles

[PageSpeed] 42

On 15 Mar 2005 21:05:12 -0800, "anups" <anups_10@yahoo.com> wrote:

>Hello there,
>
>We have PHP ver 4.3.4.4 working off Apache server version 2.0.4.6.
>
>My developer has developed a bunch of basic web pages which interact
>with the SQL Server 2000.
>
>We exposed the web application to the outside world though port 80 and
>the server crashed all of a sudden the very next day.
>
>Are there any security vulneribities with PHP ver 4.3.4.4  and Apache
>server version 2.0.4.6.which I need to be aware off.
>
>My developer is reluctant to upgrade the server to new version of
>apache and php.
>
>Any suggestion, help or pointer in the right direction will be
>appreciated.
>
>Thanks,
>anups

The solved Apache vulnerabilities between 2.0.46 and the current
2.0.53 are all mentioned in the detailed Change Logs.
	http://httpd.apache.org/  (right bottom).
PHP is at least at version 4.3.10 now.
	http://www.php.net/ChangeLog-4.php

But it all depends on the nature of the crash, of course.
Even a full database can stop a site from working...

-- 
  )  Kees Nuyt
  (
c[_]
0
Kees
3/16/2005 5:40:07 PM
Reply: