f



Help can't run properly Apache 2.0.48 / mod_jk2 (2.0.2) /Tomcat 4 on Solaris 9

Did someone succed to run Apache 2.0.48 / mod_jk2 (2.0.2) /Tomcat 4 on Solaris 9?

Does someone manage to make this work with a mod_jk2 (2.0.2)? I just get
a lot of "Can't find child ... in scoreboard" (looks like
<http://issues.apache.org/bugzilla/show_bug.cgi?id=19044>).  It seems to 
me that Apache launches its children processes and its modules 
concurrently; I once got a child process finish to configure after 
mod_jk2, and it went recognized (in the log: first a bunch of
"jk2_init() Can't find child 20363 in scoreboard; workerEnv.init() ok
/usr/local/httpd-2.0.48/conf/workers2.properties; mod_jk child init 1
-2" for child processes that had finished their loading before mod_jk2,
then "Apache/2.0.48 (Unix) mod_jk2/2.0.2 configured -- resuming normal
operations", then the last child finishing and resulting in a "Found
child ..." from mod_jk2).

I then tried compiling Apache with a "worker" MGM (instead of the 
default "prefork") and changing the StartServers parameter to 0 so that
child processes are started after Apache's modules configuration, but it
doesn't work either.

I compiled Apache with gcc3:
../configure --prefix="$HTTPD_DIR" --enable-module=most 
--enable-shared=most --without-gdbm --without-berkeley-db --with-mpm=worker
(the "without"s are mostly for avoiding to compile some things present 
on a dev machine but not on the deployment one).
And mod_jk2 with:
# I first modified jk_ws.m4 which seems bugged in JK_WS_INCDIR (3 params
# expected, 2 used by configure.in.
# configure.in needed some rework too, by replacing a if ! ${TEST} by
# if ${TEST} !
sh buildconf.sh
# --target=NONE to force subscripts to use the configure-detected system
../configure --with-apache2-include="$HTTPD_DIR/include" 
--with-apache2-lib="$HTTPD_DIR/lib" --with-apxs2="$HTTPD_DIR/bin/apxs" 
--with-tomcat41="$TOMCAT_DIR" --target=NONE



Thanks!
0
1/7/2004 6:38:58 PM
comp.lang.java.help 13340 articles. 0 followers. Post Follow

1 Replies
708 Views

Similar Articles

[PageSpeed] 28

People are discussing this on the Tomcat users mailing list right now.  It
does look like a problem (the developer is chiming in).

Try using either IP sockets or UNIX sockets.  Both work for me on Fedora
Core 1 2.4.22-1.2138.nptl.

It looks like there are some issues to work out with the in-process stuff
on UNIX at this point.

/mde/
just my two cents . . . .

On Wed, 07 Jan 2004 10:38:58 -0800, PH wrote:

> Did someone succed to run Apache 2.0.48 / mod_jk2 (2.0.2) /Tomcat 4 on
> Solaris 9?
> 
> Does someone manage to make this work with a mod_jk2 (2.0.2)? I just get a
> lot of "Can't find child ... in scoreboard" (looks like
> <http://issues.apache.org/bugzilla/show_bug.cgi?id=19044>).

0
sometoast (3)
1/8/2004 5:43:59 PM
Reply:

Similar Artilces:

Apache 2.0.47, Tomcat 4.1.27, mod_jk2 2.0.2 AND mod_deflate
I have setup Apache 2.0.47 on Windows XP to serve jsp/servlet requests using Tomcat 4.1.27. I did this using the mod_jk2 module and was able to successfully connect to http://host/examples and get the tomcat example pages. I'm using JDK 1.3.1-03. I then configured mod_deflate and was able to verify it works by telnet'ing to port 80 and giving it a request using "Accept-Encoding: gzip, deflate". I did this on both the main index.html file and the main manual document. However, any request to /examples/* (served by jk2) does NOT get compressed. I even placed the ma...

help:How can i take Export of Oracle 9.2.0.1 from Oracle 9.2.0.7
How can i take Export of Oracle 9.2.0.1 from Oracle 9.2.0.7 1-what scripts are to be used 2-Where i can find these scripts. Thnks. You can't. You can use lower version export to export higher version database. The other way around has never been possible. -- Sybrand Bakker Senior Oracle DBA You probably have Oracle 9.2.0.1 running somewhere right, perhaps on another machine ? Set your ORACLE_HOME to 9.2.0.1 then export through sqlnet: exp username/pwd @9207instance Now you'll use the 9.2.0.1 export utility; this should work. "shahsyed" <shahsyed@gmail.co...

Oracle server 9.2.0.1.0, Client 9.2.0.4.0, Red Hat Linux enterprise advanced server 2.1
Hi Everybody, My Database server is running on Red Hat Linux enterprise advanced server 2.1, And my Oracle version is 9.2.0.1.0. My Client mechine also Red Hat Linux enterprise advanced server 2.1 , Oracle client version is 9.2.0.4.0. I am running a web application. Our application is in Magic edeveloper. I connect to Oracle using oracle gateway to my application. My Problem is my application is is becoming slow. I am not able to trace where the problem is. Before our application was running fine. recently i upgraded Oracle client version to 9.2.0.4.0. My Oracle client & server versi...

Help!! Oracle 9.2.0.5.0 won't properly read the *.rsp
Here's the error I'm getting in the unattended. The problem is the patch.rsp file does have the Home names defined. I've put it under the error message. error message here ============================= Starting Oracle Universal Installer... No pre-requisite checks found in oraparam.ini, no system pre-requisite checks wi ll be executed. Preparing to launch Oracle Universal Installer from C:\DOCUME~1\ADMINI~1\LOCALS~ 1\Temp\OraInstall2005-12-02_04-15-46PM. Please wait ...Oracle Universal Installe r, Version 10.1.0.2.0 Production Copyright (C) 1999, 2004, Oracle. All rights reserved...

[ANN] gettext-2.0.2, gettext_activerecord-2.0.2, gettext_rails-2.0.2
Hi, Ruby-GetText-Package-2.0.2 and the families (gettext-2.0.2, gettext_activerecord-2.0.2 and gettext_rails-2.0.2) are now available. Ruby-GetText-Package is the library/tools for message localization. * gettext - Message localization libraries and tools for all kind of apps/libs. * gettext_activerecord - ActiveRecord Localization * gettext_rails - Rails support with gettext. Changes ------- == gettext-2.0.2 * Support ruby-1.9.1 style format string such as %<foo>d. * Apply new Locale.set_app_language_tags and Locale.candidates. [Suggested by Vladimir Dobriakov] * Enhance...

[ANN] gettext-2.0.4, gettext_activerecord-2.0.4, gettext_rails-2.0.4
Hi, Ruby-GetText-Package-2.0.4 and the families (gettext-2.0.4, gettext_activerecord-2.0.4 and gettext_rails-2.0.4) are now available. Ruby-GetText-Package is the library/tools for message localization. * gettext - Message localization libraries and tools for all kind of apps/libs. * gettext_activerecord - ActiveRecord Localization * gettext_rails - Rails support with gettext. Changes ------- == gettext-2.0.4 * Fix String#% return nil when the string have no place holders. [by okkez] * Update pofiles and remove old messages. * suppress some warnings on Ruby 1.9.x. [by Nobuhiro IMA...

optimizer_features_enable difference between 9.2.0.1/9..2.0.3/9.2.0.6?
Hi, All, I noticed for this parameter optimizer_features_enable , oracle document says: Syntax OPTIMIZER_FEATURES_ENABLE = {8.0.0 | 8.0.3 | 8.0.4 | 8.0.5 | 8.0.6 | 8.0.7 | 8.1.0 | 8.1.3 | 8.1.4 | 8.1.5 | 8.1.6 | 8.1.7 | 9.0.0 | 9.0.1 | 9.2.0} I noticed when I keep it default to 9.2.0 in init.ora, in version 9.2.0.3 and 9.2.0.5 with exact same database and exact same init.ora, oracle CBO did choose different plan. So there is some difference between 9.2.0.X versioin for the CBO. Where can we get such information about the difference? Thanks On 12 Jul 2005 23:37:28 -0700, "ch...

Can't get PCI Network Card to Work
Hello, I have an IBM Pentium III 663MHz PC (desktop) which I've been trying to get a Linux Distro to work on with Networking successfully. I know it can be done, because this box has been loaded with an early version of Redhat and operated as a web server. I wanted to start fresh so I wiped the system clean with Redhat 8 - which was able to come up quickly and correctly detect the network card that was installed. However it could not "initialize" the card. I knew that Redhat 8 had some issues, so I installed Redhat 7.2. The results were the same. So know I've taken out the...

Can't get PCI Network Card to Work
Hello, I have an IBM Pentium III 663MHz PC (desktop) which I've been trying to get a Linux Distro to work on with Networking successfully. I know it can be done, because this box has been loaded with an early version of Redhat and operated as a web server. I wanted to start fresh so I wiped the system clean with Redhat 8 - which was able to come up quickly and correctly detect the network card that was installed. However it could not "initialize" the card. I knew that Redhat 8 had some issues, so I installed Redhat 7.2. The results were the same. So know I've taken out the "big guns" - as it seems that Knoppix (4.0.2 in my case) will work with just about everything. But the results, sadly, are not much different. PCI is my only choice as the IBM only has PCI slots. I have two NICs that I've tried - and the results are pretty much the same: Card #1: This was the card that has been in there when the box was a web server - 3Com 10/100 TX Fast Etherlink XL PCI 2 - 3c905B-TX NM All three distros are able to probe the card correctly and select (what I would guess to be) the correct driver. I've tried toassign an IP through DHCP and also by assigning it a static IP - neither case worked. Card #2: (Test individually - not at the same time as card #1) - D-Link DFE-530TX REV-A1 All three distros were also able to select the correct driver for this card. I tried both DHCP and static IP. When I assigned the D...

select rowid help for oracle 9.2.0.2.0
hi, i'm hoping someone can help me with this. here's the scenerio, i have a million row table a and i do the following: begin for i in ( select /*+ full(a) */ a_column from a) loop null; end loop; end; / runtime: 2 minutes now, i try the following: begin for i in ( select /*+ full(a) */ rowid from a) loop null; end loop; end; / runtime: 10+ minutes (i've never waited long enough for it to complete) i do not know how to explain the difference in time. i believe this is a pl/sql bug. i can do a [select /*+ full(a) */ a_column from a] or [select /*+ full(a) */ rowid from a] in sq...

update Oracle from 10.2.0.2.0 to 10.2.0.2.0
Where can I get the software for 10g 10.2.0.2.0. for Windows XP 32 bit. Thank you very much. "keekee" <moongeegee@gmail.com> a �crit dans le message de news: f3b21ed0-12fd-4812-b9da-60cf59d508b9@i9g2000yqi.googlegroups.com... | Where can I get the software for 10g 10.2.0.2.0. for Windows XP 32 | bit. | Thank you very much. On Metalink (My Oracle Support). https://support.oracle.com/CSP/ui/flash.html Regards Michel ...

Win2kSP4, Apache-2.0.49 + Tomcat-5.0.27 + mod_jk2-2.0.43
OS: Windows 2000, Service Pack 4 Apache ver.: 2.0.49 Tomcat ver.: 5.0.27 mod_jk2 ver.: 2.0.43 We have a server set up to forward requests through Apache to Tomcat using mod_jk2. The setup works, except that periodically it will throw an error as follows on the server: - Application popup: Apache.exe - Application Error : The instruction at "0x6eec7826" referenced memory at "0x00000000". The memory could not be "read". - On the user end, the web app is not interrupted when this happens. In the mod_jk2 error log, the following lines appear when ...

devpi-{server-2.2.2,web-2.4.0,client-2.3.0} releases
We just released devpi-server-2.2.2, devpi-web-2.4.0 and devpi-client-2.3.0, core parts of the private pypi package management and testing system. Among the highlights are support for distributed testing with "devpi test --detox", new status pages at "/+status" for replica and master sites and support for configuring upload formats when running "devpi upload". None of the changes require an export/import cycle on the server side if you used devpi-server-2.2.X before. However, please read the respective changelog entries below for some notes and poten...

mod_perl 2.0.3 and apache 2.0.x and 2.2.x^
Hello NG, can I install the mod_perl 2.0.3 ppm packages for bothe server versions of apache? (perl 5.8.x, ActiveState/Win32) It would be good to have both installed. "mod_perl-2.0" (apache 2.0.x) _AND_ "mod_perl" (apache 2.2.x) Thomas ...

Why does '[1,2,3] EQ [2]' yield zero but '[1,2,3] EQ 2' yield [0,1,0] ?
Hi all, The post title says it all. I thought "everything" in IDL was an array, but using [2] and 2 with relational operators is not equivalent... I searched the doc and newsgroup for quite a while, but obviously I did not come up with search terms that are specific enough. It took me a while to track this down in some code I was writing. My bug is now fixed *but* I don't understand why exactly. And we all know voodoo and IDL don't mix :-) can somebody clarify please? Many thanks, Gianguido PS: I have a feeling this issue came up not too long ago, just couldn't find...

exmh 2.7.0: OK, 2.7.2: 'tkerror: can't read "pgp(pgp6,path)": no ...'
Hiya, I just upgraded to Mandriva 2007.0, which comes with exmh 2.7.2. I tried that, but I got one of those traceback windows and this in the xterm where I started exmh: exmh: tkerror: can't read "pgp(pgp6,path)": no ... exmh: tkerror: can't read "exwin(mtext)": no s ... I rebuilt my 2.7.0 exmh from my previous OS. It runs just fine. I'm running tcl-8.4.13 & tk-8.4.13, both shipped with Mandriva, if that matters. What could the problem be? Thanks.... -- PLEASE post a SUMMARY of the answer(s) to your question(s)! Show Windo...

Photoshop 6.0 under MacOS 9.2.2 doesn't launch anymore
Since I've installed Suitcase 9.0 on my system an therefore removed all fonts but the system fonts from the fonts-folder within the system-folder, Photoshop interrupts the starting progress at the point when it is trying to sort the fonts (in German: "Sortiere die Schriften"). I assume, Photoshop misses some fonts. But which? How could I find out, or does someone know, which fonts have to be in the "Fonts"-Folder? ...

Help Needed: Upgrade Fedora 4 / Apache 2 to PHP 5.2.x from 5.0.4
Help Needed: Upgrade Fedora 4 / Apache 2 to PHP 5.2.x from 5.0.4 I've been testing Joomla as a content manager for the County offices, and it looks pretty good. Unfortunately, I decided to upgrade it from the 1.0.13 version to 1.5 as we get ready to go live with the web site... and the update installation gives an error in XML processing, which seems (from what I've been able to dredge up in forum discussions) to stem from a known bug in PHP 5.0.4... I've seen this same error from a couple of other programs that want to upload XML data to PHP based server software, too, so I'...

upgrate from 9.2.0.1.0 to 9.2.0.7.0
how to upgrade.... storm pixie wrote: > how to upgrade.... You grab the upgrade download and install it. Or you re-install from a complete base version. No rocket science, just follow the instructions. On 17 May 2006 17:55:59 -0700, "storm pixie" <amit.dba@gmail.com> wrote: >how to upgrade.... go to metalink download patch. find readme.html in the patch dowloaded follow test on non-production system first when it doubt, re-read the readme. ........ We run Oracle 9iR2,10gR1/2 on RH4/RH3 remove NSPAM to email Download patch or request a cd from oracle supp check the ...

Help needed: Where can I find patch 9.2.0.2
Hi, I want to run datamining samples on Oracle 9.2.0.1 and thus need to install patch 9.2.0.2 according to the oralce document "Oracle9i data mining page A-2. But a Support Identifier number (that is one of CSI, SAC, Access Code) is needed for registration to download the patch. It's unresonable because Oracle 9.2.0.2 is free to download although it is really a pain, but the patch is not free to download!!. Could someone figure it out for me. Thanks. Jin yj wrote: > Hi, I want to run datamining samples on Oracle 9.2.0.1 and thus need > to install patch 9.2.0.2 according to the oralce document "Oracle9i > data mining page A-2. But a Support Identifier number (that is one of > CSI, SAC, Access Code) is needed for registration to download the > patch. It's unresonable because Oracle 9.2.0.2 is free to download > although it is really a pain, but the patch is not free to > download!!. Could someone figure it out for me. Thanks. Jin > I think Oracle is just trying to encourage people to live within the license agreements they have made. Seems reasonable to me. -- Daniel Morgan http://www.outreach.washington.edu/ext/certificates/oad/oad_crs.asp http://www.outreach.washington.edu/ext/certificates/aoa/aoa_crs.asp damorgan@x.washington.edu (replace 'x' with a 'u' to reply) It might be reasonalbe to you but not to me or someone else who just start to learn it. At least on th...

TRSDOS II, version 4.2.0, 4.2.2, 4.2.4, 4.2.6 (or 4.3.x or 4.4)
Hi, Group I require a copy of the above DOS, but I need it _on disk_ as I do not have an emulator for the Model II that must be tested. Is there any possible sources of the OS on disk, or can you advise if the original 8" drive can be hooked to another device so that I can transfer an electronic copy to the disk to boot the machine? What other options do I have? Thanks L replying to my own post :-) I found an article here (http://www.tim-mann.org/trs80resources.html) where Tim describes a trick to rescue a disk's contents. This should be a workable solution...

GtkAda 2.2.0
I'm taking a first shot at using GtkAda 2.2.0 and running into a show-stopper when trying to create a project with Glade-2. I'm using pretty much the default options except for picking my own directory and project name & I get the following: (glade-2.exe:1928): Gdk-WARNING **: gdk_property_delete: General case not implem ented (glade-2.exe:1928): Gdk-WARNING **: window 0x00110466 unexpectedly destroyed This is on a Windows XP platform. Anybody got a clue as to what is going on? Its a pretty significant flaw for a tool if you can't create a project. MDC -- ===========...

[Linux Suse 8.0 Prof 2.4.22 GTK+2.0.4] File dialog doesn't show all files in directory
I'm using the followoing code to browse the directories for the user to pick a file. The problem is that not all files are shown in the dialog. I choose /usr/X11R6/bin as the path and some files are shown in the dialog, but most are not. There are 9 files displayed in the dialog while there are about 250 files in the directory. Also the permissions are not shown properly. There seem to be only the user permissions displayed instead of all the permissions. I checked the permissions from the files that are shown, but they are no different then from the other files. { wxString pat...

Web resources about - Help can't run properly Apache 2.0.48 / mod_jk2 (2.0.2) /Tomcat 4 on Solaris 9 - comp.lang.java.help

Resources last updated: 3/9/2016 4:46:03 PM