java plugin for linux firefox 3.6

  • Permalink
  • submit to reddit
  • Email
  • Follow


Hi,
as for older versions of firefox I did this :
ln -s /home/thorsten/jdk1.7.0/jre/plugin/i386/ns7/libjavaplugin_oji.so .mozilla/plugins/ -f
But this doesn't work anymore.
Has something changed in 3.6 ?

Regards
Thorsten

0
Reply cylinder2 (11) 3/25/2010 12:53:44 PM

See related articles to this posting


On 25/03/10 12:53, Thorsten Kiefer wrote:
> as for older versions of firefox I did this :
> ln -s /home/thorsten/jdk1.7.0/jre/plugin/i386/ns7/libjavaplugin_oji.so .mozilla/plugins/ -f
> But this doesn't work anymore.
> Has something changed in 3.6 ?
>   

Yes - just discovered how to fix that myself.  Look for a libnpjp2.so
file in the JRE, and symlink to that.

-- 
ss at comp dot lancs dot ac dot uk

0
Reply Steven 3/25/2010 2:33:47 PM

Steven Simpson wrote:

> On 25/03/10 12:53, Thorsten Kiefer wrote:
>> as for older versions of firefox I did this :
>> ln -s /home/thorsten/jdk1.7.0/jre/plugin/i386/ns7/libjavaplugin_oji.so
>> .mozilla/plugins/ -f But this doesn't work anymore.
>> Has something changed in 3.6 ?
>>   
> 
> Yes - just discovered how to fix that myself.  Look for a libnpjp2.so
> file in the JRE, and symlink to that.
> 

Mucha Gracias, how did you find that out ?

0
Reply Thorsten 3/26/2010 10:48:24 AM

On 26/03/10 10:48, Thorsten Kiefer wrote:
> Steven Simpson wrote:
>   
>> Yes - just discovered how to fix that myself.  Look for a libnpjp2.so
>> file in the JRE, and symlink to that.
>>     
> Mucha Gracias, how did you find that out ?
>   

I probably should have gone to the source:

<http://java.sun.com/javase/6/webnotes/install/jre/manual-plugin-install-linux.html>

....but I just anticipated that Google would have crawled a few relevant
web-forum threads by now.

-- 
ss at comp dot lancs dot ac dot uk

0
Reply Steven 3/26/2010 2:10:56 PM
comp.lang.java.programmer 51894 articles. 38 followers. Post

3 Replies
184 Views

Similar Articles

[PageSpeed] 17


  • Permalink
  • submit to reddit
  • Email
  • Follow


Reply:

Similar Artilces:

Firefox 3.6.3 Java plugin issue
I Downloaded the zip file to install FF 3.6.3 I baulked at installing it because the readme file says near the top: "!IMPORTANT! The java plugin _won't_ work with firefox >= 3.6" My frequently used internet banking site uses Java to present things. What is the situation here? Am I now stuck on ver 3.5.3? -- To reply by e-mail edit this address to the correct form: vbien at attglobal dot net System: ASUS K8VSE mb, Sempron 3000+, 1028 MB DDRAM, ATI 9550 video, Soundblaster Live soundcard, on-board NIC, 500 GB SATA primary disk, IDE secondary disk, LG CD burne...

Java plugin for Firefox and JSE 6.0 on Linux
I have installed the Mustang b88 JDK but cannot get the plugin to work with Firefox under Linux (FC5). Firefox knows the plugin is installed because about:plugins displays all the relevant information but applets simply display as a empty white squares. There are no error messages. Has anyone got this to work? Is there a trick I am missing? Thanks, Wes -----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 Wes Harrison schreef: > I have installed the Mustang b88 JDK but cannot get the plugin to work with > Firefox under Linux (FC5). Firefox knows the plugin is installed because &...

[News] Signs of The Times: GNU/Linux and Firefox for Work, Firefox 3.6 Beta 3 Near
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 Signs O' The Times ,----[ Quote ] | 3. I am using my own laptop, as apparently | there isn't the budget even for mices. This | doesn't bother me overly, though it does | strike me as a tad cheeky. The upside is that | I'm using Ubuntu in a shared production | environment for the first time ever. This | includes GIMP, Geany, Evolution and Firefox. `---- http://community.zdnet.co.uk/blog/0,1000000567,10014472o-2000332346b,00.htm Firefox 3.6 Beta 3 (Revision 3) Is Cooking ,----[ Quote ] | Mozilla is cooking a new Beta Build ...

Installing java plugin 1.3.1 on Netscape 6.2.3
Hi Folks, I am running Netscape 6.2.3 on SOlaris 9. I have an applet that need to use the plugin "application/x-java-applet;jpi-version=1.3.1" when I look at the "about plugin" under "Help", I see that the only installed one is: "application/x-java-applet;jpi-version=1.4.1_01a" Q1: how do I add the plugin 1.3.1 required? Q2: how come the current 1.4.1 plugin is not compatible? Thanks, In article <67cbfc23.0406140841.6b919c0c@posting.google.com>, Meyos <yemveng@yahoo.ca> wrote: >Hi Folks, >I am running Netscape 6.2.3 on SOlaris 9. ...

java in firefox 3.6
Hi, I can't get java(jre 1.6.0.18) to work under S10/amd and firefox 3.6! Has somethings changed in the install or what can I have done, I have updated forefox mozilla and jre numerous times until now! /michael In article <7vfksvF9stU1@mid.individual.net>, Michael Laajanen <michael_laajanen@yahoo.com> wrote: >I can't get java(jre 1.6.0.18) to work under S10/amd and firefox 3.6! With Indiana and SFWfirefox: # ln -s /usr/java/jre/lib/i386/libnpjp2.so /opt/sfw/lib/firefox/plugins/ Happy hacking, John groenveld@acm.org ...

Firefox 3.6 and Java
The UPDATE file for the ports collection has a note dated 2 Feb saying that the Firefox port is now version 3.6, but Java doesn't work so if you want Java stay with 3.5. It's been two more months and I see we're now up to version 3.6.3_1. Anyone know if Java works with 3.6 yet? R's, John John Levine wrote: > It's been two more months and I see we're now up to version 3.6.3_1. > Anyone know if Java works with 3.6 yet? Not yet as far as I know. The plugin provided with diablo-jre/jdk is still the old OJI plugin format. Firefox 3.6 and above ...

LINUX+PPC+FIREFOX+JAVA PLUGIN??
Is there a solution to provide Java support to Firefox and Mozilla under Linux and PPC? I know there is a v1.3.1 Java/Plugin from Blackdown, but Firefox and Mozilla requires v1.4.x or better. IBM has a JRE/SDK v1.4.x but they have no plugin. Any ideas? abpp <abpp@mail.com> wrote: > Is there a solution to provide Java support to Firefox and Mozilla > under Linux and PPC? I know there is a v1.3.1 Java/Plugin from > Blackdown, but Firefox and Mozilla requires v1.4.x or better. IBM has a > JRE/SDK v1.4.x but they have no plugin. > Any ideas? Got it covered. Check the follo...

java servlets, javascript and firefox 3.6
I have been told on a firefox support forum to ask in a java forum (although I'm still convinced it is a firefox problem). I had an arrangement like this, which has been working for 5 years (and still works with old versions of firefox). There is a frameset (on host a port 80). The frameset contains two frames. Its HEAD defines a number of javascript functions, The top frame (a page on host a port 80) contains a form. The action of the form is a java servlet (potentially running on a different host, can be host b port 8080, or host a port 8080 which for what the browser...

FreeBSD 6.1 linux-firefox and java help
I've been struggling with freebsd firefox and getting flash to work (sometimes it works, most of the time it doesn't)! It displays things wrong and crashes often blah blah. I have linux-firefox working great. It plays flash files fine and works mostly except for the java. I cant seem to get it working well at all. I read that there is a linux-sun-jdk15 that supposedly works for linux-firefox but it is DOA due to security issues. Does anyone have any suggestions on getting this working? In article <18hsub000eic0$.7qc7tlxet7oe$.dlg@40tude.net>, Dave <bl@wme.com> ...

[News] Review of Firefox 3.6 Alpha on GNU/Linux
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 Firefox 3.6 a1: new CSS features, faster JavaScript ,----[ Quote ] | Mozilla has released the first alpha of Firefox 3.6. Ars takes a look at the | new features, such as CSS gradients. `---- http://arstechnica.com/open-source/news/2009/08/firefox-36-a1-new-css-features-javascript-speed-boost.ars Mozilla invites dark lords, Lando to play code swaps on Bespin ,----[ Quote ] | Mozilla Labs has added collaboration services to the latest version of its | cloud-based development project - Bespin. `---- http://www.theregister.co.uk/2009/08/14/mo...

[News] A Look at Firefox 3.6 (Alpha) for GNU/Linux
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 Mozilla Releases Firefox 3.6 Alpha, Codenamed 'Namoroka' ,----[ Quote ] | Currently few add-ons are available for this alpha, the other ones are | compatible only with 3.5 and older releases (which is normal given that 3.6 | is only in alpha and it won't be available until late 2009). The popular | extension Adblock Plus can be installed in 3.6 at the time of writing, | however popular themes or add-ons like Greasemonkey or Noia 2.0 eXtreme are | not available yet. `---- http://tuxarena.blogspot.com/2009/08/mozilla-release...

[News] Firefox 3.6 is Already Running on GNU/Linux
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 Install Firefox 3.6 alpha1pre Minefield in Ubuntu (from repository) http://webupd8.blogspot.com/2009/04/install-firefox-36-alpha1pre-minefield.html Recent: Desktop web apps and snappiness top next Firefox (Namoroka) plans ,----[ Quote ] | Following the tradition of using national park names as code names for | Firefox releases, Mozilla has chosen Namoroka, located in Madagascar, for the | development cycle that started a few months ago when Mozilla decided to | branch the current Firefox 3.5 (Shiretoko) and proceed with the development | of t...

Mathematica browser plugin with Firefox 3.6.x or 4 beta
Hi all, Could anyone confirm that the browser plugin that ships with Mathematica 8 (this is not the player, btw) works with Firefox 3.6.x? I'm using the beta version of Firefox 4 and the plugin doesn't seem to work with this. Also tried it on the beta versions of Chrome (doesn't work) and IE 8 (works, but with IE, an ActiveX control is used to interface to Mathematica and not the plugin used by Firefox/Chrome). I'm trying to determine if it's Mathematica at fault or Firefox. If someone running 3.6.x of Firefox is able to successfully run the demonstrations, I would re...

[News] Firefox Mobile is Coming to Linux, TrueCrypt 6.3 Released
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 Firefox Mobile on the way ,----[ Quote ] | The current version of Fennec - which is | available in an early alpha form for Maemo | devices such as Nokia's latest N900 smartphone | - is based on the Firefox 3.6 rendering engine, | which is a step ahead of the engine used in the | current desktop release of the browser. This | technology means that when Fennec finally hits | 'phones, it will offer the a complete browsing | experience - in Lilly's words, "a browser that | [does] everything - JavaScript, CSS, Flash, SVG | [...

Command-click no longer opens url in background: Firefox 3.6.x (3.6.3)
In Eudora 6.2.4 (Mac) doing a command-click on a link no longer opens it in the background (Firefox 3.6.2-3.6.3). Initially with FF 3.6.0, there were problems with links that had spaces in them (not just in Eudora), so I went back to FF 3.5.8 (or maybe 3.5.7 at the time). In FF 3.6.2 you could double-click on a link and it would open (with focus shifted to FF) but command-click no longer worked. Same with FF 3.6.3. Opening a html page in the browser also works for 3.6.2-3.6.3. Interestingly, in Google Chrome command-click does open the link in the background. Bummer, opening a li...

[News] Firefox 4.0 Now in Beta, Firefox 3.6.6 Released
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 A Look At The Latest Firefox 4.0 Design ,----[ Quote ] | The Mozilla Firefox developers are working | on several different branches of the web | browser at the same time. The latest public | version, Firefox 3.6.6 just released today, | and Firefox 3.7 which will be renamed to | Firefox 4.0 later this year. `---- http://www.ghacks.net/2010/06/27/a-look-at-the-latest-firefox-4-0-design/ Update: Mozilla Posts Firefox 4.0 Beta 1 Build ,----[ Quote ] | If you have been using a previous version | of Firefox 3.7, which now officially | become...

[News] Pioneer Linux 3.0.2 Released, Firefox 3.0 Praised by Firefox Critic
Pioneer Linux 3.0.2 has been released ,----[ Quote ] | The Pioneer Explorer and Renegade offerings include the LinSpire CNR client | preinstalled. | | [...] | | The current final release candidates all use KDE, which has a simpler | interface for Windows users to transition to Pioneer. It is expected that | Renegade will be released early next week with a Gnome interface to meet the | community demand for a different interface. No decisions have been made as of | yet to include the Gnome desktop as a Basic offering wrapped with support. `---- http://linuxmini.blogspot.com/2007/1...

errors during clan-2.0.3 on linux 2.6.6-1.435.2.3
Hi, I'm trying to compile clan-2.0.3 drivers on kernel version 2.6.6-1.435.2.3. I'm getting erros on some missing files (see below). I installed the kernel sources prior to compiling the clan drivers. Any help in this will be greatly appreciated clan1k.c:49:27: linux/wrapper.h: No such file or directory clan1k.c:50:26: linux/tqueue.h: No such file or directory /lib/modules/2.6.6-1.435.2.3/build/include/asm/irq.h:16:25: irq_vectors.h: No such file or directory /lib/modules/2.6.6-1.435.2.3/build/include/linux/irq.h:70: error: `NR_IRQS' undeclared here (not in a function...

Performance of NFS much lower on Linux kernel 2.6.17 then on Linux kernel 2.6.3?
Maybe somebody can help me with this problem: I export several directories from a Novell server and mount them on a Linux machine to have some remote backup and storage facilities. A few years back I have installed a Mandrake 10.0 box with kernel 2.6.3 and after some tinkering the NFS performance was about 3.5 MByte/s on a 100 Mbps full duplex interface card. The FTP performance to and from that same Mandrake box was about 7 MByte/s. This year I upgraded my hardware and I installed Mandriva 2006 using kernel 2.12.12 on the Linux machine. Using exactly the same mount options I get...

SW: Security updates for Firefox 3.6.16, Firefox 3.5.18 and Seamonkey 2.0.13
++ From the VOICE OS/2-eCS News Service http://www.os2voice.org ++ From: wunoDESPAM@DESPAMlsvw.de Hi, Firefox was updated to 3.5.18, 3.6.16 and SeaMonkey to 2.0.13, the OS/ 2 builds are available now. They're just interim security updates. Get them here: http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.5.18/co ntrib/firefox-3.5.18.en-US.os2.zip http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.6.16/co ntrib/firefox-3.6.16.en-US.os2.zip http://releases.mozilla.org/pub/mozilla.org/seamonkey/releases/2.0.13/ contrib/seamonkey-2.0.13.en-US.o...

using Orbix 3.3 and Orbix 6.3 C++ libraries in the same application on Linux.
Hi All, Im pretty new to Corba and Orbix. And i have at hand an application which was using Orbix 3.0.1. I have kind of migrated it to Orbix 3.3. The issue is that it has a dependency on another 3rd party software which uses orbix 6.3. I was able to link fine, first linking the 3.3 ones with the application code and then the 6.3 libraries at the end to the linker. I have the binary, but i get several kind of errors when i try to bind/connect to another orbix 3.3 server. Sometimes it connects tooo. =========================================================== Here the _bind gives an exc...

Informix4GL no longer compiles on Linux 2.6 kernel with gcc 3.3.3
Now this really is a problem. Using Informix 7.3 (4gl, IDS, esql, fourjs (3.20), RDS) on SuSE Linux 9.1 with kernel 2.6 and gcc 3.3.3 Error: __GLIBC__2.0 not supported, while support for them IS present in glibc. As a result 4gl no longer compiles, nor does FourJs. Funny thing: RDS has NO problems at all. Setting LD_ASSUME_KERNEL to 2.4.1 helps a little bit, as does __POSIX2_VERSION_=1999... but not enough, Very small program: main define lc_name char(50) open window wrtest1 at 10, 10 with 4 rows, 60 columns attribute (border) prompt "Give a name: " for lc_name ...

Re: Informix4GL no longer compiles on Linux 2.6 kernel with gcc 3.3.3
Robert A. Reissaus said: > Now this really is a problem. > > Using Informix 7.3 (4gl, IDS, esql, fourjs (3.20), RDS) on SuSE Linux > 9.1 with kernel 2.6 and gcc 3.3.3 > > Error: __GLIBC__2.0 not supported, while support for them IS present > in glibc. As a result 4gl no longer compiles, nor does FourJs. Funny > thing: RDS has NO problems at all. Why is that funny? RDS doesn't compile down to C... -- Bye now, Obnoxio "C'est pas parce qu'on n'a rien � dire qu'il faut fermer sa gueule" - Coluche "I'm tryi...

Re: Informix4GL no longer compiles on Linux 2.6 kernel with gcc 3.3.3 #2
Hi, The `mktemp', `__ctype_b', `__ctype_toupper' errors that you seem to be getting, were all resolved in the last release of 4GL on Linux - version 7.32.xC2. Please use passport advantage to download the latest version. If you still have support, you should be able to ask for patches from Tech Support, if upgrading to the latest version is an issue ( though I would not entirely recommend a patch). An upgrade would be a better option. Thanks and Regards, Abhi. -------------------------------------------------------------------- There are 10 ...