f



java.lang.UnsupportedClass error

> java -jar squirrel-sql-2.4-install.jar> Exception in thread "main" java.lang.UnsupportedClassVersionError: com/> izforge/i> zpack/installer/Installer (Unsupported major.minor version 48.0)>        at java.lang.ClassLoader.defineClass0(Native Method)>        at java.lang.ClassLoader.defineClass(Unknown Source)>        at java.security.SecureClassLoader.defineClass(Unknown Source)>        at java.net.URLClassLoader.defineClass(Unknown Source)>        at java.net.URLClassLoader.access$100(Unknown Source)>        at java.net.URLClassLoader$1.run(Unknown Source)>        at java.security.AccessController.doPrivileged(Native Method)>        at java.net.URLClassLoader.findClass(Unknown Source)>        at java.lang.ClassLoader.loadClass(Unknown Source)>        at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)>        at java.lang.ClassLoader.loadClass(Unknown Source)>        at java.lang.ClassLoader.loadClassInternal(Unknown Source)> Any suggestions?> email me at tyrone_...@yahoo.com or tyrone_...@hotmail.com
0
tyrone_bak (13)
3/12/2007 12:21:52 AM
comp.lang.java.programmer 52714 articles. 0 followers. Post Follow

3 Replies
662 Views

Similar Articles

[PageSpeed] 12

On 11 Mar 2007 17:21:52 -0700, tyrone_bak@yahoo.com wrote, quoted or
indirectly quoted someone who said :

>Exception in thread "main" java.lang.UnsupportedClassVersionError: com/

see
http://mindprod.com/jgloss/runerrormessages.html#UNSUPPORTEDCLASSVERSIONERROR
-- 
Canadian Mind Products, Roedy Green, http://mindprod.com
Priorities: Prevent global climate destabilisation. End both wars. Prepare for oil shortages.
0
Roedy
3/12/2007 12:31:15 AM
<tyrone_bak@yahoo.com> wrote in message news:1173658912.721070.87720@q40g2000cwq.googlegroups.com...>> java -jar squirrel-sql-2.4-install.jar>>>> Exception in thread "main" java.lang.UnsupportedClassVersionError: com/>> izforge/i>> zpack/installer/Installer (Unsupported major.minor version 48.0)It's not the class that's unsupported; it's the class file *version*.  It was created with a compiler more recent than your JVM.48.0 corresponds to JDK 1.4, so you're trying to run with something older than that.
0
Mike
3/12/2007 1:44:10 AM
On Mar 11, 8:44 pm, "Mike Schilling" <mscottschill...@hotmail.com>wrote:> <tyrone_...@yahoo.com> wrote in message>> news:1173658912.721070.87720@q40g2000cwq.googlegroups.com...>> >> java -jarsquirrel-sql-2.4-install.jar>> >> Exception in thread "main" java.lang.UnsupportedClassVersionError: com/> >> izforge/i> >> zpack/installer/Installer (Unsupported major.minor version 48.0)>> It's not the class that's unsupported; it's the class file *version*.  It> was created with a compiler more recent than your JVM.>> 48.0 corresponds to JDK 1.4, so you're trying to run with something older> than that.After I updated my JDK or JVM, I was able to complete the install.Now, I need SQL 101 guidance.
0
tyrone_bak
3/16/2007 7:02:18 PM
Reply: