f



jdk 1.4 and java.lang.UnsupportedClassVersionError

Got some code that work with the compiler set to jdk 1.3, but when i set the
compiler to jdk 1.4 i get this error:

[java] java.lang.UnsupportedClassVersionError: no/ds/ejbgen/EjbGenerator
(Unsupported major.minor version 48.0)

[java] at java.lang.ClassLoader.defineClass0(Native Method)

[java] at java.lang.ClassLoader.defineClass(ClassLoader.java:703)

[java] at
java.security.SecureClassLoader.defineClass(SecureClassLoader.java:133)

[java] at java.net.URLClassLoader.defineClass(URLClassLoader.java:320)

[java] at java.net.URLClassLoader.access$400(URLClassLoader.java:93)

[java] at java.net.URLClassLoader$ClassFinder.run(URLClassLoader.java:678)

[java] at java.security.AccessController.doPrivileged(Native Method)

[java] at java.net.URLClassLoader.findClass(URLClassLoader.java:239)

[java] at java.lang.ClassLoader.loadClass(ClassLoader.java:516)

[java] at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:460)

[java] at java.lang.ClassLoader.loadClass(ClassLoader.java:448)

[java] Exception in thread "main"


Is 1.4 not backward compatible with jdk 1.3 generetad code? What should i do
to solve this. Jusing IDE called WSAD 5.1.1 that can target jdk 1.4 code.
Any hints?
Thanx in advance KS


0
katos75 (7)
3/5/2004 11:02:31 AM
comp.lang.java.programmer 52714 articles. 1 followers. Post Follow

1 Replies
409 Views

Similar Articles

[PageSpeed] 19

"KS" <katos75@hotmail.com> writes:

> [java] java.lang.UnsupportedClassVersionError: no/ds/ejbgen/EjbGenerator
> (Unsupported major.minor version 48.0)

This means a Java process running in a pre-1.4 VM tries to access
classes compiled for 1.4. When do you get this error? When compiling
or running? In your code or someone else's code?
0
3/5/2004 5:24:12 PM
Reply: