f



RMI between Java 1.4 and Java 1.5 problem

When attempting to RMI between a 1.4 client and a 1.5 server ( with a
1.5 interface, remote object, stubs and skeletons using the -vcompat
rmic flag ), I get the following error:

        java.lang.ClassNotFoundException:
java.rmi.server.RemoteObjectInvocation
Handler (no security manager: RMI class loader disabled)

The plot thickens. The 1.4 client will connect to the 1.5 server if I
run the 1.4 client classes in a 1.5 jvm. However, when I run the 1.4
compiled classes in a 1.4 jvm I get no joy.

Any ideas anyone?

The context is this: getting a Java strored procedure in an Oracle
database running a 1.4 jvm to send "trigger" information to a  java
1.5 server on a different machine.

BTW, the rmi interface is very simple. One method, no return type and
the only passed parameter is a string.
0
3/22/2005 9:13:51 AM
comp.lang.java.programmer 52714 articles. 1 followers. Post Follow

1 Replies
783 Views

Similar Articles

[PageSpeed] 16

Fran Cottone wrote:
> When attempting to RMI between a 1.4 client and a 1.5 server ( with a
> 1.5 interface, remote object, stubs and skeletons using the -vcompat
> rmic flag ), I get the following error:
> 
>         java.lang.ClassNotFoundException:
> java.rmi.server.RemoteObjectInvocation
> Handler (no security manager: RMI class loader disabled)
> 
> The plot thickens. The 1.4 client will connect to the 1.5 server if I
> run the 1.4 client classes in a 1.5 jvm. However, when I run the 1.4
> compiled classes in a 1.4 jvm I get no joy.

You are running your server classes in a 1.5 JVM and they are exporting 
stubs based on RemoteObjectInvocationHandler because you haven't 
compiled the stubs with rmic. If you want to interoperate with <= 1.4 
clients you must provide stubs. RemoteObjectInvocationHandler is a 1.5-ism.

EJP
0
3/22/2005 11:47:54 PM
Reply: