f



How can I run a labview 7.2 vi in labview 8.2

We have several versions of labview running different test and control functions in our facility. There are labview 7.2 VIs in a production setting I wish to reproduce in the test lab. Can I convert them to run on 8.2 or do I have to recreate them in 8.2. I tried to open one in 8.2 and got multiple SubVI's that were not in my program library.. most dealing with AI manipulation.
 
0
x9561 (148441)
2/20/2007 9:40:13 PM
comp.lang.labview 35213 articles. 1 followers. vasusachin24 (1) is leader. Post Follow

1 Replies
1047 Views

Similar Articles

[PageSpeed] 9

And make sure you have backup copies of your 7.x code. Once you load and save in 8.2, it is a lot of work to get them back to 7.x.
Note I used 7.x because I am unaware of LabVIEW version 7.2 even existing. 7.1.1 was the last release prior to 8.0
0
x9561 (148441)
2/20/2007 9:40:16 PM
Reply:

Similar Artilces:

labview 8.2 llb run with labview 8.5
On the PC I have delete labview 8.2, but I dont find the CD for reinstall. I have a .llb file made with labview 8.2, Can i run it with labview 8.5 or download labview 8.2, I muss install ii rapidelly.   tks Costello, you can update the VIs within the LLB to LV 8.5 if they do not have their blockdiagram removed.....hope this helps,Norbert How can I update ? When I start the .vi in the lbb he dont found somme .vi located in DAQmx (wrtie.lbb, start task.lbb,...) How can i install this lbb? thks Costello, if you get loading errors when opening one VI from the LLB like you the ones you get, you have missing components.Since you spoke of DAQmx, i asume that you didn't install NI DAQmx on your machine. You should catch that up.hope this helps,Norbert ...

How to open Labview 8.5 VI in Labview 8.2
Hi I am using LabVIEW 8.2.I found one ook modulation example project(http://decibel.ni.com/content/docs/DOC-1394),it was developed in Labview 8.5.I have to oepn this one in My system mean in Labview 8.2.Please tell procedure.Is it possible or not.?Thnaking you sir. It is not possible directly. Somebody with access to version 8.5 needs to save it for version 8.2. Could you attach that particular vi in your post so that somebody can save it for 8.2 Thanks, Mathan Or you can install Labview 8.5 demo. Works for 30 days.... Hi Mathan,Thanks for your reply.i need OOK Modulation (FPGA).VI and OOK Modulation (HOST).VI in version 8.2Here i am attaching this two vi please save it in version 8.2 and send to me.Thanking you Sreenivasulu.O OOK Modulation.zip: http://forums.ni.com/attachments/ni/170/324620/1/OOK Modulation.zip Hi Sreenivasulu.O, i�m not sure if they are enough, but here they are. :smileyhappy: Mike OOK Modulation (FPGA).vi: http://forums.ni.com/attachments/ni/170/324624/1/OOK Modulation (FPGA).vi OOK Modulation (HOST).vi: http://forums.ni.com/attachments/ni/170/324624/2/OOK Modulation (HOST).vi Hi Mike,i got error like this.Here i am attaching two error image what i got.please check nad correct me.One more "OOK_Pack Bits for transmission.VI"  and "OOK_Configuration IF RIO for Transmission.VI" was not found.Thanking you sirSreenivasulu.O ook_error1.JPG: http://forums.ni.com/attachments/ni/170/327671/1/ook_error1.JPG ook_error2...

Labview 7.0 Vs Labview 8.2 Issue?
Hello, For a independent study Labview class I'm taking, I am trying to create a program that will input two different wav files and combine parts of them together for audio output. The first file I am trying to cut out the bass lines and replace them with the bass lines from the second file. Kind of like turning the second file into a karaoke version and filling in the vocals with the vocal line from the first file. A second option is simply taking the instrumentals from a song (a wav file containing only the bass line) and adding them to the first file after cutting out the original bass line of the first if this isn't possible. I found the attached file while searching for information/examples as to how to do this - it was originally posted at:http://forums.ni.com/ni/board/message?board.id=170&message.id=74618&requireLogin=FalseI tried running the file in Labview 8.20 and it came back with the error that "Build Screen.vi not found." I have searched for this file to download but have come up with nothing.Also, any tips/pointers/comments (or "there is no way this is possible") are much appreciated and very welcome. I have been searching to see if there is anything like this that has been done before and as of yet haven't been able to find anything. I am pretty new to Labview but I am a quick learner and I have a professor working with me on the project that is very familiar with Labview. However, it's spring break right no...

Why multihreaded soft worked under Labview 7 but is slower under Labview 8.2.1
Hello all ! &nbsp; I have a multithreated software developped under Labview 7.0. Under this version, multithreading can be enabled/disabled via the&nbsp;options menu&nbsp;/ performance &amp; disk section. This is not present under Labview 8.2.1. &nbsp; My software works properly under LW7 but is slower under LW8.2.1...how can I configure labview and or my vi&nbsp;to make it running as well as&nbsp;under LW7 ??? Is there a "hidden" option to enable/disable multithreading under LW8.2.1 ?&nbsp; &nbsp; Thank you for your help &nbsp; remi To disable multithreading, add ESys.StdNParallel=0 to the ini file. (See: <a href="http://digital.ni.com/public.nsf/websearch/2F606AD236C606008625718E00561A62?OpenDocument" target="_blank">http://digital.ni.com/public.nsf/websearch/2F606AD236C606008625718E00561A62?OpenDocument</a>) However, it is not celar that this is the problem. Did you save the entire hierachy under 8.2.1 after conversion (of course after making sutable backup copines of the 7.0 version ;)). Freshly converted, but not yet saved code runs typically much slower. Also, what do you mean by "slower" 10% slower, 10x slower? How do you measure speed? Thanks for your quick answer altenbach. The tips given at this link will really be useful to me! It seems that I made a wrong conversion of the files...fortunately I made suitable backup of the 7.0 version :smileywink:. I will investigate mor...

I have installed Switch Exec 2.1, running LabVIEW 8.2 and none of the VI's appear on my functions palette
See Subject Line. &nbsp; Thanks Chris ...

Installing the 8.2.1 run time engine on a system with LabVIEW 8.2 installed
Note: This is a <a href="http://forums.lavag.org/index.php?showtopic=7942" target="_blank">cross-post to LAVA</a>. If I have a system with LabVIEW 8.2 installed and I upgrade only the RTE to 8.2.1 (leaving LabVIEW 8.2 installed) will I run into any problems?- Will applications that I build in LabVIEW 8.2 still run correctly? - Which RTE will applications that I build in 8.2 require? (I'm presuming that the 8.2.1 RTE upgrade will not touch the lvapp.lib stub used by the app builder and that apps built in 8.2 will run in the 8.2 RTE) Here is what I (think I) know: - The 8.2.1 run time engine (RTE) is an upgrade to the 8.2 RTE, meaning that the 8.2 and 8.2.1 RTEs cannot be installed at the same time. - Applications built using LabVIEW 8.2 will run in the 8.2.1 RTE, however apps built using LabVIEW 8.2.1 require the 8.2.1 RTE and will not run in the 8.2 RTE Has anyone attempted this?Thanks, Hi Jim, Anything that we product that is X.X.X is mostly a bug fix release, and so you are correct in that it installs over X.X (your example 8.2.1 installs over 8.2 and so it is not possible to have them installed at the same time separately). It also means that there is a good chance that you can interchange VIs and projects without a problem, but it is not guaranteed. &nbsp; This means that applications built in LV 8.2 can run using 8.2.1 RTE, and LV 8.2.1 applications can probably run with 8.2 RTE, but it is highly recommended to have the same ve...

LabVIEW 8.2 -- "unable to locate LabView run-time" error message
I am trying to run a LabVIEW version 8 exe file and keep getting the "Unable to locate" error. I downloaded LabVIEW_8.2_Runtime_Engine.exe from the NI website and installed the entire contents of the distribution. After getting the error, I have tried uninstalling and reinstalling several times, with the same result. Is there some way I can troubleshoot this? Is there a configuration file or a registry entry I can check to see where LabVIEW is looking for the run-time? ...

Erro 10001 while running a VI in Labview 8.2
Hi, &nbsp; I'm a university undergrad that is currently running a final year experiment using Labview 8.2. I'm using a VI that created last year and when I run it I get an Error 10001 and it says something about a bad string. However there are no errors with the VI file itself. My device that I?m using is a PCI-6024E card with the NI-DAQ 7.4.4 drivers. &nbsp; Basically, in the experiment I am running a 5 volt analog input through the card (as I'm using a potentiometer). In Measurement and Automation,&nbsp;it can read the device and I have also&nbsp;run the test panel and everything checks out there. Is there something I have to do in the VI file? I'm really at a loss and don't have much time left to finish this project. &nbsp; I would be grateful for any help you could offer me. &nbsp; Thanks, Rory&nbsp; Is it possible if send someone the VI file that they can have a look at it? &nbsp; Here is the VI with the error 10001... &nbsp; Pitch Analysis.vi: http://forums.ni.com/attachments/ni/170/306890/1/Pitch Analysis.vi It looks like you have defined some channels or a task in MAX. It has been a long time since I've used traditional DAQ but I don't think you can do that. I think the channels/task you've defined can only be used with DAQmx. For traditional DAQ, use a channel number like '0' (without the quotes). Since your board and version of LabVIEW support DAQmx, you should be using tha...

saving vi in labview 7.1 and 8.2
Hi &nbsp; I am using LabView 7.1 and 8.2.I need to save a vi with all it's functionality in a single file.Is it doable ? Right now&nbsp; I have a main vi and quite a few vis are being used as subvis into this main vi.Now I need to send this vi to someone else without losing any functionality i.e. the person I am sending to , should be able to use this with all functional flexibility. &nbsp; Also let me know if there is any article to read on , about saving vis in LabView ( 7.1 and higher) depending on the application/purpose. Their are couple of options in LabView like save al...

[Urgent]How can I write to physical memory by using LabVIEW 8.2?? #2
Hi everybody, &nbsp; I am dealing with a project related to micro-EDM. We feed the gap voltage back to a NI&nbsp;DAQ card (not quite sure about the series number, might not be important&nbsp;to this problem), and we want to use this voltage to determine the command position of the motor, which is controlled by a Delta Tau PMAC motion controller. Now the problem is, the NI DAQ card and Delta Tau PMAC controller cannot communicate directly with&nbsp;each other. Therefore, we want the LabVIEW to write the value of voltage to a certain physical&nbsp;memory address, and then let the PMAC controller read that address. Is this feasible by using LabVIEW and NI-DAQ card? Which block or library in LabVIEW shall I use to achieve that? Or is there any alternative way to do it? Thanks a million! &nbsp; I have to get this done by the end of this week....if you know how to do it, please let me know. I really appreciate it!&nbsp;You are my lifesavor!&nbsp; &nbsp; Regards, Xiaofei I am not familiar with your hardware, but have a look at "out port". &nbsp; <a href="http://zone.ni.com/reference/en-XX/help/371361D-01/glang/out_port/" target="_blank">http://zone.ni.com/reference/en-XX/help/371361D-01/glang/out_port/</a> &nbsp;Message Edited by altenbach on 12-10-2007 06:18 PM ...

Converting LabView 4 vi. to LabView 7 vi.
I have a collection of programs written in LabView 4. I upgraded to LabView 7 recently. I am now trying to open my old 4 vi's with no luck. No block diagram is the error that I'm getting. Any ideas on converting would be greatly appreciated. Chris Without a block diagram, you cannot open a VI in a newer version because the block diagram is required for the recompile. The only way to upgrade is to find the original VIs with the source code. No one, NI included, can recover a block diagram once it has been deleted. Chris Merriman wrote: > I have a collection of programs written...

Can I run a LabVIEW 7.1 Application on a system with LabVIEW 6.1?
The VI App did not run properly, even after I installed the LabVIEW 7.1 Run time engine. Perhpas I need to uninstall the LV 6.1 run time engine? Thank you for any suggestions; perhaps it's something minor that I'm overlooking! Are you talking about a 7.1 exe or VI? An executable will run with 6.1 installed and the 7.1 run-time. A 7.1 VI will only run with 7.1 development system. When you say it did not run properly, what exactly do you mean? I am referring to trying to run a 7.1 EXE application on a system with a resident 6.1 development environment, and the 7.1 run-time engine ins...

Differences in CIN management between Labview 5.0 and Labview 7.1 ? #2
Hi, &nbsp; I'm using a VI on a two photon microscope. It steers the laser beam in the sample (quite the same way as a TV scan, scanning a fast line on the X axis, then moving the line down)&nbsp;controlling two mirrors by the&nbsp;PCI-MIO-16E-4 Multifunctions card&nbsp;on traditional DAQ and at the same time it serves as the acquitision through a non-NI DSP Multifunction-board with on-board buffers and hight data throughput (70 Mb/s). &nbsp; It is this part of the program which gives us strong headaches since we have upgraded to a new PC. On the old machine we used Win...

Re: Are Advantech products and its labview drivers good to work with Labview 7? #2
I have PCL 818L card. Where can I get the Labview drivers for the same Hi QWERTYU, maybe this helps: <a href="http://support.advantech.com.tw/support/DownloadSRDetail.aspx?SR_ID=1-2HYBNJ" target="_blank">http://support.advantech.com.tw/support/DownloadSRDetail.aspx?SR_ID=1-2HYBNJ</a> or this: <a href="http://support.advantech.com.tw/Support/DownloadSearchByProduct2.aspx?keyword=LabView" target="_blank">http://support.advantech.com.tw/Support/DownloadSearchByProduct2.aspx?keyword=LabView</a> MikeMessage Edited by MikeS81 on 05-07-2008 01:11 PM ...

Labview: resource not found ; Specifically a VI located in my LV 8.2 Project I am trying to download to my FP-2000 and run.
Hi,&nbsp; &nbsp; I am fairly new to the LV Project method of building executable files and embeded applications.&nbsp; I have been using LV 7.2 for the last few years and finally switched over to 8.2 this last summer. My problem is that I have an embedded application that I need to troubleshoot, but every time I try and run it from my desktop, it hits me with one of these messages: &nbsp; Deploying MPPT-Testbed&nbsp; (successfully deployed target settings)Deploying ErrorConvert.vi&nbsp; (already deployed)Deploying FP Close(IO).vi Failed to download FP Close(IO).viLabVIEW:&nbsp; Resource not found.LabVIEW:&nbsp; Resource not found. &nbsp; The FP Close(IO).vi is the latest issue, I have had other files that have failed to load as well.&nbsp; I have attempted to make a common folder for all of my shared VIs, I have 6 FP-2000 controllers.&nbsp; Any ideas?&nbsp; &nbsp; I run LV 8.2 w/RT on my desktop, my FP-2000 is running LV 8.2, FP Drivers 5.2.0 and FP VI Manager 4.1.0 &nbsp; -Bill Hi Bill, Which version of the FieldPoint driver are you using? You will probably need to uninstall and reinstall the FieldPoint driver, which is available on <a href="http://joule.ni.com/nidu/cds/fn/p/sb/navsRel/lang/en?q=fieldpoint" target="_blank">our website</a>. The driver will install to the latest version of LabVIEW, so after installing it, you will want to open up LabVIEW 8.2 and double-check that the...

Can Simulation module 8.2 be hooked to labview 8.5 How?
Hello It might seem odd and very stupid if you have done it before.I previously used a Labview 8.2 system.Now I have upgraded to Labview 8.5 system and Simulation Module 8.2 .I did install Simulation Module and it dint show up in my Labview 8.5 environment.Is there any manual&nbsp; method so that i can add this module on to 8.5&nbsp; . Im sure labview is backward compatibility.Is there a way to add this module to 8.5 so that i can work with this module ?Message Edited by Bharath kumar on 04-07-2008 09:53 AM Hi Bharath, What probably happened is that you installed the module under LabVIEW 8.2.&nbsp; By default, toolkits and modules can only be installed for one version of LabVIEW.&nbsp; However, <a href="http://digital.ni.com/public.nsf/allkb/58BE852CB35237C786256A290079DF39?OpenDocument" target="_blank">KnowledgeBase 288G6JB5: Installing Toolkits for Use with Multiple Versions of LabVIEW</a> details how to install the module for multiple versions.&nbsp; Another way would be to reinstall the toolkit and make sure that you have LabVIEW 8.5 selected as the destination.&nbsp; Good Luck! Wes PApplications EngineerNational Instruments Bharath, &nbsp; The LabVIEW Simulation 8.2 is a Module, which means that it can only work with the version that was created for. In this case, it only work on LabVIEW 8.2. &nbsp; In the 8.5, we joint the Control Design Toolkit with the Simulation Module creating the LV Control Design ...

can anyone provide me the suitable material for labview fpga &amp;labview real time?? #2
&nbsp;Message Edited by Sithu on 05-27-2008 04:33 AM duplicate post. Continue <a href="http://forums.ni.com/ni/board/message?board.id=170&amp;thread.id=326521" target="_blank">here</a> ...

labview 8.5 to labview 7.0
i am on my labview working with 8.5but at work, we only have labview 7.0.what would be my best way to get my vi to be 7.0?thank you so muchMessage Edited by krispiekream on 06-19-2008 03:59 PM In order to go from LV 8.5 to LV 7, you will need to have LV 8.5 (save it back to 8.0), LV 8.0 (save it back to 7.1) and LV 7.1 (to save back to 7.0). If it's only a few small VI's, you can post them on the forum and ask someone to do the saves for you.&nbsp; (Best if you do the save back to 8.0 and&nbsp;post that in order&nbsp;to eliminate 1 of the 3 steps for whoever will do the rest of the conversions for you.) yeah. great.. i did all those steps.i went from 8.0 to 7.1i dont have labview 7.1 so i can't go to 7.0.can someone please help me. Code.zip: http://forums.ni.com/attachments/ni/170/333708/1/Code.zip Hey Krispiekream, &nbsp; Please try the attached to see if it works with LV7.0 &nbsp; Hopefully it does!! &nbsp; &nbsp; Copy 7.0.zip: http://forums.ni.com/attachments/ni/170/334253/1/Copy 7.0.zip thank you so much. i'll try it right now. hi there,i somewhat got it to work.but i am having this error everytime i try to save it.does anyone know how i can get rid of it?<img src="http://forums.ni.com/attachments/ni/170/334653/1/untitled5.PNG"> Message Edited by krispiekream on 06-24-2008 06:02 PM untitled5.PNG: http://forums.ni.com/attachments/ni/170/334653/1/untitled5.PNG You might want to look into <a href=&...

upgrading cRIO from Labview 7 to Labview 8
Hi again :) I have a cRIO system that is running Labview 7. It runs fine. No problems. We've upgraded to LV8 and I'm wondering if I should convert the LV7 system to LV8. The only reason I would do this is because for me LV8 is much easier to work with regarding cRIO (using DMA, setting up the project etc.). Now, if I attempt to upgrade the LV7 cRIO system, what kinds of problems will I run in to? I assume it means formatting the cRIO, installing LV8, converting the program from LV7 to LV8... &nbsp; Is there an FAQ regarding this, specifically about the cRIO? &nbsp; Thanks, Jeff...

labview 8.0 to labview 7.0
Hi, Can somebody save the below VIs in LV 8.0&nbsp;for LV 7.0, please... ?! Find Power Interrupt Time.vi: http://forums.ni.com/attachments/ni/170/335061/1/Find Power Interrupt Time.vi Remove Element(s) from Array.vi: http://forums.ni.com/attachments/ni/170/335061/2/Remove Element(s) from Array.vi Hi Partha,Here are the VIs in LV7.0.Have a nice day Find Power Interrupt Time.vi: http://forums.ni.com/attachments/ni/170/335070/1/Find Power Interrupt Time.vi Remove Element(s) from Array.vi: http://forums.ni.com/attachments/ni/170/335070/2/Remove Element(s) from Array.vi ...

2d FFT Mask Filter &amp; IMAQ Complex Truncate (LabVIEW 8.2/Vision 8.2)
Hello: Although this question is another of mine that involves IMAQ Vision routines, I feel it is best to be posted on the LabVIEW board since it is a non-hardware-related question.&nbsp; This involves using FFT filters.If one looks at the attached 4506.vi, it shows a way to create a 2d mask fft filter.&nbsp; I have a subVI that I have developed that allows one to draw a mask on an intensity graph but uses the underlying IMAQ Vision fxs to essentially do the equivalent of 4506.vi.&nbsp; I go to the trouble to use the intensity graph instead of the vision container or IMAQ window because the former auotmatically scales the image dimensions and has many more property nodes associated it.One can also use IMAQ Complex Truncate to perform 2d FFT filtering also.&nbsp;&nbsp; I did some experiments in which I drew a mask, then filtered the image using the mask method per the attached example.&nbsp; Then I used IMAQ ComplexTruncate with Truncation Frequency % set to the same value as determined by the following so that I could compare results.&nbsp; I calculated the Truncation Frequency % by taking the diagonal dimension of the mask and dividing it into the diagonal dimension of the FFT image (then multiplying by 100) as per the definition of the truncation frequency %.&nbsp;&nbsp; The filtered image results from each filter method are not the same - they are not doing the same filtering process. A screen shot of the front panel is attached so you c...

Can LabView 8.5 read LabView 8.5.1 VIs
Since LabVIEW 8.5.1 is only a bug fix, can LabVIEW 8.5 read any VIs generated in LabVIEW 8.5.1? Simple answer YES. But it&nbsp;will the VIs compile so it is a good idea to make a mass compile in the folder where the VIs are. ...

Need to run old program that needs labview 2.2
I am attempting to put together an Langmuir Probe using published software written in labview 2.2. I have already purchased the same old Macintosh and the same multifunction board as used by the original devloper. I have the software, but it will not run. I get a cannot convert to current version error. Is it possible to buy a old copy or can anyone provide one. NI has conversion software. See if they'll send you a copy. When I used the on-line wizard to upgraded from 6i Full to 6.1 Pro, my order form included "LabVIEW VI Conversion Package from 2x or 3x to 6i, Multi Platform....

Error 1047 in LabVIEW 8.2: LabVIEW failed to send variable to the script server. Server:&quot;&quot;
I am working with the evaluation version of labVIEW as well and I have run into another error.&nbsp; I am using a MATLAB script node within a for loop and attempting to pass the for loop counter variable into the script.&nbsp; When I run the code it brings up a 1047 error and says "LabVIEW failed to send variable to the script server. Server:"" ".&nbsp; I looked up the error online which seems to have roots in a failed auto initialization of MATLAB.&nbsp; Is there something that I can do in labVIEW to fix the problem or is it strictly a MATLAB error? &nbsp; I really appreciate your help. Hi Patsenat, &nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; We have a knowledgebase document on our system referring to this issue.&nbsp; Try reading through <a href="http://digital.ni.com/public.nsf/allkb/2B3FF46C8512C4F786256CF30071BE53?OpenDocument" target="_blank">this</a> and attempting what it says.&nbsp; If you still have problems, please post again. ...

Web resources about - How can I run a labview 7.2 vi in labview 8.2 - comp.lang.labview

LabVIEW - Wikipedia, the free encyclopedia
LabVIEW (short for Laboratory Virtual Instrument Engineering Workbench) is a system-design platform and development environment for a visual ...

LabVIEW - Geekosystem
Don we now our gay apparel, and why shouldn’t that apparel be primarily composed of Christmas lights synchronized to flash with music ? Andy ...

National Instruments - LinkedIn
Welcome to the company profile of National Instruments on LinkedIn. It's not what we make. It's what we make possible. National Instruments is ...

Open Directory - Computers: Programming: Languages
about dmoz - dmoz blog - report abuse/spam - help the entire directory only in Programming/Languages Description Top : Computers : Programming ...

Products / Home - g.tec - Guger Technologies
g.tec medical and electrical engineering produces biosignal amplifiers, data acquisition systems, real-time processing systems and EEG Processing ...

School of Electrical & Electronic Engineering - Computing Facilities
In particular, we have technical interests in common with the other Engineering Schools (Chemical, Civil & Environmental, Mechanical and Computer ...

Handy Arduino Uno R3 Pinout Diagram
Loading... « Missed the Maker Faire? Catch the pictures! Music + Floppy = Moppy » The original post from Nick Gammon is old, but I’m pretty sure ...

Curriculum Vitae - Stefano Meroli
Curriculum Vitae - Stefano Meroli

Testing Engineering Supervisor
Testing Engineering Supervisor job. Read the Testing Engineering Supervisor job description and find other Division 10 Personnel jobs at Monster. ...

Knowledge and Content Management: A Foundation for Business Success
Knowledge management and enterprise content management are increasingly at the center of a successful business strategy.

Resources last updated: 3/19/2016 4:31:05 PM