f



LabVIEW RTE 7 does not work on Linux with Mozilla (1.7) or Netscape (7.2)

LabVIEW RTE 7 does not work on Linux (Mandrake 10.1 or Knoppix 3.7)
with Mozilla (1.7) or Netscape (7.2).

We tried everything described in
<http://exchange.ni.com/servlet/ProcessRequest?RHIVEID=101&RNAME=ViewQuestion&HOID=506500000008000000EFBC0000&ECategory=LabVIEW.LabVIEW+General>
copying plugins, but always the gray window on Mandrake or error
setting up plugin on Knoppix.

We are trying to drive remote applications on your web site with Linux
(if possible) to decide about purchasing LabVIEW for Linux. Is there a
demo version for Linux we could try? Apparently, LabVIEW for Linux was
developed for an old version of Red Hat. Do you keep maintaing it for
latest Linux releases as the aforementioned?
0
x9561 (148439)
9/28/2004 8:12:35 PM
comp.lang.labview 35210 articles. 1 followers. vasusachin24 (1) is leader. Post Follow

2 Replies
1201 Views

Similar Articles

[PageSpeed] 40

Hello =96

When you say =93you have tried copying the plugins=94, do you mean copying
the plugin file into the right directory as mentioned in the Readme
file? What is mentioned in the Readme file did not work at all?

If this is correct, let=92s try modifying the html file generated as
below:

Change:
OBJECT ID=3D"LabVIEWControl"
CLASSID=3D"CLSID:A40B0AD4-B50E-4E58-8A1D-8544233807AA" WIDTH=3D588
HEIGHT=3D475
CODEBASE=3D"ftp://ftp.ni.com/support/labview/runtime/windows/6.1/LVRunTimeE=
ng.exe"

To:
OBJECT ID=3D"LabVIEWControl"
CLASSID=3D"CLSID:A40B0AD4-B50E-4E58-8A1D-8544233807AA" WIDTH=3D588
HEIGHT=3D475

It should work now.

S Vences
Applications Engineer
National Instruments
0
x9561 (148439)
10/1/2004 4:50:59 PM
Hi SVences,

Thanks for your response.

You are right, removing the CODEBASE instruction in the web page
solves the problem locally for Linux and Mozilla/Netscape browsers for
Windows.

However, to the date, National Instruments has not solved the problem
on some of its web pages as http://ni.com/webappdemos/rfsa.htm. We
cannot see or remotely operate that panel on Linux.

Also, the html file is generated by LabVIEW, so LabVIEW needs to be
fixed, so it won't include the CODEBASE instruction.

Looking forward to your fixes...

FE
0
x9561 (148439)
10/1/2004 5:27:36 PM
Reply: