f



Run Labview as different windows user (for database connectivity)

I have to connect to a corporate remote MSSQL-Database on the network, using the database connectivity toolkit for LabVIEW.The db-authentification is realized checking the windows user (ads) who acceses the datebase (not a database user / password which is standard in the database vis)Therefore I have to run LabVIEW as the defined windows user, different than the logged in user on the pc.Is that possible to realize with LabVIEW?Other Windows-tools allow to define the windows user/password which "run" an application - how can I do that with LabVIEW?
0
x9561 (148439)
6/5/2008 10:10:07 AM
comp.lang.labview 35210 articles. 1 followers. vasusachin24 (1) is leader. Post Follow

3 Replies
776 Views

Similar Articles

[PageSpeed] 36

Hi Zav.  There is a windows command 'runas' which _may_ let you do what you want; I haven't tried what you need to do, but is has worked for other tasks for us.  Try 'runas /?' for the switches.You will have to build your LV program into an executable, then use runas to launch it.  Is therea reason you can't just login to Windows as the required user?If you can get your db admin to allow dbuser/password authentication that would be a much betterway to go.Matt
0
x9561 (148439)
6/5/2008 12:10:08 PM
Thanks for the hint - I every day can learn new things. For me it seems to works withrunas /netonly  ...even I start the LV developement enviroment.
0
x9561 (148439)
6/5/2008 1:10:06 PM
runas /netonly  ...even I start the LV developement enviroment.Thank you, Zav, now I get to learn something too!Matt
0
x9561 (148439)
6/5/2008 3:10:09 PM
Reply:

Similar Artilces:

Re: I would like to remotely control a LabVIEW application. Is it possible to create multiple different passwords for different users
Hi there,   I tried the Remote Panel Login examples which were attached by Zvezdana S. It works when main.vi running in Labview enviroment. But after I created a executable file of main.vi, it didn't work, the Web Server: Browser Access couldn't be changed from "remote panel loging.vi".  BTW, both main.exe and Remote Panel Login,vi run at the same PC.   I am confused by ports number, ini file. How could I set port number when they are running at the same PC? When I built the executable file, ini file was built in as a support file...

labview 8.2 llb run with labview 8.5
On the PC I have delete labview 8.2, but I dont find the CD for reinstall. I have a .llb file made with labview 8.2, Can i run it with labview 8.5 or download labview 8.2, I muss install ii rapidelly.   tks Costello, you can update the VIs within the LLB to LV 8.5 if they do not have their blockdiagram removed.....hope this helps,Norbert How can I update ? When I start the .vi in the lbb he dont found somme .vi located in DAQmx (wrtie.lbb, start task.lbb,...) How can i install this lbb? thks Costello, if you get loading errors when opening one VI from the LLB like you the ones you get, you have missing components.Since you spoke of DAQmx, i asume that you didn't install NI DAQmx on your machine. You should catch that up.hope this helps,Norbert ...

Does Labview run-time engine 6.0 application created by Windows NT/2000 can install & run on UNIX
LabVIEW exe created in Windows and running in UNIX LabVIEW source code from one OS can be ported to another OS (except for OS specific things like ActiveX) but executables cannot. You would need the unix version of LabVIEW and it's app builder to create an new exe. ...

change a LabVIEW array outside LabVIEW and keep updated in LabVIEW
change a LabVIEW array outside LabVIEW and keep updated in LabVIEW hi, I am Interfacing a FrameGrabber with LabVIEW using a frame grabber SDK(dll). The memory managment of this FG allow you to allocate your own Array and to give a pointer to this Array to the memory manager. Then when you acquire with the frame grabber, the acquired image will be directly accessible in your array. 1.I give to the FG memory manager a pointer to the Labview array through a SDK Dll function. 2. I run the acquisition 3. I display the array My problem is that the Array is allways displayed with it initial val...

How can I run a labview 7.2 vi in labview 8.2
We have several versions of labview running different test and control functions in our facility. There are labview 7.2 VIs in a production setting I wish to reproduce in the test lab. Can I convert them to run on 8.2 or do I have to recreate them in 8.2. I tried to open one in 8.2 and got multiple SubVI's that were not in my program library.. most dealing with AI manipulation.   And make sure you have backup copies of your 7.x code. Once you load and save in 8.2, it is a lot of work to get them back to 7.x. Note I used 7.x because I am unaware of LabVIEW version 7.2 even existing. 7.1.1 was the last release prior to 8.0 ...

Differences in CIN management between Labview 5.0 and Labview 7.1 ? #3
Hi,   I'm using a VI on a two photon microscope. It steers the laser beam in the sample (quite the same way as a TV scan, scanning a fast line on the X axis, then moving the line down) controlling two mirrors by the PCI-MIO-16E-4 Multifunctions card on traditional DAQ and at the same time it serves as the acquitision through a non-NI DSP Multifunction-board with on-board buffers and hight data throughput (70 Mb/s).   It is this part of the program which gives us strong headaches since we have upgraded to a new PC. On the old machine we used Win...

Can I run a LabVIEW 7.1 Application on a system with LabVIEW 6.1?
The VI App did not run properly, even after I installed the LabVIEW 7.1 Run time engine. Perhpas I need to uninstall the LV 6.1 run time engine? Thank you for any suggestions; perhaps it's something minor that I'm overlooking! Are you talking about a 7.1 exe or VI? An executable will run with 6.1 installed and the 7.1 run-time. A 7.1 VI will only run with 7.1 development system. When you say it did not run properly, what exactly do you mean? I am referring to trying to run a 7.1 EXE application on a system with a resident 6.1 development environment, and the 7.1 run-time engine ins...

Differences in CIN management between Labview 5.0 and Labview 7.1 ? #2
Hi,   I'm using a VI on a two photon microscope. It steers the laser beam in the sample (quite the same way as a TV scan, scanning a fast line on the X axis, then moving the line down) controlling two mirrors by the PCI-MIO-16E-4 Multifunctions card on traditional DAQ and at the same time it serves as the acquitision through a non-NI DSP Multifunction-board with on-board buffers and hight data throughput (70 Mb/s).   It is this part of the program which gives us strong headaches since we have upgraded to a new PC. On the old machine we used Win...

Differences in CIN management between Labview 5.0 and Labview 7.1 ? #4
Hi,   I'm using a VI on a two photon microscope. It steers the laser beam in the sample (quite the same way as a TV scan, scanning a fast line on the X axis, then moving the line down) controlling two mirrors by the PCI-MIO-16E-4 Multifunctions card on traditional DAQ and at the same time it serves as the acquitision through a non-NI DSP Multifunction-board with on-board buffers and hight data throughput (70 Mb/s).   It is this part of the program which gives us strong headaches since we have upgraded to a new PC. On the old machine we used Win...

Disabling access to windows while a labview program runs.
Hi   At present were designing a new ATE.  On our previous ATE's We found problems were operators deleted requiredd files which we couldn't make read only as the labview logged data to them and if they were read only we got errors..   we also had problems were operators were smart enought to figure out the proxy settings for the internet and enable internet useage and surf and download instead of doing there work..   I want to if possible as soon as the machine starts automatically load the labview program and from there on the user has no access to any of the windows environment.   Eg the labview program running is the only thing the user can use until the labview program is exited via a special password or something..   Any help is much appreciated. There is somewhere a registry setting that describes your windows explorer executable. Replace this with your executable. After finishing your program you can load explorer.exeI think tweakUI reveals this.Ton Thanks Ton. I found another Thread which detailed how to do simalar thought the group policies editer and by changing the custom user interface from explorer to a labview exe.. Think its the same thing as you suggested just a different way. Thanks Could you link this thread? Ton To disable CTRL-ALT-DEL: "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentValue\Policies\system\D isableTaskMgr=1". This isn't perfect. It will block ctrl-alt-del an...

Is anyone running LabVIEW on windows 2003 server?
I am looking at buying a server PC and running windows 2003 server OS for my data acquisition system. Has anyone run LabVIEW on windows 2003 server? Why you ask: Reliability (redundant power supplies, memory, hard drives etc) Remote acces (through client tools) Security, mountability, etc, etc.... John Greetings: I have run Labview 7 on 2003 server with no apparent bugs. You probably already know that most of the services and ports are off by default in 2003 (which is why it is more secure), so if, for example, datasocket doesn't work, be sure your firewall is co...

Connect using different Windows user name...?!?!
I've scoured Google searching for an answer that seems like it should be easy but apparently isn't...when I open SSMS to connect to a SQL 2005 database and choose Windows authentication, it greys out the User Name box...problem is, the server I need to connect to is in another domain...how on earth are you supposed to specify a different Windows user name to connect with other than the one currently logged into the machine? -Ben -- Posted via a free Usenet account from http://www.teranews.com On Jul 6, 3:12 am, "Ben Hanson" <transparency...@hotmail.com> wro...

Running a LabView exe file as a Windows Service.
I have created a LabView application that runs fine on its own.&nbsp; But I wanted to run it as a service.&nbsp; Using sc.exe I was able to create the service entry into the Windows Service Manager, but every time that I start the service I receive a 1053 error from Windows and the service is shut down.&nbsp; I do know that the program runs for a short period of time, because I am able to connect to it with a console program.&nbsp; &nbsp; Thanks &nbsp; Matt &nbsp; &nbsp; ...

How can I get handle(s) to and poll non-LabVIEW window(s)/application(s) from LabVIEW?
Want to launch&nbsp;EXE from LabVIEW, wait for user to finish with EXE's UI, and once they closed it, return execution flow in LabVIEW. Cool, no problem. Used the System Exec VI and with the "wait until completion" = TRUE the EXE never launches. Not sure why. With the "wait until completion" = FALSE, the application runs with no problems, but now LabVIEW no longer waits.&nbsp; Can't tell when user is done. Work around idea... Once the Sys Exec VI launches the EXE, wait&nbsp;and poll some Windows API call to see when the window for the specific EXE closes. Cool. I know G and no C.&nbsp; What I would ideally like is a DLL, that I can wrap with the DLL Import Wizard.&nbsp; Of course best would be a VI and the wrapped API call. Any ideas? You could try it with a pipe. With a pipe you can open an exe, and interact with it through a read and write reference. Although in your case the exe might not start, since the normal sysexec doesn't start it... http://forums.ni.com/ni/board/message?board.id=170&message.id=270461&requireLogin=False Regards, Wiebe. ...

LabVIEW 8.2 -- "unable to locate LabView run-time" error message
I am trying to run a LabVIEW version 8 exe file and keep getting the "Unable to locate" error. I downloaded LabVIEW_8.2_Runtime_Engine.exe from the NI website and installed the entire contents of the distribution. After getting the error, I have tried uninstalling and reinstalling several times, with the same result. Is there some way I can troubleshoot this? Is there a configuration file or a registry entry I can check to see where LabVIEW is looking for the run-time? ...

How to retrieve col information by labview database connectivity toolset?
Hi, there, The list table vi in the toolset output only col name, data type and size? how can I know NULL allowed or not? Also it seems that the list table vi always gives back '-1' even though it is a string type. Somebody have some experience on it? Thanks a lot. JJ Crystal answered your other posting with a great answer. <a href="http://exchange.ni.com/servlet/ProcessRequest?RHIVEID=101&RPAGEID=135&HOID=5065000000080000008FA60000&UCATEGORY_0=_49_%24_6_&UCATEGORY_S=0">How can I retrieve the col data size and Null information from table using labvi...

How do I embed a running LabVIEW child window within C?
I need to write my application using Borland C++ but I want to use LabVIEW toolkits for analysis. I have been doing some initial investigations into how I can link the LabVIEW into my C++ code. I have been successful in being able to create a LabVIEW dll and then call that from my C++ code and set the LabVIEW window as a child&nbsp;of my C++ window by&nbsp;calling the 'FindWindowA'&nbsp;function&nbsp;of the Windows API from within LabVIEW to&nbsp;supply my C++ code with a handle to the window. &nbsp; I thought I'd done the tricky part until I&nbsp;then tried to make my&nbsp;LabVIEW test&nbsp;VI a little more realistic - so instead of just suppling the handle to itself, I wanted it to sit in a loop taking commands until I was finished with it. This is where I am running in to problems.&nbsp;If I have just the&nbsp;one&nbsp;VI with&nbsp;the&nbsp;'doing something' loop in it as well as passing the handle, my C++ code waits until the VI is closed before passing the handle. I've tried splitting my LabVIEW code into the 'do something' VI, with the window I want to embed in C++, and a second&nbsp;VI which loads the 'do something' VI and which also returns the handle. When I run this in LabVIEW it acts I as I'd intended but when calling from C++ no window appears. &nbsp; So, to try and clarify, from C++ I want to get a handle to a LabVIEW VI with a front panel that I will event...

LabVIEW Run Time Modifying Windows Sleep Timer
Hi fellow LabVIEW Programmers, &nbsp; I have a very interesting issue that is occuring in my test system.&nbsp; When I run any kind of LabVIEW exe, it seems the LabVIEW run time edition changes properties of windows. One of the properties that seems to be changing is windows sleep timer/function,&nbsp; which sets the amount of time it takes between doing tasks.&nbsp;&nbsp;&nbsp; When I boot up the computer every program works normally, when I run a LabVIEW exe, even a simple counter exe, then close the code, windows will do certian tasks 4 times fasters until the computer is rebooted.&nbsp; I have one program that sends messages over USB and once the Labview EXE is ran, the wait between sending messages over USB is reduced by a factor of 4, so it looks like I have 4x the byte bandwidth. &nbsp; I would like to know what is going on when I run LabVIEW run time.&nbsp; What hooks are being called, what DLL or&nbsp; memory flushes are occuring when a EXE is called.&nbsp; I dont know much about windows API programming, but i know it an affect between labview and windows. &nbsp; &nbsp; I currently using&nbsp; LabVIEW 7.1.1 runtime engine NI-GBIP 2.5 Full NI-VISA 4.2 Full Installed on Windows XP Professional SP2+ The program is being run on a ToughBook CF-29,&nbsp; but will happen on any computer &nbsp; If any one can point out a cause or what might be happening that would be wonderful &nbsp; Thanks &nbsp; Eric ...

LabVIEW application fails to run properly at Windows startup
I have experienced problems with my Labview application after putting it in the Windows XP startup folder. The application runs perfectly if I start it manually but whenever I get Windows XP to start it after boot-up, I see various error messages. My application uses calls to the NIMotion library and it's these calls that are generating the error messages. I don't always get the same errors and the problem has occurred with two different programs on two different computers. I think it is something to do with NI services for the motion controller that load at startup and haven't yet been started before my application runs. I have configured Windows to login automatically and I have noticed thay my program executes quite early, sometimes even before the desktop icons appear. &nbsp; I have seen that a number of other users have experienced similar problems. There was a recent post titled "Waiting for Windows Idle" in the LabWindoesCVI forum that is related. The only solution that I have come across is to wait at the very start of the program until the rest of the dependent services have loaded. I have added a 30 second wait to my programs and this appears to have largely solved the problem. This is no the best solution because it is not always guaranteed to work. I have had a situation recently where Windows was installing an automatic update and the bootup process was slower than normal. This caused my program to fall over again. I don't wan't ...

Can I Run a labview application in a hidden window (i.e. I...
Can I Run a labview application in a hidden window (i.e. I don't want the front panel to pop up in this Labview created EXE)? I have a executable labview 6.1 program with a front panel. The front panel pops up every time I run it. Can I force the program to run without popping up its front panel. Thanks in Advance If you're using MS Window, you can use lvwutil32.zip to hide the front panel. lvwutil32.zip can be downloaded from NI site. Or you can move your front offscreen, so that user can't see it. And save your vi. When you run your vi again, it'll popup at the offscr...

Can I run user-programmed Matlab functions in Labview?
Ok, I'm using a Matlab node in Labview, and I'm trying to run a function that I programmed.&nbsp; For example: [az,el] = thphi2azel(th,phi);I have th and phi going into the Mathscript nodes as inputs.&nbsp; I then try to take the outputs az and el and take them out of the mathscript node.&nbsp; I get an Error 1048 when I do this and it says that el cannot be found.&nbsp; I'm not using any pre-defined Matlab names.&nbsp; I guess I'm wondering, is this even possible?&nbsp; Or is there something else I'm doing wrong?&nbsp; I have the m file for thphi2azel in the same directory as the vi.&nbsp; BTW, I'm running Labview 8.2.1 and Matlab 7.5.0 (R2007b).Thanks,Alan Stemmonsalanstem469@yahoo.com Hello Alan,What you are trying to do is indeed possible.&nbsp; The problem is that The MathWorks, Inc. MATLAB� software cannot find the function you have written.&nbsp; The MATLAB script node operates as if you had run the script in the MATLAB software environment.&nbsp; Try setting the path in the MATLAB script node to include the directory where your VI is located.&nbsp; To make this work regardless of where on disk your VI is located, drop down the "Current VI's Path" primitive from the "Programming &gt;&gt; File I/O &gt;&gt; File Constants" palette.&nbsp; Wire it to a "Strip Path" primitive from the "Programming &gt;&gt; File I/O" palette.&nb...

Integration of two different labview infinity projects and how to import labview's calcutation into flash animation
1) I have a labview project for strength gauge using flex sensor and another labview project on tracking the brightest light intensity of image captured by webcam. &nbsp;&nbsp;&nbsp; How do i integrate both together? 2) How do I show simple animations of the measurement result? &nbsp;&nbsp;&nbsp; For e.g if I am doing a measurement and position tracking of a bow and arrow game using labview program, &nbsp;&nbsp;&nbsp; how do i show the bulleye's and whether the user has hit on the bull's eye? &nbsp;&nbsp;&nbsp; Is it possible to import flash animation of the bull's eye? How do i do that? this may be an solution for your first question. the project file of LabVIEW is a XML file. you can open it with a txt editor, such as notepad, ultraedit, and so on. or a XML editor is prefer. then try to integrate (copy and paste) the part of the content&nbsp;two project. it maybe works. i think. hehe. ...

how do a client connect to a system on which a vi is running (using datasocket)(in labview)
let the publisher vi have an IP address X (it is also running a datasocket server) can a client connect to that system through internet. If so how.Anyone kindly take some time to answer this question. thank u a lot. Hello, <a href="http://zone.ni.com/devzone/conceptd.nsf/webmain/F3C85234F1075EA986256CAA005A0136?opendocument">Here</a> is a technical overview about datasocket that may help. If you need to open a port on your firewall, <a href="http://digital.ni.com/public.nsf/websearch/FE6A63983AC8289E86256B22005A067A?OpenDocument">here</a> is a docu...

Why does NiVisaServer.exe is running when Labview is running??
I am running two identical test setups for&nbsp;some system testing.&nbsp; The PC&nbsp;configuration and test cases are same on both the setups. I am using &nbsp;Labview version 8.5 . I observe the setup running with NiVisaServer.exe is slow as compared to the other setup.&nbsp;The same file is not running in the other setup.&nbsp; My question is , does NiVisaServer.exe slow down the Labview execution?? Why does NiVisaServer.exe is not running in the other tester eventough both are identical?? &nbsp; ...

Web resources about - Run Labview as different windows user (for database connectivity) - comp.lang.labview

TE Connectivity - Wikipedia, the free encyclopedia
TE Connectivity Ltd. designs and manufactures connectivity and sensor solutions for a variety of industries including automotive, industrial ...

Mark Zuckerberg Goes Into Detail On Facebook Connectivity Lab, Internet.org
Perhaps Facebook Co-Founder and CEO Mark Zuckerberg is just a wee bit excited about the Connectivity Lab , the initiative aimed at using high-altitude ...

The power of connectivity
By Keven McCammon, site data center manager, Facebook Forest City Data Center Today we announced that we’re partnering with the Town of Forest ...

Facebook, Internet.org launch Connectivity Lab
... CEO Mark Zuckerberg shed some light on the company’s acquisition of drone-maker Titan Aerospace, announcing the launch of Facebook’s Connectivity ...

Samsung Galaxy S3: Connectivity demo - USB OTG, MHL, bluetooth keyboards/mice, games controllers - YouTube ...
AndroidNZ.net - the best source for Galaxy S3 content! For navigation in the video use these links: USB Pendrive @0:55, 500GB portable drive ...

Mid-2012 MacBook Airs offer improved performance and connectivity
Believe it or not, it's been nearly four and a half years since Apple released the original MacBook Air. At the time, it was revolutionary in ...

Connectivity is key in society
They’re billing it as the place where Lewisham meets Summer Hill meets the city – and with good reason.

BMW to launch new connectivity service
Soon your car will notify the dealer when it’s due for a service. BMW Australia will introduce a new suite of in-car connectivity apps in its ...

The key to a successful hybrid cloud infrastructure? Flexible connectivity
It's becoming increasingly clear that - for most organisations - taking a 'hybrid' approach to cloud adoption makes sound business sense.

Facebook Connectivity Lab promotes access to Internet in remote areas - CTV News
Facebook is giving more details about its effort to connect remote parts of the world to the Internet - and it involves drones, lasers and satellites. ...

Resources last updated: 3/19/2016 10:00:55 AM