f



ANNOUNCE: DBD::Informix - IBM Informix Database Driver for Perl DBI Version 2005.01 (2005-03-14) released

IBM Informix Database Driver for Perl DBI Version 2005.01 (2005-03-14)
has been uploaded to CPAN.

IBM Informix Database Driver for Perl (also known as DBD::Informix) is
the driver code that enables Perl 5.6.1 or later to access Informix
databases via the DBI module (but if you are not already using Perl
5.8.5, you should be planning to upgrade to it).  You will need the code
for DBI version 1.38 or later as well (v1.48 recommended).  The code for
DBD::Informix is available for download via:

http://www.perl.org/CPAN/modules/by-category/07_Database_Interfaces
http://dbi.perl.org/

** When you successfully build this module, use the ItWorks (Perl)
** script to report your configuration to the maintenance team (meaning
** Jonathan Leffler) at dbd.informix@gmail.com.
** Note that ItWorks does not send email to anybody; you have to do that
** yourself.

New in release 2005.01:
* Various minor bug fixes made as reported - see ChangeLog.
* Release required to handle Informix ClientSDK 2.90, which includes
   ESQL/C 2.90.  The previous release (CSDK 2.81, included ESQL/C 9.51),
   and the older DBD::Informix compilation based decisions off the ESQL/C
   version, rejecting 2.90 as obsolete and unusable.
* Note that a number of obsolete versions of ESQL/C are no longer
   supported.

Known problem:
* t/t91udts.t warns about an uninitialized variable on subroutine entry.

Support email address:
* This release is supported by Jonathan Leffler <dbd.informix@gmail.com>
* You may also report your bugs via the CPAN resolution tracking system:
     http://rt.cpan.org/
* Such bug reports can be sent by email to bug-DBD-Informix@rt.cpan.org;
   they also get sent to dbd.informix@gmail.com, etc.

As always, see the ChangeLog file for details about what has changed.

Jonathan Leffler (jleffler@us.ibm.com, jleffler@earthlink.net)

@(#)$Id: Announce,v 2005.1 2005/03/14 23:23:15 jleffler Exp $


0
jleffler (73)
3/22/2005 5:51:05 AM
comp.lang.perl.modules 4194 articles. 0 followers. jerrykrinock (6) is leader. Post Follow

0 Replies
558 Views

Similar Articles

[PageSpeed] 8

Reply:

Similar Artilces:

Re: Database Server Hangs / Perl DBD Informix Module
I found a solution, It worked well with tcp connections, Looks like perl's Informix DBD Module doesn't like shared memory connections,at least with my versions. But I can live with tcp connections. Thanks anyway. I have other question , Does anybody knows how to actually get the number of rows returned/affected in a query with perl ? I tried with : $nrows=$sth->rows(); always returned 0. $nrows = $sth->{ix_sqlerrd}[2] always returned 0 too. Any ideas ? ----- Original Message ----- From: "Francisco Roldan" <f_roldan@admcentralagricola.com.gt> To: <informix-list@iiug.org> Cc: "Jonathan Leffler" <jleffler@earthlink.net>; <jleffler@us.ibm.com> Sent: Wednesday, May 12, 2004 9:12 AM Subject: Database Server Hangs / Perl DBD Informix Module > Hi everybody, > I have > Informix Dynamic Server Version 7.30.UC11 > on Red Hat Linux 9 > perl v5.8.0 built for i386-linux-thread-multi > DBI 1.42 > DBD Informix 2003.04 > > After installing perl's DBI and DBD Modules for Informix I > finally get a script to connect and disconnect to the database . > But after running the script several times (that only connects and > disconnects to the database ) , the server hangs and it does not let to > connect to any database > with the message : 25588: The appl process cannot connect to the database > server > Restarting the server f...

[Fwd: Re: Database Server Hangs / Perl DBD Informix Module]
This is a multi-part message in MIME format. --------------000806050204000100000404 Content-Type: text/plain; charset=us-ascii; format=flowed Content-Transfer-Encoding: 7bit I sent this to Francisco from the office, and I don't have direct posting access to news groups while I'm in the office. He agreed that the example code using rows worked and answered his questions. "Francisco Roldan" <f_roldan@admcentralagricola.com.gt> wrote: >> I found a solution, >> It worked well with tcp connections, >> Looks like perl's Informix DBD Module doesn't like shared memory >> connections,at least with my versions. >> But I can live with tcp connections. >> >> Thanks anyway. >> I have other question , >> Does anybody knows how to actually get the number of >> rows returned/affected in a query with perl ? >> >> I tried with : >> >> $nrows=$sth->rows(); >> >> always returned 0. Messages passing in the night... It's a bit worrying that shared memory connections aren't working, but I can imagine all sorts of configuration reasons why they weren't working, as well as bug possibilities. Works for me: #!/bin/perl -w use strict; use DBI; my $dbh = DBI->connect('dbi:Informix:stores','','',{RaiseError=>1}); my $sth = $dbh->prepare(q{SELECT tabid, tabname, tabt...

Two New Versions of the Perl DBD::DB2 Driver Released
Noticed today that there have been two new versions of the DB2 driver released over the last week.   This is the first time IBM has released an update since October 2001, so to give us two releases in a week is a bit much to cope with <G> !!! 0.77 fixes a number of problems, including one which I reported to IBM (and helped to produce a fix for) involving memory leaks. 0.78 adds some new functionality, for C-style comments in SQL (still to look and see what this exactly means) !!! HTH Phil Nelson ScotDB Limited H...

python-dev Summary for 2005-03-01 through 2005-03-15
[The HTML version of this Summary is available at http://www.python.org/dev/summary/2005-03-01_2005-03-15.html] ===================== Summary Announcements ===================== ----------------------------- Second to last summary for me ----------------------------- Just a reminder, after this Summary there is only one more left for me to write. After that Tim Lesher, Tony Meyer, and Steven Bethard will be taking over. ----------------- See you at PyCon! ----------------- PyCon_ is practically upon us! If you are going to be there, great! Please feel free to say hello if you run int...

python-dev Summary for 2005-03-01 through 2005-03-15
[The HTML version of this Summary is available at http://www.python.org/dev/summary/2005-03-01_2005-03-15.html] ===================== Summary Announcements ===================== ----------------------------- Second to last summary for me ----------------------------- Just a reminder, after this Summary there is only one more left for me to write. After that Tim Lesher, Tony Meyer, and Steven Bethard will be taking over. ----------------- See you at PyCon! ----------------- PyCon_ is practically upon us! If you are going to be there, great! Please feel free to say hello if you run into me (will be at the sprints and the conference Wednesday and Thursday; skipping Friday to see a friend). Always happy to stop-and-chat. ... _PyCon: http://www.pycon.org/ ------------------------ 2.4.1 should be out soon ------------------------ Python 2.4c2 has now been released. Assuming no major issues come up, 2.4 final will be out March 29; day after PyCon. But in order to make sure no issues come up, we need the code to be tested! Please get the code and run the regression tests. If you are on a UNIX system it is as easy as running ``make test`` (``make testall`` is even better). The tests can also be run on non-UNIX systems; see http://docs.python.org/lib/regrtest.html on how. ========= Summaries ========= ---------------------- 2.4 should be out soon ---------------------- Python 2.4.1c1 was releaseed, but enough bug...

Perl DBD:Informix on NT
Can anyone tell me if this is available and supported? I cannot find any references to NT on the CPAN site. Thanks! Cindy Lichtenauer wrote: > Can anyone tell me if this is available and supported? > > I cannot find any references to NT on the CPAN site. > > Thanks! The source did build on NT a year or two ago -- I've not done anything consciously to break it (MS might have done, but not me). However, if you're using ActiveState Perl (probably wise) you have to work out what all their bells, whistles and other compilation options mean to a poor hard-working DBD module. You need a C compiler - the one used to build your Perl. You need IBM Informix CSDK, but make sure the warnings are not cranked up as CSDK was (is?) not good about things like const-correctness. Let me know how it goes. Since I don't have a C compiler on a Windows machine, I don't ever do the building myself - not any more. -- Jonathan Leffler #include <disclaimer.h> Email: jleffler@earthlink.net, jleffler@us.ibm.com Guardian of DBD::Informix v2003.04 -- http://dbi.perl.org/ ...

CDs 2005/03/01 to 2005/04/30
CDs 2005/03/01 to 2005/04/30 GARAGE SALES, working, tested, fully functional, very cheap discounted price, low cost, --------------------------------------------------------------- 2005/03/01 2D3 Boujou Three V3.0 2005/03/01 Eonreality EON Professional for EON Studio v5.11 2005/03/01 W-Tools.LWCAD.v1.0b.for.LightWave 2005/03/01 EUKLID.v2004.3.Multilingual 2005/03/05 Texture Shaker V1.0 FEB 21 2005 2005/03/05 Eonreality EON Studio v5.11 2005/03/05 Eonreality Raptor WEB Studio v2.1 for 3DSMax 2005/03/05 Eonreality EON CAD v3.5.9 for Deep Exploration 2005/03/05 Corel.Designer.Technical.Suite.v12.0 2005/03/05 Newtek.Lightwave.v8.2.1.update.Only 2005/03/05 PSP.Audioware.Nitro.DX.VST.v1.0.2 2005/03/05 TREPCAD St V3.3.1 Bilingual 2005/03/05 Chaos.Systems.TopoCAD.v7.0.3.Multilingual 2005/03/05 Chaos.Systems.Desktop.v1.5.5 2005/03/05 BENTLEY.MX.v8.05.02.02 2005/03/05 Mastercam.Art.v9.0 1CD 2005/03/05 Cigraph Factory 2005 for ArchiCAD v9.0 HYBRID 1CD 2005/03/05 Mentor Graphics PADS PCB 2005 Build 7.1 1CD 2005/03/05 IMSI Floorplan 3D Design Suite 9.0 1CD 2005/03/05 Dosch.3D.Animated.Humans.For.Cinema.4D 1DVD 2005/03/05 MOTU.Audio.Desk.v2.0.HYBRiD 1CD 2005/03/05 Street.Productions.Combustion.3.Training.09 DVDrip 2CD 2005/03/05 Kirk.Hunter.Orchestral.Brass.Ensembles.09.GiGA 1DVD 2005/03/09 Ableton.Live.v4.1.1 2005/03/09 Synful.Orchestra.VSTi.DXi.v2.04 2005/03/09 Hash.Animation.Master.2005.v11.1D.Plus 2005/03/09 Hash.Animation.Master.2005.v11.1D.Plus.NetRender.Edition 2005/03/09 Creo...

python-dev Summary for 2005-01-01 through 2005-01-15
This is a summary of traffic on the `python-dev mailing list`_ from January 01, 2005 through January 15, 2005. It is intended to inform the wider Python community of on-going developments on the list. To comment on anything mentioned here, just post to `comp.lang.python`_ (or email python-list@python.org which is a gateway to the newsgroup) with a subject line mentioning what you are discussing. All python-dev members are interested in seeing ideas discussed by the community, so don't hesitate to take a stance on something. And if all of this really interests you then get involved and join `python-dev`_! This is the fifty-sixth summary written by Brett Cannon (I don't want to do my homework). To contact me, please send email to brett at python.org ; I do not have the time to keep up on comp.lang.python and thus do not always catch follow-ups posted there. All summaries are archived at http://www.python.org/dev/summary/ . Please note that this summary is written using reStructuredText_ which can be found at http://docutils.sf.net/rst.html . Any unfamiliar punctuation is probably markup for reST_ (otherwise it is probably regular expression syntax or a typo =); you can safely ignore it, although I suggest learning reST; it's simple and is accepted for `PEP markup`_ and gives some perks for the HTML output. Also, because of the wonders of programs that like to reformat text, I cannot guarantee you will be able to run the text version of this ...

Is DBD::Informix tied to database version?
Hi - I would like to upgrade our database from 9.21 HC5 to 9.40.FC4, but have Perl applications reading from the database using DBD::Informix. Does anyone know if the DBD interface is tied to the specific version of Informix? I have been trying to recompile the latest perl/DBI/DBD but so far have not had any luck - since the current DBD is working fine with 9.21, I would like to just upgrade to 9.40. Thanks in advance for any insights. Daniel caver wrote: > Hi - I would like to upgrade our database from 9.21 HC5 to 9.40.FC4, > but have Perl applications reading from the database using > DBD::Informix. > > Does anyone know if the DBD interface is tied to the specific version > of Informix? > > I have been trying to recompile the latest perl/DBI/DBD but so far have > not had any luck - since the current DBD is working fine with 9.21, I > would like to just upgrade to 9.40. No, DBD::Informix is not tied to a particular server version. I use my installed version of DBD::Informix (2005.01), built with CSDK 2.81.UCx, with IDS 10.00.UC3, 9.40.UC5, 9.30.UC1, 9.21.UCx (very seldom these days; about once this year), 7.31.UD7 - all with no trouble whatsoever. DBD::Informix is much more nearly tied to a particular version of CSDK. Specifically, unless you compiled the module with the environment variable DBD_INFORMIX_RELOCATABLE_INFORMIXDIR set, it will have built the absolute pathnames of the ESQL/C librar...

[Informix][Informix ODBC Driver] Database locale information mismatch
I have download ClientSDK 2.90.TC4 I am trying to connect to an IDS10 database. My iLogin works fine, but I cannot set up the ODBC driver, I keep getting the message "[Informix][Informix ODBC Driver] Database locale information mismatch" I cannot leave it blank, under environment, and I cannot find any matching pairs. Can somebody help. XP client and Linux server This is a multipart message in MIME format. --=_alternative 0046812965257177_= Content-Type: text/plain; charset="US-ASCII" I am guessing that you are using 10.00.xC4 or the version where you have fix for 171156 IDS defect. Basically this bug fix will enforce the correct database locale setting from client (i.e. ODBC etc). If you supply the (default is en_US.1252) correct database locale(that is actually the database created with) in ODBC DSN(or your connection string) then your connection should go through. However in ODBC side as well we have the corresponding fix in place. Ask your customer support to get the patch of ODBC defects 175110 and 175746. These ODBC fixes will automatically take care of getting the correct database locale value for the given database (through DSN). Thanks & Regards -Shesh bobkot@gmail.com Sent by: informix-list-bounces@iiug.org 05/23/2006 05:58 PM To informix-list@iiug.org cc Subject [Informix][Informix ODBC Driver] Database locale information mismatch I have download ClientSDK 2.90.T...

2005-September-14-to-2005-Mar-01 new programs,
2005-September-14-to-2005-Mar-01 new programs, 2005/09/13 Macromedia Dreamweaver 8 2005/09/13 Macromedia Flash 8 2005/09/13 Macromedia Fireworks 8 2005/09/13 Mainconcept.Mainactor.v5.5.18 2005/09/13 Shave.And.A.Haircut.v3.6v2.for.Maya.6.5/7.0(Win/MAC/Linux) 2005/09/13 Corel.Paint.Shop.Pro.v10 2005/09/13 HotDoor.CADtools.v4.0.for.Adobe.Illustrator 2005/09/13 Cycling.74.MAXMSP.v4.5.5 2005/09/13 Cycling.74.Mode.VSTi.RTAS.v1.2.2 2005/09/13 Way.Out.Ware.TimewARP.2600.VSTi.RTAS.v1.10 2005/09/13 FabFilter.Volcano.VST.v1.11 2005/09/13 Antares.AVOX.Vocal.Kit.Bundle.VST/RTAS.v1.02 2005/...

RE: Informix DBD, PERL and esql
sorry I suck. When running esql -o esqlbasic esqlbasic.ec -----Original Message----- From: Gentsch, Sam Sent: Thursday, June 23, 2005 4:08 PM To: informix-list@iiug.org Subject: Informix DBD, PERL and esql Actually this is a esqlc problem and may be because we are trying to use gcc instead of cc_r I receive gcc: '-b' must come at the start of the command line Or cc: '-b' must come at the start of the command line if INFORMIXC not set. IBM Support said there was a bug for 4gl basically saying gcc does not work with it and they were not planning on fixing it (and the support guy said that meant it was true for ESQLC too) So has anyone managed to overcome this problem and successfully use gcc with AIX 5.3? Hopefully, I am missing something simple. Thanks a lot! Sam System info follows (probably more than you want) Perl: perl v5.008007 aix-64all dl_aix.xs System: aix aix 3 5 00cc339e4c00 (5.3) Using INFORMIXDIR=/opt/informix/IDS_9.40.FC6 and ESQL/C compiler esql Using IBM Informix CSDK Version 2.90, IBM Informix-ESQL Version 2.90.FC3 from /opt/informix/IDS_9.40.FC6 DBI 1.48 installed IDS 9.40FC6, with a stores gcc: 3.3.2 Have INFORMIXC=gcc DBD_INFORMIX_ESQLC_LINKAGE='-b' //tried it anyways Changed LD_LIBRARY_PATH to LIBPATH since on AIX Big -V stuff: gcc -v Reading specs from /opt/freeware/lib/gcc-lib/powerpc-ibm-aix5.2.0.0/3.3.2/specs Configured with: ../configure --with-a...

How to copy a sun-database in one informix database to another informix database?
Hi, Sorry I am not an informix dba, and I was faced to copy a sub-database(sorry I don't know the clear name of such concept, as informix is like sql-server, which used multiple database) from one informix database system to another informix database. I know in oracle, we can use transportable tablespace, copy the datafile and transport the metadata, and do something else. How can I do it in informix then? Is there document which talk about the detail step? Thanks It would really help if you knew the versions of the Informix databases. Assuming Informix IDS 7.x or IDS 9.x If the two systems are binary compatible the fastest method is to use onunload/onload. If the systems are not binary compatible the easiest way is to use dbexport/dbimport. Everything is well documented in the manual "IBM Informix Migration Guide". This manual covers all Informix databases from Standard Engine and Online to IDS and XPS. See http://www.ibm.com/informix/pubs zhu chao wrote: > Hi, > Sorry I am not an informix dba, and I was faced to copy a > sub-database(sorry I don't know the clear name of such concept, as > informix is like sql-server, which used multiple database) from one > informix database system to another informix database. > I know in oracle, we can use transportable tablespace, copy the > datafile and transport the metadata, and do something else. How can I > do it in informix then? Is there...

ANNOUNCE: Initial release of WSF/Perl (Perl bindings for a WS-* framework)
Hi, The initial version of WSF/Perl is available on CPAN. Just do a search for "wsf". WSF/Perl is the Perl bindings for WSO2 WSF/C which is a WS-* framework that has Apache Axis2/C as the core with some other related projects bundled together. A "fixed" version of WSF/C which works with this release of WSF/Perl is available at http://ww2.wso2.org/~chintana/ Why? Modules of WSF/C are not linked properly and this causes the perl to throw an undefined symbol at run time. This will be fixed from the next release of WSF/ C. This is client side only with, - WS-Addressing - Support for consuming REST style - Support SOAP 1.1/1.0 and submission. More info - http://wso2.org/projects/wsf/perl Bye, -Chintana ...

Informix Perl DBI/ESQL/Online problem
I am trying to install the Informix DBI drivers for Perl onto our AIX 4.3.3 machine where we are running a very old Informix OnLine 5.10.UC1. I have downloaded the DBD-Informix-2005.01 package and it requires ESQL/C, which it suggests can be sourced as part of the Informix Client SDK (Version 2.81) which I have installed. The problem is, I can't get the ESQL/C to make a successful connection into the Informix databases. It keeps telling me I do not have permission which suggests a missing hosts.equiv entry, although I do have every name I can think of in here. Both the client and server are the same machine, so I would have hoped it was going to be straight forward. I'm left wondering if there is just version incompatibility, as one of the README files for the SDK says that the lowest tested Informix version is "Informix Dynamic Server 5.20.XX". The sqlhosts entry we are trying is : labserver onsoctcp labserver sqlexec The hosts.equiv entries are : labserver labserver.medlab.co.nz medlabh medlabh.medlab.co.nz localhost localhost.medlab.co.nz Each of these machine names exist in our hosts file. Any help anyone can offer would be appreciated. Stu Stewart Hague wrote: > I am trying to install the Informix DBI drivers for Perl onto our AIX > 4.3.3 machine where we are running a very old Informix OnLine 5.10.UC1. > > I have downloaded the DBD-Informix-2005.01 package and it requi...

RE: Informix DBD, PERL and esql #2
After stripping every flag out of the esql program that it whined about I get down to: gcc: CC_TH=gcc: No such file or directory In file included from /usr/include/sys/localedef.h:46, from /opt/freeware/lib/gcc-lib/powerpc-ibm-aix5.2.0.0/3.3.2/include/stdlib.h: 538, from esqlbasic.ec:25: /usr/include/sys/localedef31.h:195: error: conflicting types for `loc_t' /opt/informix/IDS_9.40.FC6/incl/esql/locator.h:123: error: previous declaration of `loc_t' This is my last post on this, hate to torment you folks with my lack of gcc prowess. No comments from you OTC! :) Thanks again, Sam -----Original Message----- From: owner-informix-list@iiug.org [mailto:owner-informix-list@iiug.org] On Behalf Of Gentsch, Sam Sent: Thursday, June 23, 2005 5:50 PM To: informix-list@iiug.org Subject: RE: Informix DBD, PERL and esql sorry I suck. When running esql -o esqlbasic esqlbasic.ec -----Original Message----- From: Gentsch, Sam Sent: Thursday, June 23, 2005 4:08 PM To: informix-list@iiug.org Subject: Informix DBD, PERL and esql Actually this is a esqlc problem and may be because we are trying to use gcc instead of cc_r I receive gcc: '-b' must come at the start of the command line Or cc: '-b' must come at the start of the command line if INFORMIXC not set. IBM Support said there was a bug for 4gl basically saying gcc does not work with it and they were not planning on fixin...

Informix and ESQLC Perl and DBD but Sun this time.
Semi-related to our earlier fun with AIX and DBD build environments. Solaris 8, 9.40FC, CSDK2.80UC (now in a separate dir CSDK2.90FC), Perl 5.6.1 I got the esqlbasic program to compile and run installing the 64 bit CSDK (standalone), upgrading to gcc 3.3.2 and setting INFORMIXC='gcc -m64 after clearing arch9 args out of the esql file But, when running "perl Makefile.PL" to build the Bundle:DBD::informix I am still getting: ld: fatal: file $INFORMIXDIR/lib/esql/libifsql.so: wrong ELF class: ELFCLASS64 ld: fatal: file $INFORMIXDIR/lib/libifasf.so: wrong ELF class: ELFCLASS64 ld: fatal: file $INFORMIXDIR/lib/esql/libifgen.so: wrong ELF class: ELFCLASS64 ld: fatal: file $INFORMIXDIR/lib/esql/libifos.so: wrong ELF class: ELFCLASS64 ld: fatal: file $INFORMIXDIR/lib/esql/libifgls.so: wrong ELF class: ELFCLASS64 ld: fatal: file $INFORMIXDIR/lib/esql/libifglx.so: wrong ELF class: ELFCLASS64 This is the same error I get when building esqlbasic.ec with the INFORMIXC env variable set to gcc rather than gcc -m64. I cannot seem to figure out how to make the "perl Makefile.PL" have the -m64 argument (assuming this is the problem, since it seems to have been that on the esqlbasic compile, it throws errors about sizes being redefined.) Is there some wiz-bang way to do this? I have never had issues biulding DBD with Solaris and GCC in the past, but this box is killing me. The Box I built with similar OS, etc worked like...

install_driver(Oracle) failed: Can't load 'C:/Perl/site/lib/auto/DBD/Oracle/Oracle.dll' for module DBD::Oracle: load_file:The specified procedure could not be found at C:/Perl/lib/DynaLoader.pm line 2
hello i have a strange problem with DBI module. has anyone any clue about what is wrong here? my connection string: --------------------- use DBI; use DBD::ODBC; use DBI qw(:sql_types); use strict; use warnings; my $db = "something"; my $user = 'XXX'; my $passwd = 'XXX'; my $dbh = DBI->connect('dbi:Oracle:XXX', $user,$passwd, {RaiseError => 1, AutoCommit => 0}) or die $DBI::errstr; ################# This gives the foll...

CDs 2005/01/01 to 2005/02/28
CDs 2005/01/01 to 2005/02/28 GARAGE SALES, working, tested, fully functional, very cheap discounted price, low cost, --------------------------------------------------------------- 2005/01/02 CG Toolkit Muscle TK v1.1 for Maya 5/6 2005/01/02 3dAliens.Glu3D.v1.3.08.for.3dsmax.7 2005/01/02 Adobe.Acrobat.7.0.Professional 2005/01/02 Pandromeda MojoMove for MojoWorld v3.0(Win/Mac) 2005/01/02 Pandromeda MojoTree for MojoWorld v3.0(Win/Mac) 2005/01/02 Pandromeda MojoWorld Focus v3.0(Win/Mac) 2005/01/02 SGI OpenGL Preformer v3.2 2005/01/02 HASH Animation Master 2005 v11.1b 2005/01/02 ...

CDs 2005/01/01 to 2005/02/28
CDs 2005/01/01 to 2005/02/28 GARAGE SALES, working, tested, fully functional, very cheap discounted price, low cost, --------------------------------------------------------------- 2005/01/02 CG Toolkit Muscle TK v1.1 for Maya 5/6 2005/01/02 3dAliens.Glu3D.v1.3.08.for.3dsmax.7 2005/01/02 Adobe.Acrobat.7.0.Professional 2005/01/02 Pandromeda MojoMove for MojoWorld v3.0(Win/Mac) 2005/01/02 Pandromeda MojoTree for MojoWorld v3.0(Win/Mac) 2005/01/02 Pandromeda MojoWorld Focus v3.0(Win/Mac) 2005/01/02 SGI OpenGL Preformer v3.2 2005/01/02 HASH Animation Master 2005 v11.1b 2005/01/02 Ulead.VideoStudio.v8.01 2005/01/02 Moonlight.Adobe.Premiere.Export.Plugins.v1.1 2005/01/02 Synful.Orchestra.DXi.VSTi.v2.0 2005/01/02 VeCAD DLL-OCX v6.1.0 2005/01/02 Nemetschek Allplan v2004.0b4 Multilanguage Update Only 2005/01/02 Sonic.MyDVD.Studio.Deluxe.Suite.v6.0c.Multilanguage 1CD 2005/01/02 Native.Instruments.ABSynth.v3.0.VSTi.DXi.RTAS.AU 1CD 2005/01/02 INUS Technology RapidForm 2004 PLUS Pack 2 1CD 2005/01/02 Graitec.Advance.v5.2 2CD 2005/01/02 Graitec.OMD.v12.1H 1CD 2005/01/02 RAM.Concept v1.2 1CD 2005/01/02 Telelogic.TAU Generation2.v2.4 1CD 2005/01/02 VTC.Maya.Fundamentals 1CD 2005/01/02 Gnomon.Maya.Training.DVD-Mental.Ray.I.DVDR 1DVD 2005/01/02 Discovery.Firm.Discovery.Japan.Cdda 1CD 2005/01/07 Kajima Reals 3D v2.040426 2005/01/07 LightMachine.v1.0.for.Adobe.Photoshop 2005/01/07 IK.Multimedia.Amplitube.RTAS.DX.VST.v1.3.1 2005/01/07 IK.Multimedia.T-Racks.DX.RTAS.VST.v1.2.1 2005/01/07 Korg....

perl sub and perl modules
Hi all, I am new in perl and I am having some difficulties in getting used to it. I have an array of array: my @hap = ( [qw/ a c g t g c/], [qw/ c g ? t a g/], [qw/ a c t t ? c/]); and as during the process I will need to print how this evolves during the process, I tried to place a print sub: sub MyPrint { my (@arr) =@_; for my $i (0..$#arr){ for my $j (0..$#{$arr[$i]}){ print $arr[$i][$j]."\t"; } print "\n"; } } if I call my print as reference: MyPrint(\@hap); I get: ARRAY(0x541c) ARRAY(0x7b944) ...

Re: Perl DBD::Informix and IDS 64-bit
Hi, I'm using Perl 64 bit on Solaris 9. The Sun provided Perl is 5.6.1 and 32bit. So I built my own 5.8.0 with the Sun CC 5.4 and DBD-Informix 2003.04 and DBI 1.34, CSDK 2.81FC2, IDS 7.31FD5. Works fine and is in production now. But I never managed it to get a DBI>1.34 working on this Plattform. I've escalated this case with IBM informix Support here in Germany, but it didn't get to Jonathan Leffeler I think. The problem was that DBI->errstr pointed in the wrong direction so that I got a Segmentation Violation when trying to print it. > I'm curious: does anyone have any experience using Perl > DBD::Informix with 64-bit IDS? If so, how well does it work (if it > works at all)? Any "gotchas" to look out for? There are two parts to the answer. 1. The nit-picking pedantry bit says "It depends on whether you build with a 32-bit or 64-bit version of CSDK - because a 32-bit CSDK cannot use shared memory communications with a 64-bit server - but otherwise there are no issues whatsoever". 2. I can't answer for other people, but I can give you my perspective on it. The issue with using Perl with a 64-bit IDS tends to be getting a 64-bit Perl. That depends on the platform - which you don't mention - but where you have a choice of 32-bit or 64-bit (eg Solaris), the default builds of Perl tend to be 32-bit, and that won't work with a 64-bit CSDK. So, s...

Cannot load DBD and DBI to connect perl to postgres database
I need to connect a windows client running activestate perl 5.8.8 to a postgres database running on windows 2003 server. I have loaded DBI:pg module and DBD with various degrees of success. When I run a simple test script to make a connection to the postgres database I get the error: H:\Src\Perl>perl pg1.pl The procedure entry point Perl_newXS_flags could not be located in the dynamic link library perl58.dll. install_driver(Pg) failed: Can't load 'C:/Perl/site/lib/auto/DBD/Pg/ Pg.dll' for module DBD::Pg: load_file:The specified procedure could not be found at C:/Perl/lib/DynaLoader.pm line 230. at (eval 4) line 3 Compilation failed in require at (eval 4) line 3. Perhaps a required shared library or dll isn't installed where expected at pg1.pl line 24 # # # a simple test script for connecting to the default # PostgreSQL database. # # Copyright 2000 DVL Software Limited # # see http://freebsddiary.org/postgresql-perl.html # use DBI; use strict; my $dbh; my $sth; my @vetor; my $field; $dbh =3D DBI->connect("DBI:Pg:dbname=3Dcollector; host=3Dmyhost", "postgres", "postgres"); if ($dbh) { print "connected\n"; $sth =3D $dbh->prepare("SELECT * from table limit 20"); if (!defined($sth)) { print "Cannot prepare $DBI::errstr\n"; } if (!$sth->execute) { print "Cannot execute $DBI::errstr\n"; } print "<table>\n"; while...

FAQ 1.4 What are Perl 4, Perl 5, or Perl 6? #14
This is an excerpt from the latest version perlfaq1.pod, which comes with the standard Perl distribution. These postings aim to reduce the number of repeated questions as well as allow the community to review and update the answers. The latest version of the complete perlfaq is at http://faq.perl.org . -------------------------------------------------------------------- 1.4: What are Perl 4, Perl 5, or Perl 6? (contributed by brian d foy) In short, Perl 4 is the past, Perl 5 is the present, and Perl 6 is the future. The number after perl (i.e. the 5 after Perl 5) is the m...

Connect database informix fom visual studio .net 2005
SSB3YW50IHRvIGNvbm5lY3QgZGF0YWJhc2UgaW5mb3JtaXggd2l0aCB2aXN1YWwgc3R1ZGlvIC5u ZXQgMjAwNSAuIEJ1dApJIGRvbid0IGtub3cgYWJvdXQgaXQuCldobyBpcyB5b3VyIGtub3cgYWJv dXQgaXQgPyBQbGVhc2UgYW5zd2VyIG1lIC4gcGxzCgq16c2nodLDtdS0tejNsNK5ounNwdnFIGlu Zm9ybWl4ILTpx8IgdnMubmV0IDIwMDUgzejQpNAg46TDvs2o0MHVCrXRx83C6NKnuunSp6TQILXN uuPL6cu56M3CudCk0Ao= On Nov 11, 6:13 am, wim...@gmail.com wrote: > I want to connect database informix with visual studio .net 2005 . But > I don't know about it. > Who is your know about it ? Please answer me . pls > > =B5=E9=CD=A7=A1=D2=C3=B5=D4=B4=B5=E8=CD=B0=D2=B9=A2=E9=CD=C1=D9=C5 inform= ix =B4=E9=C7=C2 vs.net 2005 =CD=E8=D0=A4=D0 =E3=A4=C3=BE=CD=A8=D0=C1=D5 > =B5=D1=C7=CD=C2=E8=D2=A7=BA=E9=D2=A7=A4=D0 =B5=CD=BA=E3=CB=E9=CB=B9=E8=CD= =C2=B9=D0=A4=D0 For some basics on ADO.Net and Informix, check out this article, though it is dated: http://www.ibm.com/developerworks/db2/library/techarticle/dm-0510durity/ The 3.00 version of the Client SDK has an updated ADO.Net driver with a few more hooks into VS2005. Check the documentation. If you are looking at building enterprise database applications with .Net you should definitely look at DevForce from IdeaBlade: www.ideablade.com That is the data and application framework I have used. Unless you *have* to build your own, don't even get started. Buy Devforce and work on the most interesting parts of your application. It is far more advanced than anything you will build...

Web resources about - ANNOUNCE: DBD::Informix - IBM Informix Database Driver for Perl DBI Version 2005.01 (2005-03-14) released - comp.lang.perl.modules

Resources last updated: 3/24/2016 8:24:55 AM