f



Help Needed: Upgrade Fedora 4 / Apache 2 to PHP 5.2.x from 5.0.4

Help Needed: Upgrade Fedora 4 / Apache 2 to PHP 5.2.x from 5.0.4

I've been testing Joomla as a content manager for the County offices,
and it looks pretty good. Unfortunately, I decided to upgrade it from
the 1.0.13 version to 1.5 as we get ready to go live with the web
site... and the update installation gives an error in XML processing,
which seems (from what I've been able to dredge up in forum
discussions) to stem from a known bug in PHP 5.0.4... 

I've seen this same error from a couple of other programs that want to
upload XML data to PHP based server software, too, so I'm inclined to
believe the problem is on the server side and that it has at least
something to do with PHP, i.e. either a bug or at least a setup/config
problem...

So I decided to upgrade the PHP from 5.0.4 to 5.2.4, but I couldn't
find a binary set for Fedora 4, so it has to be compiled.... and I
can't get it to install. 

Actually, that's not quite true - I did get it to install with the
base config, but that didn't include some needed stuff (e.g. mysqli),
and when I took the config parameters from the 5.0.4 version (from the
output of aboutphp.php) and tried those with the config build, it
complained about not finding apxs. I don't find apxs anywhere on the
system, so I'm stuck there (as far as building the PHP 5.2.4).

The install docs from php.net call for you to build Apache from
source, which I gather will create apxs as part of the build, but -
having now broken PHP and the blogging and the old Joomla which depend
on it (even phpmyadmin no longer works, because the installed PHP
doesn't include mysqli) - I am really reluctant to continue on and
break httpd also... 

Any advice? Is building Apache really the thing to do here, or is
there some other way to add the missing mysql stuff to the new PHP, or
should I keep looking for PHP 5.2.x binaries for Fedora 4, or... what?

0
11/7/2007 5:29:47 PM
comp.lang.php 32646 articles. 0 followers. Post Follow

4 Replies
1215 Views

Similar Articles

[PageSpeed] 39

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Joel Fireman wrote:
> Help Needed: Upgrade Fedora 4 / Apache 2 to PHP 5.2.x from 5.0.4
>
> Any advice? Is building Apache really the thing to do here, or is
> there some other way to add the missing mysql stuff to the new PHP, or
> should I keep looking for PHP 5.2.x binaries for Fedora 4, or... what?
> 

5.2.x is still in the dev repositories. have a look in
download.fedora.redhat.com/pub/fedora/linux/development/i386/os/Packages/
for one.

- --
Brendan Gillatt
brendan {at} brendangillatt {dot} co {dot} uk
http://www.brendangillatt.co.uk
PGP Key: http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xBACD7433
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (MingW32)

iD8DBQFHMgGfkA9dCbrNdDMRApo7AJ9FjY1LX2Ba+lP09bkwwqpkjHwwZQCfWWv7
twsUNFSERJOpbt/2ZPP//HA=
=IF6l
-----END PGP SIGNATURE-----
0
11/7/2007 6:19:11 PM
On Wed, 07 Nov 2007 18:19:11 +0000, Brendan Gillatt
<brendanREMOVETHIS@brendanREMOVETHISgillatt.co.uk> wrote:

>5.2.x is still in the dev repositories. have a look in
>download.fedora.redhat.com/pub/fedora/linux/development/i386/os/Packages/
>for one.

Thanks - I tried it, but of course, rpm doesn't want to install it -
15 failed dependencies... and they quickly turn circular... I'm afraid
the FC 4 is just too old for the new php's, so all I can think of is
an upgrade to FC 7. If I can get my amazon p/w found, I'll probably
just order a Bible with FC 7 and install that... 

I sure hope after all this screwing around that the Joomla error
really IS a php 5.0.4 problem! Of course, it's too late to go back
now, since php is already ruined by the partial install (it might be
salvageable if there were a way to add php-mysql to it)...

Thanks again, I appreciate the help.

0
11/7/2007 11:48:10 PM
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Joel Fireman wrote:
> On Wed, 07 Nov 2007 18:19:11 +0000, Brendan Gillatt
> <brendanREMOVETHIS@brendanREMOVETHISgillatt.co.uk> wrote:
> 
>> 5.2.x is still in the dev repositories. have a look in
>> download.fedora.redhat.com/pub/fedora/linux/development/i386/os/Packages/
>> for one.
> 
> Thanks - I tried it, but of course, rpm doesn't want to install it -
> 15 failed dependencies... and they quickly turn circular... I'm afraid
> the FC 4 is just too old for the new php's, so all I can think of is
> an upgrade to FC 7. If I can get my amazon p/w found, I'll probably
> just order a Bible with FC 7 and install that... 
> 
> I sure hope after all this screwing around that the Joomla error
> really IS a php 5.0.4 problem! Of course, it's too late to go back
> now, since php is already ruined by the partial install (it might be
> salvageable if there were a way to add php-mysql to it)...
> 
> Thanks again, I appreciate the help.
> 

Ah, I'm glad I left the red-hat distro world for Debian ;]

Good luck all the same.

- --
Brendan Gillatt
brendan {at} brendangillatt {dot} co {dot} uk
http://www.brendangillatt.co.uk
PGP Key: http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xBACD7433
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (MingW32)

iD8DBQFHMzsrkA9dCbrNdDMRAjeHAKDYoKwkmqOm1yFGhWcUVIdcjXQlLwCdEy/s
d2343VK/HgfuN8Lc/W0lH8c=
=Y9OJ
-----END PGP SIGNATURE-----
0
11/8/2007 4:36:59 PM
On Thu, 08 Nov 2007 16:36:59 +0000, Brendan Gillatt
<brendanREMOVETHIS@brendanREMOVETHISgillatt.co.uk> wrote:

>-----BEGIN PGP SIGNED MESSAGE-----
>Hash: SHA1
>
>Joel Fireman wrote:
>> On Wed, 07 Nov 2007 18:19:11 +0000, Brendan Gillatt
>> <brendanREMOVETHIS@brendanREMOVETHISgillatt.co.uk> wrote:
>> 
>>> 5.2.x is still in the dev repositories. have a look in
>>> download.fedora.redhat.com/pub/fedora/linux/development/i386/os/Packages/
>>> for one.
>> 
>> Thanks - I tried it, but of course, rpm doesn't want to install it -
>> 15 failed dependencies... and they quickly turn circular... I'm afraid
>> the FC 4 is just too old for the new php's, so all I can think of is
>> an upgrade to FC 7. If I can get my amazon p/w found, I'll probably
>> just order a Bible with FC 7 and install that... 
>> 
>> I sure hope after all this screwing around that the Joomla error
>> really IS a php 5.0.4 problem! Of course, it's too late to go back
>> now, since php is already ruined by the partial install (it might be
>> salvageable if there were a way to add php-mysql to it)...
>> 
>> Thanks again, I appreciate the help.
>> 
>
>Ah, I'm glad I left the red-hat distro world for Debian ;]
>
>Good luck all the same.

Yeah... I was hopeful that yum would take care of these sorts of
problems, but it didn't do much for this one. I suppose that if I knew
exactly what the "official" names (and numbers) of the applicable
packages were, that yum might be able to handle it, but in this case
it was a steady diet of building repositories and then discovering
that either the named package couldn't be found, or it was marked as
being up-to-date. Until "the Linux world" wakes up and realizes that -
my two cents' wirth here - there is a good deal of manipulation going
on in the world of M$ to keep Linux "divided and conquered" we're
going to continue to see these kinds of things happening. 

Meantime... if I had plenty of time and resources, I'd likely be
looking at other distros...but right now I'm going on the assumption
that I can install FC 7 on the system without trashing the existing
users' and apps' directories. I'm sticking with FC for now because it
seems that each distro wants to put things in differently-named
directories from the others, and even use different environment
designations. I have a SuSE box at home that is a decent enough
system, but it's a pain sometimes trying to remember where IT wants to
see various programs and data - it's reminiscent of the
keyboard-layout copyright problems, and, of course M$ itself changing
directories and whatnot with each new version, apparently more or less
gratuitously ("I know what! Let's call it 'Documents and Settings'
instead of 'home'!").

Pfui!

But, thanks, again!
0
11/9/2007 4:01:02 PM
Reply:

Similar Artilces:

Apache 2.2.4 ignores PHP 5.2.4 scripts on Win2K3
Hi all PHP newbie here, 1) I disabled IIS. 2) Loaded Apache 2.2.4 on Win2K3. 3) Loaded PHP 5.2.4 pretty much bare bones, but included MySQL, SMTP, SOAP and ZIP extensions. Installers: apache_2.2.4-win32-x86-openssl-0.9.8d.msi php-5.2.4-win32-installer.msi Installer changed the httpd.conf file and added the following: PHPIniDir "C:/Program Files/PHP/" LoadModule php5_module "C:/Program Files/PHP/php5apache2_2.dll" AddType application/x-httpd-php .php Error log shows that PHP was configured: .... [Fri Sep 14 16:07:49 2007] [notice] Apache/2.2.4 (Win32) PHP/5.2.4 configured -- resuming normal operations [Fri Sep 14 16:07:49 2007] [notice] Server built: Jan 9 2007 23:17:20 .... If I add any PHP code to the index.html file it is ignored: <?php print "My Test"; ?> or <?php phpinfo(); ?> Any ideas? -- thanks, bill "AlterEgo" <someone@dslextreme.com> wrote in message news:13em57122h92h15@corp.supernews.com... > Hi all PHP newbie here, > > 1) I disabled IIS. > 2) Loaded Apache 2.2.4 on Win2K3. > 3) Loaded PHP 5.2.4 pretty much bare bones, but included MySQL, SMTP, SOAP > and ZIP extensions. > > Installers: > apache_2.2.4-win32-x86-openssl-0.9.8d.msi > php-5.2.4-win32-installer.msi > > Installer changed the httpd.conf file and added the following: > PHPIniDir "C:/Program Files/PHP/" > LoadModule php5_module "C:/Program Files/PHP/php5apache2_2.dll" &g...

<?= does not work on Windows XP Apache 2.2.x and PHP 5.2.4
When i do <?php echo "This works fine"; ?> Everything works fine. But when i do <?= "Some text"?> nothing works. Any ideas? Best Regards, Nicos On Fri, 28 Sep 2007 10:06:26 +0200, Nicos <nicoskk@gmail.com> wrote: > When i do > <?php > echo "This works fine"; > ?> > Everything works fine. But when i do > <?=3D "Some text"?> nothing works. Any ideas? It relies on short_open_tags, which have been disabled by default for a = = very long time now. Don't rely on them, only keep the setting on for = legacy code that still uses it for which you have no time to rewrite it,= = and use full tags in new code. -- = Rik Wasmus ...

PHPBB2, PHP 4.3.4, MySQL 4.1.1, Apache 2.0.49, Fedora 2
My combination is: PHPBB2, PHP 4.3.4, MySQL 4.1.1, Apache 2.0.49, Fedora 2 Anyone out there has a successful combination of newer versions ? fr gr Erik ...

Apache 2.2.3 PHP 4.4.5 Install Fails
Sigh. I have Apache 2.2.3 installed and running on WinXP Pro SP2. I installed PHP 4.4.5 and added the following lines in httpd.conf PHPIniDir C:/PHP445/ LoadModule php4_module C:/PHP445/php4apache2.dll When I restarted Apache, i got this error: The Apache service reported the following error: >>> httpd.exe: Syntax error on line 488 of C:/Program Files/Apache Software Foundation/Apache2.2/conf/httpd.conf: Cannot load C:/PHP445/php4apache2.dll into server: The specified module could not be found. Turns out that php4apache2.dll requires libapr.dll, libaprutil.dll and libapriconv.dll...

Apache 2.0.50 php 4.3.8 Aix 5.2
I have apache 2 already installed and working. aixstar root /usr/httpd/bin > ./httpd -l Compiled in modules: core.c mod_access.c mod_auth.c mod_include.c mod_log_config.c mod_env.c mod_setenvif.c prefork.c http_core.c mod_mime.c mod_status.c mod_autoindex.c mod_asis.c mod_cgi.c mod_negotiation.c mod_dir.c mod_imap.c mod_actions.c mod_userdir.c mod_alias.c mod_so.c ../configure --with-apxs2=/usr/httpd/bin/apxs --with-oci8=/ora01/app/oracle/product/9.2.0.1.0 --enable-ftp --enable-sigchild --disable-libxml Works fine, without displaying any errors. m...

Apache 2.2.2 and PHP 5.1.4 on Win2k crashing
I just installed Apache 2.2.2 on my Windows 2000 (SP4) machine to test the new version. Everything works except PHP (version 5.1.4): when starting Apache, it pops out a message saying that it is unable to locate the module (even set on the correct path!), stops the execution and exits. On the other side, PHP works fine with Apache 2.0.55, so It's not a problem of a broken build. Got ideas? Thanks. -- Massimo Lombardo unwiredbrain@gmail.com wrote: > I just installed Apache 2.2.2 on my Windows 2000 (SP4) machine to test > the new version. > Everything works except PHP (version ...

& # 4 0 ; & # 4 4 3 0 5 ; & # 4 4 2 5 6 ; & # 4 1 ;@��������� ARS���� �����ؿ�@(����)
<HTML> <HEAD> <META content="text/html; charset=ks_c_5601-1987" http-equiv=Content-Type> <STYLE> p, font, span { line-height:120%; margin-top:0; margin-bottom:0; }</STYLE> </HEAD><BODY> <table border="1" width="629" bordercolor="#cccccc" bordercolorlight="#cccccc"> <tr> <td width="619" height="67"> <p align="center"><font face="����"><span style="FONT-SIZE: 11pt"></span></font></p...

& # 4 0 ; & # 4 4 3 0 5 ; & # 4 4 2 5 6 ; & # 4 1 ;��������� ARS���� �����ؿ�(����)
<HTML> <HEAD> <META content="text/html; charset=ks_c_5601-1987" http-equiv=Content-Type> <STYLE> p, font, span { line-height:120%; margin-top:0; margin-bottom:0; }</STYLE> </HEAD><BODY> <TABLE borderColor=#cccccc width=629 borderColorLight=#cccccc border=1> <TBODY> <TR> <TD width=619 height=67> <P align=center><FONT face=����><SPAN style="FONT-SIZE: 11pt"><IMG src="http://www.ezbizi.com/ezbizi/home_img/daechul_01.gif"></SPAN></FONT></P>&l...

need to upgrade from 9.2.0.4 to 9.2.0.5
Hello, I hope this is an easy question. At any rate I need to upgrade from 9.2.0.4 to 9.2.0.5. I'm asking becuase I've intalled patches before but never changed release numbers and I don't want to screw anything up. Is upgrading to 9.2.0.5 as simple as loading the first 9.2.0.5 patch??? I'm on metalink and looking at Doc ID: Note:161549.1 as I'm writing this. Am I in the correct area to download the 9.2.0.5 patch? Thanks! Adam Sandler wrote: > Hello, > > I hope this is an easy question. At any rate I need to upgrade from > 9.2.0.4 to 9.2.0.5. I'm asking becuase I've intalled patches before > but never changed release numbers and I don't want to screw anything > up. Is upgrading to 9.2.0.5 as simple as loading the first 9.2.0.5 > patch??? I'm on metalink and looking at Doc ID: Note:161549.1 as I'm > writing this. Am I in the correct area to download the 9.2.0.5 patch? > > Thanks! Upgrades are trivial as long as you: 1. Run a test first on a test server 2. Have a good backup 3. Read and follow Oracle documentation on how to do it. But why 9.2.0.5? Why not 9.2.0.6? -- Daniel A. Morgan Relational theory is not something that is simply a nice-to-have. http://www.psoug.org damorgan@x.washington.edu (replace x with u to respond) Maybe I wasn't clear in my first post... is going from one version to another in Oracle accomplished by loading the first patch of the next version? In MS Windo...

Apache 2.0.4.6 (Win) PHP 4.3.4.4
Hello there, We have PHP ver 4.3.4.4 working off Apache server version 2.0.4.6. My developer has developed a bunch of basic web pages which interact with the SQL Server 2000. We exposed the web application to the outside world though port 80 and the server crashed all of a sudden the very next day. Are there any security vulneribities with PHP ver 4.3.4.4 and Apache server version 2.0.4.6.which I need to be aware off. My developer is reluctant to upgrade the server to new version of apache and php. Any suggestion, help or pointer in the right direction will be appreciated. Thanks, anup...

Apache 2.0.4.6 (Win) PHP 4.3.4.4
Hello there, We have PHP ver 4.3.4.4 working off Apache server version 2.0.4.6. My developer has developed a bunch of basic web pages which interact with the SQL Server 2000. We exposed the web application to the outside world though port 80 and the server crashed all of a sudden the very next day. Are there any security vulneribities with PHP ver 4.3.4.4 and Apache server version 2.0.4.6.which I need to be aware off. My developer is reluctant to upgrade the server to new version of apache and php. Any suggestion, help or pointer in the right direction will be appreciated. Thanks, anup...

Upgrade php 4.3.6 to 5.2.4 ??
Hi, What is the best way to upgrade from PHP 4.3.6 to 5.2.4 ? I'm running windows 2003 server. Thanks On Sep 20, 4:06 pm, jerryyang_...@yahoo.com wrote: > Hi, > > What is the best way to upgrade from PHP 4.3.6 to 5.2.4 ? > > I'm running windows 2003 server. > > Thanks Hi. I did just that two days ago. are you using IIS or apache? I'm using apache, so all i needed to do was download the php 5.2.4 zip from the php website, unzip it and replace the old php directory that i had. Dont delete the old php directory until you have the new install working. Rename your current install to something like php_old or something. and rename the new install with the name of the old one, in the same location. You will then have to reconfigure the new php.ini file in the new install. Open the php directory, make a copy of the file php.ini- reccommended and rename it to 'php.ini'. Open it in a text editor and find the line extension_dir = "/." change this to the path of the 'ext' folder in your php directory (you could use the setting from your old php.ini file since you have just replaced the old directory with the new one it will be the same) Load the extensions that you want by uncommenting them in the php.ini folder, such as mysql etc THEN Open the file httpd.conf in your apache/conf directory and add this, (but change the paths to match your install) and remove the one that was for your php4 install. LoadMod...

Errors in php 5.0.4 Not in 4.3.10-16 #2
I use the following statements: $var = ""; $var = $_POST('varname'); In php 4, when 'varname' was not defined, $var remained an empty string; In php 5, I suddenly get errors. I solved these by including the function array_key_exist to check the occurence of 'varname' Is this the prefered way or is ther a better solution? Thanx, Han koster Han Koster wrote: > I use the following statements: > > $var = ""; > $var = $_POST('varname'); > > In php 4, when 'varname' was not defined, $var remained an empty string; ...

3d Studio Max 5.1 inc Character Studio 4.0 [2 CDs], Viz r42sp2, Cebas finalRender Stage-1 for 3dsmax 4.x and 5.x -new
3d Studio Max 5.1 inc Character Studio 4.0 [2 CDs], Viz r42sp2, Cebas finalRender Stage-1 for 3dsmax 4.x and 5.x -new for info please send email Only authorized resellers can sell max. <tel4@ath.forthnet.gr> wrote in message news:3F72C885.37F5A719@ath.forthnet.gr... > 3d Studio Max 5.1 inc Character Studio 4.0 [2 CDs], Viz r42sp2, Cebas > finalRender Stage-1 for 3dsmax 4.x and 5.x -new > > for info please send email > ...

ANN: ActivePython 2.6.2.2, 3.1.0b1.0, 2.5.4.4 is now available
I'm happy to announce that ActivePython 2.6.2.2, 3.1.0b1.0 and 2.5.4.4 are now available for download from: http://www.activestate.com/activepython/ This is a patch release that updates ActivePython to core Python 2.6.2 and 3.1b2. This release also contains updates to Tcl/Tk 8.5.7 and Tix 8.4.3. We recommend that you try 2.6 version first. See the release notes for full details: http://docs.activestate.com/activepython/2.6/relnotes.html What is ActivePython? --------------------- ActivePython is ActiveState's binary distribution of Python. Builds for Windows, Mac OS X,...

Does 4/2/2= (4/2)/2 =1 OR = 4/(2/2)=4
I don't have matlab and I am trying to translate some simple matlab code. Does 4/2/2 = (4/2)/2 = 1 or 4/2/2 = 4/(2/2) = 4 On 9/11/2012 9:43 AM, sarah.englander@gmail.com wrote: > I don't have matlab and I am trying to translate some simple matlab code. > > Does 4/2/2 = (4/2)/2 = 1 yes. At a given precedence level (and obviously two of the same operators are the same level) evaluation proceeds from LtoR. ....snip... <http://www.mathworks.com/help/techdoc/matlab_prog/f0-40063.html#f0-38155> -- dpb <none@non.net> wrote in message <k2njh1$jes$1@speranza.aioe.org>... > On 9/11/2012 9:43 AM, sarah.englander@gmail.com wrote: > > I don't have matlab and I am trying to translate some simple matlab code. > > > > Does 4/2/2 = (4/2)/2 = 1 > > yes. At a given precedence level (and obviously two of the same > operators are the same level) evaluation proceeds from LtoR. > > ...snip... > > <http://www.mathworks.com/help/techdoc/matlab_prog/f0-40063.html#f0-38155> > > -- There are a few thing you need to understand: 1. You need to get matlab in order to translate the simple code 2. You should define your parameters as in what is the expected output of your search based on the equations used: Is it : a) 4/2/2 b) (4/2/2) On 9/11/2012 11:13 PM, Salvinder wrote: .. > There are a few thing you need to understand: > 1. ...

PHP 5.2.0 and Python 2.5
Hi Guys, I need some wisdom from you. Is it possible to have PHP pages posting to python scripts on the server side and returning values back to the calling PHP files? Like, if my enterval.php form's action=" think.py", would the two scripts be able to talk to each other? Thanks and Best Regards, "Shortash" Shortash wrote: > Hi Guys, > > I need some wisdom from you. Is it possible to have PHP pages posting > to python scripts on the server side and returning values back to the > calling PHP files? Like, if my enterval.php form's action=" t...

freebsd-5.2.1+ php-4.3.9 + gd-2.0.33
Hello there, I am tryin to compile PHP with GD support under FreeBSD-5.2.1: # cd php-4.3.11 # ./configure \ --with-gd=/usr/local/src/gd-2.0.33/ \ --with-png-dir=/usr/local/src/libpng-1.2.8/ \ --with-zlib-dir=/usr/local/src/zlib/ \ --with-jpeg-dir=/usr/local/src/jpeg-6b/ .... checking for GD support... yes checking for the location of libpng... /usr/local/src/libpng-1.2.8/ If configure fails try --with-jpeg-dir=<DIR> configure: error: libpng.(a|so) not found. why libpng.(a|so) not found ? # ls -l /usr/local/src/libpng-1.2.8/libpng.a -rw-r--r-- 1 root wheel 160448 May 31 12:48 /usr/local/src/libpng-1.2.8/libpng.a What is my mistake? Where to read about correct way to install php + gd + libjpeg + libpng ? Encapsulin wrote: > Hello there, > I am tryin to compile PHP with GD support under FreeBSD-5.2.1: > > # cd php-4.3.11 > # ./configure \ > --with-gd=/usr/local/src/gd-2.0.33/ \ > --with-png-dir=/usr/local/src/libpng-1.2.8/ \ > --with-zlib-dir=/usr/local/src/zlib/ \ > --with-jpeg-dir=/usr/local/src/jpeg-6b/ > > ... > checking for GD support... yes > checking for the location of libpng... /usr/local/src/libpng-1.2.8/ > If configure fails try --with-jpeg-dir=<DIR> > configure: error: libpng.(a|so) not found. > > why libpng.(a|so) not found ? > > # ls -l /usr/local/src/libpng-1.2.8/libpng.a > -rw-r--r-- 1 root wheel 160448 May 31 12:48 > /usr/loca...

imagerotate problem with PHP 4.3.9
Recap: Using imagerotate within PHP 4.3.9 - PHP 5.2.0 for both XP and Linux, all using GD2 If you rotate an image 180 degrees, all is fine If you rotate an image > 0 degrees and < 180 degrees, or > 180 degrees and < 360 degrees, while the image will rotate, its dimensions are somehow not refactored and as a result you get a rather annoying black bar in the newly-rotated image, along with part of your image being cropped off. I learned about a possible workaround with ImageMagick's convert command, but has anyone found a better solution (other than using XP's built-in im...

PHP 5.0.2 and tomcat 4.0
I am using PHP 5.0.2 and tomcat 4. whenever load the the PHP pages through IE, it gives the following error. java.lang.UnsatisfiedLinkError: send at net.php.servlet.send(Native Method) at net.php.servlet.service(servlet.java:190) at net.php.servlet.service(servlet.java:214) at javax.servlet.http.HttpServlet.service(HttpServlet.java:1264) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:247) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:193) at org.apache.catalina.core.StandardWrapperValve.invoke(Sta...

WinXP SP2,Apache 2.0.52, MySQL 5.0.0, PHP 5.01
I'm having a little trouble getting MySQL to load with Apache. Apache and PHP are working OK, but MySQL isn't loading. I know php.ini is loading because the following lines are in php.ini: extension_dir = "C:\Program Files\PHP" extension=php_mysql.dll and the error I get when Apache starts up is: PHP Startup: Unable to load dynamic load library 'C:\Program Files\PHP\php_mysql.dll' - The specified procedure could not be found. php_mysql.dll is definitely there. This same setup ( MySQL 5.0.0, PHP 5.01) works unchanged with the Abyss Web Server, so I know MySQL a...

Apache 2.0.48+php 4.3.4+Aix 4.3.3
Hello. I'm trying to compile this version of apache with php support on Aix 4.3.3ML11. I use gcc 3.2.1 compiler and all seems to go right. But when i try to access to a php page apache shows segmentation fault and doesn't answer. Any idea ? Thanks. > Hello. > I'm trying to compile this version of apache with php support on Aix > 4.3.3ML11. > I use gcc 3.2.1 compiler and all seems to go right. > But when i try to access to a php page apache shows segmentation fault and > doesn't answer. > > Any idea ? Does Apache also segfaults wh...

Apache/2.0.54 (Win32) PHP/5.0.5 multiple output
A newbie question: With the config mentioned in the topic, all on localhost, Win xpsp2, i created a caledar-table. The output should be a daily calendar for half a year with about 15 cols. So everything works fine on the console, output is as it should be. But when calling the script via apache, the table is either truncated or it comes twice or three times or i get an 404-Error with the table appended. Any hints? Many thanks in advance Thomas Hermann On Tue, 13 Sep 2005 21:15:14 +0200, Thomas Hermann <thomashermann@gmx.net> wrote: >A newbie question: > >With the config...

PHP 5.x and Wordpress 1.5.2 and Apache 1.3.x
Folks, I'm using WP 1.5.2 on Apache 1.3.33 and tried it with both PHP 5.0.4 and php 5.1.0.rc.1 -- and getting seg faults (can't even complete setup) I complete the first step in Setup, and get the seg fault going to the second step. I would welcome any work arounds/solutions people might have. I checked our the wordpress site, http://www.wordpress.org/, but seeing mixed messages. Some folks say the seg fault is there, others say it works with Apache 2.0? Many thanks. -- John ________________________________________________________________...

Web resources about - Help Needed: Upgrade Fedora 4 / Apache 2 to PHP 5.2.x from 5.0.4 - comp.lang.php

Resources last updated: 3/23/2016 7:16:23 PM