f



I installed PHP from an RPM, but Apache isn't processing the PHP pages! What's going on here?

===============================================================================
  I installed PHP from an RPM, but Apache isn't processing the PHP 
pages! What's going on here?
  Somebody can help me ? If I do /usr/sbin/apachectl extendedstatus 
command, I got this.
===============================================================================

                                      * * *

                    Apache Server Status for noname.com

    Server Version: Apache-AdvancedExtranetServer/2.0.44 (Mandrake
           Linux/11mdk) mod_perl/1.99_08 Perl/v5.8.0 mod_ssl/2.0.44
           OpenSSL/0.9.7a PHP/4.3.1

    Server Built: Mar 4 2003 21:21:03
      _________________________________________________________________

    Current Time: dimanche, 21-sep-2003 21:56:22 EDT
    Restart Time: dimanche, 21-sep-2003 19:13:15 EDT
    Parent Server Generation: 0
    Server uptime: 2 hours 43 minutes 6 seconds
    1 requests currently being processed, 5 idle workers

__W___..........................................................
.................................................................
.................................................................
.................................................................

    Scoreboard Key:
    "_" Waiting for Connection, "S" Starting up, "R" Reading Request,
    "W" Sending Reply, "K" Keepalive (read), "D" DNS Lookup,
    "C" Closing connection, "L" Logging, "G" Gracefully finishing,
    "I" Idle cleanup of worker, "." Open slot with no current process

##############################################################################
                     Apache Server Status for noname.com

    Server    Version:    Apache-AdvancedExtranetServer/1.3.27   (Mandrake
    Linux/5mdk) mod_perl/1.27
    Server Built: Feb 19 2003 22:32:42
      _________________________________________________________________

    Current Time: dimanche, 21-sep-2003 21:56:22 EDT
    Restart Time: dimanche, 21-sep-2003 19:13:09 EDT
    Parent Server Generation: 0
    Server uptime: 2 hours 43 minutes 13 seconds
    1 requests currently being processed, 3 idle servers
_W__............................................................
.................................................................
.................................................................
.................................................................

    Scoreboard Key:
    "_" Waiting for Connection, "S" Starting up, "R" Reading Request,
    "W" Sending Reply, "K" Keepalive (read), "D" DNS Lookup,
    "L"  Logging,  "G" Gracefully finishing, "." Open slot with no current
    process

##############################################################################

                                      * * *
===============================================================================
Into my httpd.conf, I have that
===============================================================================
#<IfDefine HAVE_PHP4>
LoadModule php4_module    /usr/lib/apache2-extramodules-2.0.44/mod_php4.so
LoadModule php4_module    /usr/lib/apache-extramodules/libphp4.so

#</IfDefine>

....

#<IfDefine HAVE_PHP4>
</IfDefine>
#<IfDefine HAVE_PHP4>
AddModule mod_php.c
AddModule mod_php3.c
AddModule mod_php4.c

#</IfDefine>

....

AddType application/x-httpd-php .phtml
AddType application/x-httpd-php .php
AddType application/x-httpd-php .php3
AddType application/x-httpd-php .php4
AddType  application/x-httpd-php-source  .phps

I tried
/usr/sbin/apachectl restart and /etc/rc.d/init.d/httpd restart commande 
but when I open php info page (<?Php phpinfo(); ?>) is not working. I 
install rpm from Mandrake disk 2.

I noticed than I got http2.conf and the same directory than http.conf. 
If I take off http2.conf I got a error message. But If I do the same 
with httpd.conf I got nothing (no error message).I have no http.conf.

Probably a misconfiguration but I am a newbies...

Thanks

Jean-Louis

P.S. If possible sent me your answer at jlvill@sympatico.ca

0
jlvill (6)
9/22/2003 2:43:58 AM
comp.lang.php 32646 articles. 0 followers. Post Follow

0 Replies
754 Views

Similar Articles

[PageSpeed] 30

Reply: