f



PHP 5.0.4 with Windows XP - trying to do file zip utility causes Apache 2.0.53 to crash

Has anyone had any luck with file zipping utilities for PHP 4-5 and
Windows XP with Apache 2.0.53?

Following is my code snippet:

PHP Code:
 if ($this->isSuccessful) {                // RUN ZIP COMMAND BASED
UPON STRING
         $zipName = ($album) ? "${section}s_$album" : "${section}s";
         $zipName .= '.zip';
           // NEW 4/1/2005 SEE NOTES IN classes.inc.php ON
getKommandOSArray() METHOD
         list($zipKommand, $zipRedirect) =
@array_values($this->getKommandOSArray('zip-jF9'));
         $msg = exec("$zipKommand $locationPath/$zipName " .
trim($imageList) . " $zipRedirect");
         if (preg_match('/zip error:/i', $msg)) {
          $this->isSuccessful = false;
          $this->setErrorArray(array('action' => "Error attempting to
create zip file from album \"$album\": " . nl2br($msg)));
         }
         if ($this->isSuccessful && is_file("$locationPath/$zipName")
&& (int)@filesize("$locationPath/$zipName") >
(int)$maxDownloadableFileSize) {
          $this->isSuccessful = false;
          $this->setErrorArray(array('willDownloadDisk' => 'ZIP archive
file size is larger than maximum allowable downloadable file size of '
..

DownloadableComponentsView::displayReadableMaxDownloadableFileSize() .
                                                        ', file
destroyed'
                                         )
                                     );
          @unlink("$locationPath/$zipName");
         }
        }
 }

Where "zip-jF9" in Windows comes out to be

Quote:
wzzip -u -en


I read online that WZZIP is a utility that will allow for using WinZip
in Windows within a command line prompt, which I would need to do in
order to use PHP's exec() command to do such.

Following are the steps I took:

1) Downloaded and installed WZZIP - making sure wzzip.exe and
wzunzip.exe exist in the same folder as winzip32.exe
2) Added "C:\Program Files\WinZip" to my PATH environmental variable
3) Rebooted
4) Restarted Apache

However, upon attempt to run the above PHP snippet, my Firefox and my
IE windows both locked up and Apache crashed!

I am thinking "WZZIP" is a big mistake, or, bad installation, or.. ??

Any thoughts or alternative ideas for file zipping in Windows using
PHP?

Thanx
Phil

0
9/30/2005 2:56:29 PM
comp.lang.php 32646 articles. 0 followers. Post Follow

5 Replies
808 Views

Similar Articles

[PageSpeed] 27

comp.lang.php wrote:
   <snip>
> I am thinking "WZZIP" is a big mistake, or, bad installation, or.. ??
>
> Any thoughts or alternative ideas for file zipping in Windows using
> PHP?

   1. http://in2.php.net/zip
   2. http://in2.php.net/bzip
   3. http://cvs.php.net/pear/Archive_Zip/

--
  <?php echo 'Just another PHP saint'; ?>
Email: rrjanbiah-at-Y!com    Blog: http://rajeshanbiah.blogspot.com/

0
ng4rrjanbiah (1570)
10/2/2005 3:59:36 PM
I read about both of those, but neither are practical for a portable,
cross-platform, cross-version web application as mandated by the
contractual obligations, sorry.  They are great and useful, but this
has to work in PHP 4.1.2 - 5+, Windows and UNIX, and be completely and
fully portable (and I didn't list the other demands, it just gets
worse)

Phil

0
10/3/2005 3:20:35 PM
On 3 Oct 2005 08:20:35 -0700, comp.lang.php wrote:

> I read about both of those, but neither are practical for a portable,
> cross-platform, cross-version web application as mandated by the
> contractual obligations, sorry.  They are great and useful, but this
> has to work in PHP 4.1.2 - 5+, Windows and UNIX, and be completely and
> fully portable (and I didn't list the other demands, it just gets
> worse)
> 
> Phil

Please look at http://www.safalra.com/special/googlegroupsreply/
0
Obvious1 (17)
10/3/2005 4:46:09 PM
Ok, is that better? Now, do you happen to know the solution to the
problem involving a file zip utility for Windows XP for a portable web
application?

Phil


Obvious wrote:
> On 3 Oct 2005 08:20:35 -0700, comp.lang.php wrote:
>
> > I read about both of those, but neither are practical for a portable,
> > cross-platform, cross-version web application as mandated by the
> > contractual obligations, sorry.  They are great and useful, but this
> > has to work in PHP 4.1.2 - 5+, Windows and UNIX, and be completely and
> > fully portable (and I didn't list the other demands, it just gets
> > worse)
> >
> > Phil
> 
> Please look at http://www.safalra.com/special/googlegroupsreply/

0
10/4/2005 6:31:45 PM
Thanx!! A modification of Archive_Zip did the trick!  And it seems to
only be necessary within Windows/Apache as WZZIP is reported to work
within Windows/IIS using PHP 5+.

Thanx again!
Phil

0
10/13/2005 7:22:34 PM
Reply:

Similar Artilces:

Help Needed: Upgrade Fedora 4 / Apache 2 to PHP 5.2.x from 5.0.4
Help Needed: Upgrade Fedora 4 / Apache 2 to PHP 5.2.x from 5.0.4 I've been testing Joomla as a content manager for the County offices, and it looks pretty good. Unfortunately, I decided to upgrade it from the 1.0.13 version to 1.5 as we get ready to go live with the web site... and the update installation gives an error in XML processing, which seems (from what I've been able to dredge up in forum discussions) to stem from a known bug in PHP 5.0.4... I've seen this same error from a couple of other programs that want to upload XML data to PHP based server software, too, so I'm inclined to believe the problem is on the server side and that it has at least something to do with PHP, i.e. either a bug or at least a setup/config problem... So I decided to upgrade the PHP from 5.0.4 to 5.2.4, but I couldn't find a binary set for Fedora 4, so it has to be compiled.... and I can't get it to install. Actually, that's not quite true - I did get it to install with the base config, but that didn't include some needed stuff (e.g. mysqli), and when I took the config parameters from the 5.0.4 version (from the output of aboutphp.php) and tried those with the config build, it complained about not finding apxs. I don't find apxs anywhere on the system, so I'm stuck there (as far as building the PHP 5.2.4). The install docs from php.net call for you to build Apache from source, which I gather will create apxs as part of the build, but - having now...

WinXP SP2,Apache 2.0.52, MySQL 5.0.0, PHP 5.01
I'm having a little trouble getting MySQL to load with Apache. Apache and PHP are working OK, but MySQL isn't loading. I know php.ini is loading because the following lines are in php.ini: extension_dir = "C:\Program Files\PHP" extension=php_mysql.dll and the error I get when Apache starts up is: PHP Startup: Unable to load dynamic load library 'C:\Program Files\PHP\php_mysql.dll' - The specified procedure could not be found. php_mysql.dll is definitely there. This same setup ( MySQL 5.0.0, PHP 5.01) works unchanged with the Abyss Web Server, so I know MySQL a...

php java bridge dont work with windows xp and apache 2.0.5
hi I have the java bridge library working fine on a windows 2000 and running apache 1.3 but cannot for whatever reason get it to work on windows xp and apache 2.0.5 Ive included the following in php.ini: [java] java.class.path = "c:\PHP\ext\JavaBridge.jar;" java.home = "c:\Sun\AppServer\jdk\bin" java.library.path = "c:\PHP\ext" Ive installed j2ee 1.4 and jdk 5. I have installed the latest pecl package. The JavaBridge.jar and php_java.dll is in ext folder. I look in the apache error log file and always see this error: Unable to load dynamic library 'c:/php/ext\\php_java.dll' - The specified procedure could not be found.\r\n in Unknown on line 0 What is going on? any help is appreciated thank you ...

<?= does not work on Windows XP Apache 2.2.x and PHP 5.2.4
When i do <?php echo "This works fine"; ?> Everything works fine. But when i do <?= "Some text"?> nothing works. Any ideas? Best Regards, Nicos On Fri, 28 Sep 2007 10:06:26 +0200, Nicos <nicoskk@gmail.com> wrote: > When i do > <?php > echo "This works fine"; > ?> > Everything works fine. But when i do > <?=3D "Some text"?> nothing works. Any ideas? It relies on short_open_tags, which have been disabled by default for a = = very long time now. Don't rely on them, only keep the setting on for = legacy code that still uses it for which you have no time to rewrite it,= = and use full tags in new code. -- = Rik Wasmus ...

Installing PHP 5.05 on WIndows XP, Apache 2.0.54
Hi Im trying to install PHP 5.05 on Windows XP running Apache 2.0.54 Apache is running fine and ive made all the changes to the pnp.ini file and Apache config file, restarted Apache but all I get when trying to call my test.php file is a 404 error? http.config file: LoadModule php5_module "C:/php/php5apache2.dll" PHPIniDir "C:/php" AddType application/x-httpd-php .php AddType application/x-httpd-php-source .phps set my php.ini doc-root file to : doc_root = "C:\Program Files\Apache Group\Apache2\htdocs" Ive followed all the FAQs on php.net , added c:/php to the Path etc any ideas? thanks On 19 Sep 2005 15:24:12 -0700, gregsands wrote: > Hi Im trying to install PHP 5.05 on Windows XP running Apache 2.0.54 > > Apache is running fine and ive made all the changes to the pnp.ini file > and Apache config file, restarted Apache but all I get when trying to > call my test.php file is a 404 error? > > http.config file: > LoadModule php5_module "C:/php/php5apache2.dll" > PHPIniDir "C:/php" > AddType application/x-httpd-php .php > AddType application/x-httpd-php-source .phps > > set my php.ini doc-root file to : > doc_root = "C:\Program Files\Apache Group\Apache2\htdocs" > > Ive followed all the FAQs on php.net , added c:/php to the Path etc > > any ideas? > > thanks If your getting a 404 error it means it's not there on the server, not that PHP isn&...

Apache/2.0.54 (Win32) PHP/5.0.5 multiple output
A newbie question: With the config mentioned in the topic, all on localhost, Win xpsp2, i created a caledar-table. The output should be a daily calendar for half a year with about 15 cols. So everything works fine on the console, output is as it should be. But when calling the script via apache, the table is either truncated or it comes twice or three times or i get an 404-Error with the table appended. Any hints? Many thanks in advance Thomas Hermann On Tue, 13 Sep 2005 21:15:14 +0200, Thomas Hermann <thomashermann@gmx.net> wrote: >A newbie question: > >With the config mentioned in the topic, all on localhost, Win xpsp2, >i created a caledar-table. > >The output should be a daily calendar for half a year with about 15 cols. > >So everything works fine on the console, output is as it should be. > >But when calling the script via apache, the table is either >truncated or it comes twice or three times or i get an >404-Error with the table appended. Weird. Sample code? -- Andy Hassall :: andy@andyh.co.uk :: http://www.andyh.co.uk http://www.andyhsoftware.co.uk/space :: disk and FTP usage analysis tool Andy Hassall schrieb: > On Tue, 13 Sep 2005 21:15:14 +0200, Thomas Hermann <thomashermann@gmx.net> > wrote: > > >>A newbie question: >> >>With the config mentioned in the topic, all on localhost, Win xpsp2, >>i created a caledar-table. >> >>The output should be a daily cal...

PHP 4+ - 5.0.4, Windows XP and Gzip
I am simply trying to zip together selected files into a single ZIP file. Windows XP doesn't have a native process by which you can do this, so I borrowed gzip, downloaded and installed, and upon using it: <? $msg = exec('gzip -q --suffix .zip '. @join(' ', $fileArray)); ?> All of my files named in $fileArray were horribly mangled!! They all were converted individually into files with .zip extension that lost all of their original data structures. I was told it was "so easy" to use gzip.. so how do I use gzip? No tutorial exists that I can find that even explains gzip; the docs are absolutely not helpful and man gzip is not going to happen since I'm in Windows and not UNIX ("gzip -h" does not help either, I need a clear example of how to compress files together into a single .zip file, like what WinZip does). Help! Thanx Phil Resolved by not using gzip.. using PEAR-based class Archive_Zip instead. Phil comp.lang.php wrote: <snip> > I was told it was "so easy" to use gzip.. so how do I use gzip? <snip> Glad that you're sorted out already. Anyway, if I'm right you were actually trying to use command line version of gzip. If you have zlib enabled (it must be enabled as you could use Archive_zip), you can use gzip functions <http://in.php.net/zlib>. As the usernotes suggest, possibly the easiest way to create gzipped file is using URL wrapper: file_put_contents('...

PHP 5.0.2 and tomcat 4.0
I am using PHP 5.0.2 and tomcat 4. whenever load the the PHP pages through IE, it gives the following error. java.lang.UnsatisfiedLinkError: send at net.php.servlet.send(Native Method) at net.php.servlet.service(servlet.java:190) at net.php.servlet.service(servlet.java:214) at javax.servlet.http.HttpServlet.service(HttpServlet.java:1264) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:247) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:193) at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:243) at org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java:566) at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:472) at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:943) at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:215) at org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java:566) at org.apache.catalina.valves.CertificatesValve.invoke(CertificatesValve.java:246) at org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java:564) at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:472) at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:943) at org.apache.catalina.core.StandardContext.invoke(StandardContext.java:2366) at org.apache.catalina.core.StandardHostValve.invoke(Standar...

Apache 2.0.50 php 4.3.8 Aix 5.2
I have apache 2 already installed and working. aixstar root /usr/httpd/bin > ./httpd -l Compiled in modules: core.c mod_access.c mod_auth.c mod_include.c mod_log_config.c mod_env.c mod_setenvif.c prefork.c http_core.c mod_mime.c mod_status.c mod_autoindex.c mod_asis.c mod_cgi.c mod_negotiation.c mod_dir.c mod_imap.c mod_actions.c mod_userdir.c mod_alias.c mod_so.c ../configure --with-apxs2=/usr/httpd/bin/apxs --with-oci8=/ora01/app/oracle/product/9.2.0.1.0 --enable-ftp --enable-sigchild --disable-libxml Works fine, without displaying any errors. m...

mysql 5.0.22, php 5.1.4, and phpmyadmin on Apache2 on Windows XP Home
I installed Apache 2.0.58, tested it, got the "working" page. Installed MySQL 5.0.22, and didn't really see how to test that, but there is a mysql process running in the task manager. Ran through the PHP 5.1.4 installation directions, and that seems to work, since I can use phpinfo() and get all the information on a test php page. Then I installed (really just unzipped and placed some files according to the directions) PHPMyAdmin; did the configuration, ran through their setup script, and that all seemed to go OK. However, when attempting to open the index.php in the PHPMyAdmin folder, it says it couldn't open the mysqli connection (also tried setting it to mysql in the config, but same message). I then searched the groups and saw the big uproar that php 5 as a windows installer package did not include mysql support the way previous versions did. Some posts said the only option was to compile it myself w/ mysql support, or wait for a dll to be made. However, all these posts were from 2003 - 2005. I also searched online documentation at php.net, but could find no successful searches for adding mysql support to php 5. Can anyone tell me if there's a way to get phpmyadmin and mysql working on this Windows XP Home machine running Apache2? Do I need to downgrade versions of something, or can I somehow add some lines to my PHP files and put a dll somewhere? Secondary question: I notice that I have a php.ini file in the Windows dire...

PHPBB2, PHP 4.3.4, MySQL 4.1.1, Apache 2.0.49, Fedora 2
My combination is: PHPBB2, PHP 4.3.4, MySQL 4.1.1, Apache 2.0.49, Fedora 2 Anyone out there has a successful combination of newer versions ? fr gr Erik ...

Apache 2.0.4.6 (Win) PHP 4.3.4.4
Hello there, We have PHP ver 4.3.4.4 working off Apache server version 2.0.4.6. My developer has developed a bunch of basic web pages which interact with the SQL Server 2000. We exposed the web application to the outside world though port 80 and the server crashed all of a sudden the very next day. Are there any security vulneribities with PHP ver 4.3.4.4 and Apache server version 2.0.4.6.which I need to be aware off. My developer is reluctant to upgrade the server to new version of apache and php. Any suggestion, help or pointer in the right direction will be appreciated. Thanks, anup...

Apache 2.0.4.6 (Win) PHP 4.3.4.4
Hello there, We have PHP ver 4.3.4.4 working off Apache server version 2.0.4.6. My developer has developed a bunch of basic web pages which interact with the SQL Server 2000. We exposed the web application to the outside world though port 80 and the server crashed all of a sudden the very next day. Are there any security vulneribities with PHP ver 4.3.4.4 and Apache server version 2.0.4.6.which I need to be aware off. My developer is reluctant to upgrade the server to new version of apache and php. Any suggestion, help or pointer in the right direction will be appreciated. Thanks, anup...

RE: Crashing Python interpreter! (windows XP, python2.3.4, 2.3.5rc1, 2.4.0) #2
-----Original Message----- From: python-list-bounces+tim.leeuwvander=3Dnl.unisys.com@python.org on = behalf of John Machin Sent: Thu 2/3/2005 12:03 AM To: python-list@python.org Subject: Re: Crashing Python interpreter! (windows XP, python2.3.4, = 2.3.5rc1,2.4.0) =20 > Leeuw van der, Tim TOP-POSTED: > > Hi all, > > [...] > > > > Leeuw van der, Tim schrieb: > > > I'm using the following combination of software: > > > - Pydev Eclipse plugin (pydev 0.8.5) > > > - eclipse 3.0.1 > > > - windows XP SP1 > > > - pygtk 2.4.1 ...

Apache 2.0, php 5 and mysql + win xp
Hi, I am trying to run and configure Apache 2.0, php 5 and mysql on win xp professional - this is the first time I have tried to install and configure all three. I am having difficulty trying to configure them on my computer. Can somebody help me - this is what I have done so far. Installed Apache 2.0, it worked perfectly ( I checked with my browser - http://localhost) till the point where I started to point where I wanted to store my html files. I have named the folder html_files and have changed the DocumentRoot "C:/html_files" and <Directory "C:/html_files/htdocs"> on the configuration file. And now it does not work (http://localhost does not work). I get an error message saying "You don't have permission to access / on the server". What am I doing wrong? Also I have installed and configured php 5, renamed Rename e:\php\php.ini-dist it to php.ini and enterd the following on the apache configuration file LoadModule php5_module "c:/php/php5apache2.dll" AddType application/x-httpd-php .php PHPIniDir "c:/php" Obviously it does not work because apache is not working? Can somebody help me? And how do I install and configure mysql? Thanks, Gene > Hi, > > I am trying to run and configure Apache 2.0, php 5 and mysql on win xp > professional - this is the first time I have tried to install and > configure all three. I am having difficulty trying to configure them > on my compu...

Apache 2.0.50 failed to start after installing PHP 5.0.1
The error in the 'eventviewer' is as follow: Faulting application Apache.exe, version 2.0.50.0, faulting module ole32.dll, version 5.2.3790.138, fault address 0x0001e5e3. It was working with PHP 5.0.0 but then I put the 5.0.1, it won't start the Apache with the above error. Help. Thanks I somehow isolated the problem to "iisfunc.dll". I commented it and apache started with no error. Is it a bug or ???. Thanks "Sarah Tanembaum" <sarahtanembaum@yahoo.com> wrote in message news:2og6f2Faado8U1@uni-berlin.de... > The error in the 'eventviewer&#...

imagerotate problem with PHP 4.3.9
Recap: Using imagerotate within PHP 4.3.9 - PHP 5.2.0 for both XP and Linux, all using GD2 If you rotate an image 180 degrees, all is fine If you rotate an image > 0 degrees and < 180 degrees, or > 180 degrees and < 360 degrees, while the image will rotate, its dimensions are somehow not refactored and as a result you get a rather annoying black bar in the newly-rotated image, along with part of your image being cropped off. I learned about a possible workaround with ImageMagick's convert command, but has anyone found a better solution (other than using XP's built-in image rotation routines)? Thanks Phil On Wed, 20 Jun 2007 15:45:03 +0200, comp.lang.php <phillip.s.powell@gmail.com> wrote: > Recap: > > Using imagerotate within PHP 4.3.9 - PHP 5.2.0 for both XP and Linux, > all using GD2 > > If you rotate an image 180 degrees, all is fine > > If you rotate an image > 0 degrees and < 180 degrees, or > 180 degrees > and < 360 degrees, while the image will rotate, its dimensions are > somehow not refactored and as a result you get a rather annoying black > bar in the newly-rotated image, along with part of your image being > cropped off. > > I learned about a possible workaround with ImageMagick's convert > command, but has anyone found a better solution (other than using XP's > built-in image rotation routines)? Depends on what you want from it, how would you like it to behave...

Apache 2.2.2 and PHP 5.1.4 on Win2k crashing
I just installed Apache 2.2.2 on my Windows 2000 (SP4) machine to test the new version. Everything works except PHP (version 5.1.4): when starting Apache, it pops out a message saying that it is unable to locate the module (even set on the correct path!), stops the execution and exits. On the other side, PHP works fine with Apache 2.0.55, so It's not a problem of a broken build. Got ideas? Thanks. -- Massimo Lombardo unwiredbrain@gmail.com wrote: > I just installed Apache 2.2.2 on my Windows 2000 (SP4) machine to test > the new version. > Everything works except PHP (version 5.1.4): when starting Apache, it > pops out a message saying that it is unable to locate the module (even > set on the correct path!), stops the execution and exits. On the other > side, PHP works fine with Apache 2.0.55, so It's not a problem of a > broken build. > > Got ideas? > > > Thanks. > -- > Massimo Lombardo The binary interface of Apache 2.2 is different from that of Apache 2.0. You can't use the same DLL. If you really want to use Apache 2.2, then you have to recompile the SAPI module yourself. Chung Leong wrote: > The binary interface of Apache 2.2 is different from that of Apache > 2.0. You can't use the same DLL. If you really want to use Apache 2.2, > then you have to recompile the SAPI module yourself. Or wait for the new build from php.net, right? unwiredbrain@gmail.com wrote: > Chung Leong wrote: > > ...

Crashing Python interpreter! (windows XP, python2.3.4, 2.3.5rc1, 2.4.0)
Hi, I'm using the following combination of software: - Pydev Eclipse plugin (pydev 0.8.5) - eclipse 3.0.1=20 - windows XP SP1 - pygtk 2.4.1 - GTK 2.6.1 (for windows32 native) When trying to get a list of possible completions for the 'gtk' import = object, the python interpreter crashes. Happens with all versions listed = in the subject: python 2.3.4, 2.3.5rc1, 2.4.0. I understand that this isn't a useful report (yet) for anyone to look = into the problem, but I'd please like to get any hints on how to get = more useful crashdumps etc. to help debugging this. cheers, -...

WIN2K, Apache 2.0.5 and PHP 5
hi Everyone, I hope (actually I'm sure) someone can help me to solve my problem. I installed Apache V 2.0.53 on Windows 2000 pro SP4 (including latest Windows patches). Installed PHP version is V 5.0.4 Installed folder locations: Apache: E:\Program Files\Apache Group\Apache2 PHP 5: E:\usr\PHP5 I added the above path to the PHP folder to the PATH environment variable. The http.conf of Apache containes the following entries: <<< start snippet: >>> LoadModule php5_module "E:/usr/php/php5apache2.dll" AddType application/x-httpd-php .php # configure the path to php.ini PHPIniDir "E:\usr\php5\" <<< end snippet >>> I tried also the PHPINiDir value with forward-slash, with and w/o ending slash/forward-slash. Nothing worked for me. The PHP.ini file cvontaines the following entries: <<< start snippet: >>> doc_root = E:\Program Files\Apache Group\Apache2\htdocs <<< end snippet >>> My problem is, at that moment when I activate the entries in the Apache http.conf file related to PHP, the Apache service is not starting up when I reboot the system. It's reporting server specific error 1. I hope it will be easy for a seasoned Windows/Apache/PHP guys to pinpoint me to the problem. If you need more information, please let me know. Any help is much appreciated. TIA Fred On Sat, 27 Aug 2005 18:08:39 GMT, dbyy wrote: > # configure the path to php.ini &...

if time = 3 seconds, how do i set the values of the time steps 0,0.1,0.2,0.3,0.5,1.0,1.5,2.0,3.0,5.0 to -9999 from time =3 seconds
Hi &nbsp; I have 18 inputs (arrays) which contain certain statistics and if time&nbsp;&nbsp;= 3 seconds, set the values of time step 5.0 to -9999.0. &nbsp; I was wondering if there is an efficient way to do this without using a lot of case statements? &nbsp; Thank you. Hello AdrianT, it's not really clear to me what you want to do... I suspect: you have an array containing values and you want to output them with a fixed timing of 3 seconds: you should use a for loop autoindexing trough your array and sending the value to your indicator/output/whatever. Put a "wait for next multiple" into your for loop. Or do you want to have a minimum time delay of 3 seconds? Again use a for loop, get the time value and use a InRange&amp;Coerce with minimum set to 3 seconds... Or you should explain more precisely what you need... Hi Thanks for that. Let me explain. &nbsp; The time may vary. Let me give an example. if time&nbsp; = 2.1, I want to set the time step's &nbsp;3.0 and 5.0's values to -9999.0. if the time =0.1 seconds then I want to set 0.2,0.3, 0.5 etc values to -9999.0 etc .................................................................... &nbsp; Can you please help? Thank you. Hello TUDS, do you use different accounts/nicknames ? Well, that's easy, at least for a sorted array: Search for your time-value in the array (Threshold 1D array). Fill all elements from that index till the end with your "error...

php 4.4.1 constructor Vs. Php 5.0 constructor
I have a class with a constructor function that looks like so on my php 5.0 box: public function __construct(....) does this syntax change when I go back to php 4.4.1? I've never used 4.4.1 before, been solely 5.0 until now. It seems the 4.4.1 box is giving me an error on that call. I've been looking on google for a while for a simple answer, but must not be searching for the right thing. Thanks in advance. Greg Scharlemann wrote: > I have a class with a constructor function that looks like so on my php > 5.0 box: > > public function __construct(....) > > does this syntax change when I go back to php 4.4.1? I've never used > 4.4.1 before, been solely 5.0 until now. It seems the 4.4.1 box is > giving me an error on that call. > > I've been looking on google for a while for a simple answer, but must > not be searching for the right thing. > > Thanks in advance. PHP 4.x supports only constructors that have the same name as the class, e.g. class abc { // Constructor function abc() { } } The chances are pretty good that you will have to upgrade to php 5 -- Etienne Marais Cosmic Link South Africa It's true that PHP4 requires a constructor to have the same name as the class, but that doesn't mean you have to upgrade to PHP5 just to use the __construct method. Simply add a new method to you class with the same name as the class and use that to call the __construct method. So...

Apache 2.0.48+php 4.3.4+Aix 4.3.3
Hello. I'm trying to compile this version of apache with php support on Aix 4.3.3ML11. I use gcc 3.2.1 compiler and all seems to go right. But when i try to access to a php page apache shows segmentation fault and doesn't answer. Any idea ? Thanks. > Hello. > I'm trying to compile this version of apache with php support on Aix > 4.3.3ML11. > I use gcc 3.2.1 compiler and all seems to go right. > But when i try to access to a php page apache shows segmentation fault and > doesn't answer. > > Any idea ? Does Apache also segfaults wh...

Pythonutils 0.2.2 , ConfigObj 4.0.0 Beta 5, odict 0.1.1
The response to pythonutils__ was very good. Especially the odict__ module (ordered dictionary) - it's had over one hundred and fifty downloads already. Thanks to some useful user feedback, Nicola Larosa has updated and improved it. More embarassingly we've done a bugfix release of ConfigObj__ - now up to beta 5. This fixes another couple of bugs - we aim to get out of beta someday...... All this is my way of saying that *odict 0.1.2*, *pythonutils 0.2.2*, and *ConfigObj beta 5*, are all available from the `Voidspace Modules`__ page. __ http://www.voidspace.org.uk/python/pythonutils...

[ANN] gettext-2.0.4, gettext_activerecord-2.0.4, gettext_rails-2.0.4
Hi, Ruby-GetText-Package-2.0.4 and the families (gettext-2.0.4, gettext_activerecord-2.0.4 and gettext_rails-2.0.4) are now available. Ruby-GetText-Package is the library/tools for message localization. * gettext - Message localization libraries and tools for all kind of apps/libs. * gettext_activerecord - ActiveRecord Localization * gettext_rails - Rails support with gettext. Changes ------- == gettext-2.0.4 * Fix String#% return nil when the string have no place holders. [by okkez] * Update pofiles and remove old messages. * suppress some warnings on Ruby 1.9.x. [by Nobuhiro IMA...

Web resources about - PHP 5.0.4 with Windows XP - trying to do file zip utility causes Apache 2.0.53 to crash - comp.lang.php

Window - Wikipedia, the free encyclopedia
This article is about the part of a building. For the Microsoft operating system, see Microsoft Windows . For other uses, see Window (disambiguation) ...

Microsoft Windows Information, Solutions, Tools - Windows IT Pro
Microsoft Windows information and solutions for IT pros. Topics include cloud computing, Windows Server, Exchange, Outlook, PowerShell, virtualization, ...

The Windows Blog
The Windows Blog is Microsoft's Official Blog for the Windows Operating System.

Man leans out window and pulls teen off moped in Halls Head road rage incident
... on a moped were lucky to escape being killed in a road rage incident in Halls Head when one was grabbed by a person leaning out a car window. ...

Manage, move and resize your desktop windows with WinDock
... behave just as it always did. If you don’t need WinDock’s configurability, AquaSnap delivers improved snapping, and a lot of extras: window ...

The only Windows 10 tablet you should even consider is now cheaper than ever
... means people who have purchased it over the past nine months have spent their money wisely. On the other hand, it means that Microsoft's Windows ...

What to expect from Windows 10 migrations
Process changes spurred by Windows 10 servicing model will test IT more than tech-related migration issues.

Android N has a “Freeform” Desktop-Style Floating App Window Mode
As it turns out, Google’s Multi-Window in Android N isn’t the only new multi-tasking functionality the Android team has added. If you read closely ...

Microsoft Rolling Out Windows 10 Mobile to Windows Phone 8.1 Devices
DAILY VIDEO: Microsoft begins Windows 10 rollout for Windows Phone 8.1; Google to boost mobile-friendly Web pages in search results; EMC notches ...

Microsoft Monday: Xbox One Price Drop, Windows 10 Upgrade Problems, Apology For Afterparty Dancers
... details about HERE Maps being discontinued, a Reddit thread going viral about the problems associated with the automatic upgrade of Windows ...

Resources last updated: 3/24/2016 12:45:29 AM