f



php degugger on php 5.2.2 (xampp 1.6.2) real brainer

Hi,

I tried to get php dbg debugger working on my machine but it doesn't 
work at all.

Ok, what i did:

copied php_dbg-5.2.x.dll (for PHP 5.2.x version) into my xampp/php/ext 
directory
next, modified /xampp/apache/bin/php.ini file appending:

[debugger]
extension=php_dbg-5.2.x.dll
debugger.enabled=on
debugger.profiler_enabled=on
debugger.hosts_allow=localhost 127.0.0.1
;debugger.hosts_deny=ALL
debugger.ports=7869, 10000/16
debugger.JIT_host = clienthost
debugger.JIT_port = 7869


Now, when i restard my server and try to get http://localhost my apache 
crashes and windows gives me a window telling me that this application 
will be closed !@!!

what is wrong ?

im running windows xp sp2

thanks in advance
0
p.nowak2 (10)
6/28/2007 7:02:25 AM
comp.lang.php 32646 articles. 0 followers. Post Follow

1 Replies
1175 Views

Similar Articles

[PageSpeed] 31

Piotr Nowak pisze:
> Hi,
> 
> I tried to get php dbg debugger working on my machine but it doesn't 
> work at all.
> 
> Ok, what i did:
> 
> copied php_dbg-5.2.x.dll (for PHP 5.2.x version) into my xampp/php/ext 
> directory
> next, modified /xampp/apache/bin/php.ini file appending:
> 
> [debugger]
> extension=php_dbg-5.2.x.dll
> debugger.enabled=on
> debugger.profiler_enabled=on
> debugger.hosts_allow=localhost 127.0.0.1
> ;debugger.hosts_deny=ALL
> debugger.ports=7869, 10000/16
> debugger.JIT_host = clienthost
> debugger.JIT_port = 7869
> 
> 
> Now, when i restard my server and try to get http://localhost my apache 
> crashes and windows gives me a window telling me that this application 
> will be closed !@!!
> 
> what is wrong ?
> 
> im running windows xp sp2
> 
> thanks in advance

ok, found problem, just commen out lines from php.ini:

[Zend]
;zend_extension_ts = 
"D:\servers\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"
;zend_extension_manager.optimizer_ts = 
"D:\servers\xampp\php\zendOptimizer\lib\Optimizer"
;zend_optimizer.enable_loader = 0
;zend_optimizer.optimization_level=15
;zend_optimizer.license_path =
; Local Variables:
; tab-width: 4
; End:

greets.
0
p.nowak2 (10)
6/28/2007 1:30:29 PM
Reply:

Similar Artilces:

Load average differences between Apache 1.3.37/PHP 4.4.6 and Apache 2.2.4/PHP 5.2.1
Hi folks, I've encountered something rather strange. This morning, I upgraded our production server, providing web services for our library website, from Apache 1.3.37/PHP 4.4.6 to Apache 2.2.4/PHP 5.2.1. The server, which normally exhibits a load average below 1 most of the time, spiked to loads that approached 100 if left alone. The interesting part of this is that this load average seems to be almost artificial - it appears to be caused by httpd processes stuck in a "closing connection" state (TIME_WAIT, in netstat). These processes are still running according t...

CSWS 2 (apache) / PHP 1.2 (php 4.2.3) / Oracle 9i OCI8 connectivity under OpenVMS
I'm currently trying to interface CSWS 2.0 (apache) / PHP v1.2 (PHP 4.3.2) with an Oracle 9.2 database under OpenVMS 7.3.2 The database connection works fine, but i've a problem with OCIexecute when i'm trying to select varchar value. My script works fine with int value, but give no resultt (error page) when there's a varchar colum in the select statement Someone Have exeprienced such problem ? Who can help me with APACHE/PHP/Oracle9I/OpenVMS configuration ? Environnement problem ? NLS problem ? Thanks in advance for all Best regards ...

Upgrade from VO 1 - 2 - 2..1 -2.2 - 2.3 -2.4 - 2.5 - 2.6 - 2.7
About upgrade 2.5 - 2.7 at $ 384.00 For most products I'm using - the updates (2.0 - 2.1 - 2.7) are free... 2.0 to 3.0 might be worth + 10-30% of the original price? VO is + full price again & again - Full program price for every minor upgrade/bug-fix? I dropped out of the money/bugs [VO] at 2.5 after starting at 1.0 more than 10 years ago. Certainly whoever is making VO have to make a living; earning moneys: - that is OK! A 10 years old VO site; - 10 years later, how much have changed? http://www.yi.com/prany/cavo/cavofront.htm Even MS is not ...

Apache 2.2.2 and PHP 5.1.4 on Win2k crashing
I just installed Apache 2.2.2 on my Windows 2000 (SP4) machine to test the new version. Everything works except PHP (version 5.1.4): when starting Apache, it pops out a message saying that it is unable to locate the module (even set on the correct path!), stops the execution and exits. On the other side, PHP works fine with Apache 2.0.55, so It's not a problem of a broken build. Got ideas? Thanks. -- Massimo Lombardo unwiredbrain@gmail.com wrote: > I just installed Apache 2.2.2 on my Windows 2000 (SP4) machine to test > the new version. > Everything works except PHP (version ...

Unable to load dynamic link library php_mysql.dll
Hello, I am attempting to perform a PHP installation on an Apache 2.2.6 web server instance that is loaded on a Windows 2003 server operating system (R2 SP2). I have a third party application that will reside within the Apache instance that requires PHP 5.2.6 loaded with MySql support. The installation of PHP succedded without incident (it was done manually) and I can run phpinfo() to get information about the installation. However, when attempting to load the php_mysql.dll extension I recieve the following error message: ------------- PHP Warning: PHP Startup: Unable to load dynamic...

PHP 4.2.2 and php://stdin
Hello, I am using php 4.2.2 in Red Hat 9.0 with apache 2.0.40 I try to build a php script that accepts POST requests that contain multimedia data and shoves them in a MySQL database. My problem is that it seems that I cannot read the POST data from stdin. I created the following php script to test it: <?php $in = fopen("php://stdin", "rb"); $line = fread($in, 10); echo "Content-type: text/plain\n\n"; echo "len=".strlen($line)." OK\n"; ?> and however I try to POST a file either with cURL (curl --data-binary @file http://....) or with ...

Is Php built in function ' imagecreate()' compatible in Php version 5.2.2 ?
Hi All, I have the php version 5.2.2 . When I am using " $im = imagecreate(......); " I am getting the following message "Fatal error: Call to undefined function imagecreate() in C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\server.php on line 32" I want to know whether "imagecreate()" is compatible in PHP version 5.2.2.? saikiran.iitkgp@gmail.com wrote: > Hi All, > > I have the php version 5.2.2 . When I am using > > > " $im = imagecreate(......); " I am getting the following message > > > &q...

php-mcrypt module for php-4.2.2 ?
Hi I am looking for the above as my php version (Redhat) is that. Call me lazy, but I do not wish to compile php unless it becomes absolutely necessary, as it has been working fine so far. I have searched google for it, but to no avail so far. Does anyone know a source for it ? Upgrading to 4.2.3 is an option, but it will require upgrading large chunks of my installation that I do not have a problem with. Thanks, MS ...

Bug in Web/2 with PHP 5.1.2?
Hi! Sorry for my bad english. %-) I do not get both together to function. The browser gets the PHP-Script to the download offered because he can start this nothing? PHP 4.3.10 functions easily. This seems to be a mistake in Web/2, because with Apache it probably functions. One said this to me, in any case. Bye/2 Massi -- http://dungeon-bbs.homeip.net/ Hi Massi! On Sat, 29 Apr 2006 07:42:44 UTC, Michael Massenberg <mmassenberg@arcor.de> wrote: > Sorry for my bad english. %-) > > I do not get both together to function. The browser gets the PHP-Scri...

PHP 5.2.1: cli does load php_mysql.dll while the same script executed by apache 2.2 fails Call to undefined function mysql_connect()
Hi there! After I overcame some short_open_tag (thanks, Rik!) I encounter another strange php-behaviour. The script I just got to work on the windows-commandline obviously does as php.ini tells php to do and loads php_mysql.dll: E:\ersDHCP>php ./extractLog.php .... some mysql-stuff, some output, OK The same script invoked by the webserver apache 2.2 entails an error: http://localhost/extractLog.php PHP Fatal error: Call to undefined function mysql_connect() My configuration php.ini does contain the line extension=php_mysql.dll and seems to be OK while I use the script from commandline....

IIS6/FastCGI/PHP 5.2.6 to 5.2.9 upgrade loses MSSQL
I have a client who has two web servers running Windows Server 2003 with IIS6, on which I installed FastCGI and PHP 5.2.6 last summer, so that I could write in PHP instead of ASP. The PHP pages use the mssql extension to talk to an external SQL Server. This is all working fine. Today I tried to upgrade PHP on one of them from 5.2.6 to 5.2.9, using the nts msi installation file from php.net. The upgrade went easily, although I had to re-add the .php extension in the IIS configuration. However, I then discovered that the mssql module would no longer load. The PHP log file said php_mssql.dl...

Printing 2^1, 2^2, 2^3, 2^4 and 2^5
Hi, When I use a while loop, the output is: 2 4 8 16 32, as desired: <?php $c=1; while($c<=5) { $d = newpow(2, $c); print "$d "; $c++; } function newpow($base, $power) { // statements... } ?> The But when I use a for loop, the output is: 64: <?php for($c=1; $c<=5; $c++); { $d = newpow(2, $c); print "$d "; } function newpow($base, $power) { // statements... } ?> Why is this?? Many thanks, Michael mejpark wrote: > When I use a while loop, the output is: 2 4 8 16 32, as desired: [...] > The But when I use a for loop, the output is: 64...

Suse 8.2 pro Apache 2.0.44 + PHP 4.3.1-24 = PHP not working
Hi Group! I am using Suse Linux 8.2 and the Apache and PHP versions shipped on CD. It seems, that the apache server still doesn't know how to treat php files. The httpd.conf looks like this: ----- LoadModule php4_module /usr/lib/apache2-prefork/libphp4.so AddModule mod_php4.c # # PHP 4.x: # <IfModule mod_php4.c> AddType application/x-httpd-php .php .php3 .php4 .phtml AddType application/x-httpd-php-source .phps </IfModule> ----- But anyway, if i try to open a php file like http://192.168.1.101/test.php, I receive a download dialog (Save as...). If i...

PHP 5.2.1+ Informix is no longer bundled with PHP
Does anyone have details on how to get Informix to work with PHP 5.2.2 since they moved support to PECL? The PECL search shows no Informix support. Here is the link: http://us.php.net/manual/en/ref.ifx.php Thanks Gary Quiring Ifx drivers were in php/windows 5.2.3 pecl package. What r u using? Linux? Windows? Functions? Pdo? > -----Original Message----- > From: informix-list-bounces@iiug.org [mailto:informix-list- > bounces@iiug.org] On Behalf Of Gary Quiring > Sent: Wednesday, September 19, 2007 21:26 > To: informix-list@iiug.org > Subject: PHP 5.2.1...

PHP 5.2.0 and Python 2.5
Hi Guys, I need some wisdom from you. Is it possible to have PHP pages posting to python scripts on the server side and returning values back to the calling PHP files? Like, if my enterval.php form's action=" think.py", would the two scripts be able to talk to each other? Thanks and Best Regards, "Shortash" Shortash wrote: > Hi Guys, > > I need some wisdom from you. Is it possible to have PHP pages posting > to python scripts on the server side and returning values back to the > calling PHP files? Like, if my enterval.php form's action=" t...

php 5.1.4, apache 2.2.3, and libxslt
I'm having a baffling problem. I've got Apache 2.2.3 and php 5.1.4 installed on a Windows 2000 Pro machine. I've enabled the libxslt extension by uncommenting the line "extension=php_xsl.dll" in php.ini, and my extension_dir is properly pointing to "c:\php\ext". OK, it worked for a while. The problem is the libxslt functions aren't working now, and when I run php_info() it doesn't show any xslt library. I swear it did just last week. I've been going crazy trying to figure out what changed, and what I need to do to get my xslt functions working agai...

PHP 5.1.2 and using PHP w Apache2 and MySQL
Hello all, First of all I first dld and installed (unzipped) PHP 5.1.1 before 5.1.2 was released, so do I just unzip 5.1.2 over the existing 5.1.1 and use the same php.ini file, or is there more to it than that? When I run phpinfo it still displays the ver as 5.1.1, is this ok? Also, I have installed Apache 2.0.55 and PHP 5.1.2 (see above 5.1.2 question) on my personal windows me computer, and I would like to install MySQL as well. To the best of my knowledge both of the above SEEM to be working and setup correctly. My goal in doing this is so that I can learn to use Apache, PHP ...

Apache 2.2.4 ignores PHP 5.2.4 scripts on Win2K3
Hi all PHP newbie here, 1) I disabled IIS. 2) Loaded Apache 2.2.4 on Win2K3. 3) Loaded PHP 5.2.4 pretty much bare bones, but included MySQL, SMTP, SOAP and ZIP extensions. Installers: apache_2.2.4-win32-x86-openssl-0.9.8d.msi php-5.2.4-win32-installer.msi Installer changed the httpd.conf file and added the following: PHPIniDir "C:/Program Files/PHP/" LoadModule php5_module "C:/Program Files/PHP/php5apache2_2.dll" AddType application/x-httpd-php .php Error log shows that PHP was configured: .... [Fri Sep 14 16:07:49 2007] [notice] Apache/2.2.4 (Win32) PHP/5.2.4 configu...

Upgrade of Xalan 1.2.2 and Xerces 1.4.4 to Xalan 2.6 and Xerces 2.6.2
I've been tasked with upgrading the JVM from 1.3 to 1.4, and the third party libraries used by my company on our existing Java framework. I'm most worried about any problems that may occur due to upgrading Xalan and Xerces as our framework performs much XML transformation and processing. Does anyone have a link to known issues with such an upgrade (besides the Xalan / Xerces sites) ? Or has anyone done such an upgrade and can share their pearls of wisdom? Thanks Chris ...

PHP pre 4.2 VS. PHP post 4.2
My local PHP install (for development/learning) is 4.3, but my hosting service uses 4.0.6. Without turning on registered globals, is there a common way these two versions can handle form data? 4.0.6 doesn't have import_request_variable(), $_POST, or $_REQUEST, and 4.3 chokes on $HTTP_POST_VARS[]. Thanks Chris 4.3 shouldn't choke on HTTP_POST_VARS - one thing you have to watch out for, however, is that HTTP_POST_VARS is not superglobal, so if you use it in a function, you still have to say global $HTTP_POST_VARS; etc... perhaps this is the reason it 'chokes'? Chris wrote: &g...

Apache/PHP 5.1.2/mod_perl Solaris 10 Problem #2
Hi, After several days of debugging I think I figured out that perl 5.8.3 with a default config doesn't work properly on Solaris 10. I installed on a Solaris 10 (doing a major upgrade from a working Solaris 9 similar setup ) the following: Apache/1.3.34 (Unix) PHP/5.1.2 mod_perl/1.29 using the Solaris malloc (perl 5.8.3 configured with -Uusemyalloc (means: don't use perl's malloc) and the rest default) (All compiled with the Sunfreeware gcc 3.3.2 package and APACI for PHP and mod_perl) RT 3.4.5 with RTFM-2.2.0RC2. >From time to time one of the Apache processes simply bails ...

<?= does not work on Windows XP Apache 2.2.x and PHP 5.2.4
When i do <?php echo "This works fine"; ?> Everything works fine. But when i do <?= "Some text"?> nothing works. Any ideas? Best Regards, Nicos On Fri, 28 Sep 2007 10:06:26 +0200, Nicos <nicoskk@gmail.com> wrote: > When i do > <?php > echo "This works fine"; > ?> > Everything works fine. But when i do > <?=3D "Some text"?> nothing works. Any ideas? It relies on short_open_tags, which have been disabled by default for a = = very long time now. Don't rely on them, only keep the setting on fo...

building php 5.3.2 on aix 5.2
Hi, I'm trying to build PHP 5.3.2 on AIX 5.2 ML01, gcc & gcc++ 4.0, make 3.8 gmake crashes with the following msg: collect2: ld returned 254 exit status gmake: *** [sapi/cli/php] Error 1 PHP 5.0.5 builds fine. any idea? TIA Michael Michal K napisa�(a): > Hi, > > I'm trying to build PHP 5.3.2 on AIX 5.2 ML01, gcc & gcc++ 4.0, make 3.8 > > gmake crashes with the following msg: > > collect2: ld returned 254 exit status > gmake: *** [sapi/cli/php] Error 1 Of course, PHP version is 5.2.3, in addition here's my configure command ../configure --p...

Trying to build PHP 4.3.0 with Apache 2.2.2 on SUSE 9.1
What a mix! Whilst I grep around for the first set of problems, I thought I'd ask any generous members of this PHP community for clues... I've started by trying out the instructions at: http://dan.drydog.com/apache2php.html Got this out of the make: ----------------------------------------------------------------------------------------------- /bin/sh libtool --silent --mode=compile gcc -Isapi/apache2filter/ -I/root/downloads/php-4.3.0/sapi/apache2filter/ -DPHP_ATOM_INC -I/root/downloads/php-4.3.0/include -I/root/downloads/php-4.3.0/main -I/root/downloads/php-4.3.0 -I/usr/local/Apa...

Web resources about - php degugger on php 5.2.2 (xampp 1.6.2) real brainer - comp.lang.php

CMD Tab and CMD Space stopped working on Mac OSX
IT Tips, Tricks and Good Advice Technical tips for Unix, Mac, AS400 & Web Developers. CMD Tab and CMD Space stopped working on Mac OSX January ...

Web Application Security Policy Document: Mozilla Web App
IT Tips, Tricks and Good Advice Technical tips for Unix, Mac, AS400 & Web Developers. Web Application Security Policy Document: Mozilla Web ...

Zend PHP degugger not working with 64bit Apache HTTPD on Mac OSX 10.5.7
I’ve been trying to work out why the Zend Debugger wasn’t working from Zend Studio on one of our developer PC’s. We checked everything from ...

How to download an entire website to your Mac with Safari / OSX
Do you ever need to download an entire website to your Mac? May be you want to have the website on your laptop to demo incase you can't get a ...

Resources last updated: 2/14/2016 5:20:42 PM