f



Problem sending email from Windows XP / Apache 2 /php 5.0

Set up SMTP / smtp_from variable, as suggested in manual.  But the 
mail() function always return fails.  I was trying to use 
smtp.mail.yahoo.com   I wonder if yahoo is somehow blocking smtp 
requests from php?

Any thoughts on this anybody?
0
2/1/2005 9:48:24 AM
comp.lang.php 32646 articles. 0 followers. Post Follow

6 Replies
574 Views

Similar Articles

[PageSpeed] 43

Maybe Yahoo requires authentication for SMTP?  Try using the PEAR Mail 
class, which supposedly supports authentication.

- Kevin

"Martin Meng" <martinmengh@yahoo.com> wrote in message 
news:QsSdnYkcBLUJzWLcRVn-hg@giganews.com...
>
> Set up SMTP / smtp_from variable, as suggested in manual.  But the mail() 
> function always return fails.  I was trying to use smtp.mail.yahoo.com   I 
> wonder if yahoo is somehow blocking smtp requests from php?
>
> Any thoughts on this anybody? 


0
kevin4268 (43)
2/1/2005 3:18:46 PM
But I was using the syntax
[yahoo_login]:[password]@smtp.mail.yahoo.com
Still no good.  - FRUSTRATED ! -


Junxter Ad Network
http://www.junxter.com


Kevin wrote:
> Maybe Yahoo requires authentication for SMTP?  Try using the PEAR Mail 
> class, which supposedly supports authentication.
> 
> - Kevin
> 
> "Martin Meng" <martinmengh@yahoo.com> wrote in message 
> news:QsSdnYkcBLUJzWLcRVn-hg@giganews.com...
> 
>>Set up SMTP / smtp_from variable, as suggested in manual.  But the mail() 
>>function always return fails.  I was trying to use smtp.mail.yahoo.com   I 
>>wonder if yahoo is somehow blocking smtp requests from php?
>>
>>Any thoughts on this anybody? 
> 
> 
> 
0
2/1/2005 5:30:57 PM
I'm pretty sure that syntax for the SMTP server won't work.  If you need to 
authenticate, you'll need to use a package that supports it.

Is PHP giving any errors or warnings?

- Kevin

"Martin Meng" <martinmengh@yahoo.com> wrote in message 
news:41FFBCD1.8060404@yahoo.com...
> But I was using the syntax
> [yahoo_login]:[password]@smtp.mail.yahoo.com
> Still no good.  - FRUSTRATED ! -
>
>
> Junxter Ad Network
> http://www.junxter.com
>
>
> Kevin wrote:
>> Maybe Yahoo requires authentication for SMTP?  Try using the PEAR Mail 
>> class, which supposedly supports authentication.
>>
>> - Kevin
>>
>> "Martin Meng" <martinmengh@yahoo.com> wrote in message 
>> news:QsSdnYkcBLUJzWLcRVn-hg@giganews.com...
>>
>>>Set up SMTP / smtp_from variable, as suggested in manual.  But the mail() 
>>>function always return fails.  I was trying to use smtp.mail.yahoo.com 
>>>I wonder if yahoo is somehow blocking smtp requests from php?
>>>
>>>Any thoughts on this anybody?
>>
>> 

0
kevin4268 (43)
2/1/2005 11:35:41 PM
I will try the package method.  Thanx for the pointer.

Junxter Ad Network
http://www.junxter.com


Kevin wrote:
> I'm pretty sure that syntax for the SMTP server won't work.  If you need to 
> authenticate, you'll need to use a package that supports it.
> 
> Is PHP giving any errors or warnings?
> 
> - Kevin
> 
> "Martin Meng" <martinmengh@yahoo.com> wrote in message 
> news:41FFBCD1.8060404@yahoo.com...
> 
>>But I was using the syntax
>>[yahoo_login]:[password]@smtp.mail.yahoo.com
>>Still no good.  - FRUSTRATED ! -
>>
>>
>>Junxter Ad Network
>>http://www.junxter.com
>>
>>
>>Kevin wrote:
>>
>>>Maybe Yahoo requires authentication for SMTP?  Try using the PEAR Mail 
>>>class, which supposedly supports authentication.
>>>
>>>- Kevin
>>>
>>>"Martin Meng" <martinmengh@yahoo.com> wrote in message 
>>>news:QsSdnYkcBLUJzWLcRVn-hg@giganews.com...
>>>
>>>
>>>>Set up SMTP / smtp_from variable, as suggested in manual.  But the mail() 
>>>>function always return fails.  I was trying to use smtp.mail.yahoo.com 
>>>>I wonder if yahoo is somehow blocking smtp requests from php?
>>>>
>>>>Any thoughts on this anybody?
>>>
>>>
> 
0
2/2/2005 2:10:14 AM
Success!  Works like a charm using phpmailer.

Junxter Ad Network
http://www.junxter.com


Martin Meng wrote:
> I will try the package method.  Thanx for the pointer.
> 
> Junxter Ad Network
> http://www.junxter.com
> 
> 
> Kevin wrote:
> 
>> I'm pretty sure that syntax for the SMTP server won't work.  If you 
>> need to authenticate, you'll need to use a package that supports it.
>>
>> Is PHP giving any errors or warnings?
>>
>> - Kevin
>>
>> "Martin Meng" <martinmengh@yahoo.com> wrote in message 
>> news:41FFBCD1.8060404@yahoo.com...
>>
>>> But I was using the syntax
>>> [yahoo_login]:[password]@smtp.mail.yahoo.com
>>> Still no good.  - FRUSTRATED ! -
>>>
>>>
>>> Junxter Ad Network
>>> http://www.junxter.com
>>>
>>>
>>> Kevin wrote:
>>>
>>>> Maybe Yahoo requires authentication for SMTP?  Try using the PEAR 
>>>> Mail class, which supposedly supports authentication.
>>>>
>>>> - Kevin
>>>>
>>>> "Martin Meng" <martinmengh@yahoo.com> wrote in message 
>>>> news:QsSdnYkcBLUJzWLcRVn-hg@giganews.com...
>>>>
>>>>
>>>>> Set up SMTP / smtp_from variable, as suggested in manual.  But the 
>>>>> mail() function always return fails.  I was trying to use 
>>>>> smtp.mail.yahoo.com I wonder if yahoo is somehow blocking smtp 
>>>>> requests from php?
>>>>>
>>>>> Any thoughts on this anybody?
>>>>
>>>>
>>>>
>>
0
2/2/2005 2:43:08 AM
Martin Meng wrote:
> But I was using the syntax
> [yahoo_login]:[password]@smtp.mail.yahoo.com
> Still no good.  - FRUSTRATED ! -
> 
> 
> Junxter Ad Network
> http://www.junxter.com
> 
> 
> Kevin wrote:
> 
>> Maybe Yahoo requires authentication for SMTP?  Try using the PEAR Mail 
>> class, which supposedly supports authentication.
>>
>> - Kevin
>>
>> "Martin Meng" <martinmengh@yahoo.com> wrote in message 
>> news:QsSdnYkcBLUJzWLcRVn-hg@giganews.com...
>>
>>> Set up SMTP / smtp_from variable, as suggested in manual.  But the 
>>> mail() function always return fails.  I was trying to use 
>>> smtp.mail.yahoo.com   I wonder if yahoo is somehow blocking smtp 
>>> requests from php?
>>>
>>> Any thoughts on this anybody? 
>>
>>
>>
>>

More than likely, relaying is disabled on Yahoo! end. Almost all mail 
servers are configured to disable relaying as a security measure. You 
should use your own or your ISP's SMTP server.

Best regards,
Amir Khawaja.

-- 
Rules are written for those who lack the ability to truly reason,
But for those who can, the rules become nothing more than guidelines,
And live their lives governed not by rules but by reason.

     - James McGuigan
0
amir8667 (3)
2/2/2005 10:00:12 AM
Reply:

Similar Artilces:

newline \n and tab \t Not Working in PHP 5.0.3 | Apache 2.0.52 | Windows XP Pro
The following examples (see PHP 5 for Dummies, p. 82) do not produce the expected results: $string = "Hello \nWorld"; echo $string; and $string = "Line 1 \n\tLine 2"; echo $string; The first instance is for a line break such that the words are stacked: Hello World The second instance is for a line break with a tabbed second line: Line 1 Line 2 Do I need to change or add something in one of the configuration files? Otherwise, is there a known fix for this? Thank you for any assistance. garbazh@cwnet.com wrote: > The following examples (see PHP 5 for Dummies, p. 82) > do not produce the expected results: > > $string = "Hello \nWorld"; > echo $string; > > and > > $string = "Line 1 \n\tLine 2"; > echo $string; > > The first instance is for a line break such that the words are > stacked: > > Hello > World > > The second instance is for a line break with a tabbed second line: > > Line 1 > Line 2 > > Do I need to change or add something in one of the configuration > files? > Otherwise, is there a known fix for this? Thank you for any > assistance. Newlines and tabs are ignored by browsers when rendering HTML. If you view the source of the page in your browser you will see the tabs and newline breaks are there. To do a line break in HTML you need to use the <br /> tag, or enclose your sentance in <p> and </p> tags. -...

PHP 5.0.4 with Windows XP
Has anyone had any luck with file zipping utilities for PHP 4-5 and Windows XP with Apache 2.0.53? Following is my code snippet: PHP Code: if ($this->isSuccessful) { // RUN ZIP COMMAND BASED UPON STRING $zipName = ($album) ? "${section}s_$album" : "${section}s"; $zipName .= '.zip'; // NEW 4/1/2005 SEE NOTES IN classes.inc.php ON getKommandOSArray() METHOD list($zipKommand, $zipRedirect) = @array_values($this->getKommandOSArray('zip-jF9')); $msg = exec("$zipKommand $locationPath/$zipName " . trim($imageList) . " $zipRedirect"); if (preg_match('/zip error:/i', $msg)) { $this->isSuccessful = false; $this->setErrorArray(array('action' => "Error attempting to create zip file from album \"$album\": " . nl2br($msg))); } if ($this->isSuccessful && is_file("$locationPath/$zipName") && (int)@filesize("$locationPath/$zipName") > (int)$maxDownloadableFileSize) { $this->isSuccessful = false; $this->setErrorArray(array('willDownloadDisk' => 'ZIP archive file size is larger than maximum allowable downloadable file size of ' .. DownloadableComponentsView::displayReadableMaxDownloadableFileSize() . ', file destroyed' ...

php java bridge dont work with windows xp and apache 2.0.5
hi I have the java bridge library working fine on a windows 2000 and running apache 1.3 but cannot for whatever reason get it to work on windows xp and apache 2.0.5 Ive included the following in php.ini: [java] java.class.path = "c:\PHP\ext\JavaBridge.jar;" java.home = "c:\Sun\AppServer\jdk\bin" java.library.path = "c:\PHP\ext" Ive installed j2ee 1.4 and jdk 5. I have installed the latest pecl package. The JavaBridge.jar and php_java.dll is in ext folder. I look in the apache error log file and always see this error: Unable to load dynamic library 'c:/php/ext\\php_java.dll' - The specified procedure could not be found.\r\n in Unknown on line 0 What is going on? any help is appreciated thank you ...

<?= does not work on Windows XP Apache 2.2.x and PHP 5.2.4
When i do <?php echo "This works fine"; ?> Everything works fine. But when i do <?= "Some text"?> nothing works. Any ideas? Best Regards, Nicos On Fri, 28 Sep 2007 10:06:26 +0200, Nicos <nicoskk@gmail.com> wrote: > When i do > <?php > echo "This works fine"; > ?> > Everything works fine. But when i do > <?=3D "Some text"?> nothing works. Any ideas? It relies on short_open_tags, which have been disabled by default for a = = very long time now. Don't rely on them, only keep the setting on for = legacy code that still uses it for which you have no time to rewrite it,= = and use full tags in new code. -- = Rik Wasmus ...

Installing PHP 5.05 on WIndows XP, Apache 2.0.54
Hi Im trying to install PHP 5.05 on Windows XP running Apache 2.0.54 Apache is running fine and ive made all the changes to the pnp.ini file and Apache config file, restarted Apache but all I get when trying to call my test.php file is a 404 error? http.config file: LoadModule php5_module "C:/php/php5apache2.dll" PHPIniDir "C:/php" AddType application/x-httpd-php .php AddType application/x-httpd-php-source .phps set my php.ini doc-root file to : doc_root = "C:\Program Files\Apache Group\Apache2\htdocs" Ive followed all the FAQs on php.net , added c:/php to the Path etc any ideas? thanks On 19 Sep 2005 15:24:12 -0700, gregsands wrote: > Hi Im trying to install PHP 5.05 on Windows XP running Apache 2.0.54 > > Apache is running fine and ive made all the changes to the pnp.ini file > and Apache config file, restarted Apache but all I get when trying to > call my test.php file is a 404 error? > > http.config file: > LoadModule php5_module "C:/php/php5apache2.dll" > PHPIniDir "C:/php" > AddType application/x-httpd-php .php > AddType application/x-httpd-php-source .phps > > set my php.ini doc-root file to : > doc_root = "C:\Program Files\Apache Group\Apache2\htdocs" > > Ive followed all the FAQs on php.net , added c:/php to the Path etc > > any ideas? > > thanks If your getting a 404 error it means it's not there on the server, not that PHP isn&...

apache 2.2.15 service won't start w/ PHP 5.3.2, Windows XP
On a localhost development configuration under Windows XP Pro (SP3), I cannot get Apache2.2.15 http service to start after I enable PHP 5.3.2 as a module. Without PHP, Apache starts and works just fine; PHP itself works (from a command prompt). I had had Apache 2.2.14 and an older PHP 5.2.x working happily together, supporting MySQL, phpMyAdmin, etc. I uninstalled all that and instead: (1) Installed Apache 2.2.15 from httpd-2.2.15-win32-x86-no_ssl.msi (also tried the openssl version when the former + PHP didn't work). It's installed as a service for all users on port 80. And I'm running as Administrator. That worked just fine. (2) Installed PHP 5.3.2 from php-5.3.2-Win32-VC6-x86.msi (thread safe version). As php.net says, with apache.org binaries, I used the VC6 version, not VC9. Now the apache http service will not start. So of course I never got so far as to try a .php script in the browser. When that failed, I uninstalled PHP and instead tried to use php-5.3.2- Win32-VC6-x86.zip and configure manually, starting with php.ini- development copied to php.ini and edited as below. Of course I put the correct entries in Windows system environment variables PATH (starts with D:\Server\PHP\ext;D:\Server\PHP) and PHPRC (D:\Server\PHP). File httpd.conf is what the Apache installer set up plus my edits in appropriate spots: [CODE]ServerName localhost:80 DocumentRoot "E:/htdocs" <Directory "E:/htdocs"> LoadModule php5_module "D:/Serv...

WinXP SP2,Apache 2.0.52, MySQL 5.0.0, PHP 5.01
I'm having a little trouble getting MySQL to load with Apache. Apache and PHP are working OK, but MySQL isn't loading. I know php.ini is loading because the following lines are in php.ini: extension_dir = "C:\Program Files\PHP" extension=php_mysql.dll and the error I get when Apache starts up is: PHP Startup: Unable to load dynamic load library 'C:\Program Files\PHP\php_mysql.dll' - The specified procedure could not be found. php_mysql.dll is definitely there. This same setup ( MySQL 5.0.0, PHP 5.01) works unchanged with the Abyss Web Server, so I know MySQL and PHP are set up OK. I've also tried putting a copy of php_mysql.dll directly in the Windows directory - no help. Any ideas out there??? Thanks - Ron ...

Apache/2.0.54 (Win32) PHP/5.0.5 multiple output
A newbie question: With the config mentioned in the topic, all on localhost, Win xpsp2, i created a caledar-table. The output should be a daily calendar for half a year with about 15 cols. So everything works fine on the console, output is as it should be. But when calling the script via apache, the table is either truncated or it comes twice or three times or i get an 404-Error with the table appended. Any hints? Many thanks in advance Thomas Hermann On Tue, 13 Sep 2005 21:15:14 +0200, Thomas Hermann <thomashermann@gmx.net> wrote: >A newbie question: > >With the config mentioned in the topic, all on localhost, Win xpsp2, >i created a caledar-table. > >The output should be a daily calendar for half a year with about 15 cols. > >So everything works fine on the console, output is as it should be. > >But when calling the script via apache, the table is either >truncated or it comes twice or three times or i get an >404-Error with the table appended. Weird. Sample code? -- Andy Hassall :: andy@andyh.co.uk :: http://www.andyh.co.uk http://www.andyhsoftware.co.uk/space :: disk and FTP usage analysis tool Andy Hassall schrieb: > On Tue, 13 Sep 2005 21:15:14 +0200, Thomas Hermann <thomashermann@gmx.net> > wrote: > > >>A newbie question: >> >>With the config mentioned in the topic, all on localhost, Win xpsp2, >>i created a caledar-table. >> >>The output should be a daily cal...

Apache 2.0, php 5 and mysql + win xp
Hi, I am trying to run and configure Apache 2.0, php 5 and mysql on win xp professional - this is the first time I have tried to install and configure all three. I am having difficulty trying to configure them on my computer. Can somebody help me - this is what I have done so far. Installed Apache 2.0, it worked perfectly ( I checked with my browser - http://localhost) till the point where I started to point where I wanted to store my html files. I have named the folder html_files and have changed the DocumentRoot "C:/html_files" and <Directory "C:/html_files/htdocs"> on the configuration file. And now it does not work (http://localhost does not work). I get an error message saying "You don't have permission to access / on the server". What am I doing wrong? Also I have installed and configured php 5, renamed Rename e:\php\php.ini-dist it to php.ini and enterd the following on the apache configuration file LoadModule php5_module "c:/php/php5apache2.dll" AddType application/x-httpd-php .php PHPIniDir "c:/php" Obviously it does not work because apache is not working? Can somebody help me? And how do I install and configure mysql? Thanks, Gene > Hi, > > I am trying to run and configure Apache 2.0, php 5 and mysql on win xp > professional - this is the first time I have tried to install and > configure all three. I am having difficulty trying to configure them > on my compu...

Problem With Arrays Of Arrays, PHP 5.2.0, Windows
$aThePosts = array_change_key_case($_POST, CASE_LOWER); define("CONTACT_IS_LOCAL", 0); define("CONTACT_IS_REMOTE", 1); /* $aWho contains an array of arrays (contact details) * array( * array(0, CONTACT_IS_LOCAL, "My Local Contact", * "123 Any Street", "Suite 123", * "Phoenix", STATE_ARIZONA, "01234-5678", * array(800, "867-5309", "867-5309", * "1-800-000-0000", "867-5309"), * "www.example.com"), * array(1, CONTACT_IS_REMOTE, ... */ function WhichContact() { global $aThePosts, $aWho; if (isset($aThePosts['idWho'])) { $iWhich = $aThePosts['idWho']; $iWhichCheck = $aWho[$iWhich][0]; if ($iWhichCheck == $iWhich) { return($iWhich); } } return(-1); } I'm running into some strange problems. Sometimes, $aWho[$iWhich][0] turns into the index number I expect, and sometimes it returns "array[0]". For instance, when I insert the following code after a call to the above. $iWho = WhichContact(); echo("<p class=\"pc\">$iWho</p>\n"); echo("<p class=\"pc\">" . $aWho[$iWho][0] . "</p>\n"); echo("<p class=\"pc\">$aWho[$iWho][0]</p>\n"); Inside the quotes, $aWho[$iWho] turns into "array" and the string "[0]" gets added to it. Outside of the quotes it returns the number I ex...

imagerotate problem with PHP 4.3.9
Recap: Using imagerotate within PHP 4.3.9 - PHP 5.2.0 for both XP and Linux, all using GD2 If you rotate an image 180 degrees, all is fine If you rotate an image > 0 degrees and < 180 degrees, or > 180 degrees and < 360 degrees, while the image will rotate, its dimensions are somehow not refactored and as a result you get a rather annoying black bar in the newly-rotated image, along with part of your image being cropped off. I learned about a possible workaround with ImageMagick's convert command, but has anyone found a better solution (other than using XP's built-in image rotation routines)? Thanks Phil On Wed, 20 Jun 2007 15:45:03 +0200, comp.lang.php <phillip.s.powell@gmail.com> wrote: > Recap: > > Using imagerotate within PHP 4.3.9 - PHP 5.2.0 for both XP and Linux, > all using GD2 > > If you rotate an image 180 degrees, all is fine > > If you rotate an image > 0 degrees and < 180 degrees, or > 180 degrees > and < 360 degrees, while the image will rotate, its dimensions are > somehow not refactored and as a result you get a rather annoying black > bar in the newly-rotated image, along with part of your image being > cropped off. > > I learned about a possible workaround with ImageMagick's convert > command, but has anyone found a better solution (other than using XP's > built-in image rotation routines)? Depends on what you want from it, how would you like it to behave...

PHP 5.0.1, Solaris 5.9, Sablotron 1.0.2, config problems
Everything compiles. Can run sabcmd with no problems. But when running a simple php script, it cannot find the sablotron functions. So it does not appear to be linking the Sablotron stuff. Probably just something simple I am missing. Any suggestions? Built with: configure --with-xml --with-expat=/usr/local --enable-xslt --with-xslt-sablot=/usr/local Simple PHP script: <?php $parser = xslt_create(); $html = xslt_process($parser, "test.xml", "test.xsl"); xslt_free($parser); echo $html; ?> Returns: Fatal error: Call to undefined function xslt_create() in /tmp/xsl.php on line 2 krigare wrote: > Everything compiles. > Can run sabcmd with no problems. > But when running a simple php script, it cannot find the sablotron > functions. So it does not appear to be linking the Sablotron stuff. > Probably just something simple I am missing. > Any suggestions? PHP5 has new XML and XSLT extension, which is not based on sablotron. Berislav ...

Help Needed: Upgrade Fedora 4 / Apache 2 to PHP 5.2.x from 5.0.4
Help Needed: Upgrade Fedora 4 / Apache 2 to PHP 5.2.x from 5.0.4 I've been testing Joomla as a content manager for the County offices, and it looks pretty good. Unfortunately, I decided to upgrade it from the 1.0.13 version to 1.5 as we get ready to go live with the web site... and the update installation gives an error in XML processing, which seems (from what I've been able to dredge up in forum discussions) to stem from a known bug in PHP 5.0.4... I've seen this same error from a couple of other programs that want to upload XML data to PHP based server software, too, so I'm inclined to believe the problem is on the server side and that it has at least something to do with PHP, i.e. either a bug or at least a setup/config problem... So I decided to upgrade the PHP from 5.0.4 to 5.2.4, but I couldn't find a binary set for Fedora 4, so it has to be compiled.... and I can't get it to install. Actually, that's not quite true - I did get it to install with the base config, but that didn't include some needed stuff (e.g. mysqli), and when I took the config parameters from the 5.0.4 version (from the output of aboutphp.php) and tried those with the config build, it complained about not finding apxs. I don't find apxs anywhere on the system, so I'm stuck there (as far as building the PHP 5.2.4). The install docs from php.net call for you to build Apache from source, which I gather will create apxs as part of the build, but - having now...

WIN2K, Apache 2.0.5 and PHP 5
hi Everyone, I hope (actually I'm sure) someone can help me to solve my problem. I installed Apache V 2.0.53 on Windows 2000 pro SP4 (including latest Windows patches). Installed PHP version is V 5.0.4 Installed folder locations: Apache: E:\Program Files\Apache Group\Apache2 PHP 5: E:\usr\PHP5 I added the above path to the PHP folder to the PATH environment variable. The http.conf of Apache containes the following entries: <<< start snippet: >>> LoadModule php5_module "E:/usr/php/php5apache2.dll" AddType application/x-httpd-php .php # configure the path to php.ini PHPIniDir "E:\usr\php5\" <<< end snippet >>> I tried also the PHPINiDir value with forward-slash, with and w/o ending slash/forward-slash. Nothing worked for me. The PHP.ini file cvontaines the following entries: <<< start snippet: >>> doc_root = E:\Program Files\Apache Group\Apache2\htdocs <<< end snippet >>> My problem is, at that moment when I activate the entries in the Apache http.conf file related to PHP, the Apache service is not starting up when I reboot the system. It's reporting server specific error 1. I hope it will be easy for a seasoned Windows/Apache/PHP guys to pinpoint me to the problem. If you need more information, please let me know. Any help is much appreciated. TIA Fred On Sat, 27 Aug 2005 18:08:39 GMT, dbyy wrote: > # configure the path to php.ini &...

Issue with building PHP 5.2.2 from source on Windows XP
I need to build PHP from source with the pdo_ibm extension and I am having an issue with it. Firstly, I am using Visual Studio .NET 2003 and I am building PHP from source through the Visual Studio Command Prompt. When I get to the nmake step, it gets through everything until it hits the zend_language_scanner.l file. Then I get these errors: zend_language_scanner.l(24) : warning C4005: 'yyleng' : macro redefinition c:\work\php-5.2.2\Zend\zend_language_scanner.c(12) : see previous defini tion of 'yyleng' zend_language_scanner.l(25) : warning C4005: 'yytext' : macro redefinition c:\work\php-5.2.2\Zend\zend_language_scanner.c(16) : see previous defini tion of 'yytext' zend_language_scanner.l(26) : warning C4005: 'yytext_ptr' : macro redefinition zend_language_scanner.c(289) : see previous definition of 'yytext_ptr' zend_language_scanner.l(27) : warning C4005: 'yyin' : macro redefinition c:\work\php-5.2.2\Zend\zend_language_scanner.c(11) : see previous defini tion of 'yyin' zend_language_scanner.l(28) : warning C4005: 'yyout' : macro redefinition c:\work\php-5.2.2\Zend\zend_language_scanner.c(14) : see previous defini tion of 'yyout' zend_language_scanner.c(3607) : warning C4133: '=' : incompatible types - from ' FILE *' to 'zend_file_handle *' zend_language_scanner.c(3610) : warning C4133: '=' : incompatible types - from ' FI...

Apache/PHP 5.1.2/mod_perl Solaris 10 Problem #2
Hi, After several days of debugging I think I figured out that perl 5.8.3 with a default config doesn't work properly on Solaris 10. I installed on a Solaris 10 (doing a major upgrade from a working Solaris 9 similar setup ) the following: Apache/1.3.34 (Unix) PHP/5.1.2 mod_perl/1.29 using the Solaris malloc (perl 5.8.3 configured with -Uusemyalloc (means: don't use perl's malloc) and the rest default) (All compiled with the Sunfreeware gcc 3.3.2 package and APACI for PHP and mod_perl) RT 3.4.5 with RTFM-2.2.0RC2. >From time to time one of the Apache processes simply bails ...

PHP 5.2.0 and Python 2.5
Hi Guys, I need some wisdom from you. Is it possible to have PHP pages posting to python scripts on the server side and returning values back to the calling PHP files? Like, if my enterval.php form's action=" think.py", would the two scripts be able to talk to each other? Thanks and Best Regards, "Shortash" Shortash wrote: > Hi Guys, > > I need some wisdom from you. Is it possible to have PHP pages posting > to python scripts on the server side and returning values back to the > calling PHP files? Like, if my enterval.php form's action=" think.py", > would the two scripts be able to talk to each other? > > Thanks and Best Regards, > > "Shortash" Hi, I don't know about Phyton (it is on my shortlist of languages I want to learn), but from PHP you can call Phyton with CURL. That is: if you mean a real POST (HTTP) to a webserver, that happens to be running Phyton. CURL is able to catch the output produced by that script, so you have 2-way communication. If you want to call Phyton from commandline, have a look at the exec() functions and its nephews. Both can be found at www.php.net. And more: What I heard of Phyton, it is glued to whatever you can think of, so maybe another way of PHP <-> Phyton communication exists. But I don't now anything about that. :-) Regards, Erwin Moller Thanks Erwin, i will investigate the option you mentioned. Regards, "Shortash"...

Apache 2.0.50 failed to start after installing PHP 5.0.1
The error in the 'eventviewer' is as follow: Faulting application Apache.exe, version 2.0.50.0, faulting module ole32.dll, version 5.2.3790.138, fault address 0x0001e5e3. It was working with PHP 5.0.0 but then I put the 5.0.1, it won't start the Apache with the above error. Help. Thanks I somehow isolated the problem to "iisfunc.dll". I commented it and apache started with no error. Is it a bug or ???. Thanks "Sarah Tanembaum" <sarahtanembaum@yahoo.com> wrote in message news:2og6f2Faado8U1@uni-berlin.de... > The error in the 'eventviewer' is as follow: > > Faulting application Apache.exe, version 2.0.50.0, faulting module > ole32.dll, version 5.2.3790.138, fault address 0x0001e5e3. > > It was working with PHP 5.0.0 but then I put the 5.0.1, it won't start the > Apache with the above error. > > Help. Thanks > > > Sorry, I'm running Windows Server 2003 Thanks "Sarah Tanembaum" <sarahtanembaum@yahoo.com> wrote in message news:2og9h8Fabr6qU1@uni-berlin.de... > I somehow isolated the problem to "iisfunc.dll". I commented it and apache > started with no error. > Is it a bug or ???. Thanks > > > > "Sarah Tanembaum" <sarahtanembaum@yahoo.com> wrote in message > news:2og6f2Faado8U1@uni-berlin.de... > > The error in the 'eventviewer' is as follow: > > > > Faulting application Apache.exe, vers...

Apache 2.0.50 php 4.3.8 Aix 5.2
I have apache 2 already installed and working. aixstar root /usr/httpd/bin > ./httpd -l Compiled in modules: core.c mod_access.c mod_auth.c mod_include.c mod_log_config.c mod_env.c mod_setenvif.c prefork.c http_core.c mod_mime.c mod_status.c mod_autoindex.c mod_asis.c mod_cgi.c mod_negotiation.c mod_dir.c mod_imap.c mod_actions.c mod_userdir.c mod_alias.c mod_so.c ../configure --with-apxs2=/usr/httpd/bin/apxs --with-oci8=/ora01/app/oracle/product/9.2.0.1.0 --enable-ftp --enable-sigchild --disable-libxml Works fine, without displaying any errors. m...

testing PHP 5 with Apache 2 and php info file
When I go to look for php info file in the browser all i get is the actually words. <?php phpinfo(); ?> any obvious problems? thanks ...

Migrate PHP 2.0 code to PHP 5.x
Hello ppl, I have old php code that is written in PHP 2 version... now i want to move/ migrate the whole code into latest version of PHP. Is there any tool or tips and tracks to migrate code. ~thanks Vijay. -----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 Vm wrote: > Hello ppl, > > I have old php code that is written in PHP 2 version... now i want to > move/ migrate the whole code into latest version of PHP. > Is there any tool or tips and tracks to migrate code. > > > ~thanks > Vijay. Hello, well, have a look at the register gloabls settings and other gloabl vars. then I would use the following in the old code: ini_set('error_reporting',8191); // E_ALL & E_STRICT ini_set('display_errors',true); and then just run it and have a look at the error messages which will come up. I don't know about any automated way to make this. It will be try and fix errors, to solve this. regards, johannes ke�ler -----BEGIN PGP SIGNATURE----- Version: GnuPG v2.0.11 (GNU/Linux) iEYEARECAAYFAkp8PCQACgkQE++2Zdc7Etc3xwCgqMEGEkrSbcBpV5xUl3UerZ7K YQQAn12Fk+bg0lQ+lo0CxaxysqPwPOaE =Oq26 -----END PGP SIGNATURE----- On 07 Aug 2009, johannes ke�ler <mail@bananas-playground.net> wrote: > Vm wrote: >> Hello ppl, >> >> I have old php code that is written in PHP 2 version... now i >> want to move/ migrate the whole code into latest version of >> PHP. Is there any tool or tips and tracks to migrate code. &...

testing PHP 5 with Apache 2 and php info file
When I go to look for php info file in the browser all i get is the actually words. <?php phpinfo(); ?> any obvious problems? thanks ...

mysql 5.0.22, php 5.1.4, and phpmyadmin on Apache2 on Windows XP Home
I installed Apache 2.0.58, tested it, got the "working" page. Installed MySQL 5.0.22, and didn't really see how to test that, but there is a mysql process running in the task manager. Ran through the PHP 5.1.4 installation directions, and that seems to work, since I can use phpinfo() and get all the information on a test php page. Then I installed (really just unzipped and placed some files according to the directions) PHPMyAdmin; did the configuration, ran through their setup script, and that all seemed to go OK. However, when attempting to open the index.php in the PHPMyAdmin folder, it says it couldn't open the mysqli connection (also tried setting it to mysql in the config, but same message). I then searched the groups and saw the big uproar that php 5 as a windows installer package did not include mysql support the way previous versions did. Some posts said the only option was to compile it myself w/ mysql support, or wait for a dll to be made. However, all these posts were from 2003 - 2005. I also searched online documentation at php.net, but could find no successful searches for adding mysql support to php 5. Can anyone tell me if there's a way to get phpmyadmin and mysql working on this Windows XP Home machine running Apache2? Do I need to downgrade versions of something, or can I somehow add some lines to my PHP files and put a dll somewhere? Secondary question: I notice that I have a php.ini file in the Windows dire...

Compatibility problem, php 4 vs php 5? Using wamp 5, having some problems
Sorry if I too obviously clueles, but I'm just starting editing our web-site that was prepared by someone else. The web-site is running at a Norwegian web-hotel (www.domeneshop.no), running php 4. Our site (www.widenoja-design.no) works ok, menu-choices and all. When I serve the same files from my local disk for editing and testing, the menus no longer work. I'm running Wamp 5 with the php 4 module loaded and enabled. Any clues? Is there any directives I can put in my files to force php 4 execution? I am able to switch to another software bundle locally if you have a strong recommendation. Thanks for any pointers! -- Christian Aastorp Message-ID: <v0ccs1pmg5a4temr3g2gtes0nf1p708p81@4ax.com> from Christian Aastorp <> contained the following: >Any clues? Is there any directives I can put in my files to force php >4 execution? At a guess, it sounds like a register globals problem. Register globals is off in newer versions of PHP. Where you have a menu item like this http://www.widenoja-design.no/index.php?CAT=tjenester is your script accessing the choice by looking for $CAT ? If so you need to change that to $_GET['CAT'] or $_REQUEST['CAT'] -- Geoff Berrow (put thecat out to email) It's only Usenet, no one dies. My opinions, not the committee's, mine. Simple RFDs http://www.ckdog.co.uk/rfdmaker/ ...

Web resources about - Problem sending email from Windows XP / Apache 2 /php 5.0 - comp.lang.php

Is–ought problem - Wikipedia, the free encyclopedia
The is–ought problem in meta-ethics as articulated by Scottish philosopher and historian David Hume (1711–76) is that many writers make claims ...

Why Telstra's network problems could cause long-term damage
Australian phone and internet providers suffer daily network problems and outages. But Telstra falls the hardest when customers see behind the ...


Brussels terror attacks are Europe's problem, not just Belgium's
Belgium's security forces could have done more to prevent the Brussels attacks, but so could every security service in the world.

No Law Degree? No Problem! Sarah Palin To Preside Over Reality TV Court
Sarah Palin will tell you about a crazy legal theory called rootin’-tootin’ res ipsa loquitur.

Martin Sorrell to 4A's Gathering: 'There Is A Problem' With Gender, Diversity
... J. Walter Thompson's former CEO Gustavo Martinez resigned for alleged sexist and racist remarks, WPP CEO Martin Sorrell said "there is a problem" ...

Apple Has Problems with Its Cloud Infrastructure, Says The Information
... ) Google division for some cloud computing infrastructure, The Information ’s Amir Efrati and Steve Nellis today write that Apple has a problem ...

The world’s wealthiest failed state... a population that’s complicit.... a very strong implantation ...
... its success in arresting [the alleged leader of the Paris massacre Salah] Abdeslam, Belgium continues to present a special security problem ...

Yes, Expansionary Fiscal Policy in The North Atlantic Would Solve Many of Our Problems. Why Do You Ask ...
... state of the economy in a very short space with five super-short equations; * One is about our current likely-to-be-chronic inequality problems. ...

Japan sees flight delays due to airline system problems
TOKYO (AP) — Major Japanese airports were crammed with thousands of passengers unable to take domestic flights Tuesday due to problems with airline ...

Resources last updated: 3/24/2016 2:33:03 AM