f



unix / php 4.4.0 / php.ini ?

hi all,
i cant find php.ini in upgraded php from 4.3.7 ?!?!?
where the hell is it ?
the prefix is new but there is no lib directory /usr/local/php-4.4.0/ 


0
REMOVEg0c (18)
8/8/2005 2:25:48 PM
comp.lang.php 32646 articles. 0 followers. Post Follow

4 Replies
1304 Views

Similar Articles

[PageSpeed] 18

On Mon, 08 Aug 2005 16:25:48 +0200, g0c wrote:

> where the hell is it ?

find / -name "php.ini"

-- 
    JDS | jeffrey@example.invalid
        | http://www.newtnotes.com
  DJMBS | http://newtnotes.com/doctor-jeff-master-brainsurgeon/

0
jeffrey7112 (329)
8/8/2005 2:35:47 PM
On 2005-08-08, g0c <REMOVEg0c@msn.com> wrote:
> hi all,
> i cant find php.ini in upgraded php from 4.3.7 ?!?!?
> where the hell is it ?
> the prefix is new but there is no lib directory /usr/local/php-4.4.0/ 

phpinfo() will tell you where to look for it.

-- 
Cheers
- Jacob Atzen
0
jacob8003 (70)
8/8/2005 4:51:31 PM
"JDS" <jeffrey@example.invalid> wrote in message 
news:pan.2005.08.08.14.35.47.363349@example.invalid...
> On Mon, 08 Aug 2005 16:25:48 +0200, g0c wrote:
>
>> where the hell is it ?
>
> find / -name "php.ini"
>
> -- 
>    JDS | jeffrey@example.invalid
>        | http://www.newtnotes.com
>  DJMBS | http://newtnotes.com/doctor-jeff-master-brainsurgeon/
>

of course id did that, and it found only in old install dir 
/usr/local/php-4.3.7/lib

:-) 


0
REMOVEg0c (18)
8/9/2005 1:24:10 PM
"Jacob Atzen" <jacob@aub.dk> wrote in message 
news:slrndff3cj.a1s.jacob@tank.aub.dk...
> On 2005-08-08, g0c <REMOVEg0c@msn.com> wrote:
>> hi all,
>> i cant find php.ini in upgraded php from 4.3.7 ?!?!?
>> where the hell is it ?
>> the prefix is new but there is no lib directory /usr/local/php-4.4.0/
>
> phpinfo() will tell you where to look for it.
>
> -- 
> Cheers
> - Jacob Atzen

i know , but the location does not exist ?!?!? /usr/local/php-4.4.0/lib

:-| damn 


0
REMOVEg0c (18)
8/9/2005 1:24:47 PM
Reply:

Similar Artilces:

php 4.4.1 constructor Vs. Php 5.0 constructor
I have a class with a constructor function that looks like so on my php 5.0 box: public function __construct(....) does this syntax change when I go back to php 4.4.1? I've never used 4.4.1 before, been solely 5.0 until now. It seems the 4.4.1 box is giving me an error on that call. I've been looking on google for a while for a simple answer, but must not be searching for the right thing. Thanks in advance. Greg Scharlemann wrote: > I have a class with a constructor function that looks like so on my php > 5.0 box: > > public function __construct(....) > > does this syntax change when I go back to php 4.4.1? I've never used > 4.4.1 before, been solely 5.0 until now. It seems the 4.4.1 box is > giving me an error on that call. > > I've been looking on google for a while for a simple answer, but must > not be searching for the right thing. > > Thanks in advance. PHP 4.x supports only constructors that have the same name as the class, e.g. class abc { // Constructor function abc() { } } The chances are pretty good that you will have to upgrade to php 5 -- Etienne Marais Cosmic Link South Africa It's true that PHP4 requires a constructor to have the same name as the class, but that doesn't mean you have to upgrade to PHP5 just to use the __construct method. Simply add a new method to you class with the same name as the class and use that to call the __construct method. So...

Problem updating PHP 4.3.0 DEV to PHP 4.3.3
Hi! I had Apache 2.0.47 and PHP 4.3.0 DEV running successfully on a W2k Server. For some reason, I couldn't get PHP to read XML-Attributes with the DOM XML -functions. So I thought, it would be time to update PHP to a newer version. So I simply replaces the old php-files with the new ones and of course kept the php.ini. But now, PHP doesn't work anymore. As soon as I request a page with php code, I get a "document contains no data" error after a while. (Apache's error log looks like the excerpt at the end of this message) If I install PHP5, I can't even start Apache...

Comments in SELECT via PHP/ODBC DB2 UDB v8.1.9 Linux, PHP 4.4.0
Several weeks ago I asked what comments I could pass to DB2 in a SELECT statement. I don't remember whether I said via PHP/ODBC. I was assured that both /* */ style comment blocks and -- comment lines were allowed. Unfortunately, neither work. Both -- and /* */ comments cause a "premature end of statement". Any sage advice? Bob Stearns wrote: > Several weeks ago I asked what comments I could pass to DB2 in a SELECT > statement. I don't remember whether I said via PHP/ODBC. I was assured > that both /* */ style comment blocks and -- comment lines were a...

Apache 2.0.4.6 (Win) PHP 4.3.4.4
Hello there, We have PHP ver 4.3.4.4 working off Apache server version 2.0.4.6. My developer has developed a bunch of basic web pages which interact with the SQL Server 2000. We exposed the web application to the outside world though port 80 and the server crashed all of a sudden the very next day. Are there any security vulneribities with PHP ver 4.3.4.4 and Apache server version 2.0.4.6.which I need to be aware off. My developer is reluctant to upgrade the server to new version of apache and php. Any suggestion, help or pointer in the right direction will be appreciated. Thanks, anup...

Apache 2.0.4.6 (Win) PHP 4.3.4.4
Hello there, We have PHP ver 4.3.4.4 working off Apache server version 2.0.4.6. My developer has developed a bunch of basic web pages which interact with the SQL Server 2000. We exposed the web application to the outside world though port 80 and the server crashed all of a sudden the very next day. Are there any security vulneribities with PHP ver 4.3.4.4 and Apache server version 2.0.4.6.which I need to be aware off. My developer is reluctant to upgrade the server to new version of apache and php. Any suggestion, help or pointer in the right direction will be appreciated. Thanks, anup...

Differences with imap_headerinfo() between PHP 4.3.11 and 4.4.0?
I have an application which uses imap_headerinfo() to query an NNTP server and display some information as part of a web application. I am seeing a difference between 4.3.11 and 4.4.0 when the e-mail address in the article contains a spam block. I get the following notice: Notice: (null)(): Unterminated mailbox: name@.MISSING-HOST-NAME. (errflg=3) in Unknown on line 0 Notice: (null)(): Must use comma to separate addresses: somedomain(dot.dot)com> (errflg=3) in Unknown on line 0 I am unable to suppress the notice either with error_reporting() or the @ operator. Anyone else seeing anything similar? Any idea how to suppress the Notice? The oddly formed e-mail address isn't something I use so I don't really care how it is formatted but the IMAP library seems to anyway. Thanks, Mike -- Mike Walsh - mike_walsh at mindspring dot com ...

Compile PHP 4.4.4 and CentOS
What packages i should to install to compile PHP 4.4.4 without problems? I got this error: checking whether to enable DBA... yes checking for gdbm_open in -lgdbm... yes checking for GDBM support... yes configure: error: DBA: Could not find necessary header file(s). I read that I need: gdbm-1.8.0-24 gdbm-devel-1.8.0-24 bu I got them already and I still can't compile PHP. *** lukas@os.pl escribi�/wrote (1 Sep 2006 02:46:05 -0700): > What packages i should to install to compile PHP 4.4.4 without > problems? I got this error: > > checking whether to enable DBA... yes > checking for gdbm_open in -lgdbm... yes > checking for GDBM support... yes > configure: error: DBA: Could not find necessary header file(s). > > I read that I need: > gdbm-1.8.0-24 > gdbm-devel-1.8.0-24 > bu I got them already and I still can't compile PHP. Perhaps DBA are the "Database (dbm-style) Abstraction Layer Functions". According to manual, the required libraries depend on the handlers you enable. http://www.php.net/manual/en/ref.dba.php -- -+ http://alvaro.es - �lvaro G. Vicario - Burgos, Spain ++ Mi sitio sobre programaci�n web: http://bits.demogracia.com +- Mi web de humor con rayos UVA: http://www.demogracia.com -- ...

mail() To: header in PHP 4.4.4
I'm using the mail() function on a Linux server. Under PHP 4.4.3, the followng code worked as expected: $dest="webmaster@mydomain.com"; $subject="something here"; $body="contents here"; $headers = "From: fname lname <name@xxx.com\n"."To: myfname mylname <webmaster@mydomain.com>" ; mail($dest,$subject,$body,$headers) The received email message contained the following headers: To: myfname mylname <webmaster@mydomain.com> From: fname lname <name@xxx.com Subject: something here Under PHP 4.4.4, the code works differently. The additional_parameters "To:" data is concatenated to the initial "to" parameter and no longer replaces it. The received email message contains the following headers: To: webmaster@mydomain.com, myfname mylname <webmaster@mydomain.com> From: fname lname <name@domain.com Subject: something here What are the (new) rules for the mail() function to obtain a To: field formatted as "fname lname <name@domain.com>"? Is this rules change documented somewhere? regards, Andy -- ********** Please send e-mail to: usenet (dot) post (at) aaronoff (dot) com To identify everything that starts up with Windows, download "Silent Runners.vbs" at www.silentrunners.org ********** Andrew Aronoff wrote: > mail($dest,$subject,$body,$headers) ...

Apache 2.0.48+php 4.3.4+Aix 4.3.3
Hello. I'm trying to compile this version of apache with php support on Aix 4.3.3ML11. I use gcc 3.2.1 compiler and all seems to go right. But when i try to access to a php page apache shows segmentation fault and doesn't answer. Any idea ? Thanks. > Hello. > I'm trying to compile this version of apache with php support on Aix > 4.3.3ML11. > I use gcc 3.2.1 compiler and all seems to go right. > But when i try to access to a php page apache shows segmentation fault and > doesn't answer. > > Any idea ? Does Apache also segfaults wh...

PHP 4 vs PHP 5
Over the past year or so I have been teaching myself php and have exclusively used php 5. I now need to create a script to handle form information on a server running php 4 (we will upgrade to 5, but it may be a while). I will be creating and testing the script on a local server with php 5.2, then uploading for final testing and deployment on a server with 4.1.2. Now this may be vaque, but what I need to know, for a script that is just going to take a html form post information and up to 6 word files uploaded, and then email them as an attachment with the data, is there any major change between 4 and 5? If the changes between 4 & 5 are large, I will just write it in perl, but would prefer php (at least the 5 version) due to the ease of file uploading. Bill H Hi Bill, If there is absolutely no chance to have PHP 5 running on your production server, I'd suggest to run PHP 4 on your testing server... Without a doubt, you will run into trouble. No science here, just common sense... PHP 5 has more possibilities to work with classes (private/public functions, etc...). It also has specific functions or libraries that are only available to PHP5, ie. SimpleXML. The function references on php.net will usually tell you in which version those functions are available... But again, why make it hard on yourself and test your software on a server with a (deliberately) different configuration then your production environment. Kind regards, Mathew Mathieu Maes wrote: > Hi ...

Weird result?? php 4.4.0
I have a variable v with the value -1. After v++ it has the value "" not 0. Since I am using it for a subscript, the "" value is not overwriting the 0 element of the array as desired. Should v++ ever give a non-numeric value? On Thu, 27 Jul 2006 17:47:50 -0400, Bob Stearns <rstearns1241@charter.net> wrote: >I have a variable v with the value -1. After v++ it has the value "" not >0. Since I am using it for a subscript, the "" value is not overwriting >the 0 element of the array as desired. Should v++ ever give a >non-numeric value? No - post a script and output demonstrating this? Since you're not on the latest release of a branch the standard advice would be "upgrade", though, if this actually happens. -- Andy Hassall :: andy@andyh.co.uk :: http://www.andyh.co.uk http://www.andyhsoftware.co.uk/space :: disk and FTP usage analysis tool "Bob Stearns" <rstearns1241@charter.net> wrote in message news:bwayg.1867$2M3.354@fe04.lga... >I have a variable v with the value -1. After v++ it has the value "" not 0. >Since I am using it for a subscript, the "" value is not overwriting the 0 >element of the array as desired. Should v++ ever give a non-numeric value? I used to use a variable initialised with -1, and never noticed the problem you are having. What are you trying to do with it and have you got an example of the code so we can see what's...

php 4.4.0 configure question?
Hi I download php 4.4.0, there is a configure file, so i ./configure then "make" then "make install". But how can i build the modules for apache and where should i place the module? thanks from Peter (cmk128@hotmail.com) ...

imagerotate problem with PHP 4.3.9
Recap: Using imagerotate within PHP 4.3.9 - PHP 5.2.0 for both XP and Linux, all using GD2 If you rotate an image 180 degrees, all is fine If you rotate an image > 0 degrees and < 180 degrees, or > 180 degrees and < 360 degrees, while the image will rotate, its dimensions are somehow not refactored and as a result you get a rather annoying black bar in the newly-rotated image, along with part of your image being cropped off. I learned about a possible workaround with ImageMagick's convert command, but has anyone found a better solution (other than using XP's built-in image rotation routines)? Thanks Phil On Wed, 20 Jun 2007 15:45:03 +0200, comp.lang.php <phillip.s.powell@gmail.com> wrote: > Recap: > > Using imagerotate within PHP 4.3.9 - PHP 5.2.0 for both XP and Linux, > all using GD2 > > If you rotate an image 180 degrees, all is fine > > If you rotate an image > 0 degrees and < 180 degrees, or > 180 degrees > and < 360 degrees, while the image will rotate, its dimensions are > somehow not refactored and as a result you get a rather annoying black > bar in the newly-rotated image, along with part of your image being > cropped off. > > I learned about a possible workaround with ImageMagick's convert > command, but has anyone found a better solution (other than using XP's > built-in image rotation routines)? Depends on what you want from it, how would you like it to behave...

PHPBB2, PHP 4.3.4, MySQL 4.1.1, Apache 2.0.49, Fedora 2
My combination is: PHPBB2, PHP 4.3.4, MySQL 4.1.1, Apache 2.0.49, Fedora 2 Anyone out there has a successful combination of newer versions ? fr gr Erik ...

php 4.4 not working with mysql 4.1
I recently installed php 4.4.4 using windows binaries on Windows XP Pro. I also installed MySQL 4.1. I usually use Pear DB but I tried MDB2 and it worked fine until a client uses a different version so I reverted back to straigh PHP mysql function calls. I use this code: $link = mysql_connect('localhost', 'username', 'password'); if (!$link) { die('Could not connect: ' . mysql_error()); } echo 'Connected successfully'; And get this error: Warning: mysql_connect() [function.mysql-connect]: Client does not support authentication protocol requested by server; consider upgrading MySQL client in D:\MyDocuments\web\client\login.php on line 3 Line 3 = $link = mysql_connect('localhost', 'username', 'password'); This is from the PHP.ini file: ;Windows Extensions ;Note that MySQL and ODBC support is now built in, so no dll is needed for it. Therefore I assumed I didn't have to do anything to get access especially since MDB2 worked. Any ideas of what to do? Paul wrote: > I use this code: > $link = mysql_connect('localhost', 'username', 'password'); > if (!$link) { > die('Could not connect: ' . mysql_error()); > } > echo 'Connected successfully'; > > And get this error: > Warning: mysql_connect() [function.mysql-connect]: Client does not support > authentication protocol requested by server; consider upgrading MySQL client...

PGSQL 7.4.8 PHP 4.3.4 & Apache 2.0.49 Segmentation Fault with Client Certs
Hello, Having an issue that is specific to PHP compiled with PGSQL support with versions noted in subject line. I understand that there are many variables to consider here but believe I have narrowed down the Apache Client Cert failures to my PHP/PGSQL build. 1. Apache PHP without PGSQL works as expected using client certificates 2. Apache PHP with PGSQL works fine with standard SSL connections 3 Apache PHP with PGSQL fails with client certificates - no output other than Segmentation faults in the apache error logs as follows: [Wed Nov 30 23:26:57 2005] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2) [Wed Nov 30 23:26:58 2005] [notice] Apache configured -- resuming normal operations [Wed Nov 30 23:27:05 2005] [notice] child pid 4065 exit signal Segmentation fault (11) [Wed Nov 30 23:27:06 2005] [notice] child pid 4066 exit signal Segmentation fault (11) I also performed same tests on another instance of Apache/PHP/PGSQL which was version 2.0.54 of apache and PHP/PGSQL versions same as subject line with same exact results. Any ideas as to the source of this problem and suggestions for tests/fixes are greatly appreciated. There are no errors in any of the logs other than what I have included so it's very difficult to see what is wrong. All I know for sure is that I am able to reproduce the results on more than one machine. The switch that kills everthing is turning SSLVerifyClient require SSLVerifyDepth 1 on in the apache config...

Question of PHP-4 vs PHP-5
When debugging the blowfish utility I noticed that $bf = new Crypt_Blowfish($mykey); echo("BF: " . $bf"); Outputs the word "OBJECT" on a PHP-4 linux system and "OBJECT id #1" on a windoze PHP-5 system Can anyone confirm this is correct and even better - explain what the output of each is please (I dont understand PHP classes yet) tks tony tony@tony.com wrote: > > When debugging the blowfish utility I noticed that > > $bf = new Crypt_Blowfish($mykey); > echo("BF: " . $bf"); > > Outputs the word "OBJECT" on a PHP-4 linux system > > and "OBJECT id #1" on a windoze PHP-5 system > > Can anyone confirm this is correct and even better - > explain what the output of each is please > (I dont understand PHP classes yet) Yes, both are correct, but the question is wrong - if you want to describe an object then give it a method to describe itself. If you want to see inside an object then use the var_export() fn. The difference is related to the change in how objects are referenced in the different PHP versions. C. tony@tony.com wrote: > When debugging the blowfish utility I noticed that > > $bf = new Crypt_Blowfish($mykey); > echo("BF: " . $bf"); > > Outputs the word "OBJECT" on a PHP-4 linux system > > and "OBJECT id #1" on a windoze PHP-5 system > > Can anyone confirm this is correct and e...

PHP 5 or PHP 4 compatible codes
Kinda OT. I haven't yet moved to PHP5. But, interested to know how many of you _really_ started using it or moved? Are you doing any compatible tweaks specifically for PHP 5 (forward compatible) or PHP 4 (backward compatible)? -- | Just another PHP saint | Email: rrjanbiah-at-Y!com R. Rajesh Jeba Anbiah wrote: > Kinda OT. I haven't yet moved to PHP5. But, interested to know how > many of you _really_ started using it or moved? Are you doing any > compatible tweaks specifically for PHP 5 (forward compatible) or PHP 4 > (backward compatible)? Basically, if you code for...

PHP 4 & PHP 5 at the same time
Hi, I've decided it's time to take PHP5 for a spin, but all the hosts I use are still only on PHP4, so I need to keep PHP4 running and operational on my dev box. My dev environment is a Windows XP Pro Machine with Apache 1.3.33 and PHP 4.4.0 I'm sure many of you have PHP4 and PHP5 running on a Windows Box with Apache as your server. I'm particularly interested in being able to use ports to decide what version of PHP I am running, so I can just add a port number to see how a page will perform in PHP5. ie: http://randomsite/index.php -> PHP4, http://randomsite:81/index.php -> PHP5 What solutions have you guys come up with? Michael. > I'm sure many of you have PHP4 and PHP5 running on a Windows Box with > Apache as your server. I'm particularly interested in being able to use > ports to decide what version of PHP I am running, so I can just add a port > number to see how a page will perform in PHP5. ie: > http://randomsite/index.php -> PHP4, http://randomsite:81/index.php -> > PHP5 > > What solutions have you guys come up with? I've been looking into this, and found a solution - I have 2 Apache Services running (both Apache 1.3.33) I've named one service Apache which runs on port 80 and has the php4 module loaded, and another service apache-php5 which runs on port 81 and has the php5 module loaded. Can anyone see any problems with doing things this way? ...

PHP 4.2.2 and php://stdin
Hello, I am using php 4.2.2 in Red Hat 9.0 with apache 2.0.40 I try to build a php script that accepts POST requests that contain multimedia data and shoves them in a MySQL database. My problem is that it seems that I cannot read the POST data from stdin. I created the following php script to test it: <?php $in = fopen("php://stdin", "rb"); $line = fread($in, 10); echo "Content-type: text/plain\n\n"; echo "len=".strlen($line)." OK\n"; ?> and however I try to POST a file either with cURL (curl --data-binary @file http://....) or with netcat (nc host port, ...) what I get back is len=0 OK i.e. no data are read! Any ideas? Thanks! Stelios G. Sfakianakis wrote: > Hello, > I am using php 4.2.2 in Red Hat 9.0 with apache 2.0.40 I try to build a > php script that accepts POST requests that contain multimedia data and > shoves them in a MySQL database. My problem is that it seems that I > cannot read the POST data from stdin. > > I created the following php script to test it: > > <?php > > $in = fopen("php://stdin", "rb"); > $line = fread($in, 10); > echo "Content-type: text/plain\n\n"; > echo "len=".strlen($line)." OK\n"; > > ?> > > and however I try to POST a file either with cURL (curl --data-binary > @file http://....) or with netcat (nc host port, ...) what I get back is > > len=0 OK > &...

PHP 4.4.0/GD/freetype compilation problems
Hello, I've been running php/apache/etc locally on my powerbook for a lon time, but am having problems activating freetype with a new version o php. I'm using: php 4.4.0 freetype 2.1.10 (compiled from source) gd 2.0.28 (came with php) PHP configures just fine with this config line: ./configure --with-zlib-dir=/usr/include --with-libjpeg=/s --with-libtiff=/sw --with-libpng=/sw --with-freetype-dir=/usr/X11R6 --with-gd --enable-gd-native-ttf --with-png-dir=/sw --with-mysql=/s --with-xml --with-jpeg-dir=/sw --with-apxs It can find FreeType, and the gd ttf function integrator. The problem comes when I run 'make' for php: In file included from /sw-comp/php-4.4.0/ext/gd/libgd/gdft.c:65: /usr/local/include/freetype2/freetype/ftglyph.h:40:2: #erro "freetype.h of FreeType 1 has been loaded!" /usr/local/include/freetype2/freetype/ftglyph.h:41:2: #error "Pleas fix the directory search order for header files" /usr/local/include/freetype2/freetype/ftglyph.h:42:2: #error "so tha freetype.h of FreeType 2 is found first." Anyone seen this before? Thanks, - Andre -- awaege ----------------------------------------------------------------------- awaegel's Profile: http://www.macosx.com/forums/member.php?userid=4443 View this thread: http://www.macosx.com/forums/showthread.php?t=23744 macosx.com - The Answer to Mac Support - http://www.macosx.co think you need --with-gd2 ...

PHP 4.4.1
Greetings, I don't know much about PHP. My question is as follows. I am on windows hosting. They are running 4.4.1. I see the version is up to 4.4.7 with some security fixes. The only PHP I plan to run on the site is osCommerce. Is there any remotely exploitable issues in PHP itself in this scenerio? or would I be ok (against known bugs) as long as I keep osCommerce up-to-date. Thank you, Paul S. On Sun, 02 Sep 2007 19:29:12 +0200, Luap777 <Luap777@gmail.com> wrote: > Greetings, > > I don't know much about PHP. My question is as follows. > > I am on windows hosting. They are running 4.4.1. I see the version is > up to 4.4.7 with some security fixes. The only PHP I plan to run on > the site is osCommerce. Is there any remotely exploitable issues in > PHP itself in this scenerio? or would I be ok (against known bugs) as > long as I keep osCommerce up-to-date. Well, osCommerce has more bugs in it then PHP 4.4.1... For the most part you will be OK, no guarantee. -- Rik Wasmus Luap777 wrote: > Greetings, > > I don't know much about PHP. My question is as follows. > > I am on windows hosting. They are running 4.4.1. I see the version is > up to 4.4.7 with some security fixes. The only PHP I plan to run on > the site is osCommerce. Is there any remotely exploitable issues in > PHP itself in this scenerio? or would I be ok (against known bugs) as > long as I keep osCommerce up-to-date. I'd be m...

php 4.3.4
I am running php in Apache on Windows98SE PC I have been using php version 4.3.3 and everything worked OK except the mcrypt function didn't work. Because of this, I upgraded to version 4.3.4 and mcrypt now works OK but my hyperlinks to other pages no longer work. It simply jumps back to the same page. The page number in the address bar changes, e.g /index.php?page=3 changes to:- /index.php?page=5 but the displayed page is still the same. If I go back to using version 4.3.3 again, all is OK. Did I miss something when I installed 4.3.4? Thanks for any help. Geoff. *** Geoff w...

parsing RSS feeds where allow_url_fopen=OFF on php 4.4.4??
I need to get, parse and display RSS feeds while having the ini setting, allow_url_fopen = Off. I used to use (in version 4.1) domxml_open_mem() but it's not longer available in this verison for some reason - and cannot install pecl extensions. Any ideas? Any example scripts? Thanks!! Paul wrote: > I need to get, parse and display RSS feeds while having the ini setting, > allow_url_fopen = Off. > > I used to use (in version 4.1) domxml_open_mem() but it's not longer > available in this verison for some reason - and cannot install pecl > extensions. > > Any ideas? Any example scripts? Offload the URL retrieval from the server to the client? The client would get the RSS XML via JavaScript, and then it would pass it to your server as a file upload, cookie, or form variable. Paul wrote: > I need to get, parse and display RSS feeds while having the ini setting, > allow_url_fopen = Off. > > I used to use (in version 4.1) domxml_open_mem() but it's not longer > available in this verison for some reason - and cannot install pecl > extensions. > > Any ideas? Any example scripts? > > Thanks!! > > There are at least two ways to make an http connection in PHP without allow_url_fopen being enabled (I've tried both of these; the second one seems to be slightly faster). 1. The cURL library: http://www.php.net/cURL If your host has it installed. For example, Dreamhost has allow_url_fo...