f



devpi-{server-2.2.2,web-2.4.0,client-2.3.0} releases

We just released devpi-server-2.2.2, devpi-web-2.4.0 and devpi-client-2.3.0,
core parts of the private pypi package management and testing system.

Among the highlights are support for distributed testing with "devpi test --detox",
new status pages at "/+status" for replica and master sites and support for
configuring upload formats when running "devpi upload".

None of the changes require an export/import cycle on the server side if
you used devpi-server-2.2.X before.  However, please read the respective
changelog entries below for some notes and potentially
backward-incompatible changes.  See the home page for docs and tutorials:

    http://doc.devpi.net

have fun,
Holger Krekel and Florian Schulze

contracting: http://merlinux.eu

server-2.2.2
------------

- make replica thread more robust by catching more exceptions

- Remove duplicates in plugin version info

- track timestamps for event processing and replication and expose in /+status

- implement devpiweb_get_status_info hook for devpi-web >= 2.4.0 status messages

- UPGRADE NOTE: if devpi-web is installed, you have to request
  ``application/json`` for ``/+status``, or you might get a html page.

- address issue246: refuse uploading release files if they do not
  contain the version that was transferred with the metadata of
  the upload request.

- fix issue248: prevent change of index type after creation


web-2.4.0
---------

- macros.pt: Add autofocus attribute to search field

- macros.pt and style.css: Moved "How to search?" to the right of the search
  button and adjusted width of search field accordingly.

- fix issue244: server status info

  - added support for status message plugin hook ``devpiweb_get_status_info``
  - macros.pt: added macros ``status`` and ``statusbadge`` and placed them
    below the search field.
  - added status.pt: shows server status information

- toxresults.pt: fix missing closing ``div`` tag.


client-2.3.0
------------

- fix issue247: possible password leakage to log in devpi-client

- new experimental "-d|--detox" option to run tests via the "detox" distributed testing
  tool instead of "tox" which runs test environments one by one.

- address issue246: make sure we use vcs-export also for building docs (and
  respect --no-vcs for all building activity)

- address issue246: copy VCS repo dir to temporary upload dir to help
  with setuptools_scm. Warn if VCS other than hg/git are used because
  we don't copy the repo in that case for now and thus cause incompatibility
  with setuptools_scm.

- (new,experimental) read a "[devpi:upload]" section from a setup.cfg file
  with a "formats" setting that will be taken if no "--formats" option
  is specified to "devpi upload".  This allows to specify the default
  artefacts that should be created along with a project's setup.cfg file.
  Also you can use a ``no-vcs = True`` setting to induce the ``--no-vcs``
  option.

0
holger
7/9/2015 12:25:23 PM
comp.lang.python.announce 7374 articles. 0 followers. Post Follow

0 Replies
964 Views

Similar Articles

[PageSpeed] 54

Reply:

Similar Artilces:

devpi-2.0.3, devpi-server-2.0.6 and devpi-web-2.1.0 released
The new devpi releases devpi-2.0.3, devpi-server-2.0.6 and = devpi-web-2.1.0 contain several fixes for the private pypi server = system/self-updating pypi cache, see the changelog below for details. The major new change in devpi-web is support for theming, see here for = more details: http://doc.devpi.net/latest/web.html#themes And general documentation at: http://doc.devpi.net/latest with tutorials and quickstart documents for particular scenarios. Note that no export/import procedure is needed if you are already = running a 2.X devpi-server. If upgra...

[ANN] gettext-2.0.2, gettext_activerecord-2.0.2, gettext_rails-2.0.2
Hi, Ruby-GetText-Package-2.0.2 and the families (gettext-2.0.2, gettext_activerecord-2.0.2 and gettext_rails-2.0.2) are now available. Ruby-GetText-Package is the library/tools for message localization. * gettext - Message localization libraries and tools for all kind of apps/libs. * gettext_activerecord - ActiveRecord Localization * gettext_rails - Rails support with gettext. Changes ------- == gettext-2.0.2 * Support ruby-1.9.1 style format string such as %<foo>d. * Apply new Locale.set_app_language_tags and Locale.candidates. [Suggested by Vladimir Dobriakov] * Enhance...

Oracle server 9.2.0.1.0, Client 9.2.0.4.0, Red Hat Linux enterprise advanced server 2.1
Hi Everybody, My Database server is running on Red Hat Linux enterprise advanced server 2.1, And my Oracle version is 9.2.0.1.0. My Client mechine also Red Hat Linux enterprise advanced server 2.1 , Oracle client version is 9.2.0.4.0. I am running a web application. Our application is in Magic edeveloper. I connect to Oracle using oracle gateway to my application. My Problem is my application is is becoming slow. I am not able to trace where the problem is. Before our application was running fine. recently i upgraded Oracle client version to 9.2.0.4.0. My Oracle client & server versi...

OSK 2.0, 2.2 and 2.3
Does anyone here have any of the versions named in the subject? I am unravelling 68K Basic I-Code, and I need to compare 2.0, 2.2 and 2.3 modules with 2.1 and 2.4 modules. There are differences between 2.1 and 2.4, and I want to know how many other differences there are between versions. Thanks in advance. Wayne Campbell ...

TRSDOS II, version 4.2.0, 4.2.2, 4.2.4, 4.2.6 (or 4.3.x or 4.4)
Hi, Group I require a copy of the above DOS, but I need it _on disk_ as I do not have an emulator for the Model II that must be tested. Is there any possible sources of the OS on disk, or can you advise if the original 8" drive can be hooked to another device so that I can transfer an electronic copy to the disk to boot the machine? What other options do I have? Thanks L replying to my own post :-) I found an article here (http://www.tim-mann.org/trs80resources.html) where Tim describes a trick to rescue a disk's contents. This should be a workable solution...

Does 4/2/2= (4/2)/2 =1 OR = 4/(2/2)=4
I don't have matlab and I am trying to translate some simple matlab code. Does 4/2/2 = (4/2)/2 = 1 or 4/2/2 = 4/(2/2) = 4 On 9/11/2012 9:43 AM, sarah.englander@gmail.com wrote: > I don't have matlab and I am trying to translate some simple matlab code. > > Does 4/2/2 = (4/2)/2 = 1 yes. At a given precedence level (and obviously two of the same operators are the same level) evaluation proceeds from LtoR. ....snip... <http://www.mathworks.com/help/techdoc/matlab_prog/f0-40063.html#f0-38155> -- dpb <none@non.net> wrote in message <...

2 * 2 * 2 * 2 or pow(2, 4)?
Hi , I hope this isn't too trivial to ask, but I'm evaluating a polynomial that involve lots of terms like x^2y^2z^3, and although I can use the power function pow(a, b), I wonder if just writing x*x*y*y*z*z*z for example wouldn't be more efficient than pow(x, 2)*pow(y, 2)*pow(z,3). Or is it all the same? Thanks, - Olumide Olumide wrote: > I hope this isn't too trivial to ask, but I'm evaluating a polynomial > that involve lots of terms like x^2y^2z^3, and although I can use the > power function pow(a, b), I wonder if just writing x*x*y*y*z*z*z for > exam...

ANNOUNCE: Release 2 of the DJGPP ports of GNU fileutils-4.1, textutils-2.0 and shellutils-2.0.11 uploaded. For DJGPP 2.05 only.
These are updates of the ports of fileutils-4.1, textutils-2.0 and shellutils-2.0.11 to MSDOS/DJGPP. DJGPP specific changes. ======================= - These are the first ports that has been compiled with djdev205. Starting with this port version I will no longer support neither djdev204 nor djdev203. - Only those DJGPP specific changes have been done to get the sources configured and compiled using djdev205. All these changes are documented in the diffs.205 file store in the /djgpp directory. I have not waisted my time trying to get the test ...

update Oracle from 10.2.0.2.0 to 10.2.0.2.0
Where can I get the software for 10g 10.2.0.2.0. for Windows XP 32 bit. Thank you very much. "keekee" <moongeegee@gmail.com> a �crit dans le message de news: f3b21ed0-12fd-4812-b9da-60cf59d508b9@i9g2000yqi.googlegroups.com... | Where can I get the software for 10g 10.2.0.2.0. for Windows XP 32 | bit. | Thank you very much. On Metalink (My Oracle Support). https://support.oracle.com/CSP/ui/flash.html Regards Michel ...

Python 2.0 / Python 2.2
Hallo newsgroup, I have some questions concerning Python 2.2. First question: I try to port source code from Python 2.0 to Python 2.2.The following source code works with Python 2.0. If I compile it with Python 2.2, the modul "tci" is not imported. "tci" is a python module written by us. How can I change the source code to get it working with Python 2.2.? Py_Initialize(); PyStr = Py_BuildValue("s", TCIHome); PyModule = PyImport_ImportModule("sys"); PyList = PyObject_GetAttrString(PyModule, "path"); PyList_Insert(PyList, 0, PyStr); if (PyEr...

mod_perl 2.0.3 and apache 2.0.x and 2.2.x^
Hello NG, can I install the mod_perl 2.0.3 ppm packages for bothe server versions of apache? (perl 5.8.x, ActiveState/Win32) It would be good to have both installed. "mod_perl-2.0" (apache 2.0.x) _AND_ "mod_perl" (apache 2.2.x) Thomas ...

Printing 2^1, 2^2, 2^3, 2^4 and 2^5
Hi, When I use a while loop, the output is: 2 4 8 16 32, as desired: <?php $c=1; while($c<=5) { $d = newpow(2, $c); print "$d "; $c++; } function newpow($base, $power) { // statements... } ?> The But when I use a for loop, the output is: 64: <?php for($c=1; $c<=5; $c++); { $d = newpow(2, $c); print "$d "; } function newpow($base, $power) { // statements... } ?> Why is this?? Many thanks, Michael mejpark wrote: > When I use a while loop, the output is: 2 4 8 16 32, as desired: [...] > The But when I use a for loop, the output is: 64...

[ANN] gettext-2.0.3, gettext_activerecord-2.0.3, gettext_rails-2.0.3
Hi, Ruby-GetText-Package-2.0.3 and the families (gettext-2.0.3, gettext_activerecord-2.0.3 and gettext_rails-2.0.3) are now available. Ruby-GetText-Package is the library/tools for message localization. * gettext - Message localization libraries and tools for all kind of apps/libs. * gettext_activerecord - ActiveRecord Localization * gettext_rails - Rails support with gettext. Changes ------- == gettext-2.0.3, gettext_activerecord-2.0.3, gettext_rails-2.0.3 * Fixed dependencies [Reported by Hans de Graaff] (NOTE) * Rails-2.3.1 and earlier aren't supported. Website ------- ...

[ANN] gettext-2.0.4, gettext_activerecord-2.0.4, gettext_rails-2.0.4
Hi, Ruby-GetText-Package-2.0.4 and the families (gettext-2.0.4, gettext_activerecord-2.0.4 and gettext_rails-2.0.4) are now available. Ruby-GetText-Package is the library/tools for message localization. * gettext - Message localization libraries and tools for all kind of apps/libs. * gettext_activerecord - ActiveRecord Localization * gettext_rails - Rails support with gettext. Changes ------- == gettext-2.0.4 * Fix String#% return nil when the string have no place holders. [by okkez] * Update pofiles and remove old messages. * suppress some warnings on Ruby 1.9.x. [by Nobuhiro IMA...

Web resources about - devpi-{server-2.2.2,web-2.4.0,client-2.3.0} releases - comp.lang.python.announce

Resources last updated: 1/25/2016 11:38:23 AM