f



CGI errror in (only in) IIS 6.0 server 2003 #3

Hi, I've been using ActivePython 2.3 (cgi) on IIS on win xp, 2000 and
they work fine.
Until I upgrade the system the server 2003. The ASP script engine is ok
but not the CGIs.

I got these errors:

HTTP Error 403.1 - Forbidden: Execute access is denied.



I already have execute access on the directory.



Can anyone help me?


=========
kychan

0
nonamehkg (14)
1/9/2006 12:12:20 AM
comp.lang.python 77058 articles. 6 followers. Post Follow

5 Replies
331 Views

Similar Articles

[PageSpeed] 23

nonamehkg@hotmail.com wrote:
> Hi, I've been using ActivePython 2.3 (cgi) on IIS on win xp, 2000 and
> they work fine.
> Until I upgrade the system the server 2003. The ASP script engine is ok
> but not the CGIs.
>
> I got these errors:
>
> HTTP Error 403.1 - Forbidden: Execute access is denied.
>
> I already have execute access on the directory.
>
> Can anyone help me?

This is an IIS configuration issue, and has nothing to do with Python.
You will probably get much better responses if you post it in a more
appropriate group -- a quick search of Google Groups turns up
microsoft.public.inetserver.iis and
comp.os.ms-windows.nt.admin.networking, to get you started.

Hope this helps,

-- David

0
dwahler (89)
1/9/2006 12:55:04 PM
David Wahler wrote:

>> I got these errors:
>>
>> HTTP Error 403.1 - Forbidden: Execute access is denied.
>>
>> I already have execute access on the directory.
>>
>> Can anyone help me?
>
> This is an IIS configuration issue, and has nothing to do with Python.
> You will probably get much better responses if you post it in a more
> appropriate group -- a quick search of Google Groups turns up
> microsoft.public.inetserver.iis and
> comp.os.ms-windows.nt.admin.networking, to get you started.

checking the IIS documentation may help:

    http://support.microsoft.com/default.aspx?scid=kb;en-us;318380

    (scroll down a bit for the section that explains common causes for
    the 403.1 message)

the IIS faq page may also be helpful:

    http://www.iisfaq.com

e.g.

    http://www.iisfaq.com/Default.aspx?tabid=2814
    HTTP 403.1 Forbidden: Execute Access Forbidden

</F> 



0
fredrik2101 (5275)
1/9/2006 1:33:29 PM
Thanks
yes, it is. I have checked everything already, but still couldn't get
it working on server2003

0
nonamehkg (14)
1/9/2006 11:24:37 PM
Yes, I checked it.
It was really "Scripts and Executables" not None

0
nonamehkg (14)
1/9/2006 11:29:23 PM
also, the IDE pythonwin crash everythin time I run it

0
nonamehkg (14)
1/10/2006 11:09:32 PM
Reply: