f



Module for Informix Database?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


Hello,

does anybody know, if there is a module to connect to an Informix
database? I looked around, but I have seen there only modules for Python
1.x - and this ones do not work with 2.x ;-(

Thanks for any hint!
Jan
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.2 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQE/4dSsvvmCkIIgH8QRAomRAJ9vk8hKIGp3Lw+JFwPkBcRz8hWJXgCfXU5b
UW4IYY39Lsut5DCDBLG+gx0=
=lwKC
-----END PGP SIGNATURE-----
0
ich7 (3)
12/18/2003 4:24:12 PM
comp.lang.python 77058 articles. 6 followers. Post Follow

3 Replies
527 Views

Similar Articles

[PageSpeed] 56

On Thu, 18 Dec 2003 17:24:12 +0100, Jan Kesten <ich@jan-kesten.de>
wrote:

>does anybody know, if there is a module to connect to an Informix
>database? I looked around, but I have seen there only modules for Python
>1.x - and this ones do not work with 2.x ;-(

AFAIK it's definitely possible to use module 'informixdb'
(http://starship.python.net/crew/sturner/informixdb.html) with
Python2.x (although installing the module for Python 2.x is tricky)!
And it only implements version 1.0 of the DB-API specification. But,
that was good enough for me ;-)

-- 
EOP
0
parken (2)
12/18/2003 9:17:42 PM
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Olaf Ferger wrote:

| AFAIK it's definitely possible to use module 'informixdb'
| (http://starship.python.net/crew/sturner/informixdb.html) with
| Python2.x (although installing the module for Python 2.x is tricky)!
| And it only implements version 1.0 of the DB-API specification. But,
| that was good enough for me ;-)

I saw this module - but I didn't manage to compile and/or install it
into Python 2.x. I have made a work around for me a while ago, so I used
isql from Informix to unload the results into a textfile and then read
it with Python. But if there is more than one access at a time this (of
course) leads into trouble..

So if you still know, how you got "informixdb" to work with Python 2.x
please let me know.

Cheers,
Jan

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.2 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQE/4ydDvvmCkIIgH8QRAhL/AJ9fBES/1cGrhwvuiGf59csoe1DPkgCgq780
lwNckQMM8hjdIFTp0fEP2Qk=
=deuO
-----END PGP SIGNATURE-----
0
ich7 (3)
12/19/2003 4:28:51 PM
Jan Kesten <ich@jan-kesten.de> wrote:

>So if you still know, how you got "informixdb" to work with Python 2.x
>please let me know.

I did it a year ago. I'll try to reproduce it one of these days and
tell you the results.

Regards, 

  Olaf

-- 
EOP
0
parken (2)
12/21/2003 8:08:19 AM
Reply: