f



exerb4.2.0 don't work with ruby1.8.7 and yaml

There is my test.rb:
require 'yaml'
config = YAML::load(File.open("config.yml"))

and there is my config.yml:
topic: forum-39-thread-11173510-1-1

"mkexy test.rb" and "exerb test.exy" can execute all right and generate
test.exe,
but when I execute test.exe,it raise an error:
yaml.rb:9:in `require': Win32API Error #127
 (ExerbRuntime::Error)
        from yaml.rb:9
How can I fix it?Any help will be appreciated!
-- 
Posted via http://www.ruby-forum.com/.

0
wujunchen (11)
7/1/2008 6:49:15 AM
comp.lang.ruby 48886 articles. 0 followers. Post Follow

0 Replies
485 Views

Similar Articles

[PageSpeed] 2

Reply:

Similar Artilces:

Can't get PCI Network Card to Work
Hello, I have an IBM Pentium III 663MHz PC (desktop) which I've been trying to get a Linux Distro to work on with Networking successfully. I know it can be done, because this box has been loaded with an early version of Redhat and operated as a web server. I wanted to start fresh so I wiped the system clean with Redhat 8 - which was able to come up quickly and correctly detect the network card that was installed. However it could not "initialize" the card. I knew that Redhat 8 had some issues, so I installed Redhat 7.2. The results were the same. So know I've ...

Can't get PCI Network Card to Work
Hello, I have an IBM Pentium III 663MHz PC (desktop) which I've been trying to get a Linux Distro to work on with Networking successfully. I know it can be done, because this box has been loaded with an early version of Redhat and operated as a web server. I wanted to start fresh so I wiped the system clean with Redhat 8 - which was able to come up quickly and correctly detect the network card that was installed. However it could not "initialize" the card. I knew that Redhat 8 had some issues, so I installed Redhat 7.2. The results were the same. So know I've taken out the...

exmh 2.7.0: OK, 2.7.2: 'tkerror: can't read "pgp(pgp6,path)": no ...'
Hiya, I just upgraded to Mandriva 2007.0, which comes with exmh 2.7.2. I tried that, but I got one of those traceback windows and this in the xterm where I started exmh: exmh: tkerror: can't read "pgp(pgp6,path)": no ... exmh: tkerror: can't read "exwin(mtext)": no s ... I rebuilt my 2.7.0 exmh from my previous OS. It runs just fine. I'm running tcl-8.4.13 & tk-8.4.13, both shipped with Mandriva, if that matters. What could the problem be? Thanks.... -- PLEASE post a SUMMARY of the answer(s) to your question(s)! Show Windo...

rmagick for Ruby 1.8.6 won't work for Ruby 1.8.7?
if i install 2.12.0 binary gem for Ruby 1.8.6 2009-10-04 16:05 RMagick-2.12.0-ImageMagick-6.5.6-8-Q8.zip which is from http://rubyforge.org/frs/?group_id=12&release_id=43232 then when i use ruby 1.8.7 to require 'rubygems' require 'rmagick' it will say: c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_re quire': no such file to load -- rmagick (LoadError) from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `re quire' from try.rb:3 Does that mean I have to install Ruby 1.8.6 to cover up 1.8.7...

2.8.0 samples
Hi, I want to compile the samples using VC6. If I open samples.dsw under ./samples "nothing" is shown and no message is produced. If I open a single dsp file of a sample, VC6 states that the Makefile wasn't created with VC and trys to produce a converted one. But the converted project is empty. I reinstalled VC6 but nothing changed. I can open ./build/msw/wx.dsw with VC6 without problems. What is wrong here? BTW, the wx libs are compiled from within Julians DialogBlocks, which is much more comfortable to build a special config, than clicking around in the VC6 ...

/noend -noend -persist don't work on XP (3.7, 4.0, 4.1, 4.2)
I'm trying to run wgnuplot (3.7, 4.0, 4.1, and 4.2) on XP from the command-line but the plot window won't stay. I've tried everything that I've found: wgnuplot /noend test.plt wgnuplot -noend test.plt wgnuplot -persist test.plt wgnuplot test.plt /noend wgnuplot test.plt -noend wgnuplot test.plt -persist and the same with pgnuplot. Every time it's the same thing, the window flashes and disappears. If I use a different term it outputs the file just fine. I'm sure it's something stupid that I'm missing, but I can't seem to find it. c....

AOL 9.0 don't do it just don't . Don't even think of it.
I had 8.0, and it ran fine. I downloaded 9.0 and that was the end of my computer never having a problem. 3 years and no problems. 1 week with AOL 9.0 and I've had 27 error messages , sign offs and other problems. AOL was no help. They can't even admit it has a problem. So I had to REFORMAT MY HARD DRIVE AND INSTALL ALL MY PROGRAMS AND ALL MY SAVED FILES. Needless to say I no longer have AOL at all. Reformat and get rid of it. ...

.htaccess page protection don't work after update to Apache 2 (CSWS 2.0)
I have updated CSWS1.3 to CSWS2.0 under OpenVMS/AXP 7.3-2 on Sunday. Now, the .htacess based page protectin don't work. I have checked that the files are all STMFL and accessible to APACHE$WWW. I have checked the old and new httpd.conf -> no difference at the corresponding sections. I can call/open the pages without to be prompted for a username/password. Any ideas are welcome! Joerg ...

I've broken it but don't know how i915 / 2.6.17 / xorg 7.0
Hi, I brough myself a budget laptop for watching recorded TV on, and my original plan was to stick debian on it, but to support the hardware I needed a recent kernel so it had to be "unstable", I was also having trouble getting the i915 working (kept returning me to vesa) so I moved from 6.8.2 to 7.0 for the most up-to date drivers, glx said things were broken and I updated the MESA drivers to fix the problem. What I have now is god only knows, with a hand hacked xorg.conf after I managed to touch it and debian refused to touch it again after that. My problem is I would...

I don't work for IBM and I don't make promises I can't deliver on
I wish I could afford an advertising campaign to compete with what they have on the Internet now. I promise to go totally ballistic at the next LLLNL contract. Robert. On 8/12/2011 11:24 PM, Robert Myers wrote: > I wish I could afford an advertising campaign to compete with what they > have on the Internet now. > > I promise to go totally ballistic at the next LLLNL contract. > > Robert. I don't work for IBM (anymore) either. If you are talking about the death of Blue Waters, I don't believe they said they couldn't deliver. They said they chose not to beca...

HP Jetdirect Manager v.4.0 and OS 9.2.2 don't work together?
HP Jetdirect Manager v.4.0 and OS 9.2.2 don't work together? the HP manager is (was) used to select with printes on the LAN would be access from the iMacs we have around. Launching the HP JetDirect manager causes the app to freeze. Mouse still moves, but that's all. A force quit can be done. Anyone see a conflict between this app and OS 9.2.2? Thanks, hak In article <a5bd0d2b.0308261151.1b96bd53@posting.google.com>, hey_you@earthling.net (hakalugi) wrote: > HP Jetdirect Manager v.4.0 and OS 9.2.2 don't work together? > > the HP manager is (was) used to sele...

3*x''+(10^-3)*x'+123*x=2*cos(3*t); x=x(t);initial conditions x(0)=0 and x'(0)=0
Hi everybody, I need to solve the Cauchy problem written in the title box ( I paste it here again ): 3*x''+(10^-3)*x'+123*x=2*cos(3*t); x=x(t);initial conditions x(0)=0 and x'(0)=0. I tried with Runge-Kutta method and it seems to work as the solution x(t) is the same that I can get solving the equation by myself. I need to know if it would be better another method (eventually multistep one) and why it would be better (please don't just tell me 'cause it's faster or so...I need to know the why too). As last thing I need to estimate the error committed with Runge...

Databases Don't Work With OSes; OSes Don't Work With Databases -- Windos 2003 "You've Made A Mess" Say Irate Users !?!!
http://groups.google.com/groups?q=windows+2003+server+problem&hl=en&lr=&ie=UTF-8&as_drrb=b&as_mind=12&as_minm=2&as_miny=2004&as_maxd=7&as_maxm=6&as_maxy=2004&selm=ObEBOsECEHA.684%40tk2msftngp13.phx.gbl&rnum=1 Search Result 1 From: Dave Verwer (d.verwer@link-hrsystems.com) Subject: Problem with SQL Server & MSDTC on Windows 2003 (dtctester.exe related) View: Complete Thread (9 articles) Original Format Newsgroups: microsoft.public.sqlserver.server, microsoft.public.windows.server.general Date: 2004-03-12 08:02:14 PST Hi all I am not su...

vim 6.2 + vim-ruby don't work
Hi, I just downloaded the latest vim 6.2 and vim-ruby snapshot 2003-10-12 and copied ftplugin, indent, syntax to directory of vim executable. I then use vim to open a ruby file and see syntax highlight working. Then I use "gq=g" to format the whole file. It scrolls to the end of the file but nothing is indented. Please let me know what I did wrong. My .vimrc : set autoindent number ruler tabstop=2 set nocompatible " We're running Vim, not Vi! syntax on " Enable syntax highlighting filetype on " Enable fieltype detection filetype indent...

wxHTTP why don't work ??.[win32][2.4.0]
I have a problem i can't use wxHTTP control this control recives error: The client failed to connect the server. (wxPROTO_CONNERR) But why ?? This can work ?? --------------------------------------------------- wxHTTP *httpCtrl = new wxHTTP; wxInputStream *in_stream; in_stream = httpCtrl->GetInputStream(www.onet.pl); --------------------------------------------------- in_stream - not initialized beaucouse i get fu*** error msg Thanks for help Tomek [sorry for my english :] L> --------------------------------------------------- L> wxHTTP *httpCtrl = new ...

ruby 1.8.4 gives warnings where ruby 1.8.2 doesn't
Hi, How do I disable warning output in Ruby? The servers at work use ruby 1.8.2, which gives no warning when running some rake / rails scripts. If I rsync / copy those scripts to my ruby 1.8.4 machine and run them there, I get loads of warnings. I don't want to downgrade my beloved Ruby, can anyone tell me how I can simply disable those warnings at run-time? Thanks -- To reply, take of all ZIGs !! Alternative email address: emailZIG@asfandyarZIG.cjbZIG.netZIG Asfand Yar Qazi wrote: > I don't want to downgrade my beloved Ruby, can anyone tell me how I can > simply d...

'Dictionary' no longer works after 7.3-2 and Rdb 7.1.2.2. upgrade
RDbers (and comp.os.vmsers) -- OpenVMS Alpha (DS20E), Rdb 7.1.2.2, VMS 7.3-2 I have some old but still in use and maintained Fortran/TDMS/RDO precompiler programs. They get record definitions from the CDD via Dictionary statements, eg: dictionary 'cdd$top.user_support.database.rdb$relations.scheduled_propos als/list' This has been working fine. (The creation date on the include file with this statement is in 1996, so it would seem to have been working fine for a while.) The programs in question were last compiled in December. Over Christmas break, we upgraded from VMS 7....

Yet another 8.2 bug: Error 1131 in LV 8.2 which wasn't there in LV 7.1
This bug makes LV 8.2 not backwards compatible (for us at least): &nbsp; It appears that - in certain circumstances -&nbsp;the "Digital Display.Text Colors:BG Color" property&nbsp;of an enum control&nbsp;gets changed from read/write to read only&nbsp;when opening a 7.1.1 VI in 8.2. &nbsp; The attached VI, which was saved in 7.1.1,&nbsp;runs without error in 7.1.1 but returns an error in 8.2 (Error 1131: "You cannot use this property with this system control."). &nbsp; The enum on the front panel was created as follows: - In LV 7.1.1, drop a ...

wx-config don't return the right libs on 2.7.0
Hi, I'm trying to migrate my program(wxDownload Fast) with builds fine with wxWidgets 2.6.3(with patch 2) to 2.7.0-1 and I have some linking problems, I think because of the "wx-config" script. I will describe my problem: First I'm trying to cross-compile my program on Linux (Debian Unstable) to Windows with Mingw, to do this I build wxWidgets 2.6.3 with the follow command: ../configure --prefix=/usr/i586-mingw32msvc --host=i586-mingw32msvc --target=i586-mingw32msvc --with-msw --enable-monolithic --disable-shared --enable-xrc --enable-unicode And after th...

Can't seem to get any functions to work in 7.8.0 Student
Hello everyone, I just installed a student version (7.8.0 R2009aSV) of Matlab on my MacBook and have activated it. I can't seem to find any of the functions Im used to using in matlab - like 'freqz' for example. I type 'help freqz' into the command line, and it says 'freqz not found'. Could someone help me resolve this? Im not new to Matlab, just new to using Matlab on my own computers - I always had it on computers at work or school. Thanks! Mike "Michael " <michael.zartarian@gmail.com> wrote in message <holmls$p2r$1@fred.mat...

Tabs don't work in Linux Matlab 7.0.4 sp2?
I just recently switched from Windows to Linux and am now running the Linux version of Matlab (Matlab 7.0.4 sp2). Although the editors in the Windows and Linux versions are almost the same, in Linux I can't tab (or indent) using the tab key, as I could in the Windows version. Although it seems like a little thing, I'm so use to using this that I find myself constantly hitting the tab key, but with no effect. Is this a bug in the Linux version, or is there some setting I can make to get this to work? Thanks for any help with this. Pat In article <dIqdncaN7MpFH_TbnZ2dnUVZ_hisnZ2...

Linux crapware victim: Mepis8 'collapsed'... webcams don't work on Ubuntu 12.04..."Don't tell me to build a kernel..."
"I need my webcam to work with flash on web pages so that I can speak to family members overseas (Kopete and suchlike). I used mepis8 for years and everything was perfect, my webcams (three different makes), printers and anything else I cared to plug in worked from the off. lovely!! Then mepis8 collapsed suddenly and nothing worked. I tried the newer mepis variants and every other linux distro that I came across to solve the problem, but nothing works. I'm now using ubuntu 12.04, because it's not windows I suppose, but it's far from what I need. ...

updating from OS 10.2. to 10.8--regular ways don't work!
Hello again folks-- I had to reinstall OS 10.2 today, and using Software Update won't work to install the latest Combo updates, so I can get back to OS 10.8. However, nothing else seems to work either. When I go to the Apple website to download the updates manually, they won't install either--I get an error message saying that *this update is not compatible*--or words to that effect. So, until I find a solution to this--I'm at 10.2. I have iLife 04 and I'd like to try and get it working--I had trouble with the previously, but I have some time this next week to work with it...

Why don't my plots appear? My 5.2 code no longer works correctly in 6.0
Hello, I am running into difficulties with Plot. Some code of mine that worked in 5.2 no longer works correctly in 6.0.2.0. Specifically, no plots appear whenever Plot (or Plot3D or DensityPlot or ListPlot) is called within a function that I have defined. Here is a closely related question: What does the red semicolon ";" mean at the end of "Plot[ ... ];"? Why is it red? In 5.2, placing a semicolon at the end of Plot[] allowed me to output a plot in the middle of a computation, without halting the computation. Now I can no longer seem to output a plot in the midd...

Web resources about - exerb4.2.0 don't work with ruby1.8.7 and yaml - comp.lang.ruby

Resources last updated: 2/17/2016 2:46:40 PM