f



lib/ruby/1.8/e2mmap.rb:51: Use Ruby 1.1 (RuntimeError) - Windows Vista Ruby 1.8.6

Hi

I am trying to start up my application on Windows Vista with Ruby 1.8.6
and the Oniguruma-Patch applied. It results in this error:

lib/ruby/1.8/e2mmap.rb:51: Use Ruby 1.1 (RuntimeError)

the full error message is:

http://pastebin.com/U1T3SFK7

The app runs just fine on Linux with Ruby 1.8.6.

Any hints are highly appreciated.

Best
Zeno

-- 
Posted via http://www.ruby-forum.com/.

0
zdavatz (2)
1/12/2011 8:53:57 AM
comp.lang.ruby 48886 articles. 0 followers. Post Follow

2 Replies
1082 Views

Similar Articles

[PageSpeed] 25

It seems that

lib/ruby/gems/1.8/gems/gd2-1.1.1/lib/gd2/canvas.rb:23

requires

lib/ruby/1.8/matrix.rb:23

and that calls

require "e2mmap.rb"

and that will throw the error

lib/ruby/1.8/e2mmap.rb:51: Use Ruby 1.1 (RuntimeError)

is this a gd2 issue?

gd2 loads just fine in irby

C:\Users\zdavatz>irb
irb(main):001:0> require 'rubygems'
=> true
irb(main):002:0> require 'gd2'
=> true

Best
Zeno

-- 
Posted via http://www.ruby-forum.com/.

0
Zeno
1/12/2011 9:02:23 AM
Ok, this issues is connected to:

http://redmine.ruby-lang.org/issues/show/4156

Closing.

Best
Zeno

-- 
Posted via http://www.ruby-forum.com/.

0
Zeno
1/12/2011 9:31:16 AM
Reply:

Similar Artilces:

YAML on Ruby 1.8.1 and Ruby 1.8.2
I've written several programs that use YAML to store their configuration files, and I generally run them on Ruby 1.8.2. Occasionally we have a setup with a Ruby 1.8.1 or older version around and noticed that the YAML module on these older versions of Ruby behaves differently from that of 1.8.2. In particular, this YAML string: "--- :abc" produces different results from 1.8.1 and 1.8.2. Under 1.8.2, I get the expected behavior, and YAML::load("--- :abc") => :abc However, under 1.8.1: YAML:load("--- :abc") => ":abc" This totally breaks my...

Ruby 1.8.4 and Ruby 1.8.6
Hi Experts, I was wondering, if we could use previous version if we installed 1.8.6? i know this is stupid. :) any suggestions? regards, Bala On Feb 28, 2008, at 01:14 AM, Bala wrote: > Hi Experts, > > I was wondering, if we could use previous version if we installed > 1.8.6? > > i know this is stupid. :) any suggestions? [unpack a ruby 1.8.6 tarball and cd into it] /configure --prefix=/path/to/ruby186 make && make install /path/to/ruby186/bin/ruby -v On Feb 28, 2:20 pm, Eric Hodel <drbr...@segment7.net> wrote: > On Feb 28, 2008, at 01:14 AM, Bala wr...

Why is Ruby 1.8.6 RC1 more recent than Ruby 1.8.6 Final?
Getting to the Ruby One-click installer for Windows, we may go to http://www.ruby-lang.org/en/downloads/ and then http://rubyinstaller.org/download.html however over there, it seems that Ruby 1.8.6 RC1 (patchlevel 383) is actually more recent than Ruby 1.8.6 RC2 (patchlevel 27) or Ruby 1.8.6 Final (patchlevel 26) If I install them on different machines, the RC1 actually shows a more recent date than RC2 or Final, by using ruby -v What's the rule? Does it go strictly by patchlevel? That is, the patchlevel decides how update it is, instead of whether it is R...

/opt/build/ruby/lib/ruby/1.8/mkmf.rb:345:in `%': numbered(1) after unnumbered(1) (ArgumentError)
The error in the subject happens to me on HP-UX. What does it mean? Thanks, Ittay -- -- Ittay Dror <ittay.dror@gmail.com> Hi, At Sun, 7 Dec 2008 22:46:47 +0900, Ittay Dror wrote in [ruby-talk:322136]: > The error in the subject happens to me on HP-UX. What does it mean? $ ruby -e '"%s %1$s" % "a"' -e:1:in `%': numbered(1) after unnumbered(1) (ArgumentError) Fixed trunk and 1.8 branch in the repository. -- Nobu Nakada ...

/ruby/1.8 and /ruby/site_ruby/1.8
What is the difference between /ruby/1.8 and /ruby/site_ruby/1.8 ? (I can see from $: which has priority, but my question is - what is supposed to go where) I think that some problems might be caused when a library gets installed to both, perhaps with the wrong .so being loaded - not sure.... Is this possible? (My questions are towards ruby in general, but specifically towards the Windows One Click Installer) It depends The exact use and layout depends on your OS. For all OSes, ruby/1.8/ holds the core and sandard libs --those that are part of the Ruby distribution proper. And site_ruby/...

ruby1.9.2 looking for Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/csv.rb:312
Hi I have just started learning ruby and Im using ruby 1.9.2p0 (2010-08-18 revision 29036) [x86_64-darwin10.5.0]. Im trying to run a program from a book for CSV reader and when I try to run it (using csv file as input) i get error from CSV library which is under 1.8. And Im not sure if its correct.. Can someone please help Thanks guru Processing sample.csv /csv_reader.rb:14:in `read_in_csv_data': uninitialized constant CsvReader::BooksInStock (NameError) from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/csv.rb:312:in `open_reader' ...

Ruby 1.9.0/1.8.7/1.8.6/1.8.5 new releases (Security Fix)
Hi all. Some vulnerabilities were found on Ruby, one of which allow attackers to execute arbitrary codes. These are releases to fix those problems. Also note this is the last official release of ruby 1.8.5. No support are provided for it by us any longer. Detailed information should be found at: http://www.ruby-lang.org/en/news/2008/06/20/arbitrary-code-execution-vulnerabilities Released tarballs are available at: ftp://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.0-2.tar.bz2 ftp://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.0-2.tar.gz ftp://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.0-2.zip ftp://...

Ruby extension (C++) on OS X [ruby 1.8.2] and Google-Sketchup [ruby 1.8.5]
Hi, I have written a ruby extension in C++ and it works fine on OS X Tiger which ships ruby-1.8.2. With the succesful test of the extension (bundle), I then proceed to try to use it within Google-Sketchup [which I think embeds ruby-1.8.5]. Sketchup crashes the application just loading the extension. 8<------8<------8<------8<------8<------8<------8<------8<------8<------ void Init_rcl(void) { cRCL = rb_define_class("rcl", rb_cObject); <=== /CRASH 8<------8<------8<------8<------8<------8<------8<------8<------8...

Intstalled Ruby 1.8.7 but still getting ruby -v => 1.8.6
I have followed the instructions to install ruby 1.8.7. Everything seems to have installed as best that I can determine. However when I run the command ruby -v I get ruby 1.8.6 (2009-06-08 patchlevel 369) [universal-darwin9.0] Why is that? Also do I have to tell my Rails application to use 1.8.7 and if so how do I do this? Thank you in advance Mitchell -- Posted via http://www.ruby-forum.com/. Mitchell Gould wrote: > I have followed the instructions to install ruby 1.8.7. Which instructions? What did you do? On what platform? The question as-is is miss...

rmagick for Ruby 1.8.6 won't work for Ruby 1.8.7?
if i install 2.12.0 binary gem for Ruby 1.8.6 2009-10-04 16:05 RMagick-2.12.0-ImageMagick-6.5.6-8-Q8.zip which is from http://rubyforge.org/frs/?group_id=12&release_id=43232 then when i use ruby 1.8.7 to require 'rubygems' require 'rmagick' it will say: c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_re quire': no such file to load -- rmagick (LoadError) from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `re quire' from try.rb:3 Does that mean I have to install Ruby 1.8.6 to cover up 1.8.7...

the differeces among those three directories under ruby-1.8.5\lib\ruby: /1.8, /gems, and /site_ruby
can anyone explain the differeces among those three directories under ruby-1.8.5\lib\ruby: / 1.8, /gems, and /site_ruby thanks ...

Splat array with 1 value in Ruby 1.9 vs Ruby 1.8
In porting some automation code from 1.8.7 to 1.9.1, I find that in ruby 1.8 the following generated code (real code is unpacking binary strings and assigning variables, but I simplify for clarity, although the result may look a bit silly) worked: var1 = *[ val1 ] # var1 = val1 var1, var2, varn = *[ val1, val2, valn ] # ,, (the splat is not necessary in the second case, but this allowed the code to be generated in the same way, regardless of array size). With Ruby 1.9.1-p243, instead, this happens: var1 ...

Question about some changes from Ruby 1.8.6 to Ruby 1.9
So, the bulk of my issues thus far have been pretty simple and I've isolated and ported over a very lengthy app from 1.8.6 to 1.9.1. The biggest issues I saw were things like scopes: Before: named_scope :private_pages, :conditions => 'pages.parent_id IS NULL and pages.subpage_id IS NULL', :order => 'pages.position', :include => {:subpages, :subofsubs} After: named_scope :private_pages, :conditions => 'pages.parent_id IS NULL and pages.subpage_id IS NULL', :order => 'pages.position', :include => [:subpages, :subofsubs] ...

How do I install both Ruby 1.8 and Ruby 1.9?
Hi, I have Ruby 1.8 installed (on Linux) in /usr/local/bin/. I want to have a copy of a Ruby 1.9 snapshot around too, so I can try out stuff out with that. But I can't figure out how to install it in a different location. I've altered the "prefix" variable in the Makefile, but when I do a "make install", it just overwrites my Ruby 1.8 installation in /usr/ local/bin. I imagine there is a simple solution to this. Can anyone share it? David Flanagan Hi, In message "Re: How do I install both Ruby 1.8 and Ruby 1.9?" on Tue, 6 Feb 2007 15:45:09...

Ruby 1.8 vs. Ruby 1.9
Hi, Does anyone here think it's a good idea for a beginner to learn Ruby 1.8 and then learn Ruby 1.9? If it's better to just learn 1.9 and not worry about what 1.8 was like, I would appreciate any and all responses to this post. Thanks for your time, Calvin Stephens On May 20, 2009, at 10:40 AM, Calvin wrote: > Hi, > > Does anyone here think it's a good idea for a beginner to learn Ruby > 1.8 and then learn Ruby 1.9? If it's better to just learn 1.9 and not > worry about what 1.8 was like, I would appreciate any and all > responses to this post. > >...

[ANN] ruby-msg-1.3.1 (outlook msg lib) and ruby-ole-1.2.1
The new version of ruby-msg has been released! A bunch of bugs have been closed, and a lot more MAPI properties are now converted to their MIME equivalents (eg importance, priority, etc). This release also splits out the OLE storage component into a separate library: ruby-ole. This is a complete, stable lib for read/write access to OLE documents. -- Simply: 1. gem install ruby-msg (this will also install ruby-ole) 2. convert some msg files. there is now a mbox mode - (msgtool -m *.msg > mbox) Details at http://code.google.com/p/ruby-msg/, and at the wiki http://code.google.com/p/ruby-m...

Ruby 1.8.7 from 1.8.6
I have been given a project to understand the ruby and rails so every time when I try to execute the server via script/server i get following message. script/server => Booting Mongrel => Rails 2.3.8 application starting on http://0.0.0.0:3000 /usr/lib/ruby/gems/1.8/gems/mail-2.2.6.1/lib/mail.rb:19: You need to install tlsmail if you are using ruby <= 1.8.6 (RuntimeError) from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require' from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require' from /usr/lib/ruby/gems/1.8/gems/activ...

Serialization ruby 1.8 vs ruby 1.9
Hi, I am trying to marshal objects with ruby 1.8 and read them with 1.9 but I get an error on date objects: ruby 1.8: f=File.new('/tmp/date', 'w+'); f.puts Marshal.dump(Date.today); f.close ruby 1.9: m=File.read('/tmp/date'); Marshal.load(m) gives me: class Date needs to have method `_load' (TypeError) The versions of Marshal are identical, but in 1.8, Date has a _dump and _load method, in 1.9 it does not. Am I missing something or is this a bug? Any hints are appreciated. Thanks, Florian -- Posted via http://www.ruby-forum.com/. On ...

ruby 1.8.4 gives warnings where ruby 1.8.2 doesn't
Hi, How do I disable warning output in Ruby? The servers at work use ruby 1.8.2, which gives no warning when running some rake / rails scripts. If I rsync / copy those scripts to my ruby 1.8.4 machine and run them there, I get loads of warnings. I don't want to downgrade my beloved Ruby, can anyone tell me how I can simply disable those warnings at run-time? Thanks -- To reply, take of all ZIGs !! Alternative email address: emailZIG@asfandyarZIG.cjbZIG.netZIG Asfand Yar Qazi wrote: > I don't want to downgrade my beloved Ruby, can anyone tell me how I can > simply d...

[ANN] FFI 0.1.1 (Foreign Function Interface) for Ruby 1.8.6/7 and 1.9
The JRuby team is proud to announce the release of FFI for Ruby 1.8.6/7 and 1.9! FFI (gem install ffi) is a library for programmatically loading dynamic libraries, binding functions within them, and calling those functions from Ruby code. Here's a quick sample of binding and calling the getpid C library function: require 'ffi' module GetPid extend FFI::Library attach_function :getpid, [], :uint end puts GetPid.getpid Here's another, calling qsort and passing a Ruby block as a C callback: require 'ffi' module LibC extend FFI::Library callback :...

compiling ruby-1.8.1 + official ruby installer for win?
Hi! I'm trying to compile ruby with VS .NET. I got the following: [...] cl -nologo -O2 -DRUBY_EXPORT -I. -I./win32 -I. -I. -I./missing -c -Tc./w in32/win32.c win32.c win32\win32.c(743) : error C2051: case expression not constant win32\win32.c(761) : error C2051: case expression not constant win32\win32.c(785) : error C2051: case expression not constant win32\win32.c(855) : error C2051: case expression not constant NMAKE : fatal error U1077: 'cl' : return code '0x2' Stop. E:\tmp\ruby-1.8.1>cl Microsoft (R) 32-bit C/C++ Optimizing Compiler Version 13.00.9466 for 8...

Difference between ruby 1.8.x and ruby 1.9.2
Hi, I am working on ruby project that needs to be upgraded from ruby 1.8.6 to ruby 1.9.2. Is there any source/article/link where the differences between above versions can be found ? -Payal Patel -- Posted via http://www.ruby-forum.com/. http://dablog.rubypal.com/2009/1/14/10-things-to-be-aware-of-in-moving-to-ruby-1-9 http://dablog.rubypal.com/2009/1/16/son-of-10-things-to-be-aware-of-in-ruby-1-9 On Thu, Dec 9, 2010 at 12:14 PM, Payal Patel <payalpatel11@gmail.com> wrote: > Hi, > > I am working on ruby project that needs to be upgraded from ruby 1.8.6...

ruby update from 1.8.6 to 1.8.7
I have instantrails installed, updated rails to 2.3.8, but can't get ruby updated from 1.8.6 to 1.8.7. I have ruby 1.8.7 on a different directory which I can use, but under instantrails... there is a ruby directory with version 1.8.6. Any idea how I can update it to 1.8.7 ?. Thank you. Dani -- Posted via http://www.ruby-forum.com/. On Aug 8, 2010, at 5:34 AM 8/8/10, Dani Dani wrote: > I have instantrails installed, updated rails to 2.3.8, but can't get > ruby updated from 1.8.6 to 1.8.7. I have ruby 1.8.7 on a different > directory which I can use, but under inst...

Proc in ruby 1.8.6 and 1.8.7
In Ruby 1.8.7 it is possible to do such thing: pr = Proc.new do |arg, &block| block.call end pr.call(123) do puts "xyz" end xyz => nil When calling proc another block can be given as parameter. Is there any way to do it in Ruby 1.8.6 ? Not working: irb(main):001:0> aba = Proc.new do |arg, &block| irb(main):002:1* end SyntaxError: compile error (irb):1: syntax error, unexpected tAMPER, expecting '|' aba = Proc.new do |arg, &block| ^ from (irb):2 == Not working: irb(main):003:0> pr = Proc.new do |arg, block| irb(main):...

GCC 3.3.3 and Ruby 1.8.0 and 1.8.1
We recently upgraded to GCC 3.3.3 and now we can no longer compile ruby due to its use of some obsoleted constructs. Apparently GCC no longer supports <varargs.h>, and code should be revised to use <stdarg.h> Not knowing anything about it, is there a good workaround? Will this be changed in future versions of Ruby so that it will play nice with the latest GCC? gcc -fPIC -g -O2 -fPIC -mpa-risc-2-0 -I. -I/home/kgr/work/actruby/build/hpux11.0/pa2.0/debug/src/compiled-1.8.0 -I/home/kgr/work/actruby/build/hpux11.0/pa2.0/debug/src/ruby-1.8.0 -I/home/kgr/work/actruby/build/hpux11.0...

Web resources about - lib/ruby/1.8/e2mmap.rb:51: Use Ruby 1.1 (RuntimeError) - Windows Vista Ruby 1.8.6 - comp.lang.ruby

Resources last updated: 2/16/2016 6:02:47 AM