f



Spinbox - TCL/Tk 8.4 - Ruby 1.8.2

spinbox was not supported in ruby 1.8.2 'cause it uses tcl/tk 8.3 which
does not have spinbox.

I got Tk spinboxes to work via a kludge. I stole a copy of tcl 8.4 and
tk 8.4 from Python 2.4 and laid them onto Ruby 1.8.2.

add the tcl8.4 folder and tk8.4 folders from python into the ruby lib
folder (you can leave the original tcl 8.3 and tk 8.3 alone)

put a copy of the tcl84.dll and tk84.dll from python into the ruby bin
folder.

rename your old copies of tcl83.dll and tk83.dll just in case

rename the new tcl84.dll and tk84.dll to 83 and now tk 8.4 works with
ruby

0
welch (6)
1/20/2006 4:07:06 PM
comp.lang.ruby 48886 articles. 0 followers. Post Follow

0 Replies
622 Views

Similar Articles

[PageSpeed] 0

Reply: