f



Tcl/Tk on Mac OS X: LoadError

Hello.

I have a problem with Tcl/Tk in OS X, each time i try requiring tk, i
get this:

irb(main):001:0> require 'tk'
LoadError: no such file to load -- tk
        from (irb):1:in `require'
        from (irb):1
irb(main):002:0>

I am positive that I have Tcl/Tk installed - i've installed the binary
from ActiveState and I've tried compiling Ruby 1.8.6 myself and I've
tried installing it with MacPorts, but nonetheless it doesn't work.
I've tried ./configure with --enable-mac-tcltk-framework but it seems
that nothing works.

I've also tried tclsh and wish, and i even made a little button in
wish from the terminal, so I am positive that Tcl/Tk is installed, but
Ruby just doesn't know where or something like that.

I've tried googling, and found people with the same problem, but I
never found any solutino that worked for me.

What can I do?

Mac OS X 10.4.10

0
isakus (1)
7/7/2007 12:45:43 PM
comp.lang.ruby 48886 articles. 0 followers. Post Follow

0 Replies
406 Views

Similar Articles

[PageSpeed] 27

Reply: