f



Couldn't load library (libmysqltcl.dll)

Hi guys.

After uninstalling some software (a badly programmed but not
deliberately malicious app) it seems that a DLL has changed.

I'm now getting this error with some scripts which use libmysqltcl.dll,
both in script form and compiled executibles that have been working for
ages:

 Error in startup script: couldn't load library "libmysqltcl.dll": could
 not find specified procedure while executing "load libmysqltcl[info
 sharedlibextension]"

I've loaded up libmysqltcl.dll into Dependency Walker (an app by Steve
P. Miller for Microsoft) and it hasn't shown any missing dependencies or
sub-dependencies (it checks the whole dependency tree, a la ldd).

What else could be stopping libmysqltcl.dll from being loaded with this
error?

0
hfrarg3 (215)
4/29/2006 10:50:46 PM
comp.lang.tcl 23429 articles. 2 followers. Post Follow

0 Replies
1702 Views

Similar Articles

[PageSpeed] 16

Reply:

Similar Artilces:

couldn't load library "fractal.dll":
Hi, I compiled a TCL extension using mingw gcc port came with the latest cygwin installation. The command I had used was gcc -shared fractal.c -ltcl -o fractal.dll Now, if I try to use this in tclsh invoked in cygwin it works fine. But I am not able to make it work with ActiveState TCL installation. Whenever I try to load this dll it spits out this error couldn't load library "fractal.dll": this library or a dependent library could not be found in library path The compiled dll has a dependency on cygwin1.dll which is already present in the cygwin installation directory. I was wondering how I should tell tclsh or wish to pick it from there. I have double checked that the windows PATH variable does have a pointer to the cygwin library and bin directories. I even tried copying cygwin1.dll into the path where fractal.dll lies but still no luck. Regards, Madhur physiologoius@gmail.com wrote: > I compiled a TCL extension using mingw gcc port came with the latest > cygwin installation. The command I had used was > > gcc -shared fractal.c -ltcl -o fractal.dll If you change the command line by adding a -mno-cygwin, you will create a DLL which does not depend on cygwin1.dll. Does that help? I could not compile after that. Lots and lots of errors .. dunno whats happening? Any other hint clue help? ActiveState has tkImg installed. Can I somehow try to use that with cygwin's tcl/wish? That might give me some time to understand the real problem...

couldn't load library "mpexpr10.dll" ...
I'm getting the following message when trying to load mpexpr10.dll within Windows XP: couldn't load library "mpexpr10.dll": this library or a dependent library could not be found in library path The odd thing is, this was working for me a few days ago and I honestly don't know what changed to cause this issue. I'm using ActiveState ActiveTcl version 8.4.16.0. I tried a clean uninstall and install and I'm still getting this message. I couldn't find anything useful in other threads or from Google'ing. I'd appreciate any help in this matter. > I'm getting the following message when trying to load mpexpr10.dll > within Windows XP: > couldn't load library "mpexpr10.dll": this library or a dependent > library could not be found in library path This might be the problem: http://groups.google.de/group/comp.lang.tcl/browse_thread/thread/78c4a6c790fe9ea7/620d8504d50fe362?hl=de&lnk=gst&q=mpexpr#620d8504d50fe362 You seem to use the version 1.0 and I think I can remember there was trouble somehow in this version that got fixed for version 1.1. So you might try the updated version 1.1 instead (from here: http://sourceforge.net/project/showfiles.php?group_id=110298). Or ... from the sourceforge page of mpexpr (http:// mpexpr.sourceforge.net/): "Mpexpr, lightly hacked to compile on Windows for versions of TCL >8.3, is available in DLL format here. *** If you do not have Microsoft VC70 stuff al...

Can't load library TCL.tmp This library or a dependent Library could not be found in library path
I'm receiving a bizzare error message on the Windows 2003 platform. This runs fine on XP and Windows 2000. I'm executing a tclkitsh with my kit and it's failing with: Couldn't load library "C:/DOCUME~1\username\LOCALS~1\Temp\1\TCL1.tmp": this library or a dependent library could not be found in library path. I have attached a listing of the directory structure. Thank you in advance. Mike Hi Mike, >I'm executing a tclkitsh with my kit and it's failing with: >Couldn't load library "C:/DOCUME~1\username\LOCALS~1\Temp\1\TCL1.tmp": >this library or a dependent library could not be found in library >path. whenever I get this error message the first thing I check is the ... or a dependent library ... part. Go over to www.dependencywalker.com and get the, well, dependency walker. It will tell you which DLLs are - overall - required by your application and more often than not this already resolves the question. HTH Helmut Giese On Wed, 05 Sep 2007 19:52:31 +0200, Helmut Giese <hgiese@ratiosoft.com> wrote: >Hi Mike, >>I'm executing a tclkitsh with my kit and it's failing with: >>Couldn't load library "C:/DOCUME~1\username\LOCALS~1\Temp\1\TCL1.tmp": >>this library or a dependent library could not be found in library >>path. >whenever I get this error message the first thing I check is the > ... or a dependent library ... >part. > >Go over to ...

couldn't load file (error 262) during 'load'
Hi all, I am getting an error similar to the following on an AIX box running TCL: tcl> package require Test Error: couldn't load file "/..../test.so": Error 262 occurred. while executing "load [file join [file dirname [info script]] \ Shared/sharedio[info sharedlibextension]] sharedio" ...... I presume there is a problem with the .so but would like to be able to find out what, exactly... Looking at the TCL code, I can see that this error is printed from unix/tclLoadDl.c and a few others - but I haven't been able to trace the origin of the value...

MySQLTCL package and TCLApp issue: 'couldn't load library "[...]\Temp\TCL5E4.tmp"
Hi guys, After running the TDK Package Editor, I've got a mysqltcl.tap file containing: format {TclDevKit Project File} fmtver 2.0 fmttool {TclDevKit TclApp PackageDefinition} 3.2 Package {mysqltcl 3.01} Base C:/Tcl/lib/mysqltcl3.01 Path libmySQL.dll Path libmysqltcl.dll Path pkgIndex.tcl Using ActiveTCL, I'm able to start the script without any problems, with the script containing "package require mysqltcl". There's no code that uses the package yet, but, so far so good. TCLApp runs, finds the package using Scan, compiles the binary. So far so good here. It's found the package. Running the output binary though and I get the following error: couldn't load library "[...]\Temp\TCL5E4.tmp": this library or a dependent library could not be found in library path while executing "load libmusqltcl[info sharedlibextension]" (procedure "loadmysqltcl" line 4) invoked from within "loadmysqltcl [...]/test.exe/lib/mysqltcl3.01" ("package ifneeded" script) invoked from within "package require mysqltcl " I'm using ActiveTCL 8.4.11. Anyone have any suggestions as to what's going wrong (and maybe why it's only going wrong for the TCLApp compiled version)? Thanks. Synic <flavp+hfrarg@nhgbaf.arg.nh> wrote: > TCLApp runs, finds the package using Scan, compiles the binary. So far > so good here. It's found the package. > > Running ...

package require
Hi, I am building a tkpng package which depends on zlib. I have the following link line, and am linking with zlib1.lib. link -dll -nologo /MANIFEST C:/my_sandbox/third_party/tcl/tcl8.5.6/ win 32d/lib/tclstub85d.lib C:/my_sandbox/third_party/tcl/tcl8.5.6/win32d/ li b/tkstub85d.lib C:/my_sandbox/third_party/tcl/tcl8.5.6/../../ zlib-1.2.3 /shared/lib/win32d/zlib1.lib -debug -out:tkpng09d.dll tkImgPNG.obj tkImgPNGInit. Obj It finds the built package just fine if I am use it from the installation directory, i.e. where this package dll is at. But, when I try to use the package ...

Can't load library "/usr/lib/libcore.a", because load ENOENT on shared library(s)
When I issue call sqlj.install_jar('file:///f:/jars/mail.jar','MAIL'); I get the messages SQL4301N Java or .NET interpreter startup or communication failed, reason code "2". SQLSTATE=58004 2005-10-11-15.31.15.558066+600 I2352539C331 LEVEL: Warning PID : 950280 TID : 1 PROC : db2fmp INSTANCE: db2inst1 NODE : 000 FUNCTION: DB2 UDB, oper system services, sqloJVMvfprintf, probe:20 MESSAGE : Can't load library "/usr/lib/libcore.a", because load ENOENT on shared library(s) 2005-1...

Can't load library "/usr/lib/libcore.a", because load ENOENT on shared library(s)
When I issue call sqlj.install_jar('file:///f:/jars/mail.jar','MAIL'); I get the messages SQL4301N Java or .NET interpreter startup or communication failed, reason code "2". SQLSTATE=58004 2005-10-11-15.31.15.558066+600 I2352539C331 LEVEL: Warning PID : 950280 TID : 1 PROC : db2fmp INSTANCE: db2inst1 NODE : 000 FUNCTION: DB2 UDB, oper system services, sqloJVMvfprintf, probe:20 MESSAGE : Can't load library "/usr/lib/libcore.a", because load ENOENT on shared library(s) 2005-1...

load dll on windows developed with MINGW gives "couldn't find procedure Foo_Init"
Hi All I'm a newbie, starting to play around with c procedures executed from the tcl shell/console. I have created a DLL and try to load it (using the "load" command). I get the error "couldn't find procedure Foo_Init". I suspect that it is a problem with the way I have compiled the I have searched this forum, but have not been able to solve it, even though there are many posts on similar issues. specs: winXP tcl 8.4 mingw (from dev-cpp) the DLL is compiled and built without problems, but the load won't work. The code is as follows: #include <tcl.h> #include <stdio.h> static int fooCmd(ClientData clientData, Tcl_Interp *interp, int objc, char * CONST objv[]) { printf("called with %d arguments\n", objc); return TCL_OK; } int Foo_Init(Tcl_Interp *interp) { if (Tcl_InitStubs(interp, "8.1", 0) == NULL) { return TCL_ERROR; } printf("creating foo command"); Tcl_CreateObjCommand(interp, "foo", /*(Tcl_ObjCmdProc *)*/ fooCmd, NULL, NULL); return TCL_OK; } The output from compilation and building is: Compiler: Default compiler Building Makefile: "C:\Dev-Cpp\Makefile.win" Executing make clean rm -f foo.o foo.dll gcc.exe -c foo.c -o foo.o -I"C:/Dev-Cpp/include" -I"C:/Tcl/include" -DBUILDING_DLL=1 foo.c: In function `Foo_Init': foo.c:24: warning: passing arg 3 of `Tcl_CreateObjCommand' from incompatible pointer...

OS X
after a bit of reading, it looks like I did a veeeeery shtupid thing... (I'm copying my post to this newsgroup, as the alt.sys.mac.newuser-help group didn't look quite as highly-trafficked...) anyways, here's what I did... ----------------------------------- in an effort to help the owner of a nice shiny new eMac 'clean up' their personal folder, I moved a few items... including the Library folder! it appears.... correct me if I'm wrong... that Mac OS X then created a NEW library... so we restarted it, and all the Quicken data, dialup info, (etc.) was gone... so we ...

Unable to load dynamic library './php_mysql.dll'
Hi, When I start my PC(winXP Pro), it always says: Unknown(): Unable toload dynamic library './php_msql.dll' - The specified module could not be found. Then my Apache servre starts, load php module and works well. I copied php_msql.dll to my system32 directory. Who knows what's wrong? Thanks a lot? Nancy Nancy wrote: > When I start my PC(winXP Pro), it always says: Unknown(): Unable > toload dynamic library './php_msql.dll' - The specified module could > not be found. Are you talking about msql or mysql? Here you say msql, the subject says mysql. ...

Can't find a usable init.tcl ... Tcl wasn't installed correctly
I built a toy tcl/tk program with an embedded interpreter. It works as expected under Linux. When I run the program from the Windows XP command prompt, initialization of the embedded interpreter fails, returning a message like: ----------------------------------------------------------- Can't find a usable init.tcl in the following directories: This probably means that Tcl wasn't installed correctly. ----------------------------------------------------------- I tried again after executing SET TCL_LIBRARY=C:\Tcl\Lib\tcl8.4 from the command prompt, and the Tcl_Init call succeeded. Have I actually installed Tcl incorrectly? I just accepted all the default settings rather dumbly during installation. Will I have to set TCL_LIBRARY like this each time I want to run such a program? In article <0d_Of.1893$kg.1014@news02.roc.ny>, Patrick wrote: > I built a toy tcl/tk program with an embedded interpreter. It works as > expected under Linux. > > When I run the program from the Windows XP command prompt, > initialization of the embedded interpreter fails, returning a message like: > > ----------------------------------------------------------- > Can't find a usable init.tcl in the following directories: What was here? Was there a long list of directories that you trimmed away when posting? If not something is very very weird. If so, then you trimmed exactly the part that might allow me to help you. > This probably m...

http, library loaded, httpS library can't be found
I'm trying to get Verisign's Payflow Pro setup and going. I thought I had everything working, but when I went in through the SSL, httpS://, it couldn't find a library. How is it that it could find a library in http, but not https? "Can't load '/home/<username>/perllib/lib/perl5/site_perl/5.6.0/i386-linux/auto/PFProAPI/PFProAPI.so' for module PFProAPI: libpfpro.so: cannot open shared object file: No such file or directory at /usr/lib/perl5/5.6.0/i386-linux/DynaLoader.pm line 200. at /www/<username>/cgi-bin/payment.cgi line 123 Compilation failed in re...

I couldn't get a book on Tcl in Waterstone's
Hey ! I wanted to buy a good book on Tcl. I like to have a look before I buy, so that I can choose which book is best. I was hoping there would be a book entitled "Tcl/Tk Unleashed", since I tend to get a lot of "Unleashed" books. However there is no such title on Amazon, although google does appear to provide some references, but I have not yet found a supplier. Not to be deterred, I thought I would go to Birmingham city centre and have a look at the two big Waterstone book shops to look at what is available. I could not believe that there was not a single book on Tcl/Tk on the shelves in either store. I asked them to do a search on the computer and about 12 titles came up, but none were in stock. They used to stock loads of stuff on Tcl/Tk. I went to Borders, which is another book store in Birmingham, and hey ... they had just one title "Tcl/Tk in a Nutshell". Unfortunately, I didn't like this book, so I came home empty handed. Regards, Mark. -- Mark Hobley 393 Quinton Road West QUINTON Birmingham B32 1QE Telephone: (0121) 247 1596 International: 0044 121 247 1596 Email: markhobley at hotpop dot donottypethisbit com http://markhobley.yi.org/ markhobley@hotpop.deletethisbit.com (Mark Hobley) writes: >I was hoping there would be a book entitled "Tcl/Tk Unleashed", since I tend >to get a lot of "Unleashed" books. However there is no such title on Amazon, >although google does appear to pro...

standard libraries don't behave like standard 'libraries'
I guess why every programming language has some kind of a 'standard library' built in within it. In my view it must not be called as a 'library' at all. what it does is like a 'bunch of built-in programs ready-made to do stuff'. Lets see what a 'library' does: 1. offers books for customers 1.1 lets user select a book by genre, etc 1.2 lets user to use different books of same genre, etc 1.3 lets user to use books by same author, etc for different genre 2. keeps track of all the books + their genre 2.1 first knows what all books it has at present 2.2 when ...

Which DLL's might be corrupted if I can't load ActiveX Ctrls ?
Cannot load CWGraph3d ctrl. Same error with Labview 6.1 & 7. I've repaired, uninstalled, reinstalled and still have same error. If it's a DLL causing this,which one? So I can manually replace it. The following link is to a knowledge base on NI's website and I believe it directly addresses your issue. http://digital.ni.com/public.nsf/websearch/FCAAAE31A7A6927386256B640081E212?OpenDocument Repairing Labview, didn't work. It is now working, by doing the following. Uninstall EVERYTHING from National Instruments, manually delete all directories and files remaining on your C: ...

Browser won't load Toronto Public Library's website
Hello I have been trying to access Toronto Public Library web-site, but for some reason my browsers won't access to the main page -- it always get stuck at 37%. However, I am able to access one of their link page: Find Books and Materials. Can anyone tell me if it is my web browsers, or just their site? http://www.tpl.toronto.on.ca/ < Main Link > http://hip.tpl.toronto.on.ca/ <Find Books and Materials> ------- I am on DSL, and all the other sites are working fine, and I am able to download 8 Ghz torrent file in two days -- I know it's very slow... -------- My Computer...

install_driver(Oracle) failed: Can't load 'C:/Perl/site/lib/auto/DBD/Oracle/Oracle.dll' for module DBD::Oracle: load_file:The specified procedure could not be found at C:/Perl/lib/DynaLoader.pm line 2
hello i have a strange problem with DBI module. has anyone any clue about what is wrong here? my connection string: --------------------- use DBI; use DBD::ODBC; use DBI qw(:sql_types); use strict; use warnings; my $db = "something"; my $user = 'XXX'; my $passwd = 'XXX'; my $dbh = DBI->connect('dbi:Oracle:XXX', $user,$passwd, {RaiseError => 1, AutoCommit => 0}) or die $DBI::errstr; ################# This gives the foll...

unable to load DLL 'db2app.dll'
Someone are using successfully, VS.Studio 2003 on Windows 2003 with DB2 8.2.2 ? Mauro Yes, I was able to. Did not have any issues during the install. I also have Websphere Information Integrator with DB2 8.2.2 for Windows 2003. You need to load it from 8.2.2 straight, if it is from 8.1, there are fixpacks you need to put in. Thanks, IPL "Mauro Miotello" <sviluppo@ashnet.it> wrote in message news:d63d24$8gd$1@news.ngi.it... > Someone are using successfully, VS.Studio 2003 on Windows 2003 with DB2 > 8.2.2 ? > > Mauro > ...

Oracle Reports (9i)
Hi all. I'd like to lay out a problem we had the other day ... maybe someone can make sense of this: We're currently deploying our system, that includes report generation, to a number of production plants where they can then view some Oracle Reports as part of a webapplication. Now it went like this: *) Call in that they can't view the report - get REP-501 "Can't connect to DB" error. -> It turns out that the wrong charcterset is configured in the registry - we fix this and reboot the DB + Reports server machine. *) After reboot, when they try ...

can't load library
Anyone know what this means? I get the error after executing the line "package require Expect" couldn't load library "c:/tcl/tcl8.4.5/library/exp5.21/expect52.dll": this library or a dependent library could not be found in library path OK thanks! On Mon, 16 Feb 2004 13:34:12 -0800, endo4977@yahoo.com wrote: >Anyone know what this means? > >I get the error after executing the line "package require Expect" > >couldn't load library "c:/tcl/tcl8.4.5/library/exp5.21/expect52.dll": >this library or a dependent library could not ...

I can't stop the music, I couldn't stop it before...
But my M-ACPA is still silent under NT. Can't help you there...although I stand by, ready to test whenever. I've still got the tech ref up for download (at least as far as I know--it certainly shouldn't have gone anywhere). William On Apr 30, 3:12 pm, Louis Ohland <ohl...@charter.net> wrote: > But my M-ACPA is still silent under NT. I remember one day manning the phones for [big direct-marketing PC manufacturer] tech support. (Probably I told this story here before.) We were trained and had resources to support Windows 95/98, but still got calls o...

HELP!! PHP Warning: PHP Startup: Unable to load dynamic library 'c:\PHP\Ext\php_mysql.dll'
Why do I keep getting this error mesgage on my phpinfo() page trying to get PHP and MySQL to communicate? I am running this in IIS. Here's what I have - My php.ini resides in my C:\WINNT directory. In it, I have removed the ';' from the extension=php_mysql.dll. Also in the php.ini file I set extension_dir = c:\PHP\Ext In c:\PHP\Ext I have the following files: libmysqli.dll libmySQL.dll php5apache2.dll (Do I need this since I am using IIS)? php5ts.dll php_mysql.dll Any help would be tremendously appreciated. I have spent a ton of time on this. Thanks. MS wrote: > Wh...

Why didn't the new ipod come with a toaster??? Couldn't you?
You can't.. Go to: www.customsoftwarezone.com/free and get your free iPod or xbox 360 RIGHT NOW www.customsoftwarezone.com/free has links to 3 free items. You can get them ALL.. Just follow the link, follow the instructions, and get your free iPod or xbox 360. Of course, the xbox is a pre-order. But as soon as they are released, you get one shipped to you for free.. WHAT ARE YOU WAITING FOR!!????!!!! www.customsoftwarezone.com/free ipod 60 60gb 1 1gb shuffle xbox x-box 360 ipod 60 60gb 1 1gb shuffle xbox x-box 360 ipod 60 60gb 1 1gb shuffle xbox x-box 360 ipod 60 60...

Web resources about - Couldn't load library (libmysqltcl.dll) - comp.lang.tcl

Resources last updated: 3/13/2016 4:01:50 PM