f



eror sending message with mime/smtp (flush). message size?

I posted a message a few days ago and have been trying to solve the problem
I get when sending email to a particular SMTP server.
I have isolated the problem to be related to the size of the message -
nothing to do whether attachments or not.

Here is the transcript of the message (as recorded by sockspy).

14:34:59 connect from 127.0.0.1 localhost 25 1528
14:34:59 connecting to smtp.xtra.co.nz:25
14:35:02 220 web4-rme.xtra.co.nz ESMTP server ready Fri, 7 May 2004 14:34:51
+1200
14:35:02
14:35:02 EHLO localhost
14:35:02
14:35:03 250-web4-rme.xtra.co.nz
14:35:03 250-HELP
14:35:03 250-XREMOTEQUEUE
14:35:03 250-ETRN
14:35:03 250-PIPELINING
14:35:03 250-DSN
14:35:03 250-8BITMIME
14:35:03 250 SIZE 52428800
14:35:03
14:35:03 MAIL FROM:<rachael.a@becarparts.co.nz>
14:35:03
14:35:03 250 Sender <rachael.a@becarparts.co.nz> Ok
14:35:03
14:35:03 RCPT TO:<rachael.a@becarparts.co.nz>
14:35:03
14:35:03 250 Recipient <rachael.a@becarparts.co.nz> Ok
14:35:03
14:35:03 DATA
14:35:03
14:35:03 354 Ok Send data ending with <CRLF>.<CRLF>
14:35:03
14:35:03 MIME-Version: 1.0
14:35:03 Content-ID: <4293226069.1083897299.67@pc1>
14:35:03 From: <rachael.a@becarparts.co.nz>
14:35:03 To: rachael.a@becarparts.co.nz
14:35:03 Subject: Invoice TEST
14:35:03 Date: Fri, 07 May 2004 14:34:59 +1200
14:35:03 Message-ID: <4293226069.1083897299.68@pc1>
14:35:03 Content-Type: multipart/mixed;
14:35:03               boundary="----- =_FJPvtTXYqgFpLgR1pPzd/w=="
14:35:03
14:35:03 ------- =_FJPvtTXYqgFpLgR1pPzd/w==
14:35:03 MIME-Version: 1.0
14:35:03 Content-ID: <4293226069.1083897299.65@pc1>
14:35:03 Content-Type: text/plain
14:35:03
14:35:03 This email contains an electronic invoice.
14:35:03
14:35:03
14:35:03 ------- =_FJPvtTXYqgFpLgR1pPzd/w==
14:35:03 MIME-Version: 1.0
14:35:03 Content-ID: <4293226069.1083897299.66@pc1>
14:35:03 Content-Type: text/plain
14:35:03 Content-Transfer-Encoding: quoted-printable
14:35:03
14:35:03
14:35:03 ############################################
14:35:03 ## (c) Peter Campbell Software 2001-2004, all rights reserved.
##
14:35:03 ## http://www.fastbase.co.nz
=
14:35:03          ##
14:35:03 ############################################
14:35:03  BALANCE_CURRENCY char(3) NULL,

** I have removed about 500 lines of text here that was also sent **

14:35:03  PAYMENT_METHOD char(1) NULL,
14:35:03  SUPPLIER_CODE char(1
14:35:03
14:35:03 .
14:35:03
14:35:03 RSET
14:35:03 QUIT
14:35:03
14:35:03 ----- closed connection -----
14:35:03 waiting for new connection...

As you can see the system has added a blank line, dot, then blank line well
before the end of the file. The message/file I was sending did not stop
where it did - somehow the message has been truncated.
I have now tried this on a couple of SMTP servers and get similar results.
The SMTP does not log anything out of the ordinary, it gets what is sent and
accepts it.

Please help.


0
pc3301 (30)
5/7/2004 2:54:30 AM
comp.lang.tcl 23428 articles. 2 followers. Post Follow

0 Replies
865 Views

Similar Articles

[PageSpeed] 39

Reply:

Similar Artilces:

smtp error message solved (was Re: smtp error message)
I just discovered the meaning of a mysterious error code; or at least one possible meaning. The problem was that an smtp mail message didn't get sent out from one system I administer to another system I administer, and that messages between them worked fine earlier, and there was no config change. The sending system is DIGITAL TCP/IP Services for OpenVMS Alpha Version V4.2 - ECO 1 on a AlphaStation 255/300 running OpenVMS V7.1-2 The receiving system is HP TCP/IP Services for OpenVMS Alpha Version V5.4 - ECO 1 on a Digital Personal WorkStation running OpenVMS V7.3-2 The UCX SMTP log file on the sending system shows an error message of: smtp_sender_close sclose R0 status = -1, errno = 65535, vaxc$errno = 316 where: $ exit 316 %SYSTEM-F-IVCHAN, invalid I/O channel On the receiving system, there is no new TCPIP$SMTP_RECV_RUN.LOG file. Restarting SMTP on both systems had no effect. Restarting the entire TCPIP package on both systems also had no effect. As it turns out, the sending system is just fine, the error is on the receiving system, and the error code has nothing to do with the error! I have disk quotas enabled on the system disk. Without realizing it, the TCPIP$SMTP account had exceeded its disk quota. This caused the receiving process to terminate early. Subsequent activations of the smtp receiver were immediately over quota and never got started. I'm a little hazy on why the lack of error message, or the entire sequence of failures. When I...

smtp send message.vi has a wrong send time
I am using labview 7.0 with internet toolkit. When I tried to use "SMTP send message.vi" to send alert message, I got the wrong DATE field. The time is off by a hour. I would suggest looking at your computer's DST settings - perhaps you have set the clock ahead but not turned on DST. If so, the conversion to GMT and back will not be correct. There is a bug in the way the LabVIEW treats daylight savings time in LabVIEW 7.0. Date/Time To Seconds primitive currently ignores it and that is the function used in the email VI. ...

sending a message to a non program message queue
Basically, I want the messages I send to a message queue to display as one line. Just like job completion messages. Not as two lines, the first containing the user name of the sender and the second containing the message text. When I use the QMHSNDM api the message displays as two lines. Whether the message type is *INFO or *COMP. When I send a message using the SNDPGMMSG command, the message does display as one line. A message sent using the SNDMSG displays as two lines. I thought the answer was the severity of the message. Messages sent using SNDMSG arrive with severity 80 and display...

SMTP Send Message vi
Hello, I use SMTP Send Message.vi, that is part of Internet Toolkit, to send e-mail messages over company internal network and experience a strange problem: message is lost such that all recipients get "blank" e-mails. The vi would not return any errors or warnings. Has anyone experienced this type of behaviour? Labview 7.0 Internet Toolkit. Thank you for your help Insert a CRLF as the first line of your text , then try it again Good Luck Dan Tank you Dan! It worked! ...

$message is var but $$message is ???????
Hi every body, I have a really serious question which is what is the difference between $message & $$message, I know the uses of $message which is the assigning of a variables and for the forms POST & GET, but what is the uses of $$mesage also I have another Database question, Its a question I've been asked in an interview but am just a beginner in DataBase, the question was that: Company need to create a DB once and do no more edits in the future on the DB, the DB contains Category name, Sub-category, sub-sub-category so this means three level tree how to create a DB using this...

send simple smtp message
A colleague of mine recently asked to have Evan Rempel's "email18.tcl" single-file mail-message sending package installed in our system library. Searching the newsgroup leads me to believe that Evan hasn't been around for a couple of years, but you can still find his package at http://web.uvic.ca/~erempel/tcl/Email/Email.html. This package implements the smtp protocol and an easy-to-use "send" function. I suggested to my colleague that he just use the smtp package in tcllib. There is an example "send_simple_message" in the man page, and I see a little more sophisticated version on the wiki, and there is even better code in the AcitveState cookbook. But is there any particular reason for not having this code in tcllib smtp itself? Wouldn't it increase the library's utility to be able to code: package require smtp smtp::sendSimpleEmail "from" "toList" "ccList" "bccList" "subject" "message body" and by the way... anybody have any ideas of how to write tcltests for such a function? I see mime tests, but none for smtp. Should it use smtpd, which seems to be documented as suitable only for testing clients? Thanks, Bob -- Bob Techentin techentin.robert@NOSPAMmayo.edu Mayo Foundation (507) 538-5495 200 First St. SW FAX (507) 284-9171 Rochester MN, 55901 USA http://www.mayo.edu...

SMTP Email Send Message Error
When I using SMTP Email Send Message in Labview 8.0 to send an email message and I get a error message as bellow: &nbsp; Error 16500 occurred at 500 5.5.1 Command unrecognized: "MIME-Version: 1.0" Possible reason(s): LabVIEW:&nbsp; (Hex 0x4074) 500 Syntax error, command unrecognized. For example, the command line might be too long. &nbsp; Where the mistake and how to solve this error to send an email by Labview 8.0. &nbsp; Thank you. Can you give an example? &nbsp; I did some digging around in the SMTP Email Send Message code and the MIME version 1.0 command is...

Query Remote SMTP max message size
Is there a way to query the max message size limit of a remote SMTP server? I can spoof (internal testing) a MAIL From: message size to force the remote server to reject a message. Ed S. On Nov 18, 12:10=A0pm, "edspyhil...@yahoo.com" <edspyhil...@yahoo.com> wrote: > Is there a way to query the max message size limit of a remote SMTP > server? =A0I can spoof (internal testing) a MAIL From: message size to > force the remote server to reject a message. ehlo should get it. If not, all you can do is send and see what happens. 250-example.com Hello clover.cc.columbia....

client times out when sending message to smtp server
hi, im running sendmail 8.11.6 in a RH72 linux server. recently i changed the ip addresses of our servers and right after that outlook clients started timing out when sending a message to sendmail. they start the transfer, sometimes reach about 50% and then timeout after 60 seconds (default timeout). e-mails without attachments do get through sometimes. e-mails with attachments 50Kb + timeout most of the times. sendmail log shows a "timeout waiting for input during message collect" which means both sides are unable to complete the process. every word i found regarding this proble...

How to send HTML as message body using SMTP
I need to send HTML formatted emails. I used the Report Generation Toolkit to build my HTML document and make sure I had all of the formatting right. Then I modified the Save Report To File.vi to also give me the HTML text string on an output connector and I wire this string to the message input on the SMTP Email Send Message.vi. I receive the email OK, but all I see is the HTML code in the message body. What can I do to make sure that the email displays the message correctly. I use Outlook and I know it will receive and display HTML emails, I get them all the time. I would appreciate any help. Hi, your problem is that "SMTP Email Send Message.vi" send message as MINE content-type "text/plain". You must change this MINE content-type to "text/html" type. You can change this value permanent in "SMTP Email MIME Text Content-Type.vi" or you can creat new control "MINE content-type" and take it out to "SMTP Email Send Message.vi". [after care for char '\n' on the end of new control "MINE content-type" string - you must delete it] Good luck. JCC JCC, Thanks for the help. That worked perfectly. One more question. Can I send embedded jpg or gif images in an HTML formatted email? Thanks again, dgw ...

Minimize key size for sending only 10 messages
Hi If I want to have a secure system, as always. Moreover, want to minimize the key length in the nodes, for sending data over a wireless network. The keys will be used to sent only 10 messages, is there any info about suitably algorithm, and keysize? Regards Ulf Reiman ...

How to send an SMS message via an SMTP session?
I',m sorry, if this is a wrong newsgroup for my question. I'm not familiar with Lotus products. I just have to find a solution for a client of ours. We have a product that can send email using the SMTP protocol directly. Our client can send SMS messages to mobile phones from their Notes clients. How does one define a recipient for the message so that the mail server can route it to the SMS service and phone rather than to a normal mail recipient? I would suspect that some kind of protocol prefix or such needs to be prepended to the mobile phone number. Anyway, any info on ...

tcl-mq: POSIX Message Queues for Tcl. (Tcl package)
This is an announcement for a relatively new Tcl project: tcl-mp Tcl-mp is a Tcl interface to POSIX Message Queues*. It provides a Tcl package that allows scripts to create/open/close/unlink multiple parallel message queues, and to send/receive messages synchronously and asynchronously to/from them. * A POSIX message queue is an Inter-Process Communication mechanism available on Linux and some other POSIX-compliant operating systems. It allows to or more processes (or threads) to communicate under the same OS. The messages are buffered by the kernel, which gives them kernel persistency. A message queue can be thought of as a linked list of messages. Threads with adequate permission can put messages onto the queue, and threads with adequuate permission can remove messages from the queue. Each message is assigned a priority by the sender, and the oldest message of highest priority is always retrieved first. Unlike PIPES and FIFOS, no requirement exists that someone be waiting for a message to arrive on a queue, before some process writes a message to that queue. It's not even a requirement for both processes to exist at the same time. Read mq_overview(7) for more details Platform: Linux Home page: http://sourceforge.net/projects/tcl-mp/ Man page: http://tcl-mp.sourceforge.net/ Author: Alexandros Stergiakis alsterg On Sep 3, 11:37=A0am, Alexandros Stergiakis <alst...@gmail.com> wrote: > This is an announcement for a relatively new Tcl pro...

SMTP Server: Error importing RFC822 message stream
Your Notes server might have run out of disk space ! ...

TCPIP SMTP definite problem sending large messages
VAX VMS 7.2, TCPIP Services 5.3 ECO 2. If I send emails that contain attachements through my TCPIP Services SMTP server with the TCPIP$SMTP_LOG_LEVEL set to 2, they fail with: 8-JAN-2005 03:50:36.41: next open file _$2$DKA200:[SYS0.TCPIP$SMTP]050107172618 95_TCPIP$SMTP-20601205.TCPIP_BIKE;1(75) smtp_sender_close shutdown R0 status = -1, errno = 54, vaxc$errno = 8412 Printing debug_level 2, Domains and recipients: Domain: domain.com.au Recipient address: <user@domain.com.au> Domain part: domain.com.au Local part: user Address Status: Not done, not delivered...

SMTP: stop sending "no such user" messages
This might have been covered here before. I'll have a look at the archives, and also have the documentation (5.4 ALPHA and 5.3 VAX with VMS 7.3-2 ALPHA and 7.3 VAX). However, I would appreciate a quick reply. I am getting a lot of spam, not to real email addresses but to non-existent users (at real domains, obviously, otherwise I wouldn't be getting them). This is probably a dictionary-attack situation, perhaps caused by some virus. This in itself doesn't bother me (apart from the fact that it is a waste of bandwidth), but TCPIP$SMTP sends a "no such user" to the...

VM and Emacs: sending messages with arbitrary MIME-encoding
Hello! I am facing the following problem I have found no solution for, neither in manuals nor FAQ's for vm/emacs. I am using VM v7.18 on GNU-Emacs 21.3.1 with Mule installed. When I perform a MIME composition of a message written with the input method i.e. cyrillic-yawerty, the MIME-encoding chosen automatically is ISO-8859-5, which is appropriate in most cases. But what do I have to do, if I want to (i.e.): a) set the MULE encoding of the mail buffer to cp1251 b) MIME encode the message with the charset windows-1251. I have set up cp1251 by adding to .emacs: ============================== (codepage-setup 1251) ============================== and defined aliases by adding to .emacs: ============================== (define-coding-system-alias 'windows-1251 'cp1251) (define-coding-system-alias 'win-1251 'cp1251) ============================== Further on, I can READ received messages, which are MIME-encoded with the charset windows-1251 after having added to my .vm the following lines: ============================== (setq vm-mime-mule-charset-to-coding-alist (append '(("windows-1251" cp1251)) '(("win-1251" cp1251)) vm-mime-mule-charset-to-coding-alist)) ============================== But I find no clue whatsover to how to generate wuth vm a message in cp1251 MIME encoded with the charset windows-1251. Thank you for hints and references! ...

Re: SMTP Email Send Message Error #6
Well, I never said anything it being useful or not kidding users. :smileywink: ...

Re: SMTP Email Send Message Error #5
rolfk wrote:smercurio_fc wrote:Almost all email servers nowadays (including Hotmail and GMail) require a username and password for authentication. The SMTP VIs that ship with LabVIEW do not support authentication. I have yet to figure out why NI left this out for so long. You can use the OpenG SMTP Library that you can find <a href="message?board.id=170&amp;message.id=220354&amp;requireLogin=False" target="_blank">here</a>. NOTE: These won't work with servers that use <a href="http://forums.openg.org/index.php?showtopic=170&amp;pid=1389&a...

how to send messages from localhost via an external SMTP server?
I've been reading the documentation and searching the web for two weeks (not all the time, of course), but I can't find the solution to my problem. Can you please help me? I want to send all the mail sent from localhost (by apache, and by any other user, using the 'mail' command) to the outer world via an SMTP server smpt.company.com , using the address myusername@company.com in the "From" field. (i.e. it doesn't matter which local user sends the mail, myusername@company.com will be identical for all of them). No authentication is needed. Thank you ...

Re: SMTP Email Send Message Error #4
If you're on Windows you have another option, which is to use .NET. Then you can send emails using a server that requires authentication and SSL. There are examples on how to use .NET in LabVIEW (Help -&gt; Find Examples), and you can find tons of examples of how to send emails using .NET on the internet with Google. ...

Minimize key size for sending only 10 messages #2
Hi If I want to have a secure system, as always. Moreover, want to minimize the key length in the nodes, for sending data over a wireless network. The keys will be used to sent only 10 messages, is there any info about suitably algorithm, and keysize? Regards Ulf Reiman In article <1145347203.015338.88700@z34g2000cwc.googlegroups.com>, Ulf Reiman <ulf.reiman@gmail.com> wrote: >If I want to have a secure system, as always. >Moreover, want to minimize the key length in the nodes, for sending >data over a wireless network. >The keys will be used to sent only 10 messages, is there any info about >suitably algorithm, and keysize? The choice of keysize and encryption algorithm is a tradeoff between the computation required and the security level you need. You have not defined the security level you need, so we can't really make any recommendation. There really isn't any such thing as a "secure system": all there are are systems that are more difficult to get access to. You could build a 10 metre thick and 40 metre high wall around your house, and that might keep out casual intruders, but it would not stop someone who brought in a crane with wrecking ball. I want the security level to be "Compuational security" for the keysize and algorithm(s) /Ulf I want the security level to be "Compuational security" for the keysize and algorithm(s) /Ulf In article <1145428277.176391.310960@e56g2000cwe.googlegr...

Re: SMTP Email Send Message Error #3
Are you sure the server that you're using isn't using SSL? I don't know of any email servers that don't require authentication, but I'm sure there's some out there. They're far less common because they can be used as SPAM relays, and are sometimes blacklisted. Note that you can also try the <a href="http://sine.ni.com/devzone/cda/epd/p/id/1373" target="_blank">POP Mail VIs</a>. Thanks for pointing me to that VI, i finally saw my emails on my account. But what i need is to send emails not to read them so this is what i have learned so...

Cannot send messages
I have used Eudora in sponsored mode for several years. In March I could no longer Send message. Everything worked okay until I pressed the Send button and then nothing happened. No mesaage, nothing. I tried find the problem, upgraded to the latest version, but same results. I have been using several other email programs since then, but do not feel comforatble with any of them and would like to use Eudora. I downloaded 6.11 and tried again with the same results. Since I used Eudora for a long time, I feel I must have done something to cause this problem, but I have no idea what it was. Sorry, I know this was a long posting, but if anyone has any ideas, I would appreciate it... TIA, bumpy In <vle1d05urd1h7paebs06q7gqrmg2q2brvo@4ax.com> Bumpy <donh2115@yahoo.com.yuk> wrote: > I have used Eudora in sponsored mode for several years. In March I > could no longer Send message. Everything worked okay until I pressed > the Send button and then nothing happened. No mesaage, nothing. I > tried find the problem, upgraded to the latest version, but same > results. Have you contacted your ISP for assistance? It is entirely possible that they have made changes on their end that required configuration changes in Eudora. Also, try renaming eudora.ini (with Eudora quit), and then recreating your settings. You can do this without deleting any mail. -- Jennifer Mullen redjen@psu.edu Bumpy <donh2115@yahoo.com.yuk> wrote: ...

Web resources about - eror sending message with mime/smtp (flush). message size? - comp.lang.tcl

Sending/receiving relationship - Wikipedia, the free encyclopedia
A sending/receiving relationship is one in which a public school district sends some or all of its students to attend the schools of another ...

U.K. Woman Faces 20 Months For Creating Fake Facebook Accounts, Sending Herself Abusive Messages
A woman in Cornwall in the U.K. came up with a creative way to use Facebook to accelerate a family spat, and it earned her 20 months in prison. ...

CHVRCHES - Dear guys, Please stop sending us emails like... - Facebook
Dear guys, Please stop sending us emails like this. This is one of the more polite ones. Other recent classics include "I'm going to give her ...

Facebook Sending Perez Hilton More Traffic than Google, Driving 3.3% of All US Traffic to Video Sites ...
For media companies evaluating their Facebook marketing strategy , here’s an interesting sign of the times: web analytics firm Hitwise is reporting ...

A better experience for sending Tweets and DMs - Twitter Blog
... panel New Tweet panel in da...... Skip to main content Blog Got an account? Sign in Search form Search &nbsp A better experience for sending ...

How to Go From Working 60 Hours a Week to 40 By Sending 2 Emails a Week
I’m convinced 95% of cubicle workers who work over 60 hours a week constantly can cut it down to 40-45 hours by sending 2 emails a week to their ...

Live Emoji - sending GIF Animation Emoji for Zoosk,Skype,Kik,Whatsapp,Facebook Messenger Etc. on the ...
Get Live Emoji - sending GIF Animation Emoji for Zoosk,Skype,Kik,Whatsapp,Facebook Messenger Etc. on the App Store. See screenshots and ratings, ...


Cynthia McKinney - responds to Obama on sending troops into Afghanistan - Debate Answer - YouTube
Cynthia McKinney, Green Party Presidential candidate, responds to Barack Obama on his support for sending troops into Afghanistan. Based on his ...

'Shark' providers sending unskilled workers to high-risk sites, say trainers
&#8203;West Australian training companies say dodgy providers they describe as 'sharks' and 'cowboys' are flooding high-risk mine sites with ...

Resources last updated: 3/13/2016 7:37:10 PM