f



OraTcl45 on AIX 6.1

Bingo...

I finally compiled Oratcl-4.5 on AIX :)

AIX-6.1 = 64bits, I do not care 32bits softwares run on AIX-64 :)

You need:
- gcc (I did the installation via rpm) http://www.perzl.org/aix/index.php?n=Main.Gcc
- all dependencies for gcc
- rpm
- unzip
- oratcl45
- tcl-8.X (I used tcl-8.4.7)
- oracle client (I used instantclient-basiclite-aix.ppc32-11.2.0.3.0.zip form Oracle website: http://www.oracle.com/technetwork/topics/aix5l32soft-096141.html, no 6.1, so I used for 5L)

The Work:
- install rpm, gcc, unzip, tcl
- unzip instantclient and copy it to /somewhere_in_aix/clientoracle32/lib/
- untar oratcl45
- cd oratcl45
- ./configure --disable-shared (to be portable without the need to install the gcc rpms on the prod machine)
- make
- make install
- start tcl to test
tcl> set ::env(ORACLE_HOME) /somewhere_in_aix/clientoracle32
/somewhere_in_aix/clientoracle32
# oracle version to be use
tcl> set ::env(ORACLE_SID) 10.2
10.2
tcl> package require Oratcl
4.5
tcl> exit

- put in your .profile (ksh)
export ORACLE_HOME=/somewhere_in_aix/clientoracle32
export ORACLE_SID=10.2

The library is a 32bits but it runs on 64bits AIX

> dump -ov -X 32_64 libOratcl4.5.a 

libOratcl4.5.a[oratcl.o]:

                        ***Object Module Header***
# Sections      Symbol Ptr      # Symbols       Opt Hdr Len     Flags
         3      0x0000572c            352                 0     0x0000
Flags=( DEP_SYSTEM )
Timestamp = "Oct 18 10:21:56 2013"
Magic = 0x1df  (32-bit XCOFF)

....

Have Fun :)

l2f
0
10/18/2013 5:19:59 PM
comp.lang.tcl 23429 articles. 2 followers. Post Follow

0 Replies
467 Views

Similar Articles

[PageSpeed] 22

Reply:

Similar Artilces:

tcl 8.6.4
Hi, Using 8.3.0, compiled on AIX 6.1 with no problems. It compiles with the xlc= compiler. But when I try to build tcl 8.6.4, I notice some changes. Configure uses xl= c_r rather than xlc. But the difference that causes a problem is setting TC= L_LIBRARY snd TCL_PACKAGE_PATH.tclUnixInit.c is the only file that uses the= se extra variables in make and I get the following errors. xlcwrapper_r -c -DNDEBUG -O -DBUILD_tcl -I"." -I/tmp/xxxxxx/tcl8.6.4/un= ix -I/tmp/xxxxxx/tcl8.6.4/generic -I/tmp/xxxxxx/tcl8.6.4/libtommath -DPACK= AGE_NAME=3D\"tcl\" -DPACKAGE_TARN...

From 6.1.0.6 to 6.1.1, is there an Easy Way?
From 6.1.0.6 to 6.1.1, is there an Easy Way? I spent half a day going from 5.2 to 6.1.0.6, which I'd love to avoid, most of that time related to lost options, personalities, Eudora.ini stuff etc. I did the full Paid install on top of 5.2 two weeks ago. What changed in 6.1.1, maybe just the Eudora.EXE and Eudora.DLL files? And if so, can we just get these replacement files? Is there any chance that the newest installer will work properly bringing in previous settings and preferences? Thanks. John John@NoSpam_SensorySIMS.com (please remove "NoSpam_" from return address to respond directly) John <John@NoSpam_SensorySIMS.com> wrote: > >From 6.1.0.6 to 6.1.1, is there an Easy Way? [...] >Is there any chance that the newest installer will work properly >bringing in previous settings and preferences? I just did the same a couple of days ago. Completely painless. Take the usual precautions (backups, etc.) and the ver. 6.x installer will do the rest. | George Ruch | "Is there life in Clovis after Clovis Man?" John <John@nospam_sensorysims.com> wrote: > From 6.1.0.6 to 6.1.1, is there an Easy Way? Run the installer for 6.1.1. Select the appropriate locations for the program files and the data files. That's all there is to it. > I spent half a day going from 5.2 to 6.1.0.6, which I'd love to avoid, > most of that time related to lost options, p...

pthreads/dlopen issue when building krb-1.6.3 on AIX 6.1?
I'm attempting to build MIT Kerberos version 1.6.1 on AIX 6.1. I'm mostly in need of the client libraries and utilities. I'm using the following special additions to the build environment: $ export PTHREAD_LIBS="-lpthread" $ export RPATH_FLAG="-Wl,-brtl,-blibpath:" I'm using the following ./configure command: $ ./configure --prefix=/usr/local/krb5-1.6.3 --enable-log-preauth-logins --enable-login-print-issue --with-multihomed-fixes --enable-app-proxy --with-passive-mode-off --without-anonymous-ftp And I get the following resul...

fuser functionality seems to have changed in AIX 6.1 TL8 and AIX 7.1
Hi AIX Gurus, Our company has some scripts that are used to check if users are logged int= o a specific directory or file system, and the script uses the fuser comman= d. What we do is look at the PIDs listed in "fuser ${pathname}" to determine w= hich users are accessing what files. This is done so we can do maintenance = at times. We make sure all users are out of the directory, have a method to= keep them out, then do our backups or maintenance or whatever. The problem we are encountering is with AIX 6.1 TL8 and above. It seems tha= t IBM may have made a change so that a non-root user can only see their own= PIDs when running fuser, and not all of the PIDs associated with that path= .. Example from AIX 5.1, 5.3, and early 6.1 systems: # whoami office1 # oslevel -s=20 6100-06-01-1043 # fuser -u /qc/sample /qc/sample: 2490476c(postgres) 5767176c(postgres) 6094882c(postgres) 67504= 34c(postgres) 6815922c(postgres) 7143588c(postgres) 7471358c(postgres) 7799= 036c(postgres) 8913140c(postgres) 11600120c(postgres) 11731066c(1008) 12976= 256c(postgres) 13303960c(postgres) 13500622c(postgres) 13566180c(postgres) = 13893696c(postgres) 15138826c(postgres) 15466614c(postgres) 16842792c(postg= res) 18153666c(1009) 18612404c(postgres) 18743530c(postgres) 19071062c(1010= ) 19202252c(postgres) 19267626c(postgres) 19595344c(postgres) 20709580c(pos= tgres) 20840526c(postgres) 23658578c(postgres) 23986214c(postgres) 25100526= c(postgres) 2...

RE: KRB5 1.5 or 1.6 compiled on AIX 5.2/5.3 #6
Wasn't really the solution I came up with; but it worked. You might be correct since now the OpenSSL binaries will not build against the Kerberos libraries currently. libssl and libcrypto build fine along with everything else; but the actual openssl binary fails. Phil, Have you successfully linked OpenSSL with the new Kerberos libraries ? Thanks, Lamar -----Original Message----- From: Sam Hartman [mailto:hartmans@mit.edu] Sent: Friday, February 09, 2007 10:18 AM To: Saxon, Lamar Cc: pgp@psu.edu; kerberos@MIT.EDU Subject: Re: KRB5 1.5 or 1.6 compiled on AIX 5.2/5.3 Do you really wan...

AIX 5.1 / VAC 6.0 vs AIX 5.2 / patched VAC 6.0
Hi everybody, I am trying to build some C++ application on the following environment: AIX 5.2 / patched Visual Age C++ 6.0. This application is based on libraries built for the AIX 5.1 / Visual Age C++ 6.0 (base, ie no patch) platform. Compilation works fine. However link results in unresolved symbols (defined in the above libraries). According to IBM support: - AIX 5.1 / Visual Age C++ 6.0 is a supported platform - AIX 5.2 / Visual Age C++ 6.0 with lattest patch is a supported platform - AIX 5.2 / Visual Age C++ 6.00 base version (ie without any patch) isn't a supported platform (!...

java 1.4 fail with java.lang.UnsatisfiedLinkError but 1.5, 1.6 ok
My JNI program is working with java 1.5 & 1.6 but fail with java 1.4 on a HP-UX B.11.23 U ia64 computer. Please help even though java 1.4 is old. $ /opt/java1.4/bin/java -d32 -jar jHw.jar Failed to load MycompAPI and MycompAPI_64 libraries. java.lang.UnsatisfiedLinkError: no MycompAPI_64 in java.library.path at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1542) at java.lang.Runtime.loadLibrary0(Runtime.java:795) at java.lang.System.loadLibrary(System.java:834) at com.chrysalisits.crypto.MycompAPI.<clinit>(MycompAPI.java: 47) at com.chrys...

when 1.6 != 1.6? -- newbie
Really enjoying Ruby so far, but now I'm confused. To help learn Ruby, I've been translating the Java code in the "Head First Design Patterns" book into Ruby, aware that many are built-in with Ruby. While mimicking the Decorator pattern I'm getting a strange failure to an assert_equal. The unit test excerpts: @e = Expresso.new @e.setSize('grande') @e = Mocha.new(@e) assert_equal(1.40, @e.cost(),"price check") --> pass @e = Mocha.new(@e) assert_equal("Expresso, Mocha, Mocha", @e.getDescription()) --> pass #puts @e.cost() --> ...

Users Account Migration from AIX 5L to AIX 6.1
Hi to all, We have an older server and try to move the content to a new LPAR on another machine. We install all the necessary s/w to new server, and now it is time to copy the web content to the new server. However at this point, we want to keep the ownership, group, history information for those files. That's why we use the -p option of scp. However, all the necessary account information should also exist in the new system as well, o.w. we will see just user and group id's instead of their names. How can we handle this issue? I mean, the best practice is to copy the passwd, group and...

Re: [ANN] markup.py 1.6 (bugfix: 1.6.1)
> The new 1.6 release of markup.py is available for download: > > http://sourceforge.net/project/showfiles.php?group_id=161108 > > What is it? > > Markup.py is an intuitive, lightweight, easy-to-use, customizable and > pythonic HTML/XML generator. > > Where is the documentation? > > http://markup.sourceforge.net/ > > Why is it called markup.py and not markup? > > This way it's easier to search for it online and also shows that it's > a single module. Also note that the former Markup project of Edgewall > changed its name to Genshi i...

Installing Python 2.7.5-1 on AIX 6.1
--_000_FA70DDD4F493F649A8974A9605B63DD47576E77DNPBREXMP01bcnem_ Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: quoted-printable I have downloaded the "python-2.7.5-1.aix6.1.ppc.rpm" package from the IBM = Linux ToolBox site. When I try to install the python rpm package, it fails because it's looking= for (7) dependencies listed below. The dependencies listed do seem to exi= st on the server, and I have also successfully installed the openssl-0.9.8z= g package on the server. Has anyone successfully installed Python 2.7 on AIX, an...

Installing Plucker Desktop 1.6.0.1 over 1.6.0.0
Is it safe to install Plucker Desktop 1.6.0.1 over 1.6.0.0? I'm using the Windows version. Chuck -- <http://www.drchuck.net/> Home of the Dr. Chuck Network "Charles A. Kunz" <drchuck@i-2000.com> wrote in message news:6546qv07ajb7nbr9vo7tl53u71cmc5dod3@4ax.com... > Is it safe to install Plucker Desktop 1.6.0.1 over 1.6.0.0? I'm using > the Windows version. > > Chuck > -- Hi Chuck, I guess it safe; if not, email the author of the software of any problems. Byron --- Byron's Emporium - Cool eBooks for PDA's ENJOYOU...

AIX 6.1
Hi, Can someone provide me an URL to download AIX 6.1. Also, could you provide me supported PowerPC platforms of AIX 6.1. TIA, Prem On 06/24/2009 04:18 PM, Prem Sankar G wrote: > Hi, > Can someone provide me an URL to download AIX 6.1. Also, could you > provide me supported PowerPC platforms of AIX 6.1. > TIA, > Prem https://www14.software.ibm.com/iwm/web/cc/earlyprograms/ibm/aix6beta (small note: the beta program finished nearly 2 years ago) AIX 6.1 runs on systems based on POWER4™, PPC970, POWER5™ and the latest generation of POWER™ processor, POWER6. Niel On Jun 25, 2:18 am, Prem Sankar G <premsan...@gmail.com> wrote: > Hi, > Can someone provide me an URL to download AIX 6.1. Also, could you > provide me supported PowerPC platforms of AIX 6.1. > TIA, > Prem AIX is not OpenSource Henry schrieb: > On Jun 25, 2:18 am, Prem Sankar G <premsan...@gmail.com> wrote: > >>Hi, >> Can someone provide me an URL to download AIX 6.1. Also, could you >>provide me supported PowerPC platforms of AIX 6.1. >>TIA, >>Prem > > > AIX is not OpenSource but it could be "OpenBinary" :-) ...

XLF 6.1 on AIX 5.1. Can it be done? Libary issues.
Hi guys, I'm a newbie trying to learn AIX administration so I apologize if this is a dumb question. I got a used RS6000 and it has AIX 5.1. I have the original AIX 5.1 CDs. I also got an original unopened package of XLF 6.1. I used to use XLF 6.1 at work and I thought we were running it on AIX 5.1, but when I installed it on the RS6000 at home, I ran into trouble. The install was successful (although I did have to install bos.adt.libm from the AIX CD1, but I got that figured out). But when I try to compile/link something, it gives an error. The error says it could not load libxlf...

ANN: eTcl 1.0.1 (Tcl/Tk 8.5.6)
ANNOUNCE: eTcl 1.0.1 I'm pleased to announce immediate availability of eTcl 1.0.1 for Windows, Windows Mobile (2003, 2003SE, 5.x and 6.x) pocketPC and smartphones, Mac OS X (Aqua) as universal binary (x86 and PPC), and several Linux architectures, including x86, x86_64, mipsel, powerpc, arm (soft-float or hard-float) and now also arm-eabi, which allows installation as native application on Android platform. WHERE TO GET ============ It is available from: http://www.evolane.com/software/etcl/index.html http://www.evolane.com/ WHAT'S NEW ========== This rele...

Tcl 8.4.6 compilation issue with cygwin 1.5.11-1
Hi, I'm getting this compiler error, while compiling Tcl sh 8.4.6 with cygwin. Can someone help me with this. gcc -c -g -O -Wall -Wconversion -I"./../generic" -I"." -DBUILD_tcl -mno-cygwin "tclWin32Dll.c" -o tclWin32Dll.obj tclWin32Dll.c:58: error: initializer element is not constant tclWin32Dll.c:58: error: (near initialization for `asciiProcs.buildCommDCBProc') tclWin32Dll.c:59: error: initializer element is not constant tclWin32Dll.c:59: error: (near initialization for `asciiProcs.charLowerProc') tclWin32Dll.c:60: error: initializer element...

Tcl 8.4.1 64 bit on AIX 5.1 aborts
Here is my problem: I am compiling the Tcl 8.4.1 64 bit on AIX 5.1 with Vigual Age C++ 6.0.0. compiler When I perform these steps: ../configure --enable-shared --enable-64bit --enable-threads --prefix=/usr/local64 make and then start the tclsh executable, and type ? after seing the % prompt I get Segmentation fault(coredump). dbx ./tclsh: Type 'help' for help. reading symbolic information ...warning: stab entry unrecognized: type fc, class 99, value 115991a' warning: stab entry unrecognized: type 12f, class 3f, value 12f3f00' warning: stab entry unrecognized: name us...

KRB5 1.4 vs. KRB5 1.3.6 on AIX 5.2
I was hoping someone might be able to help me fix an issue I have encountered. I tested KRB5 1.3.6 on AIX 5.2 using C for AIX and the installed make. Created a krb5.conf and krb5.keytab to talk to a Windows 2k AD Domain Controller. Had no issues, connected and received tickets fine. I recently installed KRB5 1.4 on the same machine after removing the 1.3.6 footprint. I encountered an issue seen by others with the error: "Syntax error at line 1 : `(' is not matched" when using AIX's make; but it seems to work fine using GNU Make. After compiling and doing a make instal...

KRB5 1.5 or 1.6 compiled on AIX 5.2/5.3
Has any been able to successfully compile KRB5 v1.5.1, v1.5.2, or v1.6 on AIX 5.2 or 5.3 ? If so, can you send me you configs ? I have posted this message before, but no one seems to be able to help. I have successfully compiled KRB5 1.4.4 on AIX 4.3 / 5.2 / 5.3; but since the release of 1.5.1 and beyond, I am cannot get it to work. All of the versions seem to error out here: making all in lib/rpc/unit-test... Target "all" is up to date. cc -L../../../lib -blibpath:/usr/local/kerberos/lib::/usr/lib:/lib -D_LARGE_FILES -DLANL -DL ANL_ICN -qhalt=e -O -D_THREAD_SAFE ...

Please explain PS3.3-6.1.1 and PS3.3-6.1.2
PS3.3-6.1.1 reads: ...When an instance of a Composite IOD is communicated, this entire context is exchanged between Application Entities.... PS3.3-6.1.2 reads: ...When an instance of a Normalized IOD is communicated, the context for that instance is not actually exchanged. Instead, the context is provided through the use of pointers to related Normalized IOD instances. If I understand it correctly, 6.1.1 says the composite object has all the info needed to fully understand the IOD. But I can't quite figure out what 6.1.2 is saying. By a "Pointer", Is it saying that where related data is indicated, you will find data that identifies another, normalized IOD - like a foreign key in a Normalized database? If so, what will that ID look like? Is it a UID? (Would make sense because otherwise, how would the SCP be able to look this IOD up?) Or am I totally missing the point? sendjunktodp@hotmail.com (Mr. P) wrote in message news:<8cba616e.0410181142.1dfefb14@posting.google.com>... > PS3.3-6.1.1 reads: ...When an instance of a Composite IOD is > communicated, this entire context is exchanged between Application > Entities.... > > PS3.3-6.1.2 reads: ...When an instance of a Normalized IOD is > communicated, the context for that instance is not actually exchanged. > Instead, the context is provided through the use of pointers to > related Normalized IOD instances. > > If I understand it corr...

RE: KRB5 1.4 vs. KRB5 1.3.6 on AIX 5.2
The compile with CC works with no issues. The other issue still remains. "Cannot resolve network address for KDC in requested realm while getting initial credentials" I tried kinit with the -k and verbose; but not with a password. I will post the results once I get it accomplished. Thanks, Lamar -----Original Message----- From: Tom Yu [mailto:tlyu@MIT.EDU] Sent: Thursday, April 21, 2005 2:18 PM To: Saxon, Lamar Cc: kerberos@mit.edu Subject: Re: KRB5 1.4 vs. KRB5 1.3.6 on AIX 5.2 >>>>> "Lamar" == <Lamar.Saxon@americredit.com> writes: Lamar>...

RE: KRB5 1.5 or 1.6 compiled on AIX 5.2/5.3
I currently have an install of KRB5 1.4.4 on this machine and configure finds it under /usr/local/Kerberos where it is installed as seen in the blibpath option. I am currently trying without TCL and will update on what happens. Lamar -----Original Message----- From: Russ Allbery [mailto:rra@stanford.edu] Sent: Thursday, January 25, 2007 10:38 PM To: Saxon, Lamar Cc: kerberos@mit.edu Subject: Re: KRB5 1.5 or 1.6 compiled on AIX 5.2/5.3 Lamar.Saxon@americredit.com writes: > Has any been able to successfully compile KRB5 v1.5.1, v1.5.2, or v1.6 > on AIX 5.2 or 5.3 ? If so, can you se...

KRB5 1.4 vs. KRB5 1.3.6 on AIX 5.2 (fwd)
I have done some research on this problem. The host resolve code does not complete successfully. I have traced the error to the routine at /kerberos/mit/krb5-1.4/src/lib/krb5/os/dnsglue.c. In the routine a call is made to res_ninit to provide dns information for the kdc. res_ninit updates the structure at statbuf but overlays memory 72 bytes past the structure boundary. I have opened a problem with IBM on res_ninit. The problem is not yet resolved but IBM suggested using a malloc for the structure instead of static storage. I am trying to get IBM to correct the error in res_ninit...

KRB5 1.5 or 1.6 compiled on AIX 5.2/5.3 #2
I have seen several emails from different people over the last few months on trying to get KRB5 1.5 or later to compile on AIX 5.x. And no responses that fix the problem. I have had the same problem and can only presume that Kerberos is no longer supported on AIX. Is this the case? No Kerberos on AIX? It just won't compile anymore with the changes to shared libraries. ________________________________________________ Kerberos mailing list Kerberos@mit.edu https://mailman.mit.edu/mailman/listinfo/kerberos >>>>> "Grant," == Grant, Martin <Martin....

Web resources about - OraTcl45 on AIX 6.1 - comp.lang.tcl

Resources last updated: 3/7/2016 2:03:07 PM