f



Strange Problem with ActiveState Tcl 8.4 in MAC OS X 10.4

http://home.comcast.net/~kilowattradio/tcltkmac_osx1.jpg
http://home.comcast.net/~kilowattradio/tcltkmac_osx2.jpg

 In Mac OS X 10.4.11 I am having a problem with ActiveTCl's 
8.4 graying out certain .TCL files when I try to select 
a source file when running wish in the GUI.

Please see the links above to see the grayed out file names.

I am trying to load bcd396t.tcl source file but that is 
grayed out. I have tried changing the first few lines of 
the file that had some bash scripting in them. And translated
the text from mac to unix and even tried windows code with the
same results. It seems to occur after I edit a .tcl file and 
save it. The other normal tcl files that I can select have 
not been edited.

If I run the bcd396t.tcl file from
/usr/local/bin/wish bcd396t.tcl 
it works fine and there are no errors. I don't have
any problems in Win32 XP/Vista or Linux Fedora/Ubuntu either. 
I just can't figure out what is graying out the file on Mac OS X. 

Does anyone have any ideas?


-- 
Best Regards, Keith
kilowattradio at gmail.com

0
6/17/2009 11:12:23 PM
comp.lang.tcl 23429 articles. 2 followers. Post Follow

7 Replies
925 Views

Similar Articles

[PageSpeed] 23

Keith wrote:
> http://home.comcast.net/~kilowattradio/tcltkmac_osx1.jpg
> http://home.comcast.net/~kilowattradio/tcltkmac_osx2.jpg
> 
>  In Mac OS X 10.4.11 I am having a problem with ActiveTCl's 
> 8.4 graying out certain .TCL files when I try to select 
> a source file when running wish in the GUI.
> 
> Please see the links above to see the grayed out file names.
> 
> I am trying to load bcd396t.tcl source file but that is 
> grayed out. I have tried changing the first few lines of 
> the file that had some bash scripting in them. And translated
> the text from mac to unix and even tried windows code with the
> same results. It seems to occur after I edit a .tcl file and 
> save it. The other normal tcl files that I can select have 
> not been edited.
> 
> If I run the bcd396t.tcl file from
> /usr/local/bin/wish bcd396t.tcl 
> it works fine and there are no errors. I don't have
> any problems in Win32 XP/Vista or Linux Fedora/Ubuntu either. 
> I just can't figure out what is graying out the file on Mac OS X. 
> 
> Does anyone have any ideas?

I don't have access to OS X (or any Mac for that matter), but I'd guess 
you're problem is permissions related.  If you compare the permissions 
of a "grayed out" file to that of one that looks normal, I bet they're 
different.

Jeff
0
jeff_godfrey (836)
6/18/2009 3:43:53 AM
On Wed, 17 Jun 2009 22:43:53 -0500, Jeff Godfrey <jeff_godfrey@pobox.com>
wrote:

>I don't have access to OS X (or any Mac for that matter), but I'd guess 
>you're problem is permissions related.  If you compare the permissions 
>of a "grayed out" file to that of one that looks normal, I bet they're 
>different.


Hi, I checked the permissions also and they are exactly the same for all files
in the directory when I do a ls -l on the command line. Is there another
permissions setting I should check for the files? I did try a chmod 777 on the
grayed files and the results were the change. 
 If I get the original programs files and untar them in a new directory wish
GUI will load the source file and run with no problems. The minute I edit them
in midnight commander or BBEDIT program and save them wish grays out the file
so I can not load it. 
Strange. 
 
-- 
Best Regards, Keith 
http://home.comcast.net/~kilowattradio/ 
0
6/18/2009 12:21:20 PM
On Thu, 18 Jun 2009 05:21:20 -0700, Keith <kilowattradio@gmail.com> wrote:

>Hi, I checked the permissions also and they are exactly the same for all files
>in the directory when I do a ls -l on the command line. Is there another
>permissions setting I should check for the files? I did try a chmod 777 on the
>grayed files and the results were the change. 
                      ^^^^^^^^^^^^^^^^^^^^^^^^

That should be the "results were the same". 

-- 
Best Regards, Keith 
http://home.comcast.net/~kilowattradio/ 
0
6/18/2009 12:23:16 PM
Keith wrote:
> http://home.comcast.net/~kilowattradio/tcltkmac_osx1.jpg
> http://home.comcast.net/~kilowattradio/tcltkmac_osx2.jpg
> 
>  In Mac OS X 10.4.11 I am having a problem with ActiveTCl's 
> 8.4 graying out certain .TCL files when I try to select 
> a source file when running wish in the GUI.
>...

Exactly which Activestate program are you running or are you running some 
Tcl program of your own?

If you are running your own, please post the code used to select the files.


Also, why are you running an old version of Tcl?

-- 
+------------------------------------------------------------------------+
| Gerald W. Lester                                                       |
|"The man who fights for his ideals is the man who is alive." - Cervantes|
+------------------------------------------------------------------------+
0
Gerald.Lester (2014)
6/18/2009 1:22:01 PM
Gerald W. Lester wrote in <%br_l.1544$dg5.1117@newsfe25.iad>:
> Keith wrote:
>> http://home.comcast.net/~kilowattradio/tcltkmac_osx1.jpg
>> http://home.comcast.net/~kilowattradio/tcltkmac_osx2.jpg
>> 
>>  In Mac OS X 10.4.11 I am having a problem with ActiveTCl's 
>> 8.4 graying out certain .TCL files when I try to select 
>> a source file when running wish in the GUI.
>>...
>
> Exactly which Activestate program are you running or are you running some 
> Tcl program of your own?

I am running ActiveState TCL 8.4 and I have not altered it. 



>
> If you are running your own, please post the code used to select the files.
>
>
> Also, why are you running an old version of Tcl?
>

 I have an old computer and there has been no reason to upgrade. 

0
me4 (19624)
6/18/2009 8:19:18 PM
On Jun 17, 4:12=A0pm, Keith <kilowattra...@gmail.com> wrote:
> http://home.comcast.net/~kilowattradio/tcltkmac_osx1.jpg
>
> =A0In Mac OS X 10.4.11 I am having a problem with ActiveTCl's
> 8.4 graying out certain .TCL files when I try to select
> a source file when running wish in the GUI.
  ...
> same results. It seems to occur after I edit a .tcl file and
> save it. The other normal tcl files that I can select have
> not been edited.

One thing to note is that the open file dialogs are mapped over the
native OS dialogs.  Their behavior is thus not fully in Tcl's
control.  I can only guess as others do that there is something
different about these files.  What editor are you using?  What does
'ls -al' in that directory return?  How exactly are you invoking the
dialog?

Finally, you might try a newer version of Tcl, but I suspect the same
results given the dialog behavior is nearly the same.

Jeff
0
jeff.hobbs (444)
6/18/2009 8:31:39 PM
Jeff Hobbs wrote in <c7413b61-456a-4b23-8671-02030b330c89@y6g2000prf.googlegroups.com>:
> On Jun 17, 4:12�pm, Keith <kilowattra...@gmail.com> wrote:
>> http://home.comcast.net/~kilowattradio/tcltkmac_osx1.jpg
>>
>> �In Mac OS X 10.4.11 I am having a problem with ActiveTCl's
>> 8.4 graying out certain .TCL files when I try to select
>> a source file when running wish in the GUI.
>   ...
>> same results. It seems to occur after I edit a .tcl file and
>> save it. The other normal tcl files that I can select have
>> not been edited.
>
> One thing to note is that the open file dialogs are mapped over the
> native OS dialogs.  Their behavior is thus not fully in Tcl's
> control.  I can only guess as others do that there is something
> different about these files.  What editor are you using?  What does
> 'ls -al' in that directory return?  How exactly are you invoking the
> dialog?
>
> Finally, you might try a newer version of Tcl, but I suspect the same
> results given the dialog behavior is nearly the same.
>
> Jeff

 Well I uninstalled activestate tcl 8.4 from the Mac then installed
activestate tcl 8.5 and the problem has gone away, so far. 

Thanks for all the input to help me solve this problem. 

Keith

0
6/18/2009 10:31:34 PM
Reply:

Similar Artilces:

Tcl 8.4.x & tcl-dp 4.0.x
Has anyone built tcl-dp 4.0.x on windows against Tcl 8.4.x ? Is it possible to get the windows dll and the source code with modifications? ...

CW 8.3/CW 9.4 Mac OS X 10.4 problem
Hi After installing 10.4 I can not drag and drop files into the IDE window anymore I tried c/c++/java files in 8.3 and c/c++ in 9.4 Is there workaround for that? However I can add files from he Project->Add files without any problem Actually I saw that problem on all prerelease builds After clean installations upgrades Thanks In article <BE98BC82.1156%dimamarkman@comcast.net>, Dmitry Markman <dimamarkman@comcast.net> wrote: > I tried c/c++/java files in 8.3 and c/c++ in 9.4 > > Is there workaround for that? MW has said they will release a ...

Ruby 1.8.0 and Mac OS X and Tcl/Tk 8.4 Aqua (not!)
My trials with Ruby and Tcl/Tk on Mac OS X Ruby is 1.8.0 preview 7 Tcl/Tk 8.4 is the recent TclTk-Aqua build for that native OSX Aqua look Mac OS X is 10.2.3 (1) 'configure' wasn't finding Tcl/Tk, so I hacked up an OSX-only version of ext/tcltklib/extconf.rb with hard-coded parameters (which might be OK because of the frameworks) ========= # extconf.rb for tcltklib # HACKED for Mac OS X !!! require 'mkmf' if RUBY_PLATFORM !~ /mswin32|mingw|cygwin|bccwin32/ have_library("nsl", "t_open") have_library("socket&q...

TCL/TK Does not have serial port support API in Mac OS X 10.4 Tiger in a mac mini
Over the last couple of weeks I have been trying to figure out why I had no communications with a USB > Serial converter and tonight I discovered that there is no serial port support in the TCL/TK installed in MAC OS X 10.4 Mac mini. % fconfigure stdin -blocking 1 -buffering line -buffersize 4096 -encoding utf-8 -eofchar {} -translation auto I went to the Mac install on the CD-ROMs and found nothing on tcl/tk. What should I use to remove the old TCL/TK packages and install a better version? I found the aqua site tcl site and should I just install that full package binary and make the ch...

Are Mac OS X 10.5.8's iLife programs safe to use in Mac OS X 10.7.x and 10.8.x?
Hi. Someone told me that Mac OS X 10.7.x and 10.8.x do not come with iLife like the older Mac OS X versions (e.g., 10.5.x). I did not know this! Since my client uses iPhoto that came preinstalled on his old 2008 MacBook Pro's Mac OS X 10.5.x (10.5.8 right now), can he use the old one from 10.5.8? Or will he need a third party replacement (needs to import/copy the old image files) or buy a new iPhoto version for his photo(graph)s? I recalled he did not like iPhoto and wonder if the new one is any better. Thank you in advance. :) -- Quote of the Week: "Every ruler sleeps on an anthill." --Afghani /\___/\ Ant(Dude) @ http://antfarm.home.dhs.org (Personal Web Site) / /\ /\ \ Ant's Quality Foraged Links: http://aqfl.net | |o o| | \ _ / Please nuke ANT if replying by e-mail. If crediting, ( ) then please kindly use Ant nickname and AQFL URL/link. On 2012-09-21 3:05 PM ANTant@zimage.com (Ant) wrote: > Hi. > > Someone told me that Mac OS X 10.7.x and 10.8.x do not come with iLife > like the older Mac OS X versions (e.g., 10.5.x). I did not know this! > Since my client uses iPhoto that came preinstalled on his old 2008 > MacBook Pro's Mac OS X 10.5.x (10.5.8 right now), can he use the old one > from 10.5.8? Or will he need a third party replacement (needs to > import/copy the old image files) or buy a new iPhoto version for his > photo(graph)s? I rec...

scipad problem with scilab 4.0 on Mac OS X 10.4 Intel
Hello, I have a problem when running Scilab 4.0 on Mac OS X 10.4 (MacBook Intel) I open scipad by clycking on the editor button. I strike x=1:5 in the scipad window (that's all !!!) save the file as Untitled1.sce (in my home directory) when I click on execute > load into scilab in scipab I get this in the scilab window in execstr instruction called by : exec("/Users/scls/Untitled1.sce"); in execstr instruction called by : exec("/Users/scls/Untitled1.sce"); in execstr instruction called by : exec("/Users/scls/Untitled1.sce"); in execstr instruction called by : exec("/Users/scls/Untitled1.sce"); (many times) [More (y or n ) ?] I strike n and enter in execstr instruction called by : b_str,db_n,db_l,db_func]=lasterror(); TCL_EvalStr("scipad eval { global in execstr instruction called by : b_str,db_n,db_l,db_func]=lasterror(); TCL_EvalStr("scipad eval { global in execstr instruction called by : b_str,db_n,db_l,db_func]=lasterror(); TCL_EvalStr("scipad eval { global in execstr instruction called by : b_str,db_n,db_l,db_func]=lasterror(); TCL_EvalStr("scipad eval { global (many times) [More (y or n ) ?] I strike n and enter and I get the following message warning: stack problem..., cleared Moreover the x variable don't contain anything and when I strike x and ENTER a error window appear Application Error E...

tcl 8.4.4 change in behavior with WriteChars over 8.3.x
Can I get some input on the following problem: Tcl_WriteChars() no longer returns the correct number of bytes written to an output stream on Unix (I am running on a Sun Ultra30 with Solaris9, but it looks like the issue is generic to Unix. My brief Inspection of the tcl code shows that the actual return value is never checked for this routine, however, except for being non-negative. However, I am using tcl as an embedded shell in a C++ program which directs its output stream through a Tcl_Channel and uses Tcl_WriteChars as a replacement for the unix write() call, which returns the numbe...

Re: Subject: Building ACE 5.3.1 on Mac OS X (Tiger) 10.4.2 was [ace-users] Building ACE on Mac OSX 10.4
Hi Jason, Thanks for using the PRF. >> ACE VERSION: 5.3.1 This version of ACE is ANCIENT. The forthcoming ACE 5.4.8 beta should work "out of the box" for Mac OS X Tiger. If you want a preview, please download the version in our CVS repo at http://cvs.doc.wustl.edu/ take care, Doug >> HOST MACHINE and OPERATING SYSTEM: Mac OS X 10.4.2 >> COMPILER NAME AND VERSION (AND PATCHLEVEL): >> powerpc-apple-darwin8-gcc-4.0.1 >> >> CONTENTS OF $ACE_ROOT/ace/config.h: >> >> /* -*- C++ -*- */ >> // config-macosx.h,v 4.17 2003/01/20 20:02:12 seibel_r Exp >> >> // This configuration file is designed to work with the MacOS X operating >> system. >> >> #ifndef ACE_CONFIG_MACOSX_H >> #define ACE_CONFIG_MACOSX_H >> >> #if ! defined (__ACE_INLINE__) >> #define __ACE_INLINE__ >> #endif /* ! __ACE_INLINE__ */ >> >> #if defined (__GNUG__) >> # include "ace/config-g++-common.h" >> #endif /* __GNUG__ */ >> >> #undef ACE_HAS_EXPLICIT_TEMPLATE_INSTANTIATION >> >> #define ACE_SIZE_T_FORMAT_SPECIFIER ACE_LIB_TEXT ("%lu") >> >> #if defined (ACE_HAS_PENTIUM) >> # undef ACE_HAS_PENTIUM >> #endif /* ACE_HAS_PENTIUM */ >> >> #if !defined (_THREAD_SAFE) >> #define _THREAD_SAFE >&g...

[wx 2.6.3, Mac OS X 10.4.8, gcc 4.0.1] extremely slow wxStyledTextCtrl::Colourise()
Hello, I'm developing a multi-platform source code editor with syntax-highlighting based on wxWidgets. I have a problem with the wxStyledTextCtrl::Colourise() function on the Mac platform. This function is extremely slow on Mac, e.g. it takes about 40 seconds to do the lexing of a file of 500 lines of c++ code, while the same function returns within 1 second on the Windows and Linux platforms using the same version of wxWidgets. (I'm using the wxSTC_LEX_CPP lexer). The problem appears when the user wants to scroll down the wxStyledTextCtrl : the slider blocks and th...

Re: Subject: Building ACE 5.3.1 on Mac OS X (Tiger) 10.4.2 was [ace-users] Building ACE on Mac OSX 10.4 #2
Hi Jason, >> I know it isn't the most recent version available, but this version >> is used extensively across the corporation. Changing the version of >> ACE all these products used will cause the architect's heads to >> explode ;) >> >> Is it your opinion that 5.3.1 is hopeless cause on Tiger? It'll take some work, but companies like Riverace, Remedy, and OCI can help out with this stuff if staying with 5.3.1 is essential. Please see http://www.cs.wustl.edu/~schmidt/commercial-support.html for help with this stuff. >> > http://cvs.doc.wustl.edu/ >> I will try it out, and let you know how it works. Great - if there are any problems please let us know quickly so that we can get the fixes into the x.4.8 beta. Thanks, Doug -- Dr. Douglas C. Schmidt Professor and Associate Chair Electrical Engineering and Computer Science TEL: (615) 343-8197 Institute for Software Integrated Systems WEB: www.dre.vanderbilt.edu/~schmidt Vanderbilt University, Nashville TN, 37203 NET: d.schmidt@vanderbilt.edu ...

Compiling 8.13.4 with GCC 3.3--error, stdarg.h v. varargs.h on Mac OS X 10.4.1?
I'm trying to compile Sendmail 8.13.4 on Mac OS X 10.4.1, using GCC 3.3. I'm getting the message that GCC no longer supports varargs.h and code should be updated to use stdarg.h. I know this is a long-standing problem, and I used to be able to solve it (with Sendmail 8.12.x on Mac OS X 10.2.x and 10.3.x) by reverting to GCC 3.1. Unfortunately, GCC 3.1 is not installed on Mac OS X 10.4. The weird thing is that the last machine I build this way was Sendmail 8.13.3 on Mac OS X 10.3.7 and it compiled just fine with GCC 3.3. Possibly this had something to do with the fact that GCC 3...

ActiveState Tcl 8.4.4.0 and Tile 0.7.8 under Vista crashes
I am using Tcl/Tk 8.4.4.0 (because I want to also use BLT 2.4 and my understanding is that BLT will not run under 8.5), along with Tile 0.7.8 Tile loads OK under the 'package requires' command, but the first time I run a tile command (for example, creating a button), Vista crashes. ttk::button .b1 -text "Test" Is there a solution to this? I have searched comp.lang.tcl, but see no reference to this problem. Thanks On 4/8/11 10:09 PM, thoselaings wrote: > I am using Tcl/Tk 8.4.4.0 (because I want to also use BLT 2.4 and my > understanding is that BLT will not run under 8.5), along with Tile > 0.7.8 > > Tile loads OK under the 'package requires' command, but the first time > I run a tile command (for example, creating a button), Vista crashes. > ttk::button .b1 -text "Test" > > Is there a solution to this? I have searched comp.lang.tcl, but see no > reference to this problem. Most of the commonly used (particularly on Windows) used pieces of BLT have been reimplemented outside of BLT -- you may want to re-evaluate your use of BLT so you can move on to 8.5 or later. BLT is not in the cards going forward. Exactly what pieces of BLT are you using? -- +------------------------------------------------------------------------+ | Gerald W. Lester, President, KNG Consulting LLC | | Email: Gerald.Lester@kng-consulting.net ...

Mac OS X 1.0 x86 and Mac OS X 10.4 x86
I wonder of OS X on Intel runs binaries made for Mac OS X Server 1.0 or earlier x86 versions of NEXTSTEP... There should be some interesting error messages to find. I'll try it out with OmniWeb 3 one day... -- Andrew J. Brehm Marx Brothers Fan PowerPC/Macintosh User Supporter of Chicken Sandwiches In article <1gxrpng.qcld42zk38uoN%ajbrehm@gmail.com>, ajbrehm@gmail.com (Andrew J. Brehm) wrote: > I wonder of OS X on Intel runs binaries made for Mac OS X Server 1.0 or > earlier x86 versions of NEXTSTEP... > > There should be some interesting error messages to find. > > I'll try it out with OmniWeb 3 one day... I *really* doubt it. 10.0 PPC doesn't run OS X Server 1.0 PPC binaries, does it? -- "This notion that the United States is getting ready to attack Iran is simply ridiculous. And having said that, all options are on the table." -- George W. Bush in Brussels, Belgium, Feb. 22, 2005 ZnU <znu@fake.invalid> wrote: > In article <1gxrpng.qcld42zk38uoN%ajbrehm@gmail.com>, > ajbrehm@gmail.com (Andrew J. Brehm) wrote: > > > I wonder of OS X on Intel runs binaries made for Mac OS X Server 1.0 or > > earlier x86 versions of NEXTSTEP... > > > > There should be some interesting error messages to find. > > > > I'll try it out with OmniWeb 3 one day... > > I *really* doubt it. 10.0 PPC doesn't run OS X Server 1.0 PPC binaries, > does it? I think i...

Installing gnuplot 4.2.2 on Mac G4 under Mac OS X 10.4.11
In attempting to install gnuplot 4.2.2 on a Mac G4 running Mac OS X v. 4.2.2, I got several error messages before the installation failed. The error messages asked that I report these messages to the gnuplot lists, so the excerpt below contains the transcript of the installation. Any suggestions as to how to install gnuplot 4.2.2? Starfighter. Last login: Wed Nov 21 03:22:17 on ttyp1 Welcome to Darwin! dsl092-239-159:/ samueldupree$ tar -xzf gnuplot-4.2.2.tar.gz dsl092-239-159:/ samueldupree$ ls dsl092-239-159:/ samueldupree$ cd gnuplot-4.2.2 dsl092-239-159:/gnuplot-4.2.2 samueldupree$ ./configure --prefix=/usr/ local checking for a BSD-compatible install... /usr/bin/ginstall -c checking whether build environment is sane... yes checking for gawk... gawk checking whether make sets $(MAKE)... yes checking for gcc... gcc checking for C compiler default output file name... a.out checking whether the C compiler works... yes checking whether we are cross compiling... no checking for suffix of executables... checking for suffix of object files... o checking whether we are using the GNU C compiler... yes checking whether gcc accepts -g... yes checking for gcc option to accept ANSI C... none needed checking for style of include used by make... GNU checking dependency style of gcc... gcc3 checking for function prototypes... yes checking how to run the C preprocessor... gcc -E checking for egrep... grep -E checking for ANSI C header files... yes ...

difference between tcl 8.4.2 & 8.4.4
% exec $env(COMSPEC) /c net config This command now fails on Tcl 8.4.4 What can I do instead? to run with either version of tcl and windows 98. "couldn't execute "C:\WINDOWS\COMMAND.COM": no such file or directory" Running on Win 98. Win XP is ok. Peter Campbell wrote: > % exec $env(COMSPEC) /c net config > > This command now fails on Tcl 8.4.4 > What can I do instead? to run with either version of tcl and windows 98. > > "couldn't execute "C:\WINDOWS\COMMAND.COM": no such file or directory" > > Running on Win 98...

"::tcl::tm::UnknownHandler ::tclPkgUnknown msgcat 1.4" caused by replacing Tcl 8.4.1 with 8.5.7
In the blog http://planet.larrythecow.org/archives/2009-07-26.html "The Twouble with Tcl" Iain Buchanan shows that redefining OPEN proc leads to the errors similar to what I am getting - when I replaced Tcl 8.4.1 with Tcl 8.5.7. In my case I don't know the exact root cause though ... Any ideas how I should proceed with debugging this issue ? Thanks, Alex tclsh c:/Tornado/host/resource/hutils/tcl/makeSymTbl.tcl ppc tmp.o symTbl.c invalid command name "::tcl::tm::UnknownHandler" while executing "::tcl::tm::UnknownHandler ::tclPkgUnknown msg...

Problem upgrading from OS 10.4.1 to OS 10.4.9
I have a MacBook Pro with OS X version 10.4.1 installed. Model Name: MacBook Pro 15" Model Identifier: MacBookPro1,1 Processor Name: Intel Core Duo Processor Speed: 2 GHz Number Of Processors: 1 Total Number Of Cores: 2 L2 Cache (per processor): 2 MB Memory: 1 GB Bus Speed: 667 MHz I downloaded Mac_OS X 10.4.9 Combined Update (Intel) and when I tried updating it read: "You cannot install Mac OS X Update Combined (Intel) on this volume. This volume does not meet the requirements for this update." researcher wrote: > I have a MacBook Pro with OS X version 10.4.1 installed. > Model Name: MacBook Pro 15" > Model Identifier: MacBookPro1,1 > Processor Name: Intel Core Duo > Processor Speed: 2 GHz > Number Of Processors: 1 > Total Number Of Cores: 2 > L2 Cache (per processor): 2 MB > Memory: 1 GB > Bus Speed: 667 MHz > > I downloaded Mac_OS X 10.4.9 Combined Update (Intel) and when I tried > updating it read: > > "You cannot install Mac OS X Update Combined (Intel) on this volume. > This volume does not meet the requirements for this update." > Call up apple support to find out what gives. ...

Problems with BLT 2.4 and TCL 8.4.19
I have a win32 xp sp3, and recently cleaned my machine and re- installed Tcl and Blt. I tried the following piece of sample code from wiki.tcl.tk: package require Tk package require BLT namespace import blt::* # vector and stripchart are blt components. # if you have a vector v, you can update it in realtime with # v set $list # init the vectors to a fixed size. set Hz 200 vector xvec($Hz) y1vec($Hz) y2vec($Hz) # fill xvec with 0 .. $Hz-1 xvec seq 0 [expr {$Hz - 1}] stripchart .s1 -height 2i -width 8i -bufferelements no stripchart .s2 -height 2i -width 8i -bufferelements no pack .s1 .s2 .s1 element create line1 -xdata xvec -ydata y1vec -symbol none .s2 element create line2 -xdata xvec -ydata y2vec -symbol none -color red # update $Hz values with random data once per second proc proc1sec {} { # this can be done more concisely with vector random, # but if you need to fill a vector from scalar calculations, # do it this way: for {set i 0} {$i < $::Hz} {incr i} { lappend y1list [expr {rand()}] lappend y2list [expr {rand()}] } y1vec set $y1list y2vec set $y2list after 1000 proc1sec } proc1sec But, fails after package require BLT, with "can't find package BLT". I simply ran the executable. Is there anything more necessary to run BLT. Thank you for your help :) On May 12, 6:34=A0pm, Jesse Schwartz <jesseaschwa...@gmail.com> wr...

Scilab version 4 on Mac OS 10.4.8
Dear All, Today I updated my Mac OS X 10.4.7 to 10.4.8. Since then I experience problems executing scilab files. I use the Scilab version for Intel Macs downloaded from http://www.lmac.utc.fr/~mottelet/Darwin/ . Has anyone else had this problem. Tarik The error message I get is the following: in execstr instruction called by : warning: stack problem..., cleared As you can see the error message seems to be incomplete. A small precision. The error occurs only when I use "Load into Scilab" or make ctrl+l to execute the code in the editor. It does not cause problems when I select pieces of code and execute the selections. tarikocaktan@gmail.com wrote: > Dear All, > > Today I updated my Mac OS X 10.4.7 to 10.4.8. Since then I experience > problems executing scilab files. I use the Scilab version for Intel > Macs downloaded from http://www.lmac.utc.fr/~mottelet/Darwin/ . > Has anyone else had this problem. > > Tarik > > > The error message I get is the following: > > in execstr instruction called by : > warning: stack problem..., cleared > > As you can see the error message seems to be incomplete. > The error occurs only when I use "Load into Scilab" or make ctrl+l to > execute the code in the editor. It does not cause problems when I > select pieces of code and execute the selections. Please be more specific. Are you saying that it does not happ...

bind <Shift-something> does not work under XF 4.3 tcl 8.3.5, ActiveState 8.4.3
I have tried the following script, under XFree86-4.3.0-2 both with RedHat 8 and 9, either with the native RH tcl 8.3.5 and with the ActiveState tcl 8.4.3 distributions. In all these platform combinations, the binding of <Shift-* does not work. For example, for Shift-F1, I get XF86_Switch_VT_1 (see xmodmap dump below), but the binded script is not triggered. However, the script works fine under Windows, with the same tcl distributions. Any hint? pack [entry .a] bind .a <Shift_L> {puts "hello, Shift"} bind .a <Shift-F1> {puts "hello, Shift-F1"} bind .a <...

XCode (2.4.1) Linking issue, wx 2.8.6, OS X 10.4.10, GCC4.0
Platform: Mac mini - intel dual core. I'm working through the examples in the "Cross-Platform GUI Programming with wxWidgets" books and I'm stuck on an XCode linking issue. The demos on the base wxMac code base build and work fine. So I know it's the XCode setup. I can't find the entry where the libraries are described. I've setup XCode using the wx-config --cxxflags and wx-config --libs When building the minimal code example in chapter two, the build completes and goes to the link stage where: "Linking /Volumes//u01/work/wx - example...

Uninstalling PinePico-4.58-SSL-10.2.pkg on Mac OS X 10.2.8
How to uninstall PinePico-4.58-SSL-10.2.pkg on Mac OS X 10.2.8? I could not find such information at <http://www.washington.edu/pine/faq/index.html>. Please, note that I do not know about Unix commands. I am just a Mac user. I have downloaded it from <http://www.apple.com/downloads/macosx/unix_open_source/> and then <http://www.apple.com/downloads/macosx/unix_open_source/pinepico.html>. I have seen <http://www.washington.edu/pine/> I installed it thinking that it was a client eMail application that would allow me to check with a true Mac OS X Aqua interface my eMail...

Debugging in XCode 2.4 (Mac OS X 10.4)
OS: Mac OS X 10.4.8 / XCode 2.4 Hello I try to debug a QuarkXTension. Every time I want to start the debugging I get the message "QuarkXpress 7.0 exited with status (10). The debugger is still running. Use 'Restart' to debug again.". I have defined QuarkXPress 7.0 as an executable and it starts when I run it without the debugger. But with the debugger I get the message above. Do you have an idea what this error message means? A problem with the path? Source files which aren't found? A "symbol file" (or something like that) who isn't found? Maybe I have no debug informations in my XTension? Maybe a problem because QuarkXPress 7.0 doesn't contain no debug information? Thanks for the help. Regards Hans St�ssel ...

problem using blt 2.4 with tcl 8.4.19 on Windows
Hello, when using hiertable widget with blt 2.4 and wish8419 on Windows, I get the following error: bad cursor spec "@c:/perforce/CTAT/Windows/Environment/Tcl8419/lib/ blt2.4/treeview.cur" (database entry for "resizeCursor" in widget ".wxx.h") invoked from within "hiertable $wname.h -width 0 -yscrollcommand "$wname.vs set" - xscrollcommand "$wname.hs set" -selectmode multiple -hideroot yes " I'm able to use hierbox widget properly. It only happens with hiertable. Any ideas how to fix the problem above? Thank you very much for you inputs! ...

Web resources about - Strange Problem with ActiveState Tcl 8.4 in MAC OS X 10.4 - comp.lang.tcl

Canada's ActiveState Cuts Cloud Deal With HP
ActiveState, a Vancouver, Canada-based cloud software firm said that it had licensed its platform-as-a-service product, called Stackato, to Hewlett-Packard. ...

ActiveState Private PaaS With Stackato 2.8
Enterprise private-PaaS gets improved LDAP controls and SPDY support

ActiveState Ships Komodo IDE 7.1 With Cloud Debugging
ActiveState has delivered Komodo 7.1, the latest release of its integrated development environment that supports a variety of programming languages ...

HP Unveils Cloud Application Platform Powered by ActiveState
... last 6 months looking for its PaaS partner for a new global OEM licensing agreement finally settling on Vancouver, British Columbia based ActiveState ...

ActiveState - Geekosystem
... after school. Such is the case of 15-year-old Danill Kulchenko , who recently sold his startup cloud-based computing company Phenona to ActiveState ...


ActiveState buys Appsecute for its social devops smarts
ActiveState , the company behind the Stackato enterprise-focused platform as a service (PaaS), is buying Appsecute, a New Zealand-based startup ...

ActiveState Buys Appsecute To Enhance PaaS With Facebook-Style Feed For Developers And IT Pros - TechCrunch ...
ActiveState, a platform-as-a-service provider, has acquired New Zealand-based Appsecute, a company that provides social monitoring tools for ...

PaaS Provider ActiveState And The Paradox Of Aligning With HP And Cloud Foundry
Platform-as-a-Service (PaaS) provider ActiveState recently scored a sweet deal with HP: It is the official PaaS for the entire HP cloud business. ...

HP acquires ActiveState’s Stackato PaaS business
HP today announced that it has agreed to buy the Stackato business from ActiveState . Terms of the deal weren’t disclosed. Stackato is private ...

Resources last updated: 3/13/2016 11:34:08 AM