f



what version Tcl and Tk comes with Mac OS X Leopard

Hi All,

Does anyone know what version of Tcl and Tk comes with the new Mac OS
X Leopard?

Thanks

0
10/20/2007 4:11:30 PM
comp.lang.tcl 23429 articles. 2 followers. Post Follow

12 Replies
692 Views

Similar Articles

[PageSpeed] 35

This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enig6B1047DB6237F0C9229E0104
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

chewie54 wrote:
> Hi All,
>=20
> Does anyone know what version of Tcl and Tk comes with the new Mac OS
> X Leopard?
>=20
> Thanks
>=20


ask it with: info patch

--=20
David Gravereaux <davygrvy@pobox.com>
[species:human; planet:earth,milkyway(western spiral arm),alpha sector]



--------------enig6B1047DB6237F0C9229E0104
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFHGo4alZadkQh/RmERAq5AAKCmPFcs1SN49BIcID4jjAghtcvhdwCg9gFA
DWgZqNDjkm9hZ+6os9FbVLQ=
=6iJh
-----END PGP SIGNATURE-----

--------------enig6B1047DB6237F0C9229E0104--
0
davygrvy (1376)
10/20/2007 11:24:05 PM
On Oct 20, 7:24 pm, David Gravereaux <davyg...@pobox.com> wrote:
> chewie54 wrote:
> > Hi All,
>
> > Does anyone know what version of Tcl and Tk comes with the new Mac OS
> > X Leopard?
>
> > Thanks
>
> ask it with: info patch
>
> --
> David Gravereaux <davyg...@pobox.com>
> [species:human; planet:earth,milkyway(western spiral arm),alpha sector]
>
>  signature.asc
> 1KDownload

It never occurred to the that the poster might actually have a copy of
Leopard.

0
yoda (101)
10/20/2007 11:34:15 PM
On Oct 20, 7:34 pm, Sean Woods <y...@etoyoc.com> wrote:
> On Oct 20, 7:24 pm, David Gravereaux <davyg...@pobox.com> wrote:
>
>
>
> > chewie54 wrote:
> > > Hi All,
>
> > > Does anyone know what version of Tcl and Tk comes with the new Mac OS
> > > X Leopard?
>
> > > Thanks
>
> > ask it with: info patch
>
> > --
> > David Gravereaux <davyg...@pobox.com>
> > [species:human; planet:earth,milkyway(western spiral arm),alpha sector]
>
> >  signature.asc
> > 1KDownload
>
> It never occurred to the that the poster might actually have a copy of
> Leopard.

No.  I don't have Leopard.  That is why I asked.

Thanks

0
10/21/2007 2:04:21 AM
It would be in the 8.4.14/15 range I think. Certainly not .16 since
that just came out.

0
sigzero (1319)
10/23/2007 11:56:36 PM
On Oct 20, 11:11 am, chewie54 <dfabrizi...@gmail.com> wrote:
> Hi All,
>
> Does anyone know what version of Tcl and Tk comes with the new Mac OS
> X Leopard?
>
> Thanks

I just cracked open my new Leopard Box.

The Tcl that Apple ships is 8.4.7, according to "set tcl_patchLevel"

(That's the same version that ships with Tiger IIRC)
0
yoda (101)
12/13/2007 4:54:14 PM
On 13 Dez., 17:54, Sean Woods <y...@etoyoc.com> wrote:
> I just cracked open my new Leopard Box.
>
> The Tcl that Apple ships is 8.4.7, according to "set tcl_patchLevel"

uh :^) BTW, "info pa" is the short call I usually use interactively
(often together with "info na").
0
12/13/2007 5:06:50 PM
On Dec 13, 11:54 am, Sean Woods <y...@etoyoc.com> wrote:
> On Oct 20, 11:11 am, chewie54 <dfabrizi...@gmail.com> wrote:
>
> > Hi All,
>
> > Does anyone know what version of Tcl and Tk comes with the new Mac OS
> > X Leopard?
>
> > Thanks
>
> I just cracked open my new Leopard Box.
>
> The Tcl that Apple ships is 8.4.7, according to "set tcl_patchLevel"
>
> (That's the same version that ships with Tiger IIRC)

Hmmm, it *should* have been newer. I am sure later versions came out
before the Leopard "freeze" for stuff like that.

Robert
0
sigzero (1319)
12/14/2007 2:39:24 AM
On Dec 14, 3:39 am, Robert Hicks <sigz...@gmail.com> wrote:
> On Dec 13, 11:54 am, Sean Woods <y...@etoyoc.com> wrote:
> Hmmm, it *should* have been newer. I am sure later versions came out
> before the Leopard "freeze" for stuff like that.

see http://thread.gmane.org/gmane.comp.lang.tcl.mac/5613/focus=5616
for the background on why Tcl/Tk 8.4.16 did not make it into Leopard.

I repeat my recommendation from that thread to let Apple know if this
affects/concerns you:

On Oct 28, 2007, at 5:45 PM, Daniel A. Steffen wrote:
> Part of the problem is the perception that there is zero user
> demand for the presence of Tcl/Tk on the system, if you want to
> change that, please give Apple feedback about this issue:
> 	http://bugreporter.apple.com/
> 	http://www.apple.com/feedback/macosx.html
> use bugreporter if possible (reports there are harder to ignore),
> don't worry about filing a duplicate, more reports about the same
> issue increase its priority.
> If there is enough demand, we might see a Tcl/Tk upgrade for Leopard
> included in a software update at some point...

Cheers,

Daniel

0
12/15/2007 12:03:06 PM
I just encountered something very odd. I just sent a program to a
friend in Australia. His Mac is running OS 10.4. Until I sent him a
Starkit he couldn't run my program for lack of the bigfloat library.
It turns out that his Tcl is 8.5 but comes with tcllib 1.7. What an
odd combination. He says that his Tcl installation is as it came from
Apple.

Bill

0
billposer (379)
12/16/2007 2:52:39 AM
billposer@alum.mit.edu <billposer@alum.mit.edu> wrote:
> It turns out that his Tcl is 8.5 but comes with tcllib 1.7. What an
> odd combination. He says that his Tcl installation is as it came from
> Apple.

Tcl 8.5 pre-installed on an apple?  That's hard to believe ...

0
avl1 (2748)
12/17/2007 4:00:26 PM
On Dec 17, 8:00 am, Andreas Leitgeb <a...@gamma.logic.tuwien.ac.at>
wrote:
> billpo...@alum.mit.edu <billpo...@alum.mit.edu> wrote:
> > It turns out that his Tcl is 8.5 but comes with tcllib 1.7. What an
> > odd combination. He says that his Tcl installation is as it came from
> > Apple.
>
> Tcl 8.5 pre-installed on an apple?  That's hard to believe ...

I think that what he means by "as it came from Apple" is "as it came
from Apple's update service", so, not as it came with the machine, but
not the result of tinkering on his part such as downloading avant-
garde versions.
0
billposer (379)
12/17/2007 6:49:52 PM
billposer@alum.mit.edu wrote:
> On Dec 17, 8:00 am, Andreas Leitgeb <a...@gamma.logic.tuwien.ac.at>
> wrote:
>> billpo...@alum.mit.edu <billpo...@alum.mit.edu> wrote:
>>> It turns out that his Tcl is 8.5 but comes with tcllib 1.7. What an
>>> odd combination. He says that his Tcl installation is as it came from
>>> Apple.
>> Tcl 8.5 pre-installed on an apple?  That's hard to believe ...
> 
> I think that what he means by "as it came from Apple" is "as it came
> from Apple's update service", so, not as it came with the machine, but
> not the result of tinkering on his part such as downloading avant-
> garde versions.

The version of Tcl that is shipped by Apple is 8.4.7, on both Tiger and 
Leopard. It's highly unlikely that Apple would ship a pre-release 
version of Tcl.

-- 
Kevin Walzer
Code by Kevin
http://www.codebykevin.com
0
kw564 (720)
12/17/2007 7:13:38 PM
Reply:

Similar Artilces:

TCL/TK Does not have serial port support API in Mac OS X 10.4 Tiger in a mac mini
Over the last couple of weeks I have been trying to figure out why I had no communications with a USB > Serial converter and tonight I discovered that there is no serial port support in the TCL/TK installed in MAC OS X 10.4 Mac mini. % fconfigure stdin -blocking 1 -buffering line -buffersize 4096 -encoding utf-8 -eofchar {} -translation auto I went to the Mac install on the CD-ROMs and found nothing on tcl/tk. What should I use to remove the old TCL/TK packages and install a better version? I found the aqua site tcl site and should I just install that full package binary and make the ch...

Tcl/Tk on Mac OS X: LoadError
Hello. I have a problem with Tcl/Tk in OS X, each time i try requiring tk, i get this: irb(main):001:0> require 'tk' LoadError: no such file to load -- tk from (irb):1:in `require' from (irb):1 irb(main):002:0> I am positive that I have Tcl/Tk installed - i've installed the binary from ActiveState and I've tried compiling Ruby 1.8.6 myself and I've tried installing it with MacPorts, but nonetheless it doesn't work. I've tried ./configure with --enable-mac-tcltk-framework but it seems that nothing works. I've also tried tclsh and wis...

Mac OS X & tcl/tk...
Hi all, I am just wondering if anyone knows of or has compiled tk for Mac OS X the 'unix' way ie: not the tcl/tk Aqua and can help with compilling tk. As a side note, i have managed to get tcl installed, got some errors while running make test, but it 'seems' to ok so far. The error message that I'm getting while trying to compile is: pp-precomp: warning: errors during smart preprocessing, retrying in basic mode <built-in>:1:1: no macro name given in #define directive make: *** [tk3d.o] Error 1 Thanking you in advance. Shannon Shannon, In article <96e8bbb0.0...

Tcl/Tk problems on Mac OS X
The program I asked about is rather long, but here is a stripped down version consisting of just the GUI. Under GNU/Linux it creates the non-popup windows, and sets up the menus. With the exception of "Quit", the commands have been removed. My friend with the Mac says that when he tries to run it it fails in exactly the same way as the full program, that is, he sees some pastel-colored rectangles and then it hangs. encoding system utf-8 package require msgcat proc _ {s} {return [::msgcat::mc $s]}; # Define shorthand for gettext # Use a virtual event for the right mouse button and ...

Commercial Tcl/Tk applications on Mac OS X
I've recently moved the focus of my development work from open-source/freeware to commercial/shareware applications on Mac OS X. As such, I'm looking to compile a list of commercial Tcl/Tk apps that are supported on this platform--to get a sense of best Tcl/Tk practices with GUI on the Mac, and also to see what's available. By necessity, commercial applications have to place a higher focus on GUI polish than open-source freeware apps do, which is why I'm interested in seeing what's out there. I focus on Mac development, so I'm including cross-platform apps with Mac versions, but not commercial Tcl/Tk apps that don't support the Mac. Here's what I've found so far: * Various apps from ActiveState (http://www.activestate.com)--the Komodo IDE includes a GUI builder written in Tcl/Tk, while ActivePerl's package manager is written in Perl/Tk with Tile * BitRock Installbuilder (http://www.bitrock.com)--cross-platform software installer * Mark Roseman's Project Forum/CourseForum (http://www.projectforum.com)--collaboration/wiki software * Michael Kirkham's MIB Smithy and MIBViews (http://www.muonics.com)--SNMP tools * Similustics' Simile (http://www.simulistics.com)--decision-modeling tools * Alpha Tk by Vince Darley (http://www.santafe.edu/~vince/Alphatk.html)--powerful text editor written in pure Tcl/Tk * Ac3d (http://ac3d.org)--3D modeling tools My own apps could also be added to this list, as they are all now shareware. What...

what version python and wxPython comes with Mac OS X Leopard
HI All, Does anyone know what version of Python and wxPython and maybe any other related Python modules come with Leopard? Thanks, On Oct 29, 1:18 pm, chewie54 <dfabrizi...@gmail.com> wrote: > HI All, > > Does anyone know what version of Python and wxPython and maybe any > other related Python modules come with Leopard? > > Thanks, An answer to one of your questions. The Python version is 2.5.1. Howard ...

Tcl 8.5.2 version conflict on Mac OS X
Hi, I just tried to compile 8.5.2 on Mac OSX, and install it. Below is the error I get when I try to start tclsh8.5. [set tcl_patchLevel] shows also that it would be 8.5.1. What is up here, do others have the same problem? I should add that I installed ActiveTcl 8.5.2 before, and it worked. But normally it should not be a problem to overwrite this installation with another, self compiled. I have done this before without any problems... Thanks in advance Eckhard. $ /usr/local/bin/tclsh8.5 application-specific initialization failed: Can't find a usable init.tcl in the following directories: /Library/Frameworks/Tcl.framework/Versions/8.5/Resources/Scripts /usr/local/lib/tcl8.5 /usr/lib/tcl8.5 /usr/local/library /usr/library /usr/tcl8.5.1/library /tcl8.5.1/library /Library/Frameworks/Tcl.framework/Versions/8.5/Resources/Scripts/init.tcl: version conflict for package "Tcl": have 8.5.1, need exactly 8.5.2 version conflict for package "Tcl": have 8.5.1, need exactly 8.5.2 while executing "package require -exact Tcl 8.5.2" (file "/Library/Frameworks/Tcl.framework/Versions/8.5/Resources/Scripts/init.tcl" line 20) invoked from within "source /Library/Frameworks/Tcl.framework/Versions/8.5/Resources/Scripts/init.tcl" ("uplevel" body line 1) invoked from within "uplevel #0 [list source $tclfile]" /usr/local/lib/tcl8.5/init.tcl: version conflict for package "Tcl&...

Ann: Tcl/Tk "Universal" packages for Mac OS X
I've packaged "universal" installers of Tcl/Tk for Mac OS X (both the Aqua and X11 variants), and the Tile theming extension, for use on Mac OS X's PPC and Intel architectures. These builds are based on Tcl/Tk 8.4.13. Downloads and more information can be found at http://tk-components.sourceforge.net/installer/ Thanks. -- Kevin Walzer Poetic Code http://www.kevin-walzer.com ...

tcl/tk version confusion with tkinter in Python 2.6, on OS X
I'm having trouble with tkinter on a new installation of Python (2.6), built with the framework option from source that was downloaded from python.org. I'm running OS 10.4 on a PowerPC G4. The problem first arose when I tried to run matplotlib - it couldn't find tcl/tk because it was searching for 8.5, and I had 8.4. I found and built tcl/tk 8.5, which led to a new error, reproduced below: Traceback (most recent call last): File "brownian2.py", line 55, in <module> main() File "brownian2.py", line 41, in main root = Tk() File "/Library/Frameworks/Python.framework/Versions/2.6/lib/ python2.6/lib-tk/Tkinter.py", line 1645, in __init__ self._loadtk() File "/Library/Frameworks/Python.framework/Versions/2.6/lib/ python2.6/lib-tk/Tkinter.py", line 1659, in _loadtk % (_tkinter.TK_VERSION, tk_version) RuntimeError: tk.h version (8.4) doesn't match libtk.a version (8.5) I'm a bit of a neophyte - can anyone tell me how to go about fixing this? I've found some information by searching the list and Google, but no helpful solutions. Thanks, Nat On Oct 6, 4:48=A0pm, njwilso...@gmail.com wrote: > I'm having trouble with tkinter on a new installation of Python (2.6), > built with the framework option from source that was downloaded from > python.org. I'm running OS 10.4 on a PowerPC G4. > > The problem first arose when I tried to run matplotlib - it couldn't > find...

does anyone know what version of Java comes with the new Mac OS X Leopard?
Hi All,Does anyone know what version of Java comes with the new Mac OS XLeopard?Thanks chewie54 wrote:> Does anyone know what version of Java comes with the new Mac OS X> Leopard?A bit of googling seems to indicate that 1.6 will ship with Leopard.Example: http://weblogs.java.net/blog/fabriziogiudici/archive/2007/04/mac_os_x_105_de.htmlArne On Sat, 20 Oct 2007 17:26:13 -0400, Arne Vajh�j <arne@vajhoej.dk>wrote, quoted or indirectly quoted someone who said :>>A bit of googling seems to indicate that 1.6 will ship with Leopard.That is good news. Usually Apple is way behind ever...

Ruby 1.8.0 and Mac OS X and Tcl/Tk 8.4 Aqua (not!)
My trials with Ruby and Tcl/Tk on Mac OS X Ruby is 1.8.0 preview 7 Tcl/Tk 8.4 is the recent TclTk-Aqua build for that native OSX Aqua look Mac OS X is 10.2.3 (1) 'configure' wasn't finding Tcl/Tk, so I hacked up an OSX-only version of ext/tcltklib/extconf.rb with hard-coded parameters (which might be OK because of the frameworks) ========= # extconf.rb for tcltklib # HACKED for Mac OS X !!! require 'mkmf' if RUBY_PLATFORM !~ /mswin32|mingw|cygwin|bccwin32/ have_library("nsl", "t_open") have_library("socket&q...

tk::mac::ShowPreferences in Tcl/Tk Linux version?
When I define a procedure tk::mac::ShowPreferences working on a Mac Leopard Snow with the Mac version of ActiveState Tcl/Tk I can use the Mac Preference menu without problems. Great work! But normally I work on a Unix platform compiling my program with tclkit-darwin-aqua for a Mac Platform. And defining a procedure proc ::tk::mac::ShowPreferences {} { tk_messageBox -type ok -icon info -default ok \ -title "Preferences" \ -message "Here will be a Preference Dialog!" } and compiling it for aqua will fail on the Mac. Probably I have to add the tk::ma...

ANN: aem 1.0, a lightweight mechanism for Tcl/Tk applications on Mac OS X to respond to Apple Events
I have just released aem 1.0, a lightweight mechanism for Tcl/Tk applications on Mac OS X to respond to Apple Events. This package allows Tcl/Tk applications on Mac OS X to respond to arbitrary Apple Events, the Mac's system-level application IPC protocol. The Apple Events mechanism allows Mac applications to script other applications using the AppleScript language--to query them for data, execute commands, and similar functions--in a manner similar to COM scripting on Windows and shell scripting on Unix. The package differs from an older Apple Events package, TclAE (htt...

ANN:Fve Ver5.2 (Editor for "Mac OS X"/Cygwin/Unix/Windows) Tcl/Tk script
Fve Ver5.2 (Editor for "Mac OS X"/Cygwin/Unix/Windows) Tcl/Tk script (File Viewer Editor_Version Fve 5.2) http://www.ne.jp/asahi/kazuo/sasagawa/ For Tcl/Tk 8.4,8.5: TclTkAqua 8.4: Tcl/Tk-cygwin 8.4. Please use ActiveTcl 8.4.18 binary packages or "TclTkAqua 8.4.10 binary packages". *Changes(Version5.2) 1 Added a "Customizing key bingings" item to Tools_Menu. 2 Added several bindings for Mac OS X. Command-a -> Select all Command-c -> Copy Command-e -> Use Selection for Find Command-f -> Find Command-g -> Find Next Command-i -> Insert-mode or Over_write-mode Toggle switch Command-n -> New Buffer Command-s -> Save Shift-Command-s -> Save As Command-v -> Paste Command-w -> Close current buffer Command-x -> Cut Command-z -> Undo Shift-Command-z -> Redo Command-? -> Help Command-+ -> Increase Font Size Command-- -> Decrease Font Size 3 Added a "append mode" checkbutton to the bottom Menu line. When the checkbutton is ON, the selected file is appended to the end of current buffer. 4 Added a "Unpack append_mode_CheckButton"_CheckButton to View_Menu. 5 Added a "Select a Menubar background color" command to View_Menu. (UNIX,WINDOWS) 6 Added "Edit" Menu.install.txt "Undo" "Redo" -------------------- "Cut" "Copy" "Paste" "Select All" *Overview ...

Is there interest in latest Tcl/Tk version on CYGWIN, and possibly a X-windows version ?
CCd to: com.lang.tcl and gmane.os.cygwin L.S. In the context of FOSDEM 2005 (www.fosdem.org) and in general, I was wondering wether in the general public there is interest in having the latest tcl/tk source compiled on cygwin (this could be normally possible, see http://mini.net/tcl/12317 ), because it seems to be lagging behind. Not that that is necessarily a problem, backward compatibilty with normal tcl programs should be fairly good. It might be interesting though also to look at a X-version of Tk as an option, like in http://mini.net/tcl/9403 . Theo Verel...

how many people are buying a new Mac when Mac OS X 10.5 Leopard comes out?
how many people are buying a new Mac when Mac OS X 10.5 Leopard comes out? I have been wanting to buy a new Mac... but the Leopard is not coming out yet and it feels dumb to buy a OS X 10.4 machine that can obsolete in a couple of weeks. Summercool wrote: > how many people are buying a new Mac when Mac OS X 10.5 Leopard comes > out? > > I have been wanting to buy a new Mac... but the Leopard is not coming > out yet and it feels dumb to buy a OS X 10.4 machine that can obsolete > in a couple of weeks. Any computer you buy today might be obsolete tomorrow, that's just ...

[ANN] Graphviz for Mac OS X 1.12 (v10) [ANN] Graphviz for Mac OS X 1.12 (v8) [ANN] Graphviz for Mac OS X 1.12 (v8)
Hi all, Yet another Graphviz version. The old application icon had been voted off the island, and brand new application and document icons flown in for the task. Comprehensive help features in this version too. http://www.pixelglow.com/graphviz/ What's new: ------------ Added new application and document icons. Added comprehensive help. Fixed changes not affecting graph size displaying incorrectly [BTr]. Fixed export then close crashing the export of an open window. Improved shadowed frame for graph [NRi]. Improved status display [NRi]. Changed sources to pure BSD license. Cheers, Glen Low --- pixelglow software | simply brilliant stuff www.pixelglow.com ...

[ANN] Graphviz for Mac OS X 1.12 (v12) [ANN] Graphviz for Mac OS X 1.12 (v8) [ANN] Graphviz for Mac OS X 1.12 (v8)
Dear All: Them pesky bugs. A few more squashed courtesy of the sleepy pixel. http://www.pixelglow.com/graphviz/ What's new in v11 ------------ Fixed some comprehensive help [NRi]. Fixed scale option placeholder [NRi]. Improved application and document icons. Example files now double-click to open in application. What's new in v12 ------------ Added layout option tooltips [NRi]. Fixed layout popup button changing wrong graph [MKe]. Clicking on warning icon now opens Activity window [NRi, AM]. Revert menu item now disabled. Cheers, Glen Low --- pixelglow software | simply brilliant stuff www.pixelglow.com ...

Wrapping Tcl into Mac OS X executibles?
Hi guys. Well, I have three apps coming up to a v1.0 release soon and I'd like to release to the main platforms simultaneously. ActiveState's TclApp does me fine for creating stand-alone executibles for Windows and Linux. But Mac's the missing link. As mine are commercial apps, the ability to 'compile' the Tcl code to limit code snooping is essential for me. What are people currently using to convert their Tcl apps into Mac executibles? Cheers. Synic wrote: > Hi guys. > > Well, I have three apps coming up to a v1.0 release soon and I'd > like to release to the main platforms simultaneously. ActiveState's > TclApp does me fine for creating stand-alone executibles for Windows > and Linux. But Mac's the missing link. > > As mine are commercial apps, the ability to 'compile' the Tcl code to > limit code snooping is essential for me. What are people currently > using to convert their Tcl apps into Mac executibles? > > Cheers. > I wrap mine in a starpack and then put the whole thing in an application bundle. Or you can just organize the scripts into the application bundle itself. Mac OS X 10.4 comes with Tcl/Tk installed and includes tbcload, so you can even obfuscate your code. See http://tk-components.sourceforge.net/tk-bundle-tutorial/index.html for details. -- Kevin Walzer Poetic Code http://www.kevin-walzer.com In article <44E45991.1010107@kevin-walzer.com>, Kevin Walzer ...

PDF to EPS workarounds for Mac OS X Attention TeXy, TeXy peoples: PDF to EPS workarounds for Mac OS X Attention TeXy, TeXy peoples: PDF to EPS workarounds for Mac OS X Attention TeXy, TeXy
Attention TeXy, TeXy peoples: (excuse the mispronunciation; punny licence) It seems that Mac OS X has partially documented issues (http://altair.ific.uv.es/~JaxoDraw/Bugparade/bugparade.htm, http://developer.apple.com/java/faq/issues.html#anchor6) with the generation of EPS, and I'm trying to find a workaround. The Preview application cannot export to eps, but it can read it (converting it to PDF). If I use Adobe Acrobat to read the PDF generated by Preview, the EPS it generates sometimes (inconsistently) causes dvips to make an unreadable file. What I'm trying to do is the following: I made a large figure with about 50 images (EPS images generated by Mathematica, with labels) all in a nice 'tabular' array, using LaTeX and dvips. I'm too incompetent/lazy to center the image correctly, so I tell dvips to make an oversized output (30 cm by 30 cm) and then I crop it in Preview. Then, I save the image in Preview as a PDF, open the PDF in Acrobat, and export to EPS. Sometimes this works, but in this case, no. Sometimes if I open the EPS (again!) in Preview, save as PDF (again!), and convert to EPS from Adobe (again...) this makes a file that LaTeX, dvips, and Preview (or ghostview) happily process. I mention this not to impress all with my willingness to mindlessly tinker, but rather because it seems to hint that something toxic can be dropped/broken from the EPS with repeated reconversions. You've probably guessed that I should just place the large f...

[TCL/TK interface] Passing variable to TCL/TK
Hi, I am trying to sent to a variable to tcl/tk and unify there it with a string. I wrote the prolog code: :- use_module(library(tcltk)). :- use_package(classic). go(A):- tk_new([name('Simple')], Tcl), tcl_eval(Tcl, 'source simple2.tcl', _), tcl_eval(Tcl, ['ask', br(write(A))], _), tk_main_loop(Tcl), tcl_delete(Tcl). and the tcl file simple2.tcl proc ask {var} { unify_term $var my_value } unfortunatelly when I query for go(S). the interpeter goes into a loop (!?). Where I am wrong. Are there any example code somewhere i...

How I got Tcl/Tk working with Ruby on OS X
In case anyone is having trouble with this: Download the source for Tcl 8.4.16, Tk 8.4.16, and Ruby 1.8.6. Rename the source directories to tcl, tk, and ruby. cd tcl/macosx ../configure make >& make.log sudo make install cd tk/macosx ../configure make >& make.log sudo make install cd ruby ../configure --enable-tcltk-framework --with-tcltk-framework=/Library/ Frameworks --with-tcl-framework-header=/Library/Frameworks/ Tcl.framework/Headers --with-tk-framework-header=/Library/Frameworks/ Tk.framework/Headers --enable-pthread make >& make.log sudo make install Phil <...

Opening a TCL program from within another TCL program in ANSYS Tcl-Tk
Hi everyone, I have been pulling my hair with this one for a couple of days and still have not found a fix. I'm working within ANSYS Tcl-Tk implementation. I created a Tcl-Tk script that generates a simple window with three buttons. Each button opens another window which is created in a separate Tcl file. The second window have a lot of text entries, variables, procedures, etc. I can open the second Tcl file by itself and everything works as supposed, but when I open it using the button in the first window, it opens but any procedure called by the widgets on the second window are not found... Here's the deal... Since I'm working within the ANSYS implementation of Tcl-Tk, I'm actually using an ANSYS command to open the second window. The command I use is: ### ans_sendcommand ~eui,'source O:/mad_projects_2/ANSYS/Macros/ IBR_CAS.tcl' ### It actually sends a command back to ANSYS telling it to execute a Tcl command... I know this is not pretty but its the only way i was able to make it at least show the window. ############################## #Main Tcl (excerpt): ############################## namespace eval Tools { proc IBRCambpell {} { #source O:/mad_projects_2/ANSYS/Macros/IBR_CAS.tcl ans_sendcommand ~eui,'source O:/mad_projects_2/ANSYS/Macros/ IBR_CAS.tcl' } proc viewManager {} { ans_sendcommand ~eui,'source O:/mad_projects_2/ANSYS/Macros/ ViewManager.tcl' } proc powerAnnotation {} { ans_sendcommand ~eui,'source ...

compiling C extension on Mac -- which version Tcl on new Leopard
Hello, Are there any good examples of compiling C extensions on the Mac. I have seen examples on the wiki showing makefiles for Windows and Linux but the Mac examples uses one line gcc command. I got this example to work but I have multiple C files and would like to use a makefile to compile and link the source. Also, does anyone know what versions of Tcl and Tk come with the new Leopard OS? Thanks, On Oct 29, 11:03 am, chewie54 <dfabrizi...@gmail.com> wrote: > Also, does anyone know what versions of Tcl and Tk come with the new > Leopard OS? Unfortunately, it seems that it comes with the same version as Tiger (8.4.7). For more details and discussion, see this thread from the Tcl-Mac mailing list: http://www.nabble.com/%22Unified%22-windows-in-Leopard-tf4708484.html#a13459954 Jim chewie54 wrote: > Hello, > > Are there any good examples of compiling C extensions on the Mac. I > have seen examples on the wiki showing makefiles for Windows and Linux > but the Mac examples uses one line gcc command. I got this example > to work but I have multiple C files and would like to use a makefile > to compile and link the source. > > Also, does anyone know what versions of Tcl and Tk come with the new > Leopard OS? > > Thanks, > If your C extension is TEA-compliant, you can simply run "configure, make, make-install" -- see the wiki for some specific flags if you have non-standard installations. If...

Web resources about - what version Tcl and Tk comes with Mac OS X Leopard - comp.lang.tcl

Android version history - Wikipedia, the free encyclopedia
Global Android version distribution since December 2009. As of March 2014, Android 4.x Jelly Bean is the most widely used Android version, operating ...

Porsche is planning a hybrid version of the 911
Filed under: Green , Porsche , Convertible , Coupe , Future , Hybrid , Performance We've previously reported that Porsche thinks the 911 is a ...

World’s most popular version of Android is finally less than two years old
... update to the general public. Now, more than 16 months later, Lollipop has surpassed Android 4.4 KitKat to become the most widely used version ...

High school students take new version of SAT - Videos - CBS News
High schoolers got their first crack at the new version of the SAT. The idea behind the new test was to make it more fair for minorities and ...

LG's Super LCD TVs first with two versions of HDR, starting at $1800
They won't have the picture quality to match LG's OLED TVs, but the company's lineup of Super UHD LED LCD TVs will be the first to offer both ...

Suicide Squad: Margot Robbie Tried On Multiple Versions Of Harley Quinn Costume Including Court Jester ...
When the first images of Margot Robbie's Arkham-inspired Harley Quinn from Suicide Squad hit the [...]

Kaley Cuoco’s Version Of A Baseball Uniform Will Blow Your Mind
Kaley Cuoco’s Version Of A Baseball Uniform Will Blow Your Mind

Hitman deal: Take a 25 percent hit on the PC version for release week
... PC digital copy with the code listed below. It'll run through March 14 (a few days after release) and cuts the Hitman - Full Experience version ...

Lollipop becomes the most popular version of Android
... there's a new flavor of Android on top of the heap. Google has published updated stats which show that Lollipop is now the most-used version ...

Marco Rubio, The Presenter, Version 4.0
Senator Marco Rubio, Donald Trump, Senator Ted Cruz, and Governor John Kasich during the CNN Republican Presidential Debate 3/10/2016 in Miami, ...

Resources last updated: 3/13/2016 1:42:04 PM