f



Debugger problem?

Hello,
  Is there any word on whether the Debugger() call has a bug in 8.3?  It
doesn't stop where you put the call--it stops outside of the function, and
so relevant variables are not accessible.  This is bad, especially if you
are trying to teach programming with CW.

Bint


0
Bint
9/16/2003 4:03:47 PM
comp.mac.codewarrior 2568 articles. 0 followers. ja7789 (3) is leader. Post Follow

1 Replies
451 Views

Similar Articles

[PageSpeed] 40

In article <BB8C9E92.C266%juliosity@igf.com>, Bint <juliosity@igf.com> 
wrote:

>   Is there any word on whether the Debugger() call has a bug in 8.3?  It
> doesn't stop where you put the call--it stops outside of the function, and
> so relevant variables are not accessible.  This is bad, especially if you
> are trying to teach programming with CW.

Others have reported this... I believe MW has reproed it also.
0
Sean
9/17/2003 12:33:02 AM
Reply:

Similar Artilces:

debugger problem and other problem
Hi all! I gave it another try to upgarde from 1.0.1 to 1.2.1 from CVS (Rev. 6469). My system: Linux Debian Lenny, kernel 2.6.24. Problems: 1. the classical debugger doesn't show the code. First I thought it could be a color problem, but it isn't. Changing the color doesn't help. You can find a screenshot at http://www.apw-wiegand.de/apwlin/debugger.png. As you can see the debugger finds the code file and shows the line number where it actually is, but doesn't show the code. In 1.0.1 the debugger was functioning. 2. I read several times in the newsgroup that others have the...

CodeWarrior 9.3 Debugger Problems
Hi, I'm writing a Photoshop PlugIn. I am using CodeWarrior 9.5 and running on a G5/1.5GB, Dual Processor, Under Tiger. After applying the CW 9.5 update I can now build (this project builds a Mach-O binary) the sample PlugIn that comes with the Adobe SDK. I would now like to put a breakpoint into the plug in and set thru the code. In CodeWarrior I set the "Host Application for Libraries & Code Resources" to point to the Photoshop application (In the case Photoshop CS2), but when I try to run from the debugger I get the error message: "Can't fin...

problems problems problems
(The short(?) summary) I've got an Access MDB file and a DAO connect with it.. Problem 1 of 2 The below gives me a runtime error 91 Object variable or With block variable not set. I've got the db stuff after the form.show (to make sure all the objects on the form are loaded before attempting to utilize/manipulate them) But it doesn't like it when I use the data object in the form load anyway for some reason.. pffft. Private Sub Form_Load() frmTest1Project.Show datGallery.Recordset.MoveLast datGallery.Recordset.MoveFirst Call LockTextBoxes(frmTest...

problem with debugger under Mac OS 10 with code warrior 10
Hello, I changed my program and included MWMacOSCOM in order to use SysAllocString. During the debug startup, I get the following error message. The application "(null)" could not be launched because of a shared library error: "<TestLic><MWMacOSCOM><IDE_MSL><>" I looked into the MWMacOSCOM, i included the "MSL_All_Carbon_D.Shlb.xSYM" into debugging and the corresponding shared library into the code. The necessary 14 symbols fro; MWMacOSCOM pointing to IDE_MSL are exportet from MSL_All_Carbon_D.Shlb. Is there another I...

Mac-to-Mac Keyboard Mapping Problem
I need to control in iMac remotely from a MacBook. In general, the solution using VNC (Remote Desktop or VineServer + Chicken) is exactly what I need. But... Both systems are equipped with German keyboards. And VNC does not support the special characters, umlauts and so on. Even entering a semicolon becomes a serious problem. Has anybody experience in making a VNC connection working correct also for non-US keyboards? From watching around in newsgroups Apple themselves with their own RDC have a solution so it should be possible via VNC. The Apple RDC is simply too expensive for me - USD...

problem in wxMac 2.6.2 unicode mach-o build using Codewarrior 8.3 on Mac OS 10.3
Hi, I am getting the following error while compiling wxMac 2.6.2, wxLib Mach-o(debug/release) build with wxUSE_UNICODE flag set to 1 I am using Codewarrior 8.3 on Mac OS 10.3 Error : type mismatch 'wxMBConvUTF16BE' and 'wxMBConv' dobjcmn.cpp line 283 return format == wxDF_UNICODETEXT ? sUTF16Converter : (wxMBConv&) wxConvLocal; Can someone throw some light on this issue and let me know whether it is a wxMac issue or i am making some mistake in setting the flags for unicode build. Any suggestions or workaround will be highly appreciated. The only cha...

MDI on mac
------_=_NextPart_001_01C755D1.B10C7B14 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: quoted-printable Hi, WX: 2.8.1 OS: Mac OS-X, Carbon app Compiler: XCode 2.4.1 using GCC 4.0.1 I already posted this question and got no help. I tried looking at this further, and I still can't figure out what I'm doing wrong. I'm a WX newbie, so I hope I'm not wasting anyone's time with a stupid question. I've tried a lot of things to solve this, and tried the forums as well, and so far it hasn't helped. I've encounter...

about debugger problem
hai, in Vxworks, i try to launch debugger,but it is showing one exception problem. all other tools in the tools menu are working fine,except debugger. in that exceprion, it can show error in tornado.exe file .i am unable to send that log file. in that it can show some of the registers.it can show errot in tornado.exe. i reinstalled twise, then aslo i am getting same problem always. .. Hi your question is incomplete. what kind of exception it is showing. and are u doing target level debugging, or trying to debug a code which is running on the simulator with Regards ...

debugger problem
I've got a problem writing a debugger. The debugging process won't get notificated, and the debug process won't show up, although it is running in task-manager. Any idea what I did wrong? BTW: I use mingw for the program and VS ..net for the debugger program. But that's not a problem, is it? // --------------------------------------------------------------- // // This is the debugger code // --------------------------------------------------------------- // BOOL CSampleView::DebugProgram(LPCTSTR lpPathName, LPCTSTR lpComdLine) { DEBUG_EVENT DebugEv; DWORD dwCo...

Problems with debugger.
Hi I'm having trouble with the debugger on three fronts. First the version of ruby I am using is: ruby 1.8.2 (2004-12-25) [i386-mswin32] If I start the debugger from the command line I get this message: bash-3.00$ ruby -rdebug ListDir.rb Debug.rb Emacs support available. i:/programs/scripting/ruby/lib/ruby/site_ruby/1.8/ubygems.rb:4:require 'rubygems ' When I ask for a listing it has stopped on the line: require 'rubygems' In Emacs (v 21.4.1) running rubydb I get a prompt but no output: untill I type the command quit. Then I see the output of the entire session. F...

Debugger Problems
I recently purchased a copy of CodeWarrior Learning Edition v4. It works well mostly, even though it's slighty more limited that I would like. The thing in CodeWarrior I've been having problems with is the debugger. Whenever I try to debug something, CodeWarrior crashes. The problem is 100% reproducable. I've looked at http://groups.google.com/groups?threadm=20030427093158.25304.00000126@mb- m23.aol.com and http://groups.google.com/groups?threadm=9c6fb850.0306300706.f10989f@posti ng.google.com but the solutions have not helped. When I try to run CW8_GDB.bin ...

Debugger problems
Hello I am having some problems with the debugger in RHIDE. Whenever I set a break point and try to run the program I get the following message: "This program has no usable debugging information. Try to compile it with the -g switch." The -g switch *is* set, no optimizers are set and the project compiles just find. RHIDE version: 1.5 Debugger version: 5.3 DJGPP version: 2.03 GCC version: 3.2.2 Running under Win98. I hope anyone can give me some help on this matter. Thanks in advance. /Locke Magnus Malm <temp_locke@hotmail.com> wrote: : I am having some problems with t...

Mac I have a problem....
My son is handicapped and a local group gave him a PowerMac G3 running OS 9.1. Only hardware - no disks. I am trying to set his Mac on a wireless house network. The other two machines or PCs. But, when I tried to install the wireless USB adapter a window popped up and said the USB port had the wrong software. It requires 1.4.2 or higher, and this machine has only 1.4.1. I tried downloading a fix but that requires inserting the Install OS 9.1 disk - which I do not have. Anyway around this problem short of having to buy a full install disk? Or, does anyone have that OS they would be willing t...

Web resources about - Debugger problem? - comp.mac.codewarrior

Debugger - Wikipedia, the free encyclopedia
... , but its sources remain unclear because it lacks inline citations . Please improve this article by introducing more precise citations. A debugger ...

Debugger - Facebook-Entwickler
Facebook-Entwickler Search Facebook Developers Dokumente Werkzeuge Hilfe Neuigkeiten Anwendungen Anmelden Debugger Startseite › Werkzeuge Input ...

Script Debugger 5.0
Major update to one of my favorite apps of all time. If you dick around with AppleScript, you should have Script Debugger.

Review: 5 memory debuggers for Linux coding
When you're working in Linux, manually debugging memory-related errors can be difficult and time consuming. These five tools can help.

Android Studio 1.2 Reaches Beta, Adds Built-In Decompiler, Inline Debugger Variables, Smarter Formatting ...
When Android Studio v1.1 entered the Stable channel, about 6 weeks ago, the Dev Tools team gave word that v1.2 was already well underway and ...

Review: 5 memory debuggers for Linux coding
As a programmer, I'm aware that I tend to make mistakes and why not? Even programmers are human. Some errors are detected during code compilation, ...

Meet the DeBuggers An attitude adjustment regarding the "Fix" at Healthcare.gov
Let me start off by saying that Healthcare.gov is now working well in most areas of the US. Folks are accessing the site all day, every day, ...

Resolving Nightmare Bugs With Reversible Linux App Debugger
Undo and ARM partner on ARM DS-5 tool suite rapidly resolve nightmare bugs

Bed bugs: A new debugger - The Economist
FEW things destroy the reputation of a high-class hotel faster than bed bugs.

Genuitec Launches Debugger for PhoneGap, Apache Cordova
Genuitec ships GapDebug, a new debugger for developers building PhoneGap and Apache Cordova apps.

Resources last updated: 1/28/2016 4:24:10 AM