f



mail::sendmail (SOMETIMES) get "bad file descriptor" error when mail not local

I have a leased Linux box that I installed mail::Sendmail on using
CPAN

I'm using a perl script to send mail.  I have a domain on that server
and I get my personel email at that address.

The script works fine when I am using my own email address as the
recipient, but when I try to send to any other domain I get, for
example,

"sendmail failure sending to somebody@otherdomain.org Bad file
descriptor"


I don't have this problem with by Linux box at home and I thought I
configured it the same way.  (I just let CPAN do it's thing)

I noticed that there is a soft link to qmail on the remote server, but
it was my understanding that mail::Sendmail is independant of other
mail programs.

Is there some configuration file I can change to solve this problem?

Anyone have any ideas?

Thanks,

Dave



0
dave49 (12)
8/24/2003 7:16:57 PM
comp.mail.sendmail 13518 articles. 1 followers. jfretby (35) is leader. Post Follow

1 Replies
1802 Views

Similar Articles

[PageSpeed] 25

Dave Roberts wrote:
> I have a leased Linux box that I installed mail::Sendmail on using
> CPAN
> 
> I'm using a perl script to send mail.  I have a domain on that server
> and I get my personel email at that address.
> 
> The script works fine when I am using my own email address as the
> recipient, but when I try to send to any other domain I get, for
> example,
> 
> "sendmail failure sending to somebody@otherdomain.org Bad file
> descriptor"
> 
> 
> I don't have this problem with by Linux box at home and I thought I
> configured it the same way.  (I just let CPAN do it's thing)
> 
> I noticed that there is a soft link to qmail on the remote server, but
> it was my understanding that mail::Sendmail is independant of other
> mail programs.
> 
> Is there some configuration file I can change to solve this problem?
> 
> Anyone have any ideas?
> 

One idea. That this is a perl problem and not a sendmail problem. Why? 
Because sendmail is not a perl module it is a standalone MTA. Your perl 
code interfaces to it. Plus the error you got is definately a perl 
message. My guess is that you have declared something improperly in your 
perl program.


0
gerry4556 (147)
8/25/2003 1:41:12 AM
Reply:

Similar Artilces:

"Microsoft ESMTP MAIL Service" misleading the Sendmail by BODY=7BIT in "mail from"
Hello. I ran into a situation where the Sendmail deceived by the Microsoft ESMTP MAIL Service. MS ESMTP Service send to Sendmail MAIL FROM:<system@gosuslugi.ru> SIZE=12345 AUTH=<> BODY=7BIT but message is not 7BIT. It contain MIME-Version: 1.0 Content-Type: multipart/mixed; boundary="--2f2da5fd4e757bb09dce3cc4fd3fda88" Content-Transfer-Encoding: 7bit in header, but ----59b9b79d39a2fcdcd7600d2d20592b5a Content-Type: text/html; charset="utf-8" Content-Transfer-Encoding: 8bit in some parts and real text in utf8. Sendmail loses one bit. :-(...

Sendmail: mails rejected with "550-unrouteable mail domain "blade150.lafr.de""
mails sent from my Sun Blade 150 (Solaris 9) via sendmail are rejected by the destination mail server with message shown above in the subject line. My sendmail.mc file look like this: divert(0)dnl VERSIONID(`@(#)main.mc 1.5 (Sun) 08/10/00') OSTYPE(`solaris8')dnl DOMAIN(`solaris-generic')dnl FEATURE(`allmasquerade') MASQUERADE_AS(lafr.de)dnl MAILER(`local')dnl MAILER(`smtp')dnl I put in the domain name "lafr.de". I thought this will change user@host.domain.de to user@domain.de. But it seems that I am missing something else. Who can help me ? Regards - F...

Difference between "mail" and "sendmail"
What is the basic difference between "mail" ad "sendmail"? I tried both in the following ways mail [emailid] <filename1 sendmail -t -i <filename2 for mail, filename1 contains the body of the mail for sendmail,filename2 contains all the headers including to,from,subject,contenttype etc. When I was testing both the above to send mails to yahoo account, I could find that "mail" is able to send 30-40 mails per second, but for sendmail, it's taking 30-40 seconds for 1 email to be sent. When I did strace in both cases I found that after sending data to DNS...

Switch off the "Mail delivery failed: returning message to sender" mail from sendmail ?
Hello ! Now i have here a little freebsd 6.3 server. This server receive and send my lokal and worldwide emails. When this server receive a mail with unqualified local user sendmail automatic generate the mail that says "Mail delivery failed: returning message to sender". Somewhere spam known now that this mail adress has a reciving server and can probe other names before @ ? My ideas now is the feature switched off and no generate this ugly mail ? The mail with unqualified username can delete now ? Can somwhere help me to find the right option in my *.mc sendmail configuration fi...

Sendmail authentificates, client cann still send mails with fake "Mail From:" tag
hello, i've just finished my first AUTH sendmail configuration, client cann authentificate himself via LOGIN/PLAIN with TLS. I've noticed though that sendmail doesn't pose any restraints regarding the mail from: tag. lets say my domain is test.de, my loginname ist alex now i cand send mails from arbitrary name@ test.de...actually from arbitrary name @ arbitrary domain :) Am i missing something here ? what i would like is: user authentificates -> he is allowed to send mail only with the prior stipulated address (his address) Thanks! Regards, Alex alexThor wrote: > hell...

Problem using the "nail" or the "mail" command to receive E-mail. HELP!!!
Using the "nail" or the "mail" command to send and receive E-mail. Examine this line: ls -a ~ | nail -a .mailrc -A autosend -s "Dis be a tess" dock@technologist.com I have been using this line at a command prompt to send an E-mail with the subject line "Dis be a tess" using my E-mail account back to my E- mail account. What this particular line does is: list the directory using the "ls" command. It then pipes the output from the "ls" command to a "nail" command. The parameters in the "nail" command a...

E-mail Aliases in "Mail"
Suppose that my on-line store, mystore.com, sell hats and gloves. The company that hosts my site has assigned the e-mail address (and user name) mystore@mystore.com to this account. But they will forward mail addressed to anynamewhatsoever@mystore.com; in other words, they allow me to use an unlimited number of e-mail aliases. That way, a person who wants to enquire about a hat can e-mail hats@mystore.com and a person who is interested in gloves can e-mail gloves@mystore.com. Filters in "Mail" will sort the messages into the appropriate mailboxes for my convenience. The problem is t...

Welcome to the "Mails" mailing list
Thanks for Joining www.freehotlinksdirectory.com Welcome to the Mails@freehotlinksdirectory.com mailing list! To post to this list, send your email to: mails@freehotlinksdirectory.com General information about the mailing list is at: http://freehotlinksdirectory.com/mailman/listinfo/mails_freehotlinksdirectory.com If you ever want to unsubscribe or change your options (eg, switch to or from digest mode, change your password, etc.), visit your subscription page at: http://freehotlinksdirectory.com/mailman/options/mails_freehotlinksdirectory.com/python-list%40pytho...

Apple Mail "no mail" sound
When I check my mail manually and I have no mail, I get a high-pitched shrieky alert sound. I have no idea where it came from, because the sound isn't even in my list of sounds (System Preferences/Sound). I can get rid of it by unchecking "play sounds for other mail actions" in Mail preferences, but I'd prefer not to. It seems like this sound started happening after I installed Skype. But Skype doesn't have that sound in its sound choices either. Anyone have a clue? In article <nosredna-61A454.22043129012006@news.isp.giganews.com>, nosredna <nosredna@susc...

Apple Mail; mail doesn't get to server to be "saved"
I'm still one of those increasingly few AOL users (got kids). Have had the account since '95. Anyway, when I got cable access at work, I decided to use my Mac Mini in the office to not only access my work email, but also the AOL account which I use at home for personal stuff. Running Tiger 10.4.7 and Apple Mail on both systems (G4 at home). Things worked fine for months; I simply configured the Mail application to access my office mail server and also my AOL account, which is IMAP. I only use AOL at home. When I use Mail at work, I still get all of my normal AOL mail. I think that wha...

Mail.app
If I select several messages in Mail (v 6.0 in Mountain Lion), the batch of selected messages animates into a "stack" on top of the message viewing area. Nifty animation much like that on iOS. If I then move that collection of messages, say, into another mail folder, usually that's that - the "stack" zips off down into the folder and is gone and my mail view is back to normal. Sometimes - and this seems to happen about once a day - after I drag the batch of messages over, the image of the stack remains. Mail continues to otherwise work normally - i...

iBook and Mail, no "send mail" sound
A friend of mine has a white iBook (G3, I think, running Panther). She has always liked the "whoosh" sound of mail being sent from Apple Mail, but she said it disappeared after some geek relatives were visiting for the holidays (maybe just a coincidence). The file that causes the sound, "Mail Sent.aiff," accessible by viewing Mail's package contents, is definitely in her Mail app, andn other sounds are working fine in all applications. Another issue that might be related: She has never done any maintenance (with Disk Utility or something like MacJanitor), and ne...

"Check Mail" button does not check mail.
Very strange problem on my friend's computer. His system is a HP computer running W7 home version, has used Eudora for years without problems. I was (successfully) fixing the GMail untrusted certificate error when this problem occurred: Clicking the "Check Mail" toolbar icon does not check mail. Using menu item File>Check Mail does not check mail. Using the personalities window, R clicking "Dominant" & check mail DOES work. I tried, in this order: Reboot the machine. Turning off MS Security essentials. Created a restore point & re-installed Eudora....

when i open my mail application I get this:The POP server "mail.mac.com" rejected the password for user
When I open my mail application I get this:The POP server "mail.mac.com" rejected the password for user. Then I type in my password, but nothing happens. I get the same message again. So I went into my account and .mac under system preferences and retyped my password, also went onto .mac on server and did the same. Still get the same message. I can access my mail on the web server but not off my desktop application. Help! Thanks. If you're using the native Mail app., in accounts there is a request for User Name under incoming mail server. A lot of pop accounts want you to...

Sendmail running milters before "accepting" mail?
Is there any way to configure Sendmail so that milters like SpamAssassin and MIMEdefang get executed the moment a message is delivered, but before it is accepted? For example, I would like my SMTP to be able to do this: DATA Subject: Hi, I'm spam! From: thespammer@thespammersdomain.com To: me@mydomain.com To make money fast, click visit www.gulliblefools.com . 550 Message rejected (SpamAssassin says it is spam) Or: DATA Subject: Hi, I'm malware! From: thetrojanwriter@thetrojanwritersdomain.com To: me@mydomain.com To make money fast, open this a...

"Unreal" mail users in Sendmail+OpenLDAP
Hi everyone, I have FreeBSD 5.4, sendmail+tls+sasl2+ldap-8.14.0, openldap-2.3.34. Everything works fine BUT... PROBLEM. --- I don't want to create mail users in the system. I'd like to have all of them in one LDAP database. --- How messages will go i.e. to one /var/spool/mail or should I create real directories to every each of mail users? --- What schema should I use? --- I'd like to see an example of "fake" mail users LDIF file. --- Is there any specific configuration of Sendmail and OpenLDAP except standard ones in this special case? Please help me realize this idea?...

Read mails are not moved from "New mail" in IMAP
Mails are not moved from my "INBOX" of an IMAP account to the selected folder on this account. IMAP Settings: "Make this definition INBOX folder as default new mail folder" is checked. Options: "Allow read meassages to stay in new mail folder" is unchecked "Name for default mail folder" is "Read" (folder of the IMAP account). Any ideas? Dieter ...

Vexira ALERT [your mail: "Re: Mail Authentification"]
* * * * * * * * * * * * * * * Vexira ALERT * * * * * * * * * * * * * * * This version of Vexira MailArmor is licensed and full featured. Vexira has detected the following in a mail from your address: Worm/NetSky.P The mail was not delivered. Your computer may be infected with a virus! Please visit Central Command at http://www.centralcommand.com and obtain a copy of Vexira AntiVirus now. Mail-Info: --8<-- From: python-list@python.org To: arronandhollie@beaufortco.com Date: Thu, 26 Aug 2004 12:30:13 -0400 Subject: Re: Mail Authentification --8<-- ...

how to delete "outgoing mail server" in Mail prefs
I've switched service providers and I want to erase the old information from the "outgoing mail server" list in the Mail.app preference file. The pop-up menu only offers the option of adding servers, not deleting them. I know there's a way to do this because I did it before, but I've forgotten how. Can someone point me in the right direction? Thanks -- d49ot In article <klMwb.84198$sU6.1650034@weber.videotron.net>, d49ot <d49ot@invalid.invalid> wrote: > I've switched service providers and I want to erase the old > information from ...

Mail's "New Mail Sound"
I have a lot of filters set up, so I don't get much spam. The problem is that Mail insists on playing the "New Mail" sound even when a message has been filtered and does not arrive in the "In" box. So is there some way to get Mail to play the sound *only* when there's actually something worth looking at? Isaac In article <isw-677AA5.12353103012011@[216.168.3.50]>, isw <isw@witzend.com> wrote: > I have a lot of filters set up, so I don't get much spam. The problem is > that Mail insists on playing the "New Mail" so...

Sendmail keeps rejecting my mails "Domain not found"...
Hello everyone, Ok, my problem is as follows: I keep getting this error message when trying to send mail ************* The original message was received at Wed, 20 Dec 2006 15:16:08 -0600 from localhost.localdomain [127.0.0.1] ----- The following addresses had permanent fatal errors ----- <xxx@sunset.com.mx> (reason: 550 <root@vader.sunset.com.mx>: Sender address rejected: Domain not found) ----- Transcript of session follows ----- .... while talking to akenaton.sunset.com.mx.: >>> DATA <<< 550 <root@vader.sunset.com.mx>: Sender address reject...

sendmail/cyrus accepts mails for "unknown users"
Hi, the info-cyrus maillingliste told me to place my question here: I'm runnung sendmail 8.12.3 (Debian woody standard package) with cyrusv2mailer (cyrusv2.m4,v 1.1 2002/06/01) and cyrus 2.1.17 (backport from http://people.debian.org/~hmh/). Today I had a heavy spam attack caused by the fact, that sendmail accepts mails for non existing users (all addresses are defined in aliases or virtusertable). Emails those unknown accounts on local domains (local-host-names) will be accepted and than(!) bounced. Is there a way to stop/reject these mails at "rcpt to: user unknown"-point?...

"An error occurred with a temporary file while transferring your mail."
I'm getting plagued with virus laden emails that cause Eudora to hang, giving me the message of "An error occurred with a temporary file while transferring your mail." I'm having to go into the webmail interface to my email account several times an HOUR to delete the problem messages so that the rest of the email can be downloaded. I've been getting virus laden emails for several weeks without Eudora hanging on them, so this is a new problem. Does anyone have a FIX for it rather than a crappy work-around (using webmail to delete the offending email). Despite many years of using Eudora and many GBs of archived email in Eudora mailbox format, I'm about ready to dump Eudora and go back to a shell email client that doesn't barf on attachments (virus laden or not) and doesn't infect my messages with HTML and "format flowed". jc ...

Moving Mail from "Trash" to "In"
I am using Eudora 5.2.0.9 (Paid) on a Windows ME system. Sometimes I find mail is sent to "Trash" that does not belong there. Normally, all I have to do to save this mail is to highlight it and drag it to the "In Box." This procedure usually works fine. On occasion, however, when I check the contents of the "In Box" following the drag & drop procedure, the mail cannot be found even after a totally thorough search! And, of course, the mail is no longer in the "trash." What is the solution? Am I doing something wrong? Also, please don't think that I may have mistakenly dragged the item back to "Trash," (a procedure which will indeed delete the highlighted message). Keith "Norman K. Hester" <ks9c@itis.com> wrote: >I am using Eudora 5.2.0.9 (Paid) on a Windows ME system. > >Sometimes I find mail is sent to "Trash" that does not belong there. >Normally, all I have to do to save this mail is to highlight it and drag >it to the "In Box." This procedure usually works fine. > >On occasion, however, when I check the contents of the "In Box" >following the drag & drop procedure, the mail cannot be found even after >a totally thorough search! And, of course, the mail is no longer in the >"trash." > >What is the solution? Try highlighting, right-clicking, and using Transfer to move the ema...

Web resources about - mail::sendmail (SOMETIMES) get "bad file descriptor" error when mail not local - comp.mail.sendmail

Resources last updated: 2/26/2016 6:07:36 AM