f



./configure problem

hi!
I'm trying to compile karamba for a rh8.0, but ./configure gives this error:

configure:21805: error: Qt (>= Qt 3.0) (library qt-mt) not found. Please
check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!

I do have these lib in /usr/lib/qt-3.1/lib. All paths are ok.

What's going on? Why doesen't it find them? 

Thanx!
0
7/13/2003 11:07:28 PM
comp.os.linux.misc 33599 articles. 0 followers. amosa69 (78) is leader. Post Follow

9 Replies
541 Views

Similar Articles

[PageSpeed] 41

On Sun, 13 Jul 2003 23:07:28 +0000, tudor wrote:

> hi!
> I'm trying to compile karamba for a rh8.0, but ./configure gives this error:
> 
> configure:21805: error: Qt (>= Qt 3.0) (library qt-mt) not found. Please
> check your installation!
> For more details about this problem, look at the end of config.log.
> Make sure that you have compiled Qt with thread support!
> 
> I do have these lib in /usr/lib/qt-3.1/lib. All paths are ok.
> 
> What's going on? Why doesen't it find them? 

Perhaps because you did not specify --with-qt-dir=/usr/lib/qt-3.1??

Try ./configure --help

0
daveuhring (1185)
7/13/2003 11:12:09 PM
tudor wrote:

> I'm trying to compile karamba for a rh8.0, but ./configure gives this
> error:
> 
> configure:21805: error: Qt (>= Qt 3.0) (library qt-mt) not found. Please
> check your installation!
> For more details about this problem, look at the end of config.log.
> Make sure that you have compiled Qt with thread support!

So did you look into the config.log ? Most likely you will find the cause of
the error there. Do you have the qt dev package installed ? You need it as
it contains the header files in the include subdirectory. Or you have Qt
but not Qt-mt (multi thread support). The error message suggests this.

Eggert

0
7/14/2003 1:08:16 PM
Dave Uhring wrote:

> On Sun, 13 Jul 2003 23:07:28 +0000, tudor wrote:
> 
>> hi!
>> I'm trying to compile karamba for a rh8.0, but ./configure gives this
>> error:
>> 
>> configure:21805: error: Qt (>= Qt 3.0) (library qt-mt) not found. Please
>> check your installation!
>> For more details about this problem, look at the end of config.log.
>> Make sure that you have compiled Qt with thread support!
>> 
>> I do have these lib in /usr/lib/qt-3.1/lib. All paths are ok.
>> 
>> What's going on? Why doesen't it find them?
> 
> Perhaps because you did not specify --with-qt-dir=/usr/lib/qt-3.1??
> 
> Try ./configure --help

No, not because o that.
0
7/15/2003 6:44:36 AM
Eggert Ehmke wrote:

> tudor wrote:
> 
>> I'm trying to compile karamba for a rh8.0, but ./configure gives this
>> error:
>> 
>> configure:21805: error: Qt (>= Qt 3.0) (library qt-mt) not found. Please
>> check your installation!
>> For more details about this problem, look at the end of config.log.
>> Make sure that you have compiled Qt with thread support!
> 
> So did you look into the config.log ? Most likely you will find the cause
> of the error there. Do you have the qt dev package installed ? You need it
> as it contains the header files in the include subdirectory. Or you have
> Qt but not Qt-mt (multi thread support). The error message suggests this.
> 
> Eggert

Yes, qt-devel is installed. I just can't understand why it doesen't find
them.
0
7/15/2003 6:46:46 AM
On Tue, 15 Jul 2003 tudor wrote:
>Eggert Ehmke wrote:
>> tudor wrote:
>>
>>> I'm trying to compile karamba for a rh8.0, but ./configure gives this
>>> error:
>>>
>>> configure:21805: error: Qt (>= Qt 3.0) (library qt-mt) not found.
>>> Please check your installation! [...]
>>
>> So did you look into the config.log ? Most likely you will find the
>> cause of the error there. Do you have the qt dev package installed ?
>> You need it as it contains the header files in the include
>> subdirectory. Or you have Qt but not Qt-mt (multi thread support).
>> The error message suggests this.
>
>Yes, qt-devel is installed. I just can't understand why it doesen't
>find them.

You still haven't answered his query : do you have libqt-mt? See

# locate qt-mt
/usr/lib/qt-3.1/lib/libqt-mt.so.3.1.1
/usr/lib/qt-3.1/lib/libqt-mt.so.3
/usr/lib/qt-3.1/lib/libqt-mt.so.3.1
/usr/lib/qt-3.1/lib/libqt-mt.so

The last 3 are symlinks to the first.

# rpm -qf /usr/lib/qt-3.1/lib/libqt-mt.so.3.1.1
qt-3.1.1-6

V.
0
7/15/2003 7:32:56 AM
On Tue, 15 Jul 2003 tudor wrote:
>Dave Uhring wrote:
>> On Sun, 13 Jul 2003 23:07:28 +0000, tudor wrote:
>>
>>>
>>> configure:21805: error: Qt (>= Qt 3.0) (library qt-mt) not found.
>>> Please check your installation! [...]
>>>
>>> I do have these lib in /usr/lib/qt-3.1/lib. All paths are ok.
>>>
>>> What's going on? Why doesen't it find them?
>>
>> Perhaps because you did not specify --with-qt-dir=/usr/lib/qt-3.1??
>>
>> Try ./configure --help
>
>No, not because o that.

That should have fixed it. Basically, it's trying to find lib and
include paths and above directive gives the root path for qt with which
it is supposed to add /lib and /include. However, you try this

../configure --help
[snipped]

  --with-qt-dir=DIR       where the root of Qt is installed
  --with-qt-includes=DIR  where the Qt includes are.
  --with-qt-libraries=DIR where the Qt library is installed.

../configure --with-qt-includes=/usr/lib/qt-3.1/include
            --with-qt-libraries=/usr/lib/qt-3.1/lib

Put the above in one single line. And yeah, I have

# cat /etc/ld.so.conf
/usr/lib/qt-3.1/lib

Put that in the file and run 'ldconfig'. Tho this isn't necessary for
compiling.

Gl.
V.
0
7/15/2003 7:34:54 AM
tudor wrote:

> hi!
> I'm trying to compile karamba for a rh8.0, but ./configure gives this
> error:
> 
> configure:21805: error: Qt (>= Qt 3.0) (library qt-mt) not found. Please
> check your installation!
> For more details about this problem, look at the end of config.log.
> Make sure that you have compiled Qt with thread support!
> 
> I do have these lib in /usr/lib/qt-3.1/lib. All paths are ok.
> 
> What's going on? Why doesen't it find them?
> 
> Thanx!

1. Check that library in question is there.
2. Check that header fils are in place.
3. Set the QTDIR variable like "export QTDIR=/location/of/the/library".     
4. Add the path to the /etc/ld.so.conf (it should be there anyway) or set   
   the LD_LIBRARY_PATH variable. 
5. Run  ldconfig as root.
6. If it doesn't work by now try passing the options to configure script
   specifying the path to the library and the headers.
7. If it doesn't work by now - check the configure script if you have the
knowladge

Cheers.
0
blah-blah (6)
7/15/2003 11:34:50 AM
Vwakes wrote:

> On Tue, 15 Jul 2003 tudor wrote:
>>Eggert Ehmke wrote:
>>> tudor wrote:
>>>
>>>> I'm trying to compile karamba for a rh8.0, but ./configure gives this
>>>> error:
>>>>
>>>> configure:21805: error: Qt (>= Qt 3.0) (library qt-mt) not found.
>>>> Please check your installation! [...]
>>>
>>> So did you look into the config.log ? Most likely you will find the
>>> cause of the error there. Do you have the qt dev package installed ?
>>> You need it as it contains the header files in the include
>>> subdirectory. Or you have Qt but not Qt-mt (multi thread support).
>>> The error message suggests this.
>>
>>Yes, qt-devel is installed. I just can't understand why it doesen't
>>find them.
> 
> You still haven't answered his query : do you have libqt-mt? See
> 
> # locate qt-mt
> /usr/lib/qt-3.1/lib/libqt-mt.so.3.1.1
> /usr/lib/qt-3.1/lib/libqt-mt.so.3
> /usr/lib/qt-3.1/lib/libqt-mt.so.3.1
> /usr/lib/qt-3.1/lib/libqt-mt.so
> 
> The last 3 are symlinks to the first.
> 
> # rpm -qf /usr/lib/qt-3.1/lib/libqt-mt.so.3.1.1
> qt-3.1.1-6
> 
> V.
all there!
0
7/15/2003 10:00:18 PM
Vwakes wrote:

> On Tue, 15 Jul 2003 tudor wrote:
>>Dave Uhring wrote:
>>> On Sun, 13 Jul 2003 23:07:28 +0000, tudor wrote:
>>>
>>>>
>>>> configure:21805: error: Qt (>= Qt 3.0) (library qt-mt) not found.
>>>> Please check your installation! [...]
>>>>
>>>> I do have these lib in /usr/lib/qt-3.1/lib. All paths are ok.
>>>>
>>>> What's going on? Why doesen't it find them?
>>>
>>> Perhaps because you did not specify --with-qt-dir=/usr/lib/qt-3.1??
>>>
>>> Try ./configure --help
>>
>>No, not because o that.
> 
> That should have fixed it. Basically, it's trying to find lib and
> include paths and above directive gives the root path for qt with which
> it is supposed to add /lib and /include. However, you try this
> 
> ./configure --help
> [snipped]
> 
>   --with-qt-dir=DIR       where the root of Qt is installed
>   --with-qt-includes=DIR  where the Qt includes are.
>   --with-qt-libraries=DIR where the Qt library is installed.
> 
> ./configure --with-qt-includes=/usr/lib/qt-3.1/include
>             --with-qt-libraries=/usr/lib/qt-3.1/lib
> 
> Put the above in one single line. And yeah, I have
> 
> # cat /etc/ld.so.conf
> /usr/lib/qt-3.1/lib
> 
> Put that in the file and run 'ldconfig'. Tho this isn't necessary for
> compiling.
> 
> Gl.
> V.
yes, --with-qt-includes helped. It found qt-mt. 
Thank you so much for your help!
Thanx everybody!
0
7/15/2003 10:10:26 PM
Reply:

Similar Artilces:

./configure problem (linux)
Trying to compile MyODBC on my RH 9 system. Running ./configure with directions given to mysql/lib, mysql/include, mysql/src I get the following error: gcc -o conftest -g -O2 conftest.c -lmysqlclient -L/usr/local/mysql/lib -lz 1>&5 /usr/local/mysql/lib/libmysqlclient.a(my_malloc.o)(.text+0x28): In function `my_malloc': : undefined reference to `errno' /usr/local/mysql/lib/libmysqlclient.a(my_realloc.o)(.text+0x65): In function `my_realloc': : undefined reference to `errno' /usr/local/mysql/lib/libmysqlclient.a(my_lib.o)(.text+0x2e1): In function `my_dir': : und...

problems in linux install and hardware configuration
I have installed Red Hat Linux 4.0 Enterprise AS Problems: It is unable to detect any devices or hardwares even after installin latest driver and bios upgrades from intel. it has not detected devices like onboard nic , sound card, graphics , and even my second hard drive My system configuration Intel chipset 945g intel D945gnt desktop board.(not all on board controllers like nic , sound etc.. detected) 512mb ddr2 ram 80 gb sata hard drive(not detected). mouse , key brd(detected) and two ide drive 1:cd drive(detected) 2: ATA hard drive (linux installed on it).(detected). Thanking and anticipating a help o n this regards Prashant. another prob as i have already mentioned i have two hard drive (not partions 2 seperate hard drive one Ata and other SATA). although i cannot detect sata hard drive on my system . I can not change the boot sequence on my sys bios. and my linux hard drive boots 1st n sata second . though booth hard drive bootable i have win xp os on my second hard drive , i would like to have option menu so that i can chose between the 2 os . please help .............. "prashant" <meetprashant007@gmail.com> wrote in news:1152601641.193846.294180@s13g2000cwa.googlegroups.com: > > another prob as i have already mentioned i have two hard drive (not > partions 2 seperate hard drive one Ata and other SATA). although i > cannot detect sata hard drive on my system . I can not change the boot > sequence on my ...

[News] Making Linux More Like OS X and OS X More Like Linux
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 Mac OS X - Highly Customized Linux ,----[ Quote ] | Few players in the Linux arena creates their Linux distro to look like Mac OS | X or Windows.... | | Here I'm going to list some distro which looks like Mac OS. `---- http://linuxtreat.blogspot.com/2008/07/mac-os-x-highly-customized-linux.html A Linux User's Guide to Mac ,----[ Quote ] | Take a deep breath and repeat after me: A computer is just a tool. It is only | so good as it serves to make life better for users. A "better" life is | obviously not the same thing for everyone. For me, it means making my Mac | more like Linux, as I began to discuss in my last article. `---- http://www.ofb.biz/safari/article/474.html Yesterday: Ubuntu: Challenge the Mac ,----[ Quote ] | Normally I would just provide a Diigo link to this if it weren’t something | I’ve been saying a lot in talks. Over at InformationWeek, Serdar Yegulaip was | a piece called “Shuttleworth’s Ubuntu Ambitions: Challenge the Mac”. He | quotes Mark Shuttleworth saying in a Datamation article: | |     … our goal, very simply, is to make sure the Free software ecosystem can |     deliver a Mac OS-like experience, or an experience that will compete with |     the Mac OS. | | I think this is exactly right. It’s time to look past Windows, even with its | huge installed base, as any sort of “gold standard” (as Mark calls it), | especially for user interface. ...

configure problem with scilab5 (linux x86_64)
here is the relevant part of the output of configure, with the options --with-tk-library=/usr/lib64 and --with-tcl-library=/usr/lib64. There is no difference without them. ************************************************************************************ checking for header file tcl.h... found in /usr/include checking if tcl is version 8.4 or later... (8.4) yes checking for tcl library tcl8.4... found /usr/lib64/libtcl8.4.so using -L/usr/lib64 -ltcl8.4 checking for Tcl_DoOneEvent in -ltcl8.4... yes checking for header file tk.h... found in /usr/include checking if tk is version 8.4 or later... (8.4) yes checking for tk library tk8.4... found /usr/lib64/libtk8.4.so using -L/usr/lib64 -ltk8.4 checking for Tk_BindEvent in -ltk8.4... no found /usr/lib/libtk8.4.so using -L/usr/lib -ltk8.4 checking for Tk_BindEvent in -ltk8.4... (cached) no found /usr/lib64/libtk8.4.so using -L/usr/lib64 -ltk8.4 checking for Tk_BindEvent in -ltk8.4... (cached) no configure: error: header file tk.h has been found for 8.4* but no corresponding tk library (libtk8.4.so) ************************************************************************************* Of course I do have libtk8.4.so: here is the corresponding part of configure's output for scilab4.1.2 on the same machine: checking for header file tcl.h... found in /usr/include checking if tcl is version 8.4 or later... (8.4) yes checking for tcl library tcl8.4... found /usr/lib64/libtcl8.4.so using -L/usr/l...

Linux to Linux Fileshare Problem
I have two old desktops both running Ubuntu Linux, I also have an XP laptop all working behind a draytek 2600 router. Samba is set up on both Linux machines, my XP machine can access both Linux machines and both Linux machines can access the XP laptop. Problem is neither Linux machine can view the other's files. If from either Linux machine I connect to the network it shows the other Linux machine, clicking on the networked Linux machine it then lists the shared directories but if I click on the directories a window opens requesting a username, domain and password. The username shows my Linux machine username, the domain shows the WORKGROUP name and the password field is blank. I have tried numerous options but cannot open the shared directories. Geoff Lane Geoff Lane wrote: > I have two old desktops both running Ubuntu Linux, I also have an XP > laptop all working behind a draytek 2600 router. > > Samba is set up on both Linux machines, my XP machine can access both > Linux machines and both Linux machines can access the XP laptop. > > Problem is neither Linux machine can view the other's files. If from > either Linux machine I connect to the network it shows the other Linux > machine, clicking on the networked Linux machine it then lists the > shared directories but if I click on the directories a window opens > requesting a username, domain and password. > > The username shows my Linux machine username, the do...

value of computer.os.linux.misc in 2007
value of compute in 2007 http://www.bidvertiser.com/ http://bigchurch.com/go/g906803-pmem http://indianfriendfinder.com/go/g906803-pmem ...

Problem configuring monta vista linux kernel
Hello friends, I am working on a project which has the short term goal of porting Monta Vista Embedded Linux on a Intel PXA board (having ARM core). I am facing the problem at the initial stage itself. I have installed the Monta vista Linux on Windows platform. When i try to do make oldconfig (as per the kernel build guide) it shows the warning /bin/sh: line 1: xscale_le-gcc: command not found. Although make oldconfig is successful. After that i try to do make dep which gives me following error 720922@infva02366 /mykernel $ make dep /bin/sh: line 1: xscale_le-gcc: command not fo...

Problems with Linux NIS and Mac OS 10.4
Hey folks, So I gave up on LDAP today after looking at the rather lengthy description. Having had some experience with NIS I figured it would take me less time. I've got everything configured. NIS is working between two linix machines, client and server. I've got the Mac configured properly too with Directory Access. The thing is, I can't log in from the login GUI. I *can* log in as another user, then su to the NIS user just fine (I created a home directory for the NIS user) and cd into that user's HOME directory. So everything appears fine, I just can't log ...

Problem configuring monta vista linux kernel #2
Hello friends, I am working on a project which has the short term goal of porting Monta Vista Embedded Linux on a Intel PXA board (having ARM core). I am facing the problem at the initial stage itself. I have installed the Monta vista Linux on Windows platform. When i try to do make oldconfig (as per the kernel build guide) it shows the warning /bin/sh: line 1: xscale_le-gcc: command not found. Although make oldconfig is successful. After that i try to do make dep which gives me following error 720922@infva02366 /mykernel $ make dep /bin/sh: line 1: xscale_le-gcc: command not fo...

Linux Target Image Builder (ltib) configuration problem
I'm working on a custom board that requries a change to the memory map as laid out for a supported board (mcf5485evb). I can see in the sources and the configuration files where the memory locations are set but the ltib menu does not give access to these settings. Changing them in the configuration or source files just results in the ltib over writing those changes prior to performing the build. I want to do this correctly with the tool. REALLY FRUSTRATING. DOCUMENTATION SUCKS EGGS!! I know there's a way to do this it's not clear how. Any help much appreciated.... O...

New 2008 coming Computer.os.linux.misc
sefhwl iefh http://www.freewebs.com/thuiss/ http://indianfriendfinder.com/go/g906725-pmem ...

configuring linux samba to access OS/2 shares
I have just installed Linux Mint x64 release 8 (helena) on one of my systems to check it out. I am trying to configure samba on there so it will allow mounting of some OS/2 shares, but I am not getting in. I did set the workgroup properly and it shows all my OS/2 systems except my domain controller. When I attempt to open one of the OS/2 systems in the network browser I get prompted for a user/password and this the fails. So I assume I have other samba settings to change so I can use OS/2 shares from linux. Any pointers? Is there a reason my domain controller isn't being seen?...

Problems trying to configure Linux laptop to print to Windows XP shared printer
I'm at my wits end trying to get my Linux laptop (FC5) to print to a HP printer which is being shared over the LAN from a Windows XP Home desktop. I've tried CUPS, CUPS-LPD, SAMBA, and nothing is working for me. I've been all over the Internet looking for a solution to this issue but haven't found the right one. I really need a detailed step by step answer. In this post is my full smb.conf, the printcap is empty, and CUPS, HPLIP services are installed but turned off. I've also created users in the smbpasswd file. I don't think that was a problem. I deleted the printer configuration so I will be starting from scratch. [global] dos charset = CP850 unix charset = UTF-8 display charset = LOCALE workgroup = LANSYS realm = netbios name = LINUX netbios aliases = netbios scope = server string = LINUX interfaces = bind interfaces only = No security = USER auth methods = encrypt passwords = Yes update encrypted = No client schannel = Auto server schannel = Auto allow trusted domains = Yes map to guest = Never null passwords = No obey pam restrictions = No password server = * smb passwd file = /etc/samba/smbpasswd private dir = /etc/samba passdb backend = smbpasswd algorithmic rid base = 1000 root directory = guest account = nobody enable privileges = Yes pam password change = No passwd program = passwd chat = *new*password* %n\n *new*password* %n\n *changed* passwd chat debug = ...

os.rename() problems on OS X
hello, i recently had the job of having to rename about 200 files. The source for the renaming was a bunch of names in a file. I know next to nothing when it comes to bash scripting (which would have seemed the obvious choice) so i used python. The files i was renaming were canon raw files (.CR2). my problem is that after i rename the files, OS X will no longer render the thumbnails for the files, and preview is no longer the default app for viewing them. Does anyone have an idea as to why this is? Thanks for the help :) -Lukas On Fri, 11 Jan 2008 12:29:24 -0800, lukas wrote: > hello, &...

Re: [ace-users] problems with running Configure script on Linux for ACE-5.4
Hi Yev, To ensure that we have proper version/platform/compiler information, please make sure you fill out the appropriate problem report form (PRF), which is in $ACE_ROOT/PROBLEM-REPORT-FORM $TAO_ROOT/PROBLEM-REPORT-FORM or in $ACE_ROOT/BUG-REPORT-FORM $TAO_ROOT/BUG-REPORT-FORM in older versions of ACE+TAO. Make sure to include this information when asking any questions about ACE+TAO since otherwise we have to "guess" what version/platform/compiler/options you've using, which is error-prone and slows down our responsiveness. Thanks, Doug >> I'm a new ACE user. When I run configure script, it failed as it >> couldn't find stddef.h file: >> >> configure:4028: g++ -c -g -O2 conftest.cc >&5 >> In file included from conftest.cc:12: >> /usr/include/stdlib.h:33:20: stddef.h: No such file or directory >> In file included from /usr/include/sys/types.h:30, >> from /usr/include/stdlib.h:390, >> from conftest.cc:12: >> /usr/include/bits/types.h:29:20: stddef.h: No such file or directory >> In file included from /usr/include/stdlib.h:390, >> >> How do I specify the include path for this file? >> >> On my machine this file is not in the /usr/include, but in these >> locations: >> /usr/include/linux >> /usr/lib/gcc-lib/i386-redhat-linux/3.2.3/include >> ...

RE: [ace-users] problems with running Configure script on Linux for ACE-5.4 #2
ACE VERSION: 5.4 HOST MACHINE and OPERATING SYSTEM: uname -m = i686 uname -r = 2.4.9-e.38enterprise uname -s = Linux (Red Hat) uname -v = #1 SMP Tue Feb 10 23:59:30 EST 2004 TARGET MACHINE and OPERATING SYSTEM, if different from HOST: COMPILER NAME AND VERSION (AND PATCHLEVEL): same as above g++ 3.2.2 [103] --> g++ -v Reading specs from /opt/gcc/3.2.2/lib/gcc-lib/i386-redhat-linux/3.2.2/specs Configured with: ../configure --prefix=/opt/gcc/3.2.2 --mandir=/opt/gcc/3.2.2/share/man --infodir=/opt/gcc/3.2.2/share/info --enable-shared --enable-threads=posix --disable-checking --with-system-zlib --enable-__cxa_atexit --with-as=/opt/binutils/2.13/bin/as --with-ld=/opt/binutils/2.13/bin/ld --host=i386-redhat-linux Thread model: posix gcc version 3.2.2 20030222 (Red Hat Linux 3.2.2-5.relocate2) CONTENTS OF $ACE_ROOT/ace/config.h: ln -s to config-linux.h CONTENTS OF $ACE_ROOT/include/makeinclude/platform_macros.GNU (unless this isn't used in this case, e.g., with Microsoft Visual C++): ln -s to platform_linux.GNU AREA/CLASS/EXAMPLE AFFECTED: [What example failed? What module failed to compile?] DOES THE PROBLEM AFFECT: ACE installation SYNOPSIS: [Brief description of the problem] examples run by the configure script fail because they cannot find stddef.h and few other include files. DESCRIPTION: This is from config.log file: configure:4028: g++ -c -g -O2 conftest.cc >&5 ...

Facing Problem While configuring Proxy Cache in httpd in Red Hat Linux with 'CacheRoot'
Hi, Could anyone please help me out. While configuring Proxy Cache I di the following <IfModule mod_proxy.c> ProxyRequests On <Directory proxy:*> Order deny,allow Deny from all Allow from 10.0.0 </Directory> ProxyVia Full CacheRoot "/etc/httpd/proxy" CacheSize 5 CacheGcInterval 4 CacheMaxExpire 24 CacheLastModifiedFactor 0.1 CacheDefaultExpire 1 </IfModule> But when I restart my server I get the error:Invalid command 'CacheRoot', perhaps mis-spelled or de...

RE: [ace-users] problems with running Configure script on Linux for ACE-5.4 #2
Please disregard my question. I was using a wrong version of gcc. It works now. Thank you for the prompt responses, Yev -----Original Message----- From: Thomas Lockhart [mailto:Thomas.Lockhart@jpl.nasa.gov] Sent: Thursday, January 05, 2006 2:07 PM To: Gendelman, Yevgeniy Cc: ace-users@cs.wustl.edu Subject: Re: [ace-users] problems with running Configure script on Linux for ACE-5.4 > ACE VERSION: 5.4 Use at least 5.4.1, which is a bug-fix-only followup to 5.4. We use 5.4.1 in production with success. > [103] --> g++ -v > Reading specs from > /opt/gcc/3.2.2/lib/gcc-lib/i386-redhat-linux/3.2.2/specs .... 3.2.2 probably works, though I'm not using that in production now. > This is from config.log file: > configure:4028: g++ -c -g -O2 conftest.cc >&5 > In file included from conftest.cc:12: > /usr/include/stdlib.h:33:20: stddef.h: No such file or directory In > file included from /usr/include/sys/types.h:30, > from /usr/include/stdlib.h:390, > from conftest.cc:12: > /usr/include/bits/types.h:29:20: stddef.h: No such file or directory .... Either /usr/include/linux/stddef.h does not exist, or your compiler does not know how to find it. My g++ does not need anything on the command line to find /usr/include/linux. On my FC4 machine, the files are in the following RPM packages: mini> rpm -qf /usr/include/linux/stddef.h glibc-kernhead...

RE: [ace-users] problems with running Configure script on Linux for ACE-5.4 #2
------------------------------------------------------------------------ ------ Either /usr/include/linux/stddef.h does not exist, or your compiler does not know how to find it. My g++ does not need anything on the command line to find /usr/include/linux. On my FC4 machine, the files are in the following RPM packages: mini> rpm -qf /usr/include/linux/stddef.h glibc-kernheaders-2.4-9.1.94 mini> rpm -qf /usr/include/stdlib.h glibc-headers-2.3.5-10.3 Maybe you do not have "glibc-kernheaders" installed? hth - Tom ------------------------------------------------------------------------ -------- Tom, I can compile and run the programs with g++, too. I get this error (cannot find stddef.h) when I try to compile it with gcc. Sample program: #include <stdlib.h> #include <stddef.h> int main () { exit (42); ; return 0; } -----Original Message----- From: Thomas Lockhart [mailto:Thomas.Lockhart@jpl.nasa.gov] Sent: Thursday, January 05, 2006 2:07 PM To: Gendelman, Yevgeniy Cc: ace-users@cs.wustl.edu Subject: Re: [ace-users] problems with running Configure script on Linux for ACE-5.4 > ACE VERSION: 5.4 Use at least 5.4.1, which is a bug-fix-only followup to 5.4. We use 5.4.1 in production with success. > [103] --> g++ -v > Reading specs from > /opt/gcc/3.2.2/lib/gcc-lib/i386-redhat-linux/3.2.2/specs .... 3.2.2 probably works, though I'...

BIG PROBLEM : Configuration Boot Problem Stratix
hi, we've got some Stratix DSP development kit EP1S25 where at the power-on don't load the flash memory to the FPGA !!! We've seen that the EPLD MAX 7064 often fail the programmation of the FPGA... We've seen that the RESET of this EPLD is in the same time that the 3.3 V power-on... Did someone have this this problem yet... and how to boot at any time on power-on ? Perhaps it's be better if the RESET is after the 3.3V power-on ? We utilizes 3 board in a big system and we have this problem now of non programming at boot.. Thanks "Patrick" <patrick.melet...

Linux: tons of problems XP: one problem
"My friend is a linux lover...Linux gives him tons of problems (he uses PCLOS) and he always talks about how good it feels to fix problems in Linux, yet when his XP install gives him ONE PROBLEM after three years he starts talking shit about microsoft." #9 at http://www.dvorak.org/blog/?p=14453 A perfect description of many of the luser hypocrites that populate the Linux world. Micoshaft fraudster DFS wrote on behalf of half wits from Micoshaft Corporation: > when his XP install gives him ONE PROBLEM after three years he > starts talking shit about microsoft." #9...

ROX Linux and ROX on OS X and arm linux
Hi I've just just done some searches on Google for ROX linux, and ROX on other platforms. I've not managed to find anything. Is ROX available for OS X? Is ROX available for Acorn\Iyonix Arm linux? Did ROX Linux ever come to anything? I was a member of the mailing list a while ago, it started off interesting and then seemed to go off on a tangent then it all went quiet. It seemed like an excellent idea, a linux distro structured like RISC OS. It would have been an ideal compliment to a RISC OS system, same UI but different set of applications (probably not quite so consistent as we are used to though). It could also have been a life boat if RISC OS were ever to grind to a halt. Presumably some sorts of common apps (python perhaps) would have been possible and if RISCOSE or similar were to be developed too, the possibilities would be even greater. Do others consider it would have been desirable? -- Jess Iyonix contact http://jess.itworkshop-nexus.net Hotmail is my spam trap - don't email valid - mailto:nospam@jess.itworkshop-nexus.net In message <729a59544e.jess@itworkshop.invalid> Jess <phantasm_39@hotmail.com> wrote: > Hi > > I've just just done some searches on Google for ROX linux, and ROX on > other platforms. > These starting points might help. http://www.google.co.uk/search?sourceid=navclient&q=ROX filer desktop http://rox.sourceforge.net/phpwiki/ http://rox.sourceforg...

Problems booting OS X after booting OS 9
BW G3, 300 MHz, 256Mb RAM, OS 10.3.3 and OS 9.2.2, Sony Trinitron Multiscan E210 monitor I have a UMAX scanner for which there are no OSX drivers. This means that I have to boot in OS 9 whenever I need to scan something (which is daily, at least). The computer boots fine in OS9 and everything runs great, until I reboot in OSX. Immediately after the chime, the monitor goes into a power-saving mode (I have system prefs set NOT to put the monitor to sleep) and I'm not sure what else is going on because the monitor is black, and all HD sounds cease. If I zap the PRAM, everything s...

Problems booting in OS X after booting in OS 9
BW G3, 300 MHz, 256Mb RAM, OS 10.3.3 and OS 9.2.2, Sony Trinitron Multiscan E210 monitor I have a UMAX scanner for which there are no OSX drivers. This means that I have to boot in OS 9 whenever I need to scan something (which is daily, at least). The computer boots fine in OS9 and everything runs great, until I reboot in OSX. Immediately after the chime, the monitor goes into a power-saving mode (I have system prefs set NOT to put the monitor to sleep) and I'm not sure what else is going on because the monitor is black, and all HD sounds cease. If I zap the PRAM, everything s...

[News] [Linux] Linux Has Advantage in the Mobile OS World
How Linux morphed from a server to a mobile OS ,----[ Quote ] | When evaluating Linux as a possible OS candidate, it is important to | remember that the Linux "model" for mobile devices is horizontal. That | is, Linux is not presented as a vertically integrated top to bottom | solution for a mobile device supplied by one vendor. | | It's a sharp contrast to the other OS suppliers such as Microsoft | with Windows Mobile, Symbian and PalmSource. These suppliers | support a highly integrated software stack, incorporating not | only an OS but also extensive middleware and application layer | pieces. Arguably the price for such integration is lack of | flexibility and loss of control. `---- http://www.wirelessnetdesignline.com/howto/broadband/199600344;jsessionid=N1IAB5VKZRD0QQSNDLRCKH0CJUNN2JVN http://tinyurl.com/2c3z7z Microsoft taps mobiles for developing world ,----[ Quote ] | Microsoft is facing fierce competition from Linux, however, most | notably the One Laptop per Child project to ship low cost | notebooks to schools in developing nations. | | Linux vendor Red Hat unveiled a Global Desktop last week | targeting computers at small and medium sized businesses as | well as governments in third world nations. `---- http://www.vnunet.com/vnunet/news/2189936/microsoft-taps-mobile-tech Related: 70 percent of smartphones use Symbian ,----[ Quote ] | At 3GSM it became clear that 70 percent of all smartphones use Symbian. | | Linux accounts for 16.9 perc...

Web resources about - ./configure problem - comp.os.linux.misc

configure script - Wikipedia, the free encyclopedia
A Configure script is an executable script designed to aid in developing a program to be run on a wide number of different computers. It matches ...

CloudNex correctly configures NetSuite for retailer
IT consultant and NetSuite solution provider, CloudNex has implemented a NetSuite configuration for local fashion designer and retailer, Briggins. ...

Cydia Tweak: How To Configure A Touch ID Grace Period For Your iPhone 5s
... Into A Paid Subscription , and Facebook’s Paper Launches In The App Store, Brings A More Elegant News Feed To iOS . Cydia Tweak: How To Configure ...

Configure - Apple
Get free shipping on iMac with Retina 5K display from the Apple Online Store. It packs 14.7 million pixels into its 27-inch display, and it features ...

Xcode Continuous Integration Guide: Configure Bots to Perform Continuous Integrations
Provides guidelines and examples for using Xcode continuous integration features.


Apple TV to get automatic "touch to configure" setup via Bluetooth 4.0, iOS 7
Apple appears to be using a novel device setup method to ease initial configuration of Apple TV under iOS 7, using an NFC-like touch without ...

Model brain with 2.5 million neurons configures itself to solve problems
Chris Eliasmith, et. al Over the last few years, the meteoric rise of computing power has allowed us to build ever-larger collections of model ...

Time to configure your McLaren 650S
Filed under: Car Buying , Convertible , Coupe , Performance , McLaren If you're like us, Friday afternoons are the bane of your existence - ...

Customize and configure your PC with Windows Tweaker 5.0
Windows is a highly configurable operating system, with hundreds of settings and options available. But taking full advantage of this can be ...

Resources last updated: 3/16/2016 8:38:36 PM