f



Firefox 50 and avcodec

Latest upgrade of firefox on various linux platforms breaks videos 
because the installed libavcodecs are not up to date - there was a 
security issue in earlier versions.

For those who don't want to break their get_iplayer installations by 
installing prom source or from a different repository a newer 
libavcodec, the following work around works

In firefox about: config will reveal two relevant configuration entries.

media.libavcodec.allow-obsolete;true

will allow you to actually play video using the old codecs, but still 
generates a warning.

media.decoder-doctor.notifications-allowed;MediaWMFNeeded,MediaWidevineNoWMFNoSilverlight

is a modified entry with the avcodec bit removed from its tail to stop 
moaning about obsolete libavcodecs.

Be aw3are of the security implications of using the old codecs, of course.



-- 
Canada is all right really, though not for the whole weekend.

"Saki"
0
The
11/24/2016 9:08:48 AM
comp.os.linux.misc 33599 articles. 1 followers. amosa69 (78) is leader. Post Follow

8 Replies
749 Views

Similar Articles

[PageSpeed] 15

On Thursday, November 24, 2016 at 4:08:53 AM UTC-5, The Natural Philosopher wrote:
> Latest upgrade of firefox on various linux platforms breaks videos 
> because the installed libavcodecs are not up to date - there was a 
> security issue in earlier versions.
> 
> For those who don't want to break their get_iplayer installations by 
> installing prom source or from a different repository a newer 
> libavcodec, the following work around works
> 
> In firefox about: config will reveal two relevant configuration entries.
> 
> media.libavcodec.allow-obsolete;true
> 
> will allow you to actually play video using the old codecs, but still 
> generates a warning.
> 
> media.decoder-doctor.notifications-allowed;MediaWMFNeeded,MediaWidevineNoWMFNoSilverlight
> 
> is a modified entry with the avcodec bit removed from its tail to stop 
> moaning about obsolete libavcodecs.
> 
> Be aw3are of the security implications of using the old codecs, of course.
> 
> 
> 
> -- 
> Canada is all right really, though not for the whole weekend.
> 
> "Saki"


I was just coming here to post a question about how I could fix thing problem.

Thank You

0
beforewisdom
11/24/2016 2:10:43 PM
On 24/11/16 14:10, beforewisdom@gmail.com wrote:
> On Thursday, November 24, 2016 at 4:08:53 AM UTC-5, The Natural Philosopher wrote:
>> Latest upgrade of firefox on various linux platforms breaks videos
>> because the installed libavcodecs are not up to date - there was a
>> security issue in earlier versions.
>>
>> For those who don't want to break their get_iplayer installations by
>> installing prom source or from a different repository a newer
>> libavcodec, the following work around works
>>
>> In firefox about: config will reveal two relevant configuration entries.
>>
>> media.libavcodec.allow-obsolete;true
>>
>> will allow you to actually play video using the old codecs, but still
>> generates a warning.
>>
>> media.decoder-doctor.notifications-allowed;MediaWMFNeeded,MediaWidevineNoWMFNoSilverlight
>>
>> is a modified entry with the avcodec bit removed from its tail to stop
>> moaning about obsolete libavcodecs.
>>
>> Be aw3are of the security implications of using the old codecs, of course.

> I was just coming here to post a question about how I could fix thing problem.
>
> Thank You
>
Can you confirm it worked for you?



-- 
All political activity makes complete sense once the proposition that 
all government is basically a self-legalising protection racket, is 
fully understood.

0
The
11/24/2016 3:09:38 PM
On 11/24/2016 07:09 AM, The Natural Philosopher wrote:
> On 24/11/16 14:10, beforewisdom@gmail.com wrote:
>> On Thursday, November 24, 2016 at 4:08:53 AM UTC-5, The Natural
>> Philosopher wrote:
>>> Latest upgrade of firefox on various linux platforms breaks videos
>>> because the installed libavcodecs are not up to date - there was a
>>> security issue in earlier versions.
>>>
>>> For those who don't want to break their get_iplayer installations by
>>> installing prom source or from a different repository a newer
>>> libavcodec, the following work around works
>>>
>>> In firefox about: config will reveal two relevant configuration entries.
>>>
>>> media.libavcodec.allow-obsolete;true
>>>
>>> will allow you to actually play video using the old codecs, but still
>>> generates a warning.
>>>
>>> media.decoder-doctor.notifications-allowed;MediaWMFNeeded,MediaWidevineNoWMFNoSilverlight
>>>
>>>
>>> is a modified entry with the avcodec bit removed from its tail to stop
>>> moaning about obsolete libavcodecs.
>>>
>>> Be aw3are of the security implications of using the old codecs, of
>>> course.
>
>> I was just coming here to post a question about how I could fix thing
>> problem.
>>
>> Thank You
>>
> Can you confirm it worked for you?
>
>
>
Isn't this what the EME version is supposed to involve?
What do you need to play to test?  I just upgraded and that media.libav 
config is set to false..
The media decoder default value here is 
MediaWMFNeeded,MediaWidevineNoWMFNoSilverlight,MediaUnsupportedLibavcodec


0
jrg
11/24/2016 3:25:46 PM
On 24/11/16 15:25, jrg wrote:
> On 11/24/2016 07:09 AM, The Natural Philosopher wrote:
>> On 24/11/16 14:10, beforewisdom@gmail.com wrote:
>>> On Thursday, November 24, 2016 at 4:08:53 AM UTC-5, The Natural
>>> Philosopher wrote:
>>>> Latest upgrade of firefox on various linux platforms breaks videos
>>>> because the installed libavcodecs are not up to date - there was a
>>>> security issue in earlier versions.
>>>>
>>>> For those who don't want to break their get_iplayer installations by
>>>> installing prom source or from a different repository a newer
>>>> libavcodec, the following work around works
>>>>
>>>> In firefox about: config will reveal two relevant configuration
>>>> entries.
>>>>
>>>> media.libavcodec.allow-obsolete;true
>>>>
>>>> will allow you to actually play video using the old codecs, but still
>>>> generates a warning.
>>>>
>>>> media.decoder-doctor.notifications-allowed;MediaWMFNeeded,MediaWidevineNoWMFNoSilverlight
>>>>
>>>>
>>>>
>>>> is a modified entry with the avcodec bit removed from its tail to stop
>>>> moaning about obsolete libavcodecs.
>>>>
>>>> Be aw3are of the security implications of using the old codecs, of
>>>> course.
>>
>>> I was just coming here to post a question about how I could fix thing
>>> problem.
>>>
>>> Thank You
>>>
>> Can you confirm it worked for you?
>>
>>
>>
> Isn't this what the EME version is supposed to involve?
> What do you need to play to test?

If the warning doesn't pop up and videos that didnt play before now 
play, that's passed the test!


  I just upgraded and that media.libav
> config is set to false..
> The media decoder default value here is
> MediaWMFNeeded,MediaWidevineNoWMFNoSilverlight,MediaUnsupportedLibavcodec
>
>
Yup. Those are the defaults. Change em and you can run with the old 
libavcodec...


-- 
The biggest threat to humanity comes from socialism, which has utterly 
diverted our attention away from what really matters to our existential 
survival, to indulging in navel gazing and faux moral investigations 
into what the world ought to be, whilst we fail utterly to deal with 
what it actually is.

0
The
11/24/2016 3:37:35 PM
On 11/24/2016 07:37 AM, The Natural Philosopher wrote:

> Change em and you can run with the old libavcodec...

Haven't had the need, thanks anyway
0
jrg
11/24/2016 4:29:58 PM
On 11/24/2016 08:29 AM, jrg wrote:

> On 11/24/2016 07:37 AM, The Natural Philosopher wrote:
>
>> Change em and you can run with the old libavcodec...
>
> Haven't had the need, thanks anyway

ha- wtf do I know - yahoo finance site just reported libavcodec not 
supported.  Its on one of their multiple (and quite annoying) 
unrequested videos so I'll wait until something I want to see comes up 
cropping.

-- 
Jeff G.
You're never too old to learn something stupid.
0
jrg
11/25/2016 4:08:15 PM
On 25/11/16 16:08, jrg wrote:
> On 11/24/2016 08:29 AM, jrg wrote:
>
>> On 11/24/2016 07:37 AM, The Natural Philosopher wrote:
>>
>>> Change em and you can run with the old libavcodec...
>>
>> Haven't had the need, thanks anyway
>
> ha- wtf do I know - yahoo finance site just reported libavcodec not
> supported.  Its on one of their multiple (and quite annoying)
> unrequested videos so I'll wait until something I want to see comes up
> cropping.
>
it takes 5 mins and it works, so I recommend doing it anyway.


-- 
"Corbyn talks about equality, justice, opportunity, health care, peace, 
community, compassion, investment, security, housing...."
"What kind of person is not interested in those things?"

"Jeremy Corbyn?"

0
The
11/25/2016 6:11:42 PM
On 11/25/2016 10:11 AM, The Natural Philosopher wrote:
> On 25/11/16 16:08, jrg wrote:
>> On 11/24/2016 08:29 AM, jrg wrote:
>>
>>> On 11/24/2016 07:37 AM, The Natural Philosopher wrote:
>>>
>>>> Change em and you can run with the old libavcodec...
>>>
>>> Haven't had the need, thanks anyway
>>
>> ha- wtf do I know - yahoo finance site just reported libavcodec not
>> supported.  Its on one of their multiple (and quite annoying)
>> unrequested videos so I'll wait until something I want to see comes up
>> cropping.
>>
> it takes 5 mins and it works, so I recommend doing it anyway.
>
>

ok, it only took 2 minutes since I had read your fine instructions earlier.


0
jrg
11/26/2016 12:28:50 AM
Reply: