f



A Strange problem - 421 Service not available, remote server has closed connection

Everything works fine before, but suddenly the error occurs since
yesterday. Here is my machine configuration:

I have three Window Server 2003 machines.  Each one hosts a VMWare
server, which in turn contains both window based and linux based
virtual machines.

All the window based virtural machines have no problem connecting to
any outside world FTP server.  But the linux based (i386-redhat-linux-
gnu) virutal machines return the "421 Service not available, remote
server has closed connection" error right after the "username" is
entered.  For instance:

ftp> open wirefreethought.com
Connected to wirefreethought.com (66.199.224.58).
220 (vsFTPd 2.0.1)
Name (wirefreethought.com:root): vince
421 Service not available, remote server has closed connection
Login failed.
No control connection for command: Transport endpoint is not connected

The strange thing is, if I first do the "ping hostname", then
immediately follow by "ftp hostname", everything works fine.  Any
other times the same error occurs.  Why does this happen?  Everything
worked fine before until yesterday.

Any insight will be greatly appreciated!

Best Regards,
Vince

0
law.vince (5)
3/9/2007 10:24:46 PM
comp.os.linux.networking 15677 articles. 0 followers. Post Follow

4 Replies
2372 Views

Similar Articles

[PageSpeed] 44

On Mar 9, 2:24 pm, "vince" <law.vi...@gmail.com> wrote:
> Everything works fine before, but suddenly the error occurs since
> yesterday. Here is my machine configuration:
>
> I have three Window Server 2003 machines.  Each one hosts a VMWare
> server, which in turn contains both window based and linux based
> virtual machines.
>
> All the window based virtural machines have no problem connecting to
> any outside world FTP server.  But the linux based (i386-redhat-linux-
> gnu) virutal machines return the "421 Service not available, remote
> server has closed connection" error right after the "username" is
> entered.  For instance:
>
> ftp> open wirefreethought.com
> Connected to wirefreethought.com (66.199.224.58).
> 220 (vsFTPd 2.0.1)
> Name (wirefreethought.com:root): vince
> 421 Service not available, remote server has closed connection
> Login failed.
> No control connection for command: Transport endpoint is not connected
>
> The strange thing is, if I first do the "ping hostname", then
> immediately follow by "ftp hostname", everything works fine.  Any
> other times the same error occurs.  Why does this happen?  Everything
> worked fine before until yesterday.
>
> Any insight will be greatly appreciated!
>
> Best Regards,
> Vince

Sorry, this is a duplicated post, the browser timed out on me and I
thought I didn't post it successfully, therefore I reposted it again.

0
law.vince (5)
3/9/2007 10:53:15 PM
On Mar 10, 6:24 am, "vince" <law.vi...@gmail.com> wrote:
> Everything works fine before, but suddenly the error occurs since
> yesterday. Here is my machine configuration:
>
Can you figure out what operation caused the problem?

> I have three Window Server 2003 machines.  Each one hosts a VMWare
> server, which in turn contains both window based and linux based
> virtual machines.
>
> All the window based virtural machines have no problem connecting to
> any outside world FTP server.  But the linux based (i386-redhat-linux-
> gnu) virutal machines return the "421 Service not available, remote
> server has closed connection" error right after the "username" is
> entered.  For instance:
>
> ftp> open wirefreethought.com
> Connected to wirefreethought.com (66.199.224.58).
> 220 (vsFTPd 2.0.1)
> Name (wirefreethought.com:root): vince
> 421 Service not available, remote server has closed connection
> Login failed.
> No control connection for command: Transport endpoint is not connected
>
> The strange thing is, if I first do the "ping hostname", then
> immediately follow by "ftp hostname", everything works fine.  Any
> other times the same error occurs.  Why does this happen?  Everything
> worked fine before until yesterday.
>
> Any insight will be greatly appreciated!
>
I feel that it's the problem of the server. Maybe it cannot accept
more connections.

> Best Regards,
> Vince


0
3/10/2007 1:57:56 PM
The server is fine (I tried it with other FTP servers too), I could
make ftp connection to it from all the  microsoft window based
clients.  The strange thing is, if I do a "ping hostname" first, then
"ftp hostname" right after, it works.  I am guessing something like
the client lost its connection route to the server after the initial
connection (after "ftp hostname", and before username is entered).
But why only happens to the linux based machines?   There must be some
problem in the network (could be the router) that the window machines
can overcome, but not the Linux.  I would like to see if there are
people who had encountered this problem before and had figured out the
solution for it.

Thanks,
Vince

On Mar 10, 5:57 am, "Thomas.Chang" <MingZhang2...@gmail.com> wrote:
> On Mar 10, 6:24 am, "vince" <law.vi...@gmail.com> wrote:> Everything works fine before, but suddenly the error occurs since
> > yesterday. Here is my machine configuration:
>
> Can you figure out what operation caused the problem?
>
>
>
>
>
> > I have three Window Server 2003 machines.  Each one hosts a VMWare
> > server, which in turn contains both window based and linux based
> > virtual machines.
>
> > All the window based virtural machines have no problem connecting to
> > any outside world FTP server.  But the linux based (i386-redhat-linux-
> > gnu) virutal machines return the "421 Service not available, remote
> > server has closed connection" error right after the "username" is
> > entered.  For instance:
>
> > ftp> open wirefreethought.com
> > Connected to wirefreethought.com (66.199.224.58).
> > 220 (vsFTPd 2.0.1)
> > Name (wirefreethought.com:root): vince
> > 421 Service not available, remote server has closed connection
> > Login failed.
> > No control connection for command: Transport endpoint is not connected
>
> > The strange thing is, if I first do the "ping hostname", then
> > immediately follow by "ftp hostname", everything works fine.  Any
> > other times the same error occurs.  Why does this happen?  Everything
> > worked fine before until yesterday.
>
> > Any insight will be greatly appreciated!
>
> I feel that it's the problem of the server. Maybe it cannot accept
> more connections.
>
>
>
> > Best Regards,
> > Vince- Hide quoted text -
>
> - Show quoted text -- Hide quoted text -
>
> - Show quoted text -


0
law.vince (5)
3/11/2007 1:38:29 AM
We've figured out the cause of the problem.  We have two different DSL
lines.  Our router has a capability to intelligently balance accross
multiple DSL connections.  One of the DSL line has problem with the
ftp connection.  After we disabled the problematic DLS line, the
problem doesn't occur anymore.

Thanks,
Vince

On Mar 10, 5:38 pm, "vince" <law.vi...@gmail.com> wrote:
> The server is fine (I tried it with other FTP servers too), I could
> make ftp connection to it from all the  microsoft window based
> clients.  The strange thing is, if I do a "ping hostname" first, then
> "ftp hostname" right after, it works.  I am guessing something like
> the client lost its connection route to the server after the initial
> connection (after "ftp hostname", and before username is entered).
> But why only happens to the linux based machines?   There must be some
> problem in the network (could be the router) that the window machines
> can overcome, but not the Linux.  I would like to see if there are
> people who had encountered this problem before and had figured out the
> solution for it.
>
> Thanks,Vince
>
> On Mar 10, 5:57 am, "Thomas.Chang" <MingZhang2...@gmail.com> wrote:
>
>
>
> > On Mar 10, 6:24 am, "vince" <law.vi...@gmail.com> wrote:> Everything works fine before, but suddenly the error occurs since
> > > yesterday. Here is my machine configuration:
>
> > Can you figure out what operation caused the problem?
>
> > > I have three Window Server 2003 machines.  Each one hosts a VMWare
> > > server, which in turn contains both window based and linux based
> > > virtual machines.
>
> > > All the window based virtural machines have no problem connecting to
> > > any outside world FTP server.  But the linux based (i386-redhat-linux-
> > > gnu) virutal machines return the "421 Service not available, remote
> > > server has closed connection" error right after the "username" is
> > > entered.  For instance:
>
> > > ftp> open wirefreethought.com
> > > Connected to wirefreethought.com (66.199.224.58).
> > > 220 (vsFTPd 2.0.1)
> > > Name (wirefreethought.com:root):vince
> > > 421 Service not available, remote server has closed connection
> > > Login failed.
> > > No control connection for command: Transport endpoint is not connected
>
> > > The strange thing is, if I first do the "ping hostname", then
> > > immediately follow by "ftp hostname", everything works fine.  Any
> > > other times the same error occurs.  Why does this happen?  Everything
> > > worked fine before until yesterday.
>
> > > Any insight will be greatly appreciated!
>
> > I feel that it's the problem of the server. Maybe it cannot accept
> > more connections.
>
> > > Best Regards,
> > >Vince- Hide quoted text -
>
> > - Show quoted text -- Hide quoted text -
>
> > - Show quoted text -- Hide quoted text -
>
> - Show quoted text -


0
law.vince (5)
3/14/2007 7:40:52 PM
Reply:

Similar Artilces:

Remote SSH problem
Hi everyone, I have been reading every post that I could find about this particular error message: ssh_exchange_identification: Connection closed by remote host I'm working with an external client who wants to grab some files from us via SFTP. I set up a Solaris 9 server with "ChrootSSH" from here: http://chrootssh.sourceforge.net/index.php I compiled it locally with the following options: ../configure --with-pam --disable-suid-ssh --without-rsh --with- lastlog=/var/adm/lastlog --sysconfdir=/usr/local/etc/openssh --prefix=/ usr/local --without-privsep-user--without-privsep-...

remote connection to MySQL Server on Mac OS X Server
Hi! I've just fully installed the Mac OS X Server on my Mac. When trying to administer the MySQL database using PHPMyAdmin I am presented with the following error msg: "Server xxx.xxx.xxx.xxx is not allowed to connect to this MySQL Server" error number: 1130 Any help will be very much appreciated. Thanks in advance. In article <78ae14f3.0309090827.4f7200cf@posting.google.com>, ujgelijkheid@yahoo.co.uk (Tom Sas) wrote: >I've just fully installed the Mac OS X Server on my Mac. >When trying to administer the MySQL database using PHPMyAdmin I am &g...

Strange problem: no problem with Linux, when I boot windows 2K network is down...
Guys: This is very strange problem, looklike this problem is not going to leave me for months. I have a computer with Windows2K and Linux. I have Netgear 4-port Switch/Router (connected to DSL modem). If I boot with Linux, everything is OK, I can be on-line, also two of my other computers works fine. If I boot my PC with Win2K, then immediately all computers are down. None of the computer connected to network. I thought some problem with LAN card, so I went for early bird sale on day after Thanksgiving and I got one LinkSys PCI LAN card and one Router and I plugged new LAN card into my machin...

<Newbie> Problem with Server-Name in Connect to Remote Server
Dear group, kindly please answer me my newbie question :-) I want to connect to a remote SQL-Server using sp_addlinkedservers and "openquery". I tried and tried and I couldn't get it to work. Then i found out, that it works with a different server which doesn't have the '-' character within its servername. So sp_addlinkedserver 'ULI-SERVER' select * from openquery(uli-server, 'select * from northwind.dbo.sometable') yields a syntax error ("Incorrect syntax near '-'") sp_addlinkedserver 'someotherserver' select * from op...

Problem having multiple connections From OS 9 clients to OS X.3 server
This problem occurs on any machine that we have running OS 9. When I go to connect to a server or share point on the server it lets me do it the first time. However once I am connected to one share point I cannot connect to a second one. It first tells me that I am already connected and then comes up with the error "No response from the server". I know that the server is still responding because I can get to everything on the share point I am already connected to. Also, if I trash my connection I can then go in and connect again. I can even choose multiple share points to conne...

Problem when multiple SCP connections in Solaris 10
We have two Solaris 10 servers (A & B) setup for sending files between them via SCP. The keys/hosts configuration are set up between the two servers. There's no problem when sending individual file between the two servers. However, when we are standing multiple files "cocncurrently" via shell script or commands from server A to server B, we are getting the following messages repeatedly. Some files got sent OK and some didn't go thru when the messages below appear, regardless of the size or type of these "unsent" files in server A : : : ssh_exc...

Problem closing server connection
Hi I'm developing a webapp using servlets, which processes a HTTP Post request and sent back MIME message (multipart/related - essentially SOAP message with Attachments). I'm constructing the MIME message manually (as I need to stream it to the client) and writing it to OutputStream (few bytes everytime). In the end, I close the OutputStream (without getting any exception), but still client keeps on waiting on the socket and it never get -1, while it reads from the InputStream. Thus server is not closing the socket even after closing the OutputStream. This problem ...

Linux server and remote connection.
Hi, do anyone has an experience with linux server? I have an option to buy either a linux server at $700/year, or a windows server at $1200 per year. I think linux server is a better bargain. However, the windows server has perks too. It comes with remote connection that I am familiar with. Is there an equivalent in linux? How many applications run in linux? jonathanthio@yahoo.com.sg wrote: : Hi, do anyone has an experience with linux server? : I have an option to buy either a linux server at $700/year, or a : windows server at $1200 per year. Sounds like you mean "lease" rathe...

server unexpectedly closed network connection
I have just installed OpenSSH_5.1pq-hpn13v5, OpenSSL 0.9.8i 15 Sep 2008 on a server and find that I need to use PuTTY 0.58 in order to connect. 0.59 and 0.60 both fail to connect with a 'Server unexpectedly closed network connection' error. Running sshd in debug mode gives this output Any suggestions what could be the issue? debug1: HPN Disabled: 1, HPN Buffer Size: 131072 debug1: Client protocol version 2.0; client software version PuTTY_Release_0.60 SSH: Server;Ltype: Version;Remote: 10.xxx.xxx.xxx-1046;Protocol: 2.0;Client: PuTTY_Release_0.60 debug1: no match: PuTTY_Release_0.60...

Process has Problems connecting to remote server
I have a process that goes out to a server and does a software update. Originally it took 60 - 80 seconds to accomplish. It now takes 500 - 1000 seconds to do the same function. Several other box's that do this same script have not seen this increase. The script will sit at this function for long periods of time; Connecting to www.uabc.edu[1xx.xxx.1xx.182]:80... Then it finally gets the; Connecting to www.uabc.edu[1xx.xxx.1xx.182]:80... connected. HTTP request sent, awaiting response... 200 OK I noticed that the tw value is high on this box as seen in the /proc/net/sockstat file [...

FileZilla Server remote connection problem
Server Newby; Help is appreciated ... I just installed Filezilla Server on my office computer (Dell 1.8mh P4;WinXp) behind Linksys router (BEFW11S4) connected to RR Cable . Filezilla Server seems to work fine when FPT'ing (using WS-FTP) from that local computer connecting to router's WAN IP address. (i.e router port forwarding sends FTP data through IP back to self OK). Now I am at home(on Toshiba laptop P4/WinXP via LInksys router (BEFW11S4) via RR cable, and using same logon parameters to connect to my FTP server( using WS-FTP); we connect OK & FTP tells current remot...

Process has Problems connecting to remote server
I have a process that goes out to a server and does a software update. Originally it took 60 - 80 seconds to accomplish. It now takes 500 - 1000 seconds to do the same function. Several other box's that do this same script have not seen this increase. The script will sit at this function for long periods of time; Connecting to www.uabc.edu[1xx.xxx.1xx.182]:80... Then it finally gets the; Connecting to www.uabc.edu[1xx.xxx.1xx.182]:80... connected. HTTP request sent, awaiting response... 200 OK I noticed that the tw value is high on this box as seen in the /proc/net/sockstat file [...

connect a database in remote server (can connect to the server via SSH)
Hi, All: My perl code need to connect to a database (MySQL) in remote server, and I can login that server via SSH. I am a new to perl, can anyone give me a hint how can I do that. Many thanks. Xiaoyu zhangxiaoyu912@gmail.com wrote: > My perl code need to connect to a database (MySQL) in remote server, > and I can login that server via SSH. You don't need to have ssh access to the remote database server in order to be able to connect to the database (at least if the database server is configured to wait for remote connections). > I am a new to perl, can anyone give me a hint h...

Connection problem from Windows Client to Linux Server
Hi, I have a problem to get data from a linux server over UDP. I have two applications (self written), the first runs under Windows (Client), the other on Slackware 10.2, Kernel 2.4.32. The Windws Client asks the Linux Server for an UDP data packet, and Linux answers with the requested data. So far so good. Now I tried to get data with size over 1500 bytes, and I get ... nothing. To get more information, I've started Wireshark, and got following line at the client side from the server: "Flags: 0x06 (Don't Fragment) (More Fragments)". My MTU settings are 1500 on linux, 1492 on...

Connot connect to port on server : networking problem?
Hi, We have a unique problem, which I am sure is due to netwroking setup, whereas our adnministrator are caliming otherwise. We are running RedHat Linux 3. I have written a service which listens on a port. Its running on a server test.xyz.co.in with IP 10.10.50.10. Whenever this listener is not bound to the hostname, it accepts connections from any machine whether that request is given with IP or fully qualified server name. However, whenever we bind the listener to tha particular hostname (test.xyz.co.in) and we try to connect to it from the server itself, it connaot connect when request i...

TADOConnection connecting to a remote server: timeout problems
Dear developers, I'm developing a simple DB Client application. This application establishes a connection to a remote DB with a TADOConnection component. But, sometimes, the remote server is down, so that my application freezes for 30 seconds before raising an exception. That's a very bad behavior. Is there a way to "cancel" the connection attempt. I tried making the connection asynchronous and stopping it with Cancel method, but doing this way the connection is always "apparently successful" even if it is not. I can't understand how can I make...

strange problem connecting 2 linux boxes
Hello, - Last week I had posted here a strange problem I had connecting 2 linux boxes. I had done some more tests and I am quite in despair. please help! - I had tried to conenct 2 Linux boxes directly. I did it with a cross cable connecting directly one nic to the other nic. (also tried all my tests with non-cross cable, but AFAIK it should be with cross cable). Clifford Kite asked about that cable: it is a brand new cable that I bought, and testd today on other machines, and it's OK. For this I set the address of one of them to 192.168.0.2 subnet: 255.255.255.0 the other i...

very strange display problem with PC Linux OS!!!!!!
I just bought a new computer, custom built. Had it set up with dual boot PC Linux/Windows. Default boot is Linux. When I boot to Linux, everything looks great and I see the splash screen and the progress bar telling me it's loading. But, after it's loaded, and I'm waiting for the login prompt, my display goes blank, and stays blank (black.) On my LCD, I get a message box moving around that says "frequency out of range." It was running at 60hz so I set it to 75hz...same problem. Hooked up an old NEC CRT monitor, screen still goes black, but no message is displayed....

Remote Desktop Connection Problem to windows network
I wonder if someone can help me please. I have a mac powerbook g4 operating osx 10.4.3 and have downloaded remote desktop connection from microsoft. I use the windows version of rdc to connect my home pc to work and that is fine however, I cannot get the mac version to work at all. I keep getting the message " The client could not connect to the remote computer. Either remote connections are not enabled, the maximum number of connections was exceeded, or a network error occurred......" I can connect ok from my mac to the internet through 'airport' via a router using safari ...

Problem on Linux OS/390 for Db2 Connect
I have a problem to connect to db2 connect on suse os/390. I've created 2 classes DB_R.java driver type 4. and DB_L.java driver type 2. When I run I have result: Driver type 4 works fine. Driver type 2 does not work. "SQLException: No suitable driver" After all I was trying to use db2profile, result the same. But every thing works fine on Windows box. beausr@APPS1:~/cafe> export JAVA_HOME=/opt/IBMJava2-s390-141 beausr@APPS1:~/cafe> export PATH=${JAVA_HOME}/bin:/home/db2usr/sqllib/bin:${PATH} beausr@APPS1:~/cafe> ex...

Strange Linspire Linux and Windows network problem!
Hello, Strange things are going on... computers can browse linux shared files, through the local network ONLY when connected to the internet.. when the internet connection is closed.. it takes several minuites to see inside the shared folder of the linux machine! DETAILS: I have set up a linspire box (LINUX) in a network with 5 other computers that have windows xp and win98... This network has stiatic addresses, XP main machine 192.168.0.1 and the rest 192.168.0.x This XP machines is working as an internet connection share machine, sharing is internet connection to the others. On the Lin...

Strange Linux <-> Windows Connectivity Problem
Hello, I have a very strange problem on my home network. The setup is: Linux 2.2.17 Firewall/Gateway (ipchains): fw-old Linux 2.4.22 Firewall/Gateway (iptables) : fw-new Several Windows 2000 and one Windows 98 (not 2nd Edition)-Boxes attached to the same switch and the same subnet. I build a new server (fw-new) with iptables to replace the old one. The iptable-Rules were setup with Shorewall. A test run with my Windows 2000-Clients was successful, everything runs fine. So I completely replaced the old-fw, and was happy. However, I have serious problems connecting the only Windows98 Box: A...

Login problem: ssh_exchange_identification: Connection closed by remote host
Hello the error message ssh_exchange_identification: Connection closed by remote host is what I get, when I want to login to a server/login, that until now already has worked. When will this error message be printed? Ciao, Oliver On 2006-02-03, Oliver Bandel <oliver@first.in-berlin.de> wrote: > ssh_exchange_identification: Connection closed by remote host [...] > When will this error message be printed? The most common cause of this is when sshd drops a connection because it is denied by tcpwrappers (/etc/hosts.allow and /etc/hosts.deny). Another possible cause is that...

LC_TYPE setting strangely causes network connection problem
Hi, everyone. My Ubuntu box has been suffering from this strange problem for more than one week so please help if you have an idea what's going on. I installed Ubuntu 7.10 Gusty Gibbon and because I'm processing a lot of Simplified Chinese text files I generated the zh_CN.GB18030 locale by modifying /var/lib/locale/local, and run 'locale-gen'. Then I set LC_CTYPE="zh_CN.GB18030" in /etc/environment. After restarting I could view Chinese texts in GB but later found various network connection problems: 1. apt-get update doesn't work and reports 404 not...

Strange OS/2 Networking Problem
I am having a wierd problem with one of my os/2 machines on a peer network. The machine that is giving me trouble has an ECS K7S5A motherboard in it. I have been successful in getting the machine to logon to my peer network. It can even do a NET VIEW and I can see the other machines. But I cannot do a NET VIEW \\machineid or a NET USE to access a resource. I get an error that says that the resource is not longer available. Well, all my other machines can see it. I don't get it. I have tried with the built in SIS 900 lan adapter and with a Linksys LN100TX. Same result on both...

Web resources about - A Strange problem - 421 Service not available, remote server has closed connection - comp.os.linux.networking

Connection - Wikipedia, the free encyclopedia
Text is available under the Creative Commons Attribution-ShareAlike License ;additional terms may apply. By using this site, you agree to the ...

iMedia Connection: Interactive Marketing News, Features, Podcasts and Video - iMediaConnection.com
High-quality data, if not used properly, can still lead marketers to make bad decisions. Consider these common ways that numbers are used to ...

HTTP persistent connection - Wikipedia, the free encyclopedia
... tacked on to an existing protocol. If the browser supports keep-alive, it adds an additional header to the request: Following this, the connection ...

Alec Baldwin, Tommy Hilfiger and a Designer With a ‘Downton’ Connection
It was something of a British invasion at Michael’s today with plenty of posh folks (Majesty magazine EIC Ingrid Seward , the always dashing ...

French (Canadian) connection helps Coyotes snap 7-game skid
The Arizona Coyotes defeat the Florida Panthers 5-1 Saturday behind a dominate performance by the team's French-Canadian players.

Quantum Break requires Internet connection for streaming cut scenes on PC
Single-player game puts videos in cloud to save disc and hard drive space. The idea of requiring an Internet connection for single-player gaming ...

4G Connections Hit One Billion as Mobile Broadband Momentum Extends to the Developing World
The number of 4G mobile connections worldwide has surpassed the one billion mark and is on track to account for a third of all mobile connections ...

Zika virus-microcephaly connection hunted in Brazil - CNN.com
Is the Zika virus linked to microcephaly? The CDC and Brazilian health officials are leading the first-ever large scale investigation to find ...

Smart city tech shows complex connections between data and sensors
... MWC, Parkeon and Sierra Wireless announced that Sierra Wireless AirPrime HL Series embedded modules will be used to enable cellular connections ...

Van Jones And Jeffrey Lord Nearly End Up In A Fist Fight Over Trump's KKK Connections
CNN needs to fire Jeffrey Lord if they want to keep the name "News" in their name. His performance with Van Jones tonight was shameful. Utterly ...

Resources last updated: 3/6/2016 7:27:42 PM