f



"xterm Xt error: Can't open display"

What am I doing wrong ??? Please see:

spongebob@bubbles:~> xhost + patrick
patrick being added to access control list
spongebob@bubbles:~> ssh patrick
spongebob@patrick's password:
This machine is now actively used
102 spongebob@patrick [1]: setenv DISPLAY bubbles:0.0
103 spongebob@patrick [0]: printenv
USER=spongebob
LOGNAME=spongebob
HOME=/users/spongebob
PATH=/usr/X11/bin:/usr/local/sbin:/usr/sbin:/sbin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin
MAIL=/var/mail/spongebob
SHELL=/bin/tcsh
SSH_CLIENT=xxx.xxx.xxx.xxx xxxxx xx
SSH_CONNECTION=xxx.xxx.xxx.xxx xxxxx xx
SSH_TTY=/dev/pts/0
TERM=xterm
HOSTTYPE=i386-linux
VENDOR=intel
OSTYPE=linux
MACHTYPE=i386
SHLVL=1
PWD=/users/spongebob
GROUP=sbhelp
HOST=patrick
REMOTEHOST=bubbles
LS_COLORS=no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;35:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:
G_BROKEN_FILENAMES=1
SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
LANG=en_US.UTF-8
SUPPORTED=en_US.UTF-8:en_US:en:fr_FR.UTF-8:fr_FR:fr:de_DE.UTF-8:de_DE:de:es_ES.UTF-8:es_ES:es:ja_JP.eucJP:ja_JP:ja:zh_CN.GB18030:zh_CN:zh
LESSOPEN=|/usr/bin/lesspipe.sh %s
HOSTNAME=patrick
OS_RELEASE=Linux_2.4.20-30.9smp
LD_LIBRARY_PATH=/usr/local/lib:/usr/lib:/lib
DISTRIBUTION_RELEASE=9
MANPATH=/usr/local/man:/usr/share/man:/software/modules/current/man:/usr/man
DISTRIBUTION_NAME=redhat
_MODULESBEGINENV_=/users/spongebob/.modulesbeginenv
ARCH=i686
PAGER=less
DISPLAY=bubbles:0.0
104 spongebob@patrick [0]: xterm &
[1] 17698
105 spongebob@patrick [0]: xterm Xt error: Can't open display:
bubbles:0.0

[1]    Exit 1                        xterm

0
dlcurrell
4/25/2005 1:46:04 PM
comp.os.linux.x 2543 articles. 0 followers. Post Follow

1 Replies
326 Views

Similar Articles

[PageSpeed] 13

On 25 Apr 2005 06:46:04 -0700, dlcurrell@yahoo.com staggered into the
Black Sun and said:
> What am I doing wrong ??? Please see:
> spongebob@bubbles:~> xhost + patrick
> spongebob@bubbles:~> ssh patrick

What the hell are you using xhost for?  There's no need for xhost if
sshd is configured properly on the remote side and you use ssh -X (or
ssh -Y, depending.)

> spongebob@patrick [1]: setenv DISPLAY bubbles:0.0
> spongebob@patrick [0]: xterm &
> spongebob@patrick [0]: xterm Xt error: Can't open display:
> bubbles:0.0

It's highly probable that the X server on bubbles was started with
"-nolisten tcp".  http://groups.google.com/advanced_group_search , this
newsgroup, keywords "nolisten tcp" for advice--though you really want to
use ssh -X since you have sshd running on the other machine.

-- 
Matt G|There is no Darkness in Eternity/But only Light too dim for us to see
Brainbench MVP for Linux Admin /    mail: TRAP + SPAN don't belong
http://www.brainbench.com     /                Hire me! 
-----------------------------/ http://crow202.dyndns.org/~mhgraham/resume
0
Dances
4/25/2005 2:02:45 PM
Reply: