f



Debugger problems

Hello

I am having some problems with the debugger in RHIDE. Whenever I set a
break point and try to run the program I get the following message:

"This program has no usable debugging information. Try to compile it with
the -g switch."

The -g switch *is* set, no optimizers are set and the project compiles just
find.

RHIDE version: 1.5
Debugger version: 5.3
DJGPP version: 2.03
GCC version: 3.2.2

Running under Win98.

I hope anyone can give me some help on this matter.

Thanks in advance.

/Locke

0
8/14/2003 8:28:19 PM
comp.os.msdos.djgpp 3308 articles. 2 followers. tigrepotrazosalvaje (34) is leader. Post Follow

3 Replies
501 Views

Similar Articles

[PageSpeed] 52

Magnus Malm <temp_locke@hotmail.com> wrote:
: I am having some problems with the debugger in RHIDE. Whenever I set a
: break point and try to run the program I get the following message:

: "This program has no usable debugging information. Try to compile it with
: the -g switch."

: The -g switch *is* set, no optimizers are set and the project compiles just
: find.

Use some newer debug format. Try using "-gstabs+". Or some other one,
check the manual for the whole list.


Right,

						MartinS
0
ams1289 (23)
8/14/2003 8:37:39 PM
On 14 Aug 2003 20:37:39 GMT, Martin Str|mberg <ams@speedy.ludd.luth.se>
wrote:

>Magnus Malm <temp_locke@hotmail.com> wrote:
>: I am having some problems with the debugger in RHIDE. Whenever I set a
>: break point and try to run the program I get the following message:
>
>: "This program has no usable debugging information. Try to compile it with
>: the -g switch."
>
>: The -g switch *is* set, no optimizers are set and the project compiles just
>: find.
>
>Use some newer debug format. Try using "-gstabs+". Or some other one,
>check the manual for the whole list.
>

-gstabs+ did make it work. I chose -1 as value since I couldn't find any
info about this switch in the help. Diden't look that hard though since
debugging works, at last. :)

Now there's only 2 tiny lil probs left to figure out: The help window crash
and the exe creation failing, creating a file called <foo>.xxx, where xxx
is 000, 001, and so on. The latter only happens if the prog crashes prior
to the exe creation fail event and I diden't restart RHIDE. Really odd. But
restarting RHIDE isn't that hard work. :)

Many thanks for the help. Cheers

/Locke

0
8/14/2003 9:14:28 PM
Magnus Malm (temp_locke@hotmail.com) wrote:
: -gstabs+ did make it work. I chose -1 as value since I couldn't find any
: info about this switch in the help. Diden't look that hard though since
: debugging works, at last. :)

??? What -1 value?

: Now there's only 2 tiny lil probs left to figure out: The help window crash
: and the exe creation failing, creating a file called <foo>.xxx, where xxx
: is 000, 001, and so on. The latter only happens if the prog crashes prior
: to the exe creation fail event and I diden't restart RHIDE. Really odd. But
: restarting RHIDE isn't that hard work. :)

Add -v to the gcc options and you will see when they are
created. (It's when the stub is prepended.)


Right,

						MartinS
0
eplmst (10)
8/19/2003 1:43:12 PM
Reply:

Similar Artilces:

debugger problem and other problem
Hi all! I gave it another try to upgarde from 1.0.1 to 1.2.1 from CVS (Rev. 6469). My system: Linux Debian Lenny, kernel 2.6.24. Problems: 1. the classical debugger doesn't show the code. First I thought it could be a color problem, but it isn't. Changing the color doesn't help. You can find a screenshot at http://www.apw-wiegand.de/apwlin/debugger.png. As you can see the debugger finds the code file and shows the line number where it actually is, but doesn't show the code. In 1.0.1 the debugger was functioning. 2. I read several times in the newsgroup that others have the...

How to develop on OS X + debugger problems
Hi, I just started developing Ruby on OS X and didn't find any good IDEs. What is the best way to do it? I absolutely need a debugger. Currently, I am using Eclipse with the RDT plugin, but all I get when stepping is: ruby 1.8.4 debugger listens on port 54606 /Users/dittert/Documents/workspace/FileManager/Test.rb:2: [BUG] Bus Error ruby 1.8.4 (2005-12-24) [powerpc-darwin8.4.0] The program is puts "abc\n" puts "abc\n" puts "abc\n" <-- breakpoint puts "abc\n" puts "abc\n" puts "abc\n" puts "abc\n" G5:~ dittert$ ru...

os.rename() problems on OS X
hello, i recently had the job of having to rename about 200 files. The source for the renaming was a bunch of names in a file. I know next to nothing when it comes to bash scripting (which would have seemed the obvious choice) so i used python. The files i was renaming were canon raw files (.CR2). my problem is that after i rename the files, OS X will no longer render the thumbnails for the files, and preview is no longer the default app for viewing them. Does anyone have an idea as to why this is? Thanks for the help :) -Lukas On Fri, 11 Jan 2008 12:29:24 -0800, lukas wrote: > hello, &...

Problems booting OS X after booting OS 9
BW G3, 300 MHz, 256Mb RAM, OS 10.3.3 and OS 9.2.2, Sony Trinitron Multiscan E210 monitor I have a UMAX scanner for which there are no OSX drivers. This means that I have to boot in OS 9 whenever I need to scan something (which is daily, at least). The computer boots fine in OS9 and everything runs great, until I reboot in OSX. Immediately after the chime, the monitor goes into a power-saving mode (I have system prefs set NOT to put the monitor to sleep) and I'm not sure what else is going on because the monitor is black, and all HD sounds cease. If I zap the PRAM, everything s...

Problems booting in OS X after booting in OS 9
BW G3, 300 MHz, 256Mb RAM, OS 10.3.3 and OS 9.2.2, Sony Trinitron Multiscan E210 monitor I have a UMAX scanner for which there are no OSX drivers. This means that I have to boot in OS 9 whenever I need to scan something (which is daily, at least). The computer boots fine in OS9 and everything runs great, until I reboot in OSX. Immediately after the chime, the monitor goes into a power-saving mode (I have system prefs set NOT to put the monitor to sleep) and I'm not sure what else is going on because the monitor is black, and all HD sounds cease. If I zap the PRAM, everything s...

Debugger problem?
I use the debugger regularly and have just run into a problem that I have not seen before: Using C5.5H ABC on W2K machine Not all the procedures are available in the debugger. They simply are not there. Every procedure is set to debug mode and the whole app is set to Full debug. For example: Modules 1 through 18 and 20 through 25 are available, but module 19 is missing. I move the procedure in module 19 into module 18 and, although the source code shows up in the debugger, it is not "active." That is, I cannot set a break point in it or step into it. The AppFile.map file is also ...

Debugger Problems
I recently purchased a copy of CodeWarrior Learning Edition v4. It works well mostly, even though it's slighty more limited that I would like. The thing in CodeWarrior I've been having problems with is the debugger. Whenever I try to debug something, CodeWarrior crashes. The problem is 100% reproducable. I've looked at http://groups.google.com/groups?threadm=20030427093158.25304.00000126@mb- m23.aol.com and http://groups.google.com/groups?threadm=9c6fb850.0306300706.f10989f@posti ng.google.com but the solutions have not helped. When I try to run CW8_GDB.bin ...

os walk() and threads problems (os.walk are thread safe?)
Hello list, I have a strange problem with os.walk and threads in python script. I have one script that create some threads and consume Queue. For every value in Queue this script run os.walk() and printing root dir. But if i increase number of threads the result are inconsistent compared with one thread. For example, run this code plus sort with one thread and after run again with ten threads and see diff(1). --code-- #!/usr/local/bin/python import os, time, glob import Queue import threading EXIT=False POOL=Queue.Queue(0) NRO_THREADS=1 #NRO_THREADS=10 class Worker(threading.Thread)...

debugger problem
I've got a problem writing a debugger. The debugging process won't get notificated, and the debug process won't show up, although it is running in task-manager. Any idea what I did wrong? BTW: I use mingw for the program and VS ..net for the debugger program. But that's not a problem, is it? // --------------------------------------------------------------- // // This is the debugger code // --------------------------------------------------------------- // BOOL CSampleView::DebugProgram(LPCTSTR lpPathName, LPCTSTR lpComdLine) { DEBUG_EVENT DebugEv; DWORD dwCo...

Debugger problem?
Hello, Is there any word on whether the Debugger() call has a bug in 8.3? It doesn't stop where you put the call--it stops outside of the function, and so relevant variables are not accessible. This is bad, especially if you are trying to teach programming with CW. Bint In article <BB8C9E92.C266%juliosity@igf.com>, Bint <juliosity@igf.com> wrote: > Is there any word on whether the Debugger() call has a bug in 8.3? It > doesn't stop where you put the call--it stops outside of the function, and > so relevant variables are not accessible. T...

Problems with debugger
Hi, Do you know, what my be a reason for such "screen of death" during debuggin= g ? It looks like this : - the program stops on a beakpoint and I invoke locals and database (ctrl = L + ctrl D) - in few seconds iI get the error screen with "unhandled exception 0xC0...= 5" - after such exit I found a new module __VO__DebugModule (on the beginning= it is hidden, and I am not able to compile program; I must export the whol= e program to aef, delete it in a repository and then import from aef; after= such strange operations the extra module is visible and I am...

debugger problem
I am trying to convert an clipper app to VO 2.7b. I am using the debugger to see what is going on. The debugger appears to work until the shell window and menu appears on screen. After this I can not see any more code. I have checked the properties box in each module. Any suggestions or is this a problem with debug. Malcolm Hi Malcolm, whenever you want the debugger to pop up, you'll have to code AltD() there in your Code where you want to have a look. It's not done as in the old days by pressing "Alt+D" (-8 HAND Klaus "me" <lus...

Debugger problem
Hello, I am new to OS X programming, and i use C++ compiler Codewarrior 8.0 with OS as 10.2 and i somehow managed to crash my system so that i had to reinstall the OS (10.2.2) But now my Codewarrior 8.0 complains to me whenever i try to debug an application. It says "Unknown Error. Can't connect to GDB", Also the interface builder and project builder dont work with the new install Before the latest install they worked correctly. I have the folder known as 'previous system' which contains all the preferences and libraries that i used previously what can i take from these files without doing a reinstall? Please advise. Kind Regards Joji In article <8149dc89.0407070407.3e41f028@posting.google.com>, jojiv@hotmail.com (Joji V) wrote: >Hello, >I am new to OS X programming, and i use C++ compiler >Codewarrior 8.0 with OS as 10.2 >and i somehow managed to >crash my system so that i had to reinstall the OS (10.2.2) >But now my Codewarrior 8.0 complains to me whenever i >try to debug an application. >It says "Unknown Error. Can't connect to GDB", You need to install the Apple Developers Tools In order to debug or rebuild libraries on OS X you also need to go to the Apple Developers Connection http://www.apple.com/developer/ or http://connect.apple.com and download the December 2002 Developers tools for OS X 10.2.x The versions of gdb that came with OS X CD's h...

Problems problems....
I've got Fujitsu MAN3184MP and Adaptec 29160 scsi card. Sometimes i have this message "A disk read error occured" , sometimes even bios does not recognize it, sometimes it does but the boot sequence does not start it seems that motherboard bios has problems with it ( so it seems to me, i could be wrong about that assumption) . Then i reset and it all works perfectly. I've noticed a speed degradation in Win XP lately. I'm angry :)) I have LVD/SE terminator, and i think 68pin cable ( not sure about that ). Hope i gave you enough info to try and help. Thanx! -- ----------------------------------- Makni #### iz adrese Seems obvious that the drive is going belly up. You could download the manufacture's utility disk and confirm it. I think time would more wisely be spent backing up your data before you can't read it at all. DaveL "biBU" <idolovcak####@inet.hr> wrote in message news:cuslus$ljq$1@fegnews.vip.hr... > I've got Fujitsu MAN3184MP and Adaptec 29160 scsi card. > > Sometimes i have this message "A disk read error occured" , sometimes even > bios does not recognize it, sometimes it does but the boot sequence does > not start it seems that motherboard bios has problems with it ( so it > seems to me, i could be wrong about that assumption) . Then i reset and it > all works perfectly. I've noticed a speed degradation in Win XP lately. > I'm angry :)) > > ...

os.execve(pth,args,env) and os.chroot(pth) = problems
Hello fellow python users, I've been working on a basic implementation of a privilege separated web server, and I've goto the point of running a basic cgi script. Basically when the execCGI function in my Unpriv.py program is called a few things should happen, it should fork (which it does), the stdout of the child should be redirected to a given pipe (which it does), and the script should execute using execve(which is has problems with). Also before the execCGI() fucntion is executed, a few important things happen in __init__: os.chroot('/var/www/webroot/') the path is web s...

Problem upgrading from OS 10.4.1 to OS 10.4.9
I have a MacBook Pro with OS X version 10.4.1 installed. Model Name: MacBook Pro 15" Model Identifier: MacBookPro1,1 Processor Name: Intel Core Duo Processor Speed: 2 GHz Number Of Processors: 1 Total Number Of Cores: 2 L2 Cache (per processor): 2 MB Memory: 1 GB Bus Speed: 667 MHz I downloaded Mac_OS X 10.4.9 Combined Update (Intel) and when I tried updating it read: "You cannot install Mac OS X Update Combined (Intel) on this volume. This volume does not meet the requirements for this update." researcher wrote: > I have a MacBook Pro with OS X version 10.4.1 installed. > Model Name: MacBook Pro 15" > Model Identifier: MacBookPro1,1 > Processor Name: Intel Core Duo > Processor Speed: 2 GHz > Number Of Processors: 1 > Total Number Of Cores: 2 > L2 Cache (per processor): 2 MB > Memory: 1 GB > Bus Speed: 667 MHz > > I downloaded Mac_OS X 10.4.9 Combined Update (Intel) and when I tried > updating it read: > > "You cannot install Mac OS X Update Combined (Intel) on this volume. > This volume does not meet the requirements for this update." > Call up apple support to find out what gives. ...

DJGPP port of GNU debugger (GDB) 7.7.1 uploaded (DJGPP 205 only).
This is a port of GNU debugger (GDB) 7.7.1 to MSDOS/DJGPP. GDB is a source-level debugger for C, C++, Pascal, Objective-C and many other languages. GDB can target (i.e., debug programs running on) more than a dozen different processor architectures, and GDB itself can run on most popular GNU/Linux, Unix and Microsoft Windows variants. DJGPP specific changes. ======================= - There are no DJGPP specific user visible changes. - The only reason to make this port available, is because it is probably the last gdb version that supports the CO...

Announcement: DJGPP port of GNU debugger (GDB) 7.10 uploaded (DJGPP 205 only).
This is a port of GNU debugger (GDB) 7.10 to MSDOS/DJGPP. GDB is a source-level debugger for C, C++, Pascal, Objective-C and many other languages. GDB can target (i.e., debug programs running on) more than a dozen different processor architectures, and GDB itself can run on most popular GNU/Linux, Unix and Microsoft Windows variants. DJGPP specific changes. ======================= - There are no DJGPP specific user visible changes. - The BFD library will support 32 bit wide relocation counters for DJGPP as has been implemented for the latest DJG...

[ace-bugs] Installation/Build Problem: problem installing on Mac OS X 10.3
--Apple-Mail-5-278401698 Content-Transfer-Encoding: 7bit Content-Type: text/plain; charset=US-ASCII; format=flowed ACE VERSION: 5.3.6 HOST MACHINE and OPERATING SYSTEM: Mac OS X (10.3), 1Ghz Powerbook CONTENTS OF $ACE_ROOT/ace/config.h: (attached) CONTENTS OF $ACE_ROOT/include/makeinclude/platform_macros.GNU: (attached) AREA/CLASS/EXAMPLE AFFECTED: Installation/building DOES THE PROBLEM AFFECT: Installation/building SYNOPSIS: I'm trying to build ACE on Mac OS X 10.3. The build ran for a while and seemed to be working, then terminated with a...

Release 2 of the DJGPP port of GNU debugger (GDB) 7.9.1 uploaded (DJGPP 2.05 only).
This is a port of GNU debugger (GDB) 7.9.1 to MSDOS/DJGPP. GDB is a source-level debugger for C, C++, Pascal, Objective-C and many other languages. GDB can target (i.e., debug programs running on) more than a dozen different processor architectures, and GDB itself can run on most popular GNU/Linux, Unix and Microsoft Windows variants. DJGPP specific changes. ======================= - The previous port still had a dependency of libiconv. This dependency made it necessary to have the licv114br2 port installed to get gdb runing. Thus the previous ...

[ace-users] Re: ACE version 5.4 compilation problem . My OS is Cent OS 4.2
Hi Rafi, Thanks very much for your email. Please make sure to send all questions related to TAO or ACE to the ACE mailing list or ACE+TAO newsgroup, rather than to me directly since I travel frequently and often don't have ready access to email. See http://www.cs.wustl.edu/~schmidt/ACE-mail.html for more info on how to access these resources. > I am trying to locate libACE.so, and looks like it created as follows (?): > > lrwxrwxrwx 1 root root 15 Feb 24 19:28 /usr/local/lib/libACE.so > -> libACE.so.5.4.0 > > Is it right ? I installed 5.4.10, and the library it craeted does not > reflect the version ? I believe this is an option now, but I'm not the guru on this, which is yet another reason to post questions to the ACE mailing list, rather than to me. > Also, I was looking at the example files - looks like it is to much > information, and I am sort of lost (I am new ACE user ). I would > like to test some simple client/server ACE examples, and how to > compile, and link with the libs that I created...Can you please help > me locating this simple example ? There are many examples in ACE_ROOT/examples/C++-NPv1/ ACE_ROOT/examples/C++-NPv2/ ACE_ROOT/examples/APG/ These examples are explained in great detail in the three books at ACE available from http://www.cs.wustl.edu/~schmidt/ACE/ This link also contains links to various tutorials on ACE. Take care, Doug ...

Problem linking with gfortran v4.9.2 on OS X Yosemite: 'Undefined symbol "start"' problem
Hello, I posted to the gfortran mailing list but haven't received a reply so I thought I'd toss it out to the newsgroup to see if anyone had encountered (and solved) this problem. I installed gfortran 4.9.2 for Yosemite on my mac. The install was quick and easy as always (Thanks FX!). Compilation works, but when I reach the linking phase I get the following error: Undefined symbols for architecture x86_64: "start", referenced from: -u command line option ld: symbol(s) not found for architecture x86_64 collect2: error: ld returned 1 exit status mak...

Xcode debugger problem
I am using Xcode 1.5 and have had problems with the debugger window. I am working on a multithreaded standard tool (very vanilla C command line program) and the debugger window is messed up. The stack display gets lost. The window below the tool bar is divided roughly in half (adjustable) with the left half the call stack and the right half variable/value display. There is a dimple you can use to adjust the relative sizes of these two windows. Anyway when the debugger is messed up the dimple disappears and so does the stack display window. (It's like it got dragged to 0 size, which you cannot do and the drag dimple disappears). Very frustrating when you hit a break point and cannot see the call stack... After much fighting I managed to get it back by throwing away the <name>.pbxuser object inside the xcode project, cleaning the object code and rebuilding. I'm not sure which of these did it but finally I had the window back in normal form. Any suggestions on (a) how to prevent this or (b) a better way or perhaps THE way to fix it. -jim ...

Web resources about - Debugger problems - comp.os.msdos.djgpp

Debugger - Wikipedia, the free encyclopedia
... , but its sources remain unclear because it lacks inline citations . Please improve this article by introducing more precise citations. A debugger ...

Debugger - Facebook-Entwickler
Facebook-Entwickler Search Facebook Developers Dokumente Werkzeuge Hilfe Neuigkeiten Anwendungen Anmelden Debugger Startseite › Werkzeuge Input ...

Script Debugger 5.0
Major update to one of my favorite apps of all time. If you dick around with AppleScript, you should have Script Debugger.

Review: 5 memory debuggers for Linux coding
When you're working in Linux, manually debugging memory-related errors can be difficult and time consuming. These five tools can help.

Android Studio 1.2 Reaches Beta, Adds Built-In Decompiler, Inline Debugger Variables, Smarter Formatting ...
When Android Studio v1.1 entered the Stable channel, about 6 weeks ago, the Dev Tools team gave word that v1.2 was already well underway and ...

Review: 5 memory debuggers for Linux coding
As a programmer, I'm aware that I tend to make mistakes and why not? Even programmers are human. Some errors are detected during code compilation, ...

Meet the DeBuggers An attitude adjustment regarding the "Fix" at Healthcare.gov
Let me start off by saying that Healthcare.gov is now working well in most areas of the US. Folks are accessing the site all day, every day, ...

Resolving Nightmare Bugs With Reversible Linux App Debugger
Undo and ARM partner on ARM DS-5 tool suite rapidly resolve nightmare bugs

Bed bugs: A new debugger - The Economist
FEW things destroy the reputation of a high-class hotel faster than bed bugs.

Genuitec Launches Debugger for PhoneGap, Apache Cordova
Genuitec ships GapDebug, a new debugger for developers building PhoneGap and Apache Cordova apps.

Resources last updated: 3/22/2016 6:00:33 PM