f



OS/2 Warp 3 Connect

So, my legal copy of OS/2 Warp Connect v3 came in the mail today :)  I am
trying to install it in a VirtualBox VM.  I found the necessary AMD PCNet
III drivers and made a floppy disk image and that driver seems to work.
However, when the installer picks up after the "Installing MPTS adapters and
drivers" portion, the screen after that just freezes and then does nothing.
As is always the case with OS/2, a right Ctrl-R reboots the VM and when it
restarts, it picks up right at the same place.

I am wondering if anyone else has had this issue as well and if anyone
else has had success in installing OS/2 Warp 3 (red or blue spine) under
Oracle's VirtualBox?

.... Elvis has left the echo.
--- MultiMail/OS/2 v0.50
0
robert
10/23/2016 1:01:01 AM
comp.os.os2.misc 2779 articles. 0 followers. Post Follow

2 Replies
348 Views

Similar Articles

[PageSpeed] 8

Am 23.10.16 um 08.52 schrieb Robert Wolfe:
> So, my legal copy of OS/2 Warp Connect v3 came in the mail today :)  I am
> trying to install it in a VirtualBox VM.  I found the necessary AMD PCNet
> III drivers and made a floppy disk image and that driver seems to work.
> However, when the installer picks up after the "Installing MPTS adapters and
> drivers" portion, the screen after that just freezes and then does nothing.
> As is always the case with OS/2, a right Ctrl-R reboots the VM and when it
> restarts, it picks up right at the same place.
>
> I am wondering if anyone else has had this issue as well and if anyone
> else has had success in installing OS/2 Warp 3 (red or blue spine) under
> Oracle's VirtualBox?
>
> ... Elvis has left the echo.
> --- MultiMail/OS/2 v0.50
>
I would think that you either have to severely limit the size of your 
virtual disk or that you have to use updated IDE drivers + OS2DASD.DMD.
You will then need to modify the installation disks with the updated files.

Lars
0
Lars
10/23/2016 10:59:45 AM
Lars Erdmann schrieb:
> Am 23.10.16 um 08.52 schrieb Robert Wolfe:
>> So, my legal copy of OS/2 Warp Connect v3 came in the mail today :)  I am
>> trying to install it in a VirtualBox VM.  I found the necessary AMD PCNet
>> III drivers and made a floppy disk image and that driver seems to work.

In which version of VirtualBox? AMD PCNet is not necessary - the other 
option is an emulated Intel E1000.

>> However, when the installer picks up after the "Installing MPTS
>> adapters and
>> drivers" portion, the screen after that just freezes and then does
>> nothing.
>> As is always the case with OS/2, a right Ctrl-R reboots the VM and
>> when it
>> restarts, it picks up right at the same place.
>>
>> I am wondering if anyone else has had this issue as well and if anyone
>> else has had success in installing OS/2 Warp 3 (red or blue spine) under
>> Oracle's VirtualBox?
>>
>> ... Elvis has left the echo.
>> --- MultiMail/OS/2 v0.50
>>
> I would think that you either have to severely limit the size of your
> virtual disk or that you have to use updated IDE drivers + OS2DASD.DMD.


> You will then need to modify the installation disks with the updated files.

There is no reason to do. Simply remove the IDE controller from the VM 
configuration. Add a (virtual) SCSI host adapter with your hd image and 
a cd drive and change the settings to the "BusLogic" type, that Warp 3 
supports out of the box. I don't know why this setting is not default by 
choosing an "OS/2 Warp 3" machine.

Networking inside VirtualBox has some problems not specific to the 
emulated NIC. But it's not impossible to do a network install of Warp 
Connect inside a VM.

--
Andreas
0
Andreas
10/23/2016 12:00:56 PM
Reply: