f



How to integrate gcc 3.4.4 to Tornado 2.2.1 for VxWorks 5.5.1

Hi, all.

Did anybody tried to integrate the gcc 3.4.4 to Tornado 2.2.1, whose
native compiler is gcc 2.96 ?
I know that the gcc 3.4.4 is delivered as part of Workbench IDE with
VxWorks 6.x and generally it is supported by WindRiver.

If you tried and, hopefully, succeeded to integrate the compiler,
please outline the procedure or, alternatively, point me to a resource
explaining this issue.
If you tried and not succeeded, please give me an indication -
whether, in your opinion, it is possible at all.

We have an application written under VxWorks 5.5.1 with Tornado 2.2.1
and now we trying to evaluate efforts necessary to port the
application to VxWorks 6.x - without actually use it.

Whether code produced by gcc 3.4.4 is binary compatible with code
produced by gcc 2.96, I mean - should we be able to run this code on
VxWorks 5.5.1 target ?

I guess that we cannot get any support from WR techsupp regarding this
issue, so I looking for your inputs.
If you need some additional details, please let me know.

Thanks in advance.
mb

0
10/18/2007 10:07:33 PM
comp.os.vxworks 5962 articles. 3 followers. motamedi24 (67) is leader. Post Follow

4 Replies
892 Views

Similar Articles

[PageSpeed] 54

On Oct 19, 3:07 am, maxim.bakus...@gmail.com wrote:
> Hi, all.
>
> Did anybody tried to integrate the gcc 3.4.4 to Tornado 2.2.1, whose
> native compiler is gcc 2.96 ?
> I know that the gcc 3.4.4 is delivered as part of Workbench IDE with
> VxWorks 6.x and generally it is supported by WindRiver.
>
> If you tried and, hopefully, succeeded to integrate the compiler,
> please outline the procedure or, alternatively, point me to a resource
> explaining this issue.
> If you tried and not succeeded, please give me an indication -
> whether, in your opinion, it is possible at all.
>
> We have an application written under VxWorks 5.5.1 with Tornado 2.2.1
> and now we trying to evaluate efforts necessary to port the
> application to VxWorks 6.x - without actually use it.
>
> Whether code produced by gcc 3.4.4 is binary compatible with code
> produced by gcc 2.96, I mean - should we be able to run this code on
> VxWorks 5.5.1 target ?
>
> I guess that we cannot get any support from WR techsupp regarding this
> issue, so I looking for your inputs.
> If you need some additional details, please let me know.
>
> Thanks in advance.
> mb

hi,

i dont think anyone wud hav tried it because people will use that
compiler supplied in that package and will never try to integrate it
with lower OS versions.

regards

0
swavxworks (20)
10/19/2007 9:49:50 AM
On Oct 19, 11:49 am, pappuda <swavxwo...@gmail.com> wrote:
> On Oct 19, 3:07 am, maxim.bakus...@gmail.com wrote:
>
>
>
>
>
> > Hi, all.
>
> > Did anybody tried to integrate the gcc 3.4.4 to Tornado 2.2.1, whose
> > native compiler is gcc 2.96 ?
> > I know that the gcc 3.4.4 is delivered as part of Workbench IDE with
> > VxWorks 6.x and generally it is supported by WindRiver.
>
> > If you tried and, hopefully, succeeded to integrate the compiler,
> > please outline the procedure or, alternatively, point me to a resource
> > explaining this issue.
> > If you tried and not succeeded, please give me an indication -
> > whether, in your opinion, it is possible at all.
>
> > We have an application written under VxWorks 5.5.1 with Tornado 2.2.1
> > and now we trying to evaluate efforts necessary to port the
> > application to VxWorks 6.x - without actually use it.
>
> > Whether code produced by gcc 3.4.4 is binary compatible with code
> > produced by gcc 2.96, I mean - should we be able to run this code on
> > VxWorks 5.5.1 target ?
>
> > I guess that we cannot get any support from WR techsupp regarding this
> > issue, so I looking for your inputs.
> > If you need some additional details, please let me know.
>
> > Thanks in advance.
> > mb
>
> hi,
>
> i dont think anyone wud hav tried it because people will use that
> compiler supplied in that package and will never try to integrate it
> with lower OS versions.
>
> regards- Hide quoted text -
>
> - Show quoted text -

Thanks.

Any other opinions ?

0
10/20/2007 7:05:33 PM
On Oct 21, 12:05 am, maximb <maxim.bakus...@gmail.com> wrote:
> On Oct 19, 11:49 am, pappuda <swavxwo...@gmail.com> wrote:
>
>
>
>
>
> > On Oct 19, 3:07 am, maxim.bakus...@gmail.com wrote:
>
> > > Hi, all.
>
> > > Did anybody tried to integrate the gcc 3.4.4 to Tornado 2.2.1, whose
> > > native compiler is gcc 2.96 ?
> > > I know that the gcc 3.4.4 is delivered as part of Workbench IDE with
> > > VxWorks 6.x and generally it is supported by WindRiver.
>
> > > If you tried and, hopefully, succeeded to integrate the compiler,
> > > please outline the procedure or, alternatively, point me to a resource
> > > explaining this issue.
> > > If you tried and not succeeded, please give me an indication -
> > > whether, in your opinion, it is possible at all.
>
> > > We have an application written under VxWorks 5.5.1 with Tornado 2.2.1
> > > and now we trying to evaluate efforts necessary to port the
> > > application to VxWorks 6.x - without actually use it.
>
> > > Whether code produced by gcc 3.4.4 is binary compatible with code
> > > produced by gcc 2.96, I mean - should we be able to run this code on
> > > VxWorks 5.5.1 target ?
>
> > > I guess that we cannot get any support from WR techsupp regarding this
> > > issue, so I looking for your inputs.
> > > If you need some additional details, please let me know.
>
> > > Thanks in advance.
> > > mb
>
> > hi,
>
> > i dont think anyone wud hav tried it because people will use that
> > compiler supplied in that package and will never try to integrate it
> > with lower OS versions.
>
> > regards- Hide quoted text -
>
> > - Show quoted text -
>
> Thanks.
>
> Any other opinions ?- Hide quoted text -
>
> - Show quoted text -

i did read in one of the release notes of VxWorks platform versions
that al GNU 2.96 + librries are provided with the latest GNU compiler.
so i feel these gnu compilers have been upward compatible to 6.x but
no idea if the same compiler can be used in Tornado 2.2.1.

Did you try installing only the GNU compiler 3.4.4 media in the
Tornado 2.2.1 tree?
Please let me know. well i shall also give a try to it at my end and
revert after thursday as i am travelling till then.

bye.

0
swavxworks (20)
10/21/2007 1:00:31 PM
On Oct 21, 3:00 pm, pappuda <swavxwo...@gmail.com> wrote:
> On Oct 21, 12:05 am, maximb <maxim.bakus...@gmail.com> wrote:
>
>
>
>
>
> > On Oct 19, 11:49 am, pappuda <swavxwo...@gmail.com> wrote:
>
> > > On Oct 19, 3:07 am, maxim.bakus...@gmail.com wrote:
>
> > > > Hi, all.
>
> > > > Did anybody tried to integrate the gcc 3.4.4 to Tornado 2.2.1, whose
> > > > native compiler is gcc 2.96 ?
> > > > I know that the gcc 3.4.4 is delivered as part of Workbench IDE with
> > > > VxWorks 6.x and generally it is supported by WindRiver.
>
> > > > If you tried and, hopefully, succeeded to integrate the compiler,
> > > > please outline the procedure or, alternatively, point me to a resource
> > > > explaining this issue.
> > > > If you tried and not succeeded, please give me an indication -
> > > > whether, in your opinion, it is possible at all.
>
> > > > We have an application written under VxWorks 5.5.1 with Tornado 2.2.1
> > > > and now we trying to evaluate efforts necessary to port the
> > > > application to VxWorks 6.x - without actually use it.
>
> > > > Whether code produced by gcc 3.4.4 is binary compatible with code
> > > > produced by gcc 2.96, I mean - should we be able to run this code on
> > > > VxWorks 5.5.1 target ?
>
> > > > I guess that we cannot get any support from WR techsupp regarding this
> > > > issue, so I looking for your inputs.
> > > > If you need some additional details, please let me know.
>
> > > > Thanks in advance.
> > > > mb
>
> > > hi,
>
> > > i dont think anyone wud hav tried it because people will use that
> > > compiler supplied in that package and will never try to integrate it
> > > with lower OS versions.
>
> > > regards- Hide quoted text -
>
> > > - Show quoted text -
>
> > Thanks.
>
> > Any other opinions ?- Hide quoted text -
>
> > - Show quoted text -
>
> i did read in one of the release notes of VxWorks platform versions
> that al GNU 2.96 + librries are provided with the latest GNU compiler.
> so i feel these gnu compilers have been upward compatible to 6.x but
> no idea if the same compiler can be used in Tornado 2.2.1.
>
> Did you try installing only the GNU compiler 3.4.4 media in the
> Tornado 2.2.1 tree?
> Please let me know. well i shall also give a try to it at my end and
> revert after thursday as i am travelling till then.
>
> bye.- Hide quoted text -
>
> - Show quoted text -

Hi,

I've downloaded the gcc 3.4.4 package with cygwin and just copied its
precompiled binaries into the Tornado tree. My try to compile the
application with our custom makefile failed with multiple errors.

Can you suggest plz - which binaries should I replace / copy from
cygwin to Tornado ? My understanding is that the compiler tree was
changed too between the 2.96 and 3.4.4 versions...

Thanks in advance.
maximb

0
10/22/2007 8:38:59 AM
Reply: