f



PNY flash drive on PC running RH 9.1 vs. RH 7.1

I have been trying to get a PNY USB 2.0 FD flash drive to work on two
PC's, one of which has RH 7.1 and the other of which has RH 9.1. I have
succeeded in getting it to work on the one with RH 7.1 but I don't know
for certain which of the things I did are responsible for it working. I
am unable to get it to work on the one with RH 9.1.

Basically, on the one with RH 7.1, I created a file named /etc/updfstab.conf
and placed

symlink false
device flash {
	match hd flash
	}

in it. I also added the line
/dev/sda1               /mnt/flash              auto    noauto,owner    0 0
to the file /etc/fstab. I also created the directory /mnt/flash and executed
/usr/sbin/modprob usb-storage
just in case and found after plugging in the flash drive that
/proc/scsi/scsi/usb-storage-0/0 contained all the information about the
flash drive. Then I mounted it with the command
mount -t msdos /dev/sda1 /mnt/flash
and was able to read and write to the flash drive with no difficulty.

Question: is there such a thing as formatting the flash drive for Linux,
e.g. with an ext2 file system? If so, how.

On the other PC, with RH 9.1, there was already a file /etc/updfstab.conf
which simply sourced another file named /etc/updfstab.conf.default. The
entry for flash in the latter read

device flash {
	partition 1
	match hd CompactFlash
	match hd ImageMate
	}

I have no idea what these are. I added match hd PNY as a third option
in /etc/updfstab.conf after the default file was read in, since later
entries override earlier ones. I also tried it with the same version I
used on the RH 7.1 system. In neither case could I mount the flash drive.
It did create the file /proc/scsi/usb-storage-0/0 with the right information
but it said that is is not attached. The error message when I plugged in
the flash drive was, according to dmesg:

hub.c: already running port 1 disabled by hub (EMI?), re-enabling
usb.c: USB disconnect on device 00:1d.0-1 address 2
hub.c: Cannot enable port 1 of hub 1, disabling port.
hub.c: Maybe the USB cable is bad?

As I already mentioned, it works on RH 7.1 without the cable but I get
this error message on RH 9.1 with or without the cable. When I execute

mount -t msdos /dev/sda1 /mnt/flash

I get the error message

mount: /dev/sda1 is not a valid block device

which I think means it isn't detecting the flash drive, which is consistent
with the proc file saying the device is not attached. I have no idea which
of the /dev/sd* devices is the right one to use. On RH 7.1, I first tried
/dev/sda and got an error message. When I used /dev/sda1, it worked fine.
None of the choices works on the RH 9.1 but that might be irrelevant, the
real problem being that Linux thinks the flash drive is not attached.

Anyway, the differences in the configurations of the various files
/etc/*fstab* between the two versions of RH show that there might be
some features of the upgraded OS that I need to understand. I suspect
that I'm actually close to being able to get the flash drive to work
on the RH 9.1 system. If you know how to do it, based on the above,
please let me know.

I think that, strictly speaking, the flash drive is not a scsi device,
even though it gets registered in /proc/scsi. But maybe it is close enough
for this newsgroup. I tried comp.os.linux.misc and haven't gotten any replies
so far. RedHat 7.1 and RedHat 9.1 Linux are both old versions of the
operating system and most people probably don't have it on their systems
anymore and can't really help with it.
-- 
Ignorantly,
Allan Adler <ara@zurich.csail.mit.edu>
* Disclaimer: I am a guest and *not* a member of the MIT CSAIL. My actions and
* comments do not reflect in any way on MIT. Also, I am nowhere near Boston.
0
ara68 (499)
6/11/2005 4:37:33 AM
comp.periphs.scsi 2473 articles. 0 followers. l_x2828 (153) is leader. Post Follow

0 Replies
345 Views

Similar Articles

[PageSpeed] 30

Reply:

Similar Artilces:

LV 7.1.1 vs 7.1 Run-Time conflicts
Is it just me or is the upgrade to 7.1.1 a bit quirky?<br><br>NI has chosen= to keep the same run-time engine folder (7.1), but has changed the run-tim= e. <br><br>First of all the 7.1 run-time did not get removed properly so th= e first time I build an application it gave an error during startup, saying= that the resource file had the wrong version. I had to uninstall the run-t= ime, delete the files that refused to be uninstalled, and then install the = 7.1.1 version...fine enough. That part might very well be a local phenomeno= n(?).<br><br>However, if ...

1.9.1-p376 vs. 1.9.1-p378
I just noticed that both http://www.ruby-lang.org/en/ and http://www.ruby-lang.org/en/downloads/ advertise 1.9.1-p376, but ftp://ftp.ruby-lang.org/pub/ruby/1.9/ also contains ruby-1.9.1-p378 as well? Which is preferred? Regards, Jeremy Henty Jeremy Henty wrote: > I just noticed that both http://www.ruby-lang.org/en/ and > http://www.ruby-lang.org/en/downloads/ advertise 1.9.1-p376, but > ftp://ftp.ruby-lang.org/pub/ruby/1.9/ also contains ruby-1.9.1-p378 as > well? Which is preferred? > > Regards, > > Jeremy Henty p376 is the advertised as the ...

Upgrading RH-9.0 to RH-9.1
Has anyone successfully upgraded to RH-9.1 (severn)? I get the error ======================================================= /usr/src/build/309579-i386/install/usr/lib/anaconda/text.py line 451, in run TypeError: __call() takes exactly 2 arguments (4 given) ======================================================= I've reported this to bugzilla -- I just wondered if anyone else had encountered, or not encountered, it. -- Timothy Murphy e-mail: tim@birdsnest.maths.tcd.ie tel: +353-86-233 6090 s-mail: School of Mathematics, Trinity College, Dublin 2, Ireland Timothy Murph...

photosmart 7760 driver on PC running RH 7.1
I want to attach a HP PhotoSmart 7760 Photo Printer to a PC running Red Hat 7.1 Linux. I once connected a Canon Bubble Jet printer to the PC using printtool and was able to print something out on it. The printer driver is postscript (i.e. I have ghostscript installed). Since this printtool is older than the printer, it doesn't know about it. I don't want to upgrade at the moment. I just want to find whatever file or information printtool needs to know about the PhotoSmart 7760 and place it where printtool can find it. As far as finding the printer driver goes, I've went to www.li...

photosmart 7760 driver on PC running RH 7.1
I want to attach a HP PhotoSmart 7760 Photo Printer to a PC running Red Hat 7.1 Linux. I once connected a Canon Bubble Jet printer to the PC using printtool and was able to print something out on it. The printer driver is postscript (i.e. I have ghostscript installed). Since this printtool is older than the printer, it doesn't know about it. I don't want to upgrade at the moment. I just want to find whatever file or information printtool needs to know about the PhotoSmart 7760 and place it where printtool can find it. As far as finding the printer driver goes, I've went to www.linuxprinting.org and eventually found a file named HP-PhotoSmart_7760-hpijs.ppd and downloaded it. I am not sure whether this is the file I actually need. If so, how do I make printtool aware of it? While looking at the linuxprinting site, I saw pointers to a website for CUPS, which seems to know something about ppd files, but the documentation for CUPS says that installing it will destroy the existing printing system on my computer, which I don't want to do. So, I'm rather confused by all this. -- Ignorantly, Allan Adler <ara@zurich.csail.mit.edu> * Disclaimer: I am a guest and *not* a member of the MIT CSAIL. My actions and * comments do not reflect in any way on MIT. Also, I am nowhere near Boston. On RH 9.1, I got the printer to work by telling printtool that it was a Photosmart 7550. On RH 7.1, the closest is a Photosmart 1100. There a...

BIND 9.7.1-P1 planned to address issues in BIND 9.7.0 and 9.7.1
Dear Users, We have received reports that BIND 9.7.0 and 9.7.1 are failing to resolve certain zones. These zones are resolved correctly by earlier versions of BIND. BIND 9.7.0 and 9.7.1 follows the DNS protocol more strictly than earlier versions. We felt that this change created added safety for certain types of responses from potentially misconfigured servers, but now believe it is hurting more than helping. We are planning a patch release to revert to previous behavior. We hope to get BIND 9.7.1-P1 released to our forum members this week and to the public shortly after. T...

1 - 1, 1 -1, 1-1, 1
Hi, I have a question regarding lexical analysis. I recently came across a bug in our lexical analyser in phc (www.phpcompiler.org), that I am unsure how to solve. This is the problem: our current definition for integer constant looks something like INT ([1-9][0-9]*)|0 In particular, note that it does not allow for an (optional) "+" or "-" at the start of the integer. This means that the strings "1 - 1", "1 -1" and "1-1" all generate the same sequence of three tokens INT(1), OP(-), INT(1), for which the syntax analyser generates the subtree BIN_OP(-, 1, 1). For the string "1 - -1", the lexer (unsurprisingly) generates INT(1), OP(-), OP(-), INT(1). The syntax analyser recognises this as BIN_OP(1, UNARY_OP(-, 1)). In other words, the second "-" is treated as a unary operator, rather than as part of the number. This works fine, with the sole exception of the number "-2147483648". The problem is, of course, overflow: -2147483648 is a valid negative number (assuming 32-bit numbers), but the integer 2147483648 is _not_ a valid positive number. Thus, the above method of dealing with "-" as a unary operator breaks down. The solution is to interpret the "-" as part of the number, and generate INT(-2147483648), rather than OP(-), INT(...). However, changing the definition of INT to INT [+-]?([1-9][0-9]*)|0 causes "1-1" to be recognised as INT(1), INT(-1), which is...

1.1.1.1 ?
hi my firewall logs dropped packets from an internal IP address trying to contact 1.1.1.1 through port 9999. Any ideas whether 1.1.1.1 is valid IP? and what is port 9999?? thanks mike wrote: > hi > > my firewall logs dropped packets from an internal IP address trying to > contact 1.1.1.1 through port 9999. Any ideas whether 1.1.1.1 is valid > IP? and what is port 9999?? > thanks These trojans *BlitzNet*, *Backdoor.Oracle*, *Backdoor.Spadeace* uses port 9999 -- S.S. "StarScripter" <Star@privacy.net> wrote in message news:<bv8ejj$p54t3$1@ID-185702.new...

[ANN] RubyInstaller: 1.8.7-p299, 1.9.1-p429 and 1.9.2-rc1 installers and packages released
Hello, Wanted to inform that RubyInstaller project released installers and packages for 1.8.7-p299 and 1.9.1-p429, available as usual at RubyForge: http://rubyforge.org/frs/?group_id=3D167 We have also uploaded 1.9.2-rc1 into experimental section of the same group download page. Regards, --=20 Luis Lavena AREA 17 - Perfection in design is achieved not when there is nothing more to add, but rather when there is nothing more to take away. Antoine de Saint-Exup=E9ry ...

Giving away: Unixware 7.1.0, 7.1.1, 7.1.2 and 7.1.3 media, SDK and updates
I'm cleaning-up and need to give away or throw-out all my unixware media: 7.1.0 - 7.1.3, the software development kit and updates. I've already sold-off the licenses so this is the media only! Please respond to ftarz@mindspring.com if you are interested. You pay the shipping of your choice. ...

openssl-1.0.1 bind-9.10.1 softhsm-1.3.7
Greetings, I am new to this list. I am trying to compile bind-9.10.1 to use softhsm-1.3.7. My system has these --cpu amd64 2 ores --os blfs 64bit linux, gcc-4.8, openssl-1.0.1i I am using a recent version of openssl because of the recent news regarding the heartbeat bug ) I fetched the latest pdf manual for bind-9.10.1; namely Bv9ARM.pdf from https://kb.isc.org/article/AA-01031 section 3.11.3.4 of Bv9ARM.pdf building openssl for softhsm reads:- --pkll-libname=/path/to/libsofthsm.so --pk11-flavor=sign-only ( seems to be a recipe for openssl0.9.8y It does not seem to work with openssl-1.0.1i I tried the above and also --with-pkll-libname=/path/to/libsofthsm.so \ --with-pk11-flavor=sign-only but configure failed ai all instances. Openssl compiles in all instances without the pk11 references. I would be grateful for some advice on how to build openssl-1.0.1i to work with bind-9.10.1 and softhsm-1.3.7 thanks in advance sincerely sibuxolo ...

rh 7.1, apache 1.3.27, and php4
Hello, I have a very urgent problem! The situation is i have an rh 7.1 box, i know it's not mine though, that has apache 1.3.27 on it in the form of what i presume is an rpm, it's actually on a vps system. Apache was built with dso support as well as php4 which was also installed, then mhash was to be added. A source version of php4.3.4 was downloaded and installed with mhash support, and now not only does this not work, but apache is no longer processing php pages! In the httpd.conf file there are references to if defined php, php3, and php4, and the index line has index.p...

plot 1, -1, 1, -1, -1
Hi, How to plot those numbers in a rectangle style? thanks x = linspace(-4*pi,4*pi,1000); y = sin(x); plot(x,sign(y)), axis([-12 12 -2 2]) PZ <patrick.zou@gmail.com> wrote in message <d64c545f-f2ac-4f87-af89-051bda896707@x6g2000vbg.googlegroups.com>... > Hi, > > How to plot those numbers in a rectangle style? > > thanks help stairs stairs([-1 1 -1 1 -1 1]) hth Jos ...

newbie 1.8.7 to 1.9.1 problem
Several scripts that used to work now don't. I had not used ruby or any of these scripts for several months. In the meantime i upgraded vista to windows 7 (clean install) and decided to install 1.9.1 rather than the 1.8.7 i used previously. And now here's the problem i have: f = open("http... webpage = f.read ... dump = webpage.sub(%r{<body.*?>(.*?)... ... # process the rest line-by-line dump.each do |eachline| # this line produces this error: ... :in `block in <main>': undefined method `each' for #<String:0x1f3f620> (NoMethodError) ...

Rere: cppunit 1.8.0
Hi Herard, I got exactly the same error when translating cppunit 1.9.10 with SuSE 9.0 and gcc 3.3.1 (I believe - I am here on a different system right now). I hoped it would run immediately, as usualy it does with ../configure, make, make install. I will investigate the problem this weekend. Cheers, Markus ...

Rere: cppunit 1.8.0
Hi Herard, I got exactly the same error when translating cppunit 1.9.10 with SuSE 9.0 and gcc 3.3.1 (I believe - I am here on a different system right now). I hoped it would run immediately, as usualy it does with ../configure, make, make install. I will investigate the problem this weekend. Cheers, Markus ...

KDE 3.1-1 RH 9 and an Ati Radeon Card
First of all, I'm sorry for having to cross-post this to three groups, but no one seems to have an answer in the RH xfree-lists. Having a wonderful problem with RH 9 hope someone can help. I've been having problems (for several weeks) with the KDE screensavers locking up. Once the screen-lock is activated, the system "appears" to lock up at random times - sometimes it happens instantly, other times it takes several consecutive screen-locks to do it. When this happens I can ssh in and kill the screensaver itself and kdesktop_lock processes and then I get my deskto...

require in 1.9.2 and 1.9.1
#i have a file 'user.rb' in the current directory. if i ... require "user" #i get this messege (1.9.2 in xp and in windows 7) ##<internal:lib/rubygems/custom_require>:29:in `require': no such file to ##load -- user_input (LoadError) ## from <internal:lib/rubygems/custom_require>:29:in `require' ##this worked fine in 1.9.1 in xp. and when i puts $: #in 1.9.1 the last load path is '.', but '.' is not in load path for #1.9.2 #works fine if i require_relative 'user' #or if i load 'user.rb' #a bug or a reason for this ...

Runtime 7.1 and Runtime 7.1.1
Hi,all &nbsp; I wrote VI sequencer that can run different VI's. I was built this sequencer to exe in LabVIEW&nbsp;7.1.1 and it work as executable and run VI's in run-time engine 7.1.1 Now i have some VI that was wrote in LabVIEW 7.1 and executable can't run it, because VI opened with error: &nbsp; "VI has an error of type A340. Full development version of LabVIEW is required for fix the errors" &nbsp; But when i open this VI in LabVIEW 7.1.1 it hasn't errors and only it opened as changed VI (with star) because there is different LV version. &nbsp;...

case statement variation 1.9.2 vs 1.8.7
I have this case statement: case n.hll_normalize when "common name" @my_correspondent.correspondent_common_name = s when "legal name" . . . else raise ArgumentError, "#{n} attribute is not provided for." end I pass it this value for n: "common name" When run with Ruby-1.8.7p302 this works. The exact same code run with Ruby-1.9.2p0 yields: common name attribute is not provided for. (ArgumentError) Is this change in behaviour intentional or a bug? If intentional then what is the version insensi...

apache 1.3.27, rh 7.1, and php4.3.4
Hello, I have a very urgent problem! The situation is i have an rh 7.1 box, i know it's not mine though, that has apache 1.3.27 on it in the form of what i presume is an rpm, it's actually on a vps system. Apache was built with dso support as well as php4 which was also installed, then mhash was to be added. A source version of php4.3.4 was downloaded and installed with mhash support, and now not only does this not work, but apache is no longer processing php pages! In the httpd.conf file there are references to if defined php, php3, and php4, and the index line has index.p...

mozilla-1.2.1-26 on RH 9 is giving strange error
Hello, I downloaded ISO images, burned CD's and installed RH 9.0 on July 16, 2003; everything was working fine till yet. Today, the mozilla have started giving a strange message in a new panel at the bottom of every window whether it is Navigator, Mail & Newsgroups, Composer, Address Book and, or Manage Bookmarks etc. Many of the menu bar options/tags like File, Edit and Help etc are also missing. The error message appears in red color as follows (in two lines): <broadcaster id="Communicator:WorkMode" --^ I attempted to find, this string in ~/.mozilla, /usr/lib/mo...

Difference between 1.8.6(7) RDOC and 1.9.1
[Note: parts of this message were removed to make it a legal post.] Team, Is there any way to know, by looking the rdoc site http://www.ruby-doc.org/core/ what's new in 1.9.1? I just want to be able to tell if I am using a new feature introduced by 1.9.1. Thank you -- Ruby Student Ruby Student wrote: > Team, > > Is there any way to know, by looking the rdoc site > http://www.ruby-doc.org/core/ what's new in 1.9.1? > I just want to be able to tell if I am using a new feature introduced by > 1.9.1. > > Thank you > The new features are at http://ruby-...

Web resources about - PNY flash drive on PC running RH 9.1 vs. RH 7.1 - comp.periphs.scsi

Running - Wikipedia, the free encyclopedia
This article is about the type of locomotion in humans. For running in horses, see Horse gait . For locomotion in dogs, see Gait (dog) . For ...

Canberra weather: March's longest running heatwave set to be broken on Thursday
If Thursday hits its predicted peak it will be the ACT's longest March heat spell on record.

Hillary Clinton: Running for president about delivering results, not insults
The Democratic contender held her campaign rally in Ohio, which holds a critical primary next Tuesday

4 new ways to bypass passcode lock screen on iPhones, iPads running iOS 9
There are multiple bypass vulnerabilities which could allow an attacker to get past the passcode lock screen on Apple devices running iOS 9. ...

Trump Admits He Views Running For President Like The Apprentice: 'That's The Way It Is'
Republican presidential candidate Donald Trump on Sunday said that his presidential campaign and his former reality show, The Apprentice , were ...

NFL Running Back Tased, Arrested In Florida
'I warned the defendant if he did not identify himself he would be subject to arrest and he smirked as he was making eye contact'

Sean Parker’s New Distribution Concept Has Studios & Exhibition Running For Exits
Today our sister publication Variety reported on the Screening Room , a new first-run movie service being pitched around town by Napster co-founder ...

Rams Running Back Tre Mason Arrested In Florida On Four Drug And Traffic Charges
Los Angeles Rams running back Tre Mason was arrested yesterday in Hollywood, Florida and charged with resisting arrest, marijuana possession, ...

What Running the Most Competitive Business School in the Country Taught Me About Running a Business
It may sound foreign to describe running a nonprofit grad school like running a business, but at the Acton School of Business, we live by the ...

Time Running out to Charge Anyone Who Helped Gangster Bulger
Prosecutors have only a few months left to charge anyone with assisting Boston gangster James "Whitey" Bulger while he was on the run for 16 ...

Resources last updated: 3/9/2016 8:00:41 PM