f



Fw: SQL Error: pqReadData() -- read() failed: errno=0 No error

I am a Postgres novice.  I have not done anything in the way of configuring
the DB differently from what the defaults are.

Here is my problem...
     I am sending the source text from web pages to the DB (7.3.2) through a
dataset in Delphi.  The field in the DB table is of the type "text", and the
fieldtype in Delphi shows ftMemo (a Blob type).  When I "ApplyUpdates" from
my application I get the "SQL Error: pqReadData() --  read() failed: errno=0
No error"  message.

Now, this is only happening when the length of the text that I am
attempting
to update to the DB is large.  On smaller text string sizes (ie. simple Web
Pages), I get no error and everything posts fine.

Is there some sort of setting that needs to be set for large "text" strings
on the DB, or is it likely to be an issue with the dataset - ApplyUpdates
procedure inside Delphi?

Is there a way to increase the buffer for incoming  requests?  Will this
help?


Thanks,
Derrick


---------------------------(end of broadcast)---------------------------
TIP 1: subscribe and unsubscribe commands go to majordomo@postgresql.org

0
Derrick
9/8/2003 3:39:37 PM
comp.postgresql.novice 1135 articles. 0 followers. Post Follow

2 Replies
815 Views

Similar Articles

[PageSpeed] 35

"Derrick Betts" <Derrick@grifflink.com> writes:
>      I am sending the source text from web pages to the DB (7.3.2) through a
> dataset in Delphi.  The field in the DB table is of the type "text", and the
> fieldtype in Delphi shows ftMemo (a Blob type).  When I "ApplyUpdates" from
> my application I get the "SQL Error: pqReadData() --  read() failed: errno=0
> No error"  message.

> Now, this is only happening when the length of the text that I am
> attempting
> to update to the DB is large.

Are you using an SSL-encrypted connection?  Some versions of libpq could
create this failure with SSL.  Unfortunately, the first version that
really works *reliably* with SSL is not yet released :-( ... 7.3.2
through 7.3.4 misbehave even worse than the 7.3 or 7.3.1 libpq you
appear to be using.  I believe that the problems are finally fixed as of
CVS tip, but I do not know when or whether there will be a 7.3.5.
Instead of waiting, your best bet might be to pull the tip of the
REL7_3_STABLE branch from our CVS server (see
http://developer.postgresql.org/docs/postgres/cvs.html) and build libpq
from it.

Or, don't use SSL ...

			regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 8: explain analyze is your friend

0
tgl
9/8/2003 3:59:18 PM
Thank you very much for your input.  I will look over the options you have
suggested. :)

Derrick

----- Original Message ----- 
From: "Tom Lane" <tgl@sss.pgh.pa.us>
To: "Derrick Betts" <Derrick@grifflink.com>
Cc: <pgsql-novice@postgresql.org>
Sent: Monday, September 08, 2003 9:59 AM
Subject: Re: [NOVICE] Fw: SQL Error: pqReadData() -- read() failed: errno=0
No error


> "Derrick Betts" <Derrick@grifflink.com> writes:
> >      I am sending the source text from web pages to the DB (7.3.2)
through a
> > dataset in Delphi.  The field in the DB table is of the type "text", and
the
> > fieldtype in Delphi shows ftMemo (a Blob type).  When I "ApplyUpdates"
from
> > my application I get the "SQL Error: pqReadData() --  read() failed:
errno=0
> > No error"  message.
>
> > Now, this is only happening when the length of the text that I am
> > attempting
> > to update to the DB is large.
>
> Are you using an SSL-encrypted connection?  Some versions of libpq could
> create this failure with SSL.  Unfortunately, the first version that
> really works *reliably* with SSL is not yet released :-( ... 7.3.2
> through 7.3.4 misbehave even worse than the 7.3 or 7.3.1 libpq you
> appear to be using.  I believe that the problems are finally fixed as of
> CVS tip, but I do not know when or whether there will be a 7.3.5.
> Instead of waiting, your best bet might be to pull the tip of the
> REL7_3_STABLE branch from our CVS server (see
> http://developer.postgresql.org/docs/postgres/cvs.html) and build libpq
> from it.
>
> Or, don't use SSL ...
>
> regards, tom lane
>
> ---------------------------(end of broadcast)---------------------------
> TIP 8: explain analyze is your friend
>


---------------------------(end of broadcast)---------------------------
TIP 4: Don't 'kill -9' the postmaster

0
Derrick
9/8/2003 4:06:30 PM
Reply:

Similar Artilces:

SQL Errors: Where is the error?
I have just finished -- I hope I have finished -- some changes to one program of mine that has some hairy SQL. One of the SQL statments is 40 lines long. Granted it could be shorter vertically, but it is still 852 characters long. Occasionally -- read "All too often" -- while wrestling with this program, there would be an error in my SQL syntax. VFP is not terribly helpful with such error messages as Syntax error. Command is missing required clause. These are not terribly useful. Sometimes, I have hunted for minutes before realising that...

When is an error not an error?
The Java language specification claims in: 8.8.7.1 Explicit Constructor Invocations .... "If an anonymous class instance creation expression appears within an explicit constructor invocation statement, then the anonymous class may not refer to any of the enclosing instances of the class whose constructor is being invoked." Helpfully it gives an example: "For example: class Top { int x; class Dummy { Dummy(Object o) {} } class Inside extends Dummy { Inside() { super(new Object() { int r = x; }); // err...

When is an error not an error?
When it's OSS slopware, of course. http://www.angelfire.com/planet/dfs0/Knode_send_error.png On 2006-09-12 02:42, * DFS wrote: > When it's OSS slopware, of course. > > http://www.angelfire.com/planet/dfs0/Knode_send_error.png > Well, some time ago I had a problem with OE - too long reference line to other posts, and OE of course refused to send... then crashed. Should I name it a feature? -- Andrea On Tue, 12 Sep 2006 03:25:29 +0200, Andrea wrote: > On 2006-09-12 02:42, * DFS wrote: >> When it's OSS slopware, of course. >> >> http:/...

error or not an error ...
I was just testing out the R4 REXX thingy, and it found an error in the following program. My question is this, is it an error or not? My PC/REXX and Regina don't barf on it, but I thought they should've. _____________________________________________ /**/ ?.='' ?.z='batman' trace i if ?.z\==''then do; say '?.z=' ?.z; end ______________________________________________ Note that there is space before the THEN. I'm not sure of the exact rules for parsing an IF statement, I know that THEN is a "reserved" keyword when an IF statement is...

Xemacs crashes: Fatal error: assertion failed, file xlwtabs.c, line 1997, *reply_width > 0 && *reply_height > 0 Fatal error (6)
Using XEmacs 21.4.15 together with gnus 5.10.6 XEmacs crashes with a core file. when I start it in a teminal I get this error: Fatal error: assertion failed, file xlwtabs.c, line 1997, *reply_width > 0 && *reply_height > 0 Fatal error (6). The absolut strange thing is, it does not happen in all news-groups. The other point, the crash does not produce a "core" file. Accourding to the output in the terminal: No GDB on your system? You may have DBX, or XDB, or SDB. (Ask your system administrator if you need help.) If no core file was produced, enable the...

HPL Loading error with Fatal error in server row processing
Hi All Seeking help on HPL loading. HPL loading gives Fatal error in server row processing - SQL error -271 ISAM error -151. However, exactly same project and job works fine in another INFORMIX installation with slight version different. Data gets converted from iso81 to utf8 using HP utility inconv and same is used in both the boxes. Conversion is required to facilitate data from various countries sitting in non-unicode database to central UNICODE. Appreciate any help and please find details below on the project / job Project $ onpladm create project smpl_proj -T $INFORMIXSE...

Getting the following error "Logbackup failed
Hi , Any one could you please let me help me to solve this issue when i take the ontape backup i am getting the following error message . informix@HR-Server:~> ontape -a Performing automatic backup of logical logs. The primary group for user informix must be group informix. Logbackup failed - function open tape device /informix/backup/logs/ failed code -1 errno 0 I also checked the permissions of the file it looks fine informix@HR-Server:/informix> ll total 8 drwxrw-r-x 4 informix informix 4096 2011-04-30 11:16 backup drwxrwx--- 2 informix informix 4096 2011-04-30 11...

I have a problem. My VI is showing a error, but in the error list they say error = 0
The arrow is broken, but the error list is clear. I can't see the error and I can't run the VI. Someone have some suggest? Hello Luis i have seen this behaviour by myself after changing a StrictTypedef and save/closing it without "Apply Changes". Maybe a Masscompile helps. greetings chris Thank you Chris. How do you have the solution? ...

Resolver Error 0 (no error)
I'm installing a new Solaris DNS server running Bind 9.2.2. This system is in a DMZ and the firewall is NAT translating to a public IP address. At first glance it appears to properly resolve the zones that it is authoritative for and it is retreiving the proper addresses for external systems. But there is one test that is giving me an odd result and I'm just not sure what's going on. When I specify another nameserver on the command line for nslookup, I get a no-error error, and then get a (correct) response from the *local* nameserver instead of the specified one. ...

close failed: [Errno 0] No error goes to stdout
I use the following code to the console output: def get_console(cmd): try: p_in, p_out, p_err = os.popen3(cmd) except: pass out_str = '' for obj in p_out: out_str = out_str + obj for obj in p_err: out_str = out_str + obj return out_str for some reason some exceptions (stderr outputs) are not captured by the try method, and slip to the screen. Any one has any idea on how can prevent from any output that I don't want to? The output I get on these exceptions i...

Error Editor ERROR - Small attachment
Hi When I click on c55 Icon to load it comes up with the attached screen - which I cannot close. When you close it in Task manager it closes c55. If I Pick an app an dtry and compile it gives me the most horrible error messages! Please help. --------------------------------------------------------------------------- Johan van Zyl - Somerset West - South Africa JVZ Systems CC johan@jvz.co.za Customised Software using Clarion & MS SQL http://www.jvz.co.za http://www.jvz.co.za/pastel - Pastel Utilities & Data Doctor http://www.jvz.co.za/mssql http://communities.msn.co.za/ClarionMSSQL ...

Objc Nubie: Errors Errors Errors
I've been toying with learning ObjC/Cocoa for sometime and finally got over the hump of "brackets vs. braces" but am wondering why my little test throws so many warnings when run: // gcc FileTest.m -o FileTest -ObjC -framework Cocoa #include <Cocoa/Cocoa.h> #include <Foundation/Foundation.h> int main( void ) { NSString * str = [ [NSStringalloc] initWithString:@"~/samplefromcocoa.txt" ]; NSString * full = [ NSString stringWithString: [str stringByExpandingTildeInPath ] ]; if( [ [NSFileManager defaultManager] fileExistsAtP...

503 5.0.0 error Say Hello first error
I got hit by a virus. Once I got it cleaned off now my Eudora will not send email. I get an error saying "503 5.0.0 Polite people say Hello First". I have a second computer on the same network that uses the same ISP and same version of Eudora so I know it is not the ISP or the network. Have any of you ever seen that error message? Cordell Vail Seattle Wa In article <eb0ad0e2.0411261849.8f4165f@posting.google.com>, cordellv@yahoo.com says... > I got hit by a virus. Once I got it cleaned off now my Eudora will > not send email. I get an error saying "503 5.0.0 Polite people say > Hello First". I have a second computer on the same network that uses > the same ISP and same version of Eudora so I know it is not the ISP or > the network. Have any of you ever seen that error message? Try: Polite People Say Hello First http://www.eudora.com/techsupport/kb/1492hq.html -- Over and Out Daniel Jacobson > Try: > Polite People Say Hello First > http://www.eudora.com/techsupport/kb/1492hq.html > -- > Over and Out > Daniel Jacobson Daniel, Thank you so much for answering that question for me. I have not been able to send email from my coputer for 2 months. WOW!!! I wish I could send you a snikers bar. I found a similar reply from you from 1998/01/16 but the URL's were no longer good. I tried to do a search on this newsgroup for Polite People but did not f...

SQL Error Code -443, SQL State 38553
DB21085I Instance "md" uses "32" bits and DB2 code release "SQL08012" with level identifier "02030106". Informational tokens are "DB2 v8.1.0.16", "s030508", "MI00048", and FixPak "2". Product is installed at "/opt/IBM/db2/V8.1". Red Hat AS -------------------------------- what does this error mean? SQL Error Code -443, SQL State 38553, Routine "SYSIBM.SQLCOLUMNS" (specific name "COLUMNS") has returned an error SQLSTATE with diagnostic text "SYSIBM:CLI:-727". ...

Getting rid of "close failed: [Errno 0] No Error" on Win32
I am using os.popen3 to call a console process and get its output and stderr. However on Win32 (and not OS X) I also get the Errno message. It's printed to the screen, which I wish to keep clean. How can disable this notification? Thanks. Ok , I tried: try: os.popen3(...) except: as someone suggested here. And on FreeBSD I don't get the error message, and it works great. However, on Win32 I do get the annoying message. Any idea why? And How I can make it go away? thanks. Yoav wrote: > I am using os.popen3 to call a console process and get its output and > stderr. Ho...

tun0: Warning: ff02::%tun0/32: Change route failed: errno: Undefined error: 0
Hi, i am using ppp with openbsd and i am not able to get rid of this error message: tun0: Warning: ff02::%tun0/32: Change route failed: errno: Undefined error: 0 I get this warning everytime I connect or disconnect my ppp connection but my connection works flawlessly. Here is my ppp.conf: default: set log Phase Chat IPCP CCP tun command set redial 15 0 set reconnect 15 10000 pppoe: set device "!/usr/sbin/pppoe -i xl1" set mtu max 1454 disable acfcomp protocomp ipv6cp deny acfcomp set crtscts off set speed sync enable lqr set lqrperiod 60 set dial set l...

Beware this non-error SQL error
Just a quick heads-up to those of you with error-scanning programs/functions that I have just run across the following missed error. This was a V8 batch job creating SAS datasets from Oracle tables using PROC SQL. It was a simple pull without any joins or conditions. Here is the only indication of failure I received: --------------- Segmentation Violation In Task ( SQL ] Fault Occurred at [0x103ebc54(?)] Task Traceback sqxcrta -- bridge stub sqlloop -- bridge stub NOTE: The SAS System stopped processing this step because of errors. Stack overflow detected In Task ( SQL ] Fault O...

innerHTML, IE5.0, Error 'Line: 0 Error: Object required
I have some code that works everywhere but IE5.0, including IE5.5. Here is a snippet of where the code seems to go wrong: Location.prototype.change = function(current) { this.current = current; // refers to the currently selected estate agent var elem = dhtml_get_element(this.id()); // cross browser getElementById var oldElem = elem.parentNode; // we can't replace tables using innerHTML - get the parent element (a div) oldElem.innerHTML = this.html(); // set the innerHTML return false; }; This function is executed when an estate agent is selected under a property (onclick) - it...

ISAM Error SQL error -243
Hello, I am hoping you cold help me. I have a program written in C with embedded SQL (CESL) code. In running the program, in one of the delete steps, I get an error SQL ERROR -243 SQL Message = [owner.tabname] ISAM error=[-113] ISAM error: the file is locked. I know that there are no other processes running simultaneously to have caused a lock on this table. What might have caused this issue?. The problem is if I run the program again, it rUNs fine.. Thanks, Jernand devtakh wrote: > I am hoping you cold help me. I have a program written in C with > embedded SQL (CE...

Error: isc_lex_gettoken() failed: I/O error
While running a checkzone, one of my users is getting this error: dns_master_load: /var/named/var/named:1: isc_lex_gettoken() failed: I/O error dns_master_load: /var/named/var/named:1: I/O error Google isn't helping me too much. We're thinking maybe it's terminal related - a user has had success using an xterm, but me and others are using SecureCRT and have problems. Can anyone say what this error actually means? We're a little stumped at what's going on. Thanks! Todd. --------------------------------------------------------------------- Thi...

Link Error : ISL error : 0
Hi, I need help with this, please! I'm working in a cw5ee , legacy templates, big program . It's a multi-dll program that worked fine since today, when I added some lines of code , it can't compile. If delete these lines, It compiles ok !! I added some "message("jjj"") lines to test, and another time the error, seems like the procedure is "too big" for the linker or something. Is the biggest procedure of the program, 25.513 hand coded lines, distributed in 46 "source" embeds (due to IDE problems with large embeds) There is a maximum procedu...

EvaluateFunction error .... fails with no error message
When I attempt to make a call to a a function in a matlab assembly built for .net, an exception is thrown with error message (with no message!): .... MWMCR::EvaluateFunction error ... .. StackTrace: at MathWorks.MATLAB.NET.Utility.MWMCR.EvaluateFunction(String functionName, Int32 numArgsOut, Int32 numArgsIn, MWArray[] argsIn) at MathWorks.MATLAB.NET.Utility.MWMCR.EvaluateFunction(Int32 numArgsOut, String functionName, MWArray[] argsIn) at RevScenarios.RevScenarios.generateScenarios(Int32 numArgsOut, MWArray NetRevenue, MWArray AdSpend, MWArray ClicksCharged, MWArray AvgPosition, MWArray NumScenarios) The error I believe has something to do with the MWArray assembly. This error only occurs when using the 64bit version of MWArray.dll. Using a 32bit version of the assembly works just fine. Both MCR v710 32bit and 64bit ARE installed on the machine when it's running. What could be causing this? ...

RE: Resolver Error 0 (no error)
I wish that were my problem, but I get the same error with other servers as well... > nslookup www.dell.com ns-east.cerf.net *** Can't find server address for 'ns-east.cerf.net': Resolver Error 0 (no error) Server: ns.mydomain.com Address: 10.10.10.12 Non-authoritative answer: Name: www.ins.dell.com Address: 143.166.224.230 Aliases: www.dell.com I just noticed the error that dig displays.... > dig @ns-east.cerf.net www.dell.com ; <<>> DiG 8.3 <<>> @ns-east.cerf.net www.dell.com ; Bad server: ns-east.cerf.net -- using defa...

Error Directing BCP In Errors to error file
Greetings, I am trying to bcp in data to a table which is in different server. Though the bcp in works fine but the error file is not being created and rejected records are not being directyd to the error file. Query looks like: bcp <db>..test_b_plan_cp in /home/file_out.txt -c -t '|' -S *****-U ****** -P ******-I /home/bcp2db_sql.ini -e /home/bcp2db.error. Can someone please help? TIA. Regards, Rajpreet ...

Urgent : DB-Library Error 10007: General SQL Server error: Check messages from the SQL
DB-Library Error 10007: General SQL Server error: Check messages from the SQL Server. CREATE PROCEDURE [dbo].[spu_Import_Export_Image] ( @srvr varchar(50), @db varchar(50), @usr varchar(15), @pwd varchar(50), @tbl varchar(50), @col varchar(50), @mod varchar(1), @imgpath1 varchar(1000), @pk varchar(50) ) AS BEGIN declare @path varchar(50) declare @whr varchar(200) declare @fil varchar(100) declare @cmd varchar(1000) declare @imgpath varchar(800) declare @ext...

Web resources about - Fw: SQL Error: pqReadData() -- read() failed: errno=0 No error - comp.postgresql.novice

Resources last updated: 2/19/2016 2:51:23 PM