f



Re: Bind 9.2.5 and IPv6 fails with client.c:1325: unexpected error: failed to get request's destination: failure #2

> 
> > Hi,
> > 
> > I have a very strange problem with a Bind server version 9.2.5 on Fedora 
> > Core 3.
> > 
> > Named listen to one IPv4 address and any IPv6 address. The configuration 
> > has been running for many months. No changes where made recently to the 
> > configuration except for adding or removing slave zones.
> > 
> > The symptom is that the server does not answer request to the IPv6 
> > address + port UDP 53. It still answers requests to the UDP and TCP port 
> > 53 using IPv4 and to the TCP port  53 using IPv6. Using dig on the 
> > server, or on any server on the same LAN, leads to the following behavior :
> > - dig ns some.domain @IPv4-address : works fine
> > - dig +vc ns some.domain @IPv4-address : works fine
> > - dig +vc ns some.domain @IPv6-address: works fine
> > - dig ns some.domain @IPv6-address: works once or twice immediately 
> > after restarting named, fails afterwards
> > 
> > The logs show the following message :
> > Jan 16 23:34:25 named[32125]: failed to get request's destination: failure
> > Jan 16 23:34:27 named[32125]: client.c:1325: unexpected error:
> > 
> > I had a look on client.c around line 1325 but it didn't help much.
> > 
> > Does someone on the list have an idea on what's wrong ?
> > 
> > Thanks very much in advance.
> > 
> > Roland.
> > 
> > -- 
> > Roland Dirlewanger
> > CNRS - D�l�gation Aquitaine-Limousin
> > Esplanade des Arts et M�tiers - BP 105
> > 33402 TALENCE CEDEX
> > 
> > T�l�phone: 05.57.35.58.52, T�l�copie: 05.57.35.58.01
> 
> 	Run 9.3 or 9.4.  They both handle IPv6 a lot better than
> 	9.2 especially with Linux's broken IPv6 stack.
> 
> 	Mark

	I would also try to upgrade your kernel as it is broken.

	It is not consistantly returning packet info despite it
	being requested when the socket was created.

	Mark
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: Mark_Andrews@isc.org


0
Mark
1/17/2007 12:35:33 AM
comp.protocols.dns.bind 16245 articles. 1 followers. Post Follow

0 Replies
833 Views

Similar Articles

[PageSpeed] 52

Reply:

Similar Artilces:

Re: Bind 9.2.5 and IPv6 fails with client.c:1325: unexpected error: failed to get request's destination: failure
> Hi, > > I have a very strange problem with a Bind server version 9.2.5 on Fedora > Core 3. > > Named listen to one IPv4 address and any IPv6 address. The configuration > has been running for many months. No changes where made recently to the > configuration except for adding or removing slave zones. > > The symptom is that the server does not answer request to the IPv6 > address + port UDP 53. It still answers requests to the UDP and TCP port > 53 using IPv4 and to the TCP port 53 using IPv6. Using dig on the > server, or on any server on the same LAN, leads to the following behavior : > - dig ns some.domain @IPv4-address : works fine > - dig +vc ns some.domain @IPv4-address : works fine > - dig +vc ns some.domain @IPv6-address: works fine > - dig ns some.domain @IPv6-address: works once or twice immediately > after restarting named, fails afterwards > > The logs show the following message : > Jan 16 23:34:25 named[32125]: failed to get request's destination: failure > Jan 16 23:34:27 named[32125]: client.c:1325: unexpected error: > > I had a look on client.c around line 1325 but it didn't help much. > > Does someone on the list have an idea on what's wrong ? > > Thanks very much in advance. > > Roland. > > -- > Roland Dirlewanger > CNRS - D�l�gation Aquitaine-Limousin > Esplanade des Arts et M�tiers - BP ...

Re: Bind 9.2.5 and IPv6 fails with client.c:1325: unexpected error: failed to get request's destination: failure #3
> Hello, > > Roland Dirlewanger a �crit : > > > > I have a very strange problem with a Bind server version 9.2.5 on Fedora > > Core 3. > > > > Named listen to one IPv4 address and any IPv6 address. The configuration > > has been running for many months. No changes where made recently to the > > configuration except for adding or removing slave zones. > > > > The symptom is that the server does not answer request to the IPv6 > > address + port UDP 53. It still answers requests to the UDP and TCP port > > 53 using IPv4 and to the TCP port 53 using IPv6. Using dig on the > > server, or on any server on the same LAN, leads to the following behavior : > > - dig ns some.domain @IPv4-address : works fine > > - dig +vc ns some.domain @IPv4-address : works fine > > - dig +vc ns some.domain @IPv6-address: works fine > > - dig ns some.domain @IPv6-address: works once or twice immediately > > after restarting named, fails afterwards > > > > The logs show the following message : > > Jan 16 23:34:25 named[32125]: failed to get request's destination: failure > > Jan 16 23:34:27 named[32125]: client.c:1325: unexpected error: > > I think I experienced a similar problem with BIND 9.2.4 on Debian Sarge. > It seems to be triggered when the IPv6 UDP socket receives an IPv4 > request, which can occur in t...

Bind 9.2.5 and IPv6 fails with client.c:1325: unexpected error: failed to get request's destination: failure
Hi, I have a very strange problem with a Bind server version 9.2.5 on Fedora Core 3. Named listen to one IPv4 address and any IPv6 address. The configuration has been running for many months. No changes where made recently to the configuration except for adding or removing slave zones. The symptom is that the server does not answer request to the IPv6 address + port UDP 53. It still answers requests to the UDP and TCP port 53 using IPv4 and to the TCP port 53 using IPv6. Using dig on the server, or on any server on the same LAN, leads to the following behavior : - dig ns some.domain @IPv4-address : works fine - dig +vc ns some.domain @IPv4-address : works fine - dig +vc ns some.domain @IPv6-address: works fine - dig ns some.domain @IPv6-address: works once or twice immediately after restarting named, fails afterwards The logs show the following message : Jan 16 23:34:25 named[32125]: failed to get request's destination: failure Jan 16 23:34:27 named[32125]: client.c:1325: unexpected error: I had a look on client.c around line 1325 but it didn't help much. Does someone on the list have an idea on what's wrong ? Thanks very much in advance. Roland. -- Roland Dirlewanger CNRS - D�l�gation Aquitaine-Limousin Esplanade des Arts et M�tiers - BP 105 33402 TALENCE CEDEX T�l�phone: 05.57.35.58.52, T�l�copie: 05.57.35.58.01 ...

Re: My ISP's nameserver confuses the resolver in glibc 2.3.2 and BIND 9.2.1 #2
> > > I've been seeing some DNS lookup failures on my redhat 9 box. > > They are accomapnied by this in /var/log/messages: > > > > Jan 1 22:29:11 localhost mozilla-bin: gethostby*.getanswer: asked for > > "www.google.com.au", got "www.google.akadns.net" > > > > A little experimentation with dig reveals that all the info is being > > returned, only the A record arrives first, followed by the CNAME: > > > > [david@localhost david]$ dig www.google.com.au > > > > ; <<>&g...

Re: 'failed setting up socket' error with BIND9 on Solaris 2.5 #2
> Hi Mark, > > > Looks like you are dealing with a kernel bug in SunOS 5.5.1. > > My bet is that connect() is complaining that bind() has already > > been called on the socket. > > Yep, you're right ! :-) > > > This is done to get the correct > > source address for the packets. > > You should be able to remove the isc_socket_bind() call but > > transfer-source will nolonger be effective for the TCP connection. > [....] > > > I compiled the bind again with your suggestions and that seems to wo...

Re: My ISP's nameserver confuses the resolver in glibc 2.3.2 and BIND 9.2.1
> I've been seeing some DNS lookup failures on my redhat 9 box. > They are accomapnied by this in /var/log/messages: > > Jan 1 22:29:11 localhost mozilla-bin: gethostby*.getanswer: asked for > "www.google.com.au", got "www.google.akadns.net" > > A little experimentation with dig reveals that all the info is being > returned, only the A record arrives first, followed by the CNAME: > > [david@localhost david]$ dig www.google.com.au > > ; <<>> DiG 9.2.1 <<>> www.google.com.au > ;; global opt...

Problem running bind 9.2.3, bind 9.2.4rc2 and bind 9.3.0beta2 on bsd/os 5.1
named.run gives me: 16-Apr-2004 17:35:17.656 starting BIND 9.3.0beta2 -d 9 -n 2 16-Apr-2004 17:35:17.668 found 1 CPU, using 2 worker threads 16-Apr-2004 17:35:17.679 loading configuration from '/etc/named.conf' 16-Apr-2004 17:35:17.705 set maximum stack size to 67108864: success 16-Apr-2004 17:35:17.706 set maximum data size to 1073741824: success 16-Apr-2004 17:35:17.706 set maximum core size to 0: success 16-Apr-2004 17:35:17.706 set maximum open files to 128: success 16-Apr-2004 17:35:17.719 listening on IPv4 interface lo0, 127.0.0.1#53 16-Apr-2004 17:35:17.720 clientmgr ...

Re: Very odd errors from bind 9.2.2 #2
Ok, turns out you were right: On Sat, 25 Oct 2003 Mark_Andrews@isc.org wrote: > > Suddenly, with _no change in configuration_, I am seeing these three > > errors in /var/log/messages every time I HUP my named process: > > > > Oct 24 22:56:38 ns1 named[8255]: dns_master_load: /etc/namedb/s/.:1: > > unexpected end of line > > Oct 24 22:56:38 ns1 named[8255]: dns_master_load: /etc/namedb/s/.:1: > > unexpected end of input > > Oct 24 22:56:38 ns1 named[8255]: zone ./IN: loading master file > > /etc/namedb/s/.: unexpected end o...

Re: BIND 9.2.3: complains about low TTL's on startup? #2
> Mark Andrews <Mark_Andrews@isc.org> wrote in message news:<cv38m6$6k1$1@sf1.isc > .org>... > > > Hello, I'm actually migrating from BIND8 to BIND9 (9.2.3). I have some > > > entries with smaller TTL's (600) than the default TTL of the zone > > > (which is set to 43200). > > > Everytime I startup the named it complains like that: > > > > > > Feb 17 17:55:56 xxx named[19917]: [ID 873579 daemon.warning] > > > dns_master_load: x.y.in-addr.arpa.db:753: TTL set to prior TTL (43200) > > > ...

RE: ISC Bind 9 Service Fails with Fatal Error #2
When would a version for Windows be expected? If not for some time, what version before this would be the most stable because 9.2.2 crashed quite regularly? Russ -----Original Message----- From: Mark_Andrews@isc.org [mailto:Mark_Andrews@isc.org] Sent: Monday, August 25, 2003 4:45 PM To: Russell Findley Cc: 'comp-protocols-dns-bind@isc.org' Subject: Re: ISC Bind 9 Service Fails with Fatal Error > I am running Bind 9 on Windows with SP4 and the latest critical updates. I > rebuilt the machine on Monday because of the failures, but this morning the > ser...

BIND 9 2 BIND 9 transfer fails with KEY after CHROOT
Hello all, I have a master and slave named server running BIND 9.2.2. I recently changed them to use chroot. When they do a transfer with a TSIG key they fail with the error below. When I do allow-transfer{any;}; it works fine. When creating my chroot I copied over all the file including the key that I am including and do not get any errors when loading bind. I checked the key files and made sure they were the same by scp'ing it over. BTW this same setup worked fine with these keys prior to using chroot. At first I was getting some other errors until I created a random entry (wh...

Re: Migration from BIND 4.9 to 9.2 or Microsoft DNS #2
Mokwena Motseto <MotsetM@sapo.co.za> wrote: >> Do you know of any problems I might encounter if I migrate to Microsoft >> DNS I don't what version it is, or if it has versions at all phn@icke-reklam.ipsec.nu replied: > You won't get support from this forum :-) Sorry to disappoint Peter, but there have been discussions of the interaction between MS W2k (or W2k+3) DNS Server and BIND in the on this list (and on its now-defunct sister list bind9-users@isc.org). Check the list archives. Discussions of BIND interoperability with other DNS software is n...

RE: BIND 8.2.7 master ixfr to 9.2.2 slave #5
I'd love to upgrade to BIND-9, but BIND-9 doesn't support rrset-order { class IN type A name "sas.com" order fixed; }; According to Cricket Liu, IXFR has been supported in BIND 8 since 8.2.2. See=20 http://www.fruug.org/Archive/2000-05/bind_822.pdf if you don't believe me. If IXFR is so broken in BIND 8, why is the code still present in 8.4.6? Why isn't it at least ifdef'd out so it's not an option? Why is the answer "don't do that" instead of "hmm.. Lets see if we can fix the bug"? Mike Mitchell -----Original...

Re: TCP queries fail
Have tested some more different versions for Windows: 9.4.2 used to run this without any problems, and perhaps the best option at the moment even vulnerable to the spoofing attack. Typically our servers used about 40-50M RAM 9.4.2p1 leaks memory and crashes after few hours (even plenty of free RAM left). Named process is still on and responds to windows task manager, but no reply to DNS queries. 9.5.0 leaks memory & handles, takes 2-3 days and the server runs out of memory and named stops responding. Named process still keeps running though. Restarting the named process "fixes" the problem till 2-3 days again. 9.5.0p1 leaks memory and crashes after few hours (even plenty of free RAM left). Named process is still on and responds to windows task manager, but no reply to DNS queries. 9.5.1b1 leaks memory & handles, takes 2-3 days and the server runs out of memory and named stops responding. Named process still keeps running though. Restarting the named process "fixes" the problem till 2-3 days again. Currently running the 9.5.1b1 and restarting the service every day in every server.... Jukka ...

Installing Python 2.5.2: 'make' fails in posixmodule.c
Dear friends: I'm trying to install python on irix 6, the lab server. It fail at ' make ' procedure for Modules/posixmodule.c. I've just configured the prefix for my own path and no other option changed. make clean didn't help. Here it is: gcc -c -fno-strict-aliasing -DNDEBUG -g -O3 -Wall -Wstrict- prototypes -I. -IInclude -I./Include -DPy_BUILD_CORE - DPYTHONPATH='":plat-irix6:lib-tk"' \ -DPREFIX='"/user_data2/yzhou/local"' \ -DEXEC_PREFIX='"/user_data2/yzhou/local"' \ ...

Re: Can I have a HPUX bind 4.9.7 slaved to a Solaris bind 9.2.2 master ?
>>>>> "Terry" == Terry Pike <terry.j.pike@gsk.com> writes: Terry> I have a HPUX bind 4.9.7 master server that I want to Terry> convert to a slave server. I want to create a new master Terry> on Solaris bind 9.2.2. Terry> Question: will the V4.9.7 server accept zone transfers from Terry> V9.2.2 ?? Of course. Why shouldn't it? The zone transfer protocol hasn't changed. However BIND9 by default tries a more efficient data transfer scheme that long-dead stuff like BIND4 doesn't understand. This behaviour ...

Re: Very odd errors from bind 9.2.2
> > Suddenly, with _no change in configuration_, I am seeing these three > errors in /var/log/messages every time I HUP my named process: > > Oct 24 22:56:38 ns1 named[8255]: dns_master_load: /etc/namedb/s/.:1: > unexpected end of line > Oct 24 22:56:38 ns1 named[8255]: dns_master_load: /etc/namedb/s/.:1: > unexpected end of input > Oct 24 22:56:38 ns1 named[8255]: zone ./IN: loading master file > /etc/namedb/s/.: unexpected end of input > > This confuses me greatly, as the file it seems to be telling me there is a > problem with is: >...

Initial BIND 9.9.2 RPZ xfr (spamhaus) failing with "failed to connect: timed out" ?
hi, i've installed named -v BIND 9.9.2-rpz+rl.028.23-P1 i've registered my nameserver IP with spamhaus for use of its RPZ list; i've been approved for access. i've setup my bind9 conf for slave access to a spamhaus RPZ ... acl rpz4_spamhaus { 199.168.90.51; 199.168.90.52; 199.168.90.53; }; masters rpz4_spamhaus { 199.168.90.51; 199.168.90.52; 199.168.90.53; }; ... channel bind_rpzlog { file "/var/log/bind-rpz.log" versions 10 size 5m; print-time yes; print-category yes; print-severity yes; severity d...

Re: 'failed setting up socket' error with BIND9 on Solaris 2.5
> Hi all, > > I wonder if anyone has experience with BIND9 (9.2.5 or 9.3.1 in this case) on > a SunOS 5.5.1 (Solaris 2.5) Ultra-2 Box. > > I tried to set up a BIND9 on this machine and everything seems to be ok, > compiling, installation, resolving - no problems. > > But I did not manage to configure the BIND as a slave for several domains. > There is not one zonetransfer that did it successfully. Any attempt of an > axfr from the slave to the master fails with the following error: > > -- > Nov 20 04:20:58 moebius named[5278]: tra...

Bind 9.2.4 slaving problem [bind 9.2.1 and bind 8.3.3]
Greetings. I have a master name server running BIND 9.2.1 [Debian Woody - server not available on the Internet] and a slave server running bind 9.2.4 [Debian Sarge - not currently available on the Internet] and two others running bind 8.3.3 [Debian Woody - on the Internet]. The 9.2.1 is a master for all the others to slave from. I have an entry in a zone defined on the master as the following: > $ORIGIN example.com. > spamhaus-datafeed IN NS local-rbl-a > spamhaus-datafeed IN NS local-rbl-b When I issue the following command: #> host -t nx spam...

Re: How do I get statistics from BIND 9.3.2? #2
Both of the scripts only works with INTEGER32, if the statistics exceeds 2**32, number got from SNMP will not change. Joe --- Brandino Andreas <mailinglist@ebox.gr> wrote: > Hello S�ren, > > Maybe this can help you: > http://forums.cacti.net/about3018-0-asc-0.html > > has instructions how to enable statistics and how to > poll them > > > Tuesday, February 21, 2006, 11:15:38 PM, you wrote: > > > I have BIND 9.3.2 and I would like to see how many > queries I serve every > > second or minute. Is that possible? ...

Re: Very odd errors from bind 9.2.2 #3
> > Ok, turns out you were right: > > > On Sat, 25 Oct 2003 Mark_Andrews@isc.org wrote: > > > > Suddenly, with _no change in configuration_, I am seeing these three > > > errors in /var/log/messages every time I HUP my named process: > > > > > > Oct 24 22:56:38 ns1 named[8255]: dns_master_load: /etc/namedb/s/.:1: > > > unexpected end of line > > > Oct 24 22:56:38 ns1 named[8255]: dns_master_load: /etc/namedb/s/.:1: > > > unexpected end of input > > > Oct 24 22:56:38 ns1 named[8255]: zon...

Re: DNS bind-9.2.2-13 not working
The reason for specifying multiple servers is to provide REDUNDANCY. Giving two names to the same machine does not provide redunacy and just wastes bandwidth. ns1.polychip.net. 2D IN A 67.95.110.169 ns2.polychip.net. 2D IN A 67.95.110.169 I suspect you problem is a firewall. You need to open up both 53/UDP and 53/TCP. Mark > Hi, > > I have been trying to set up the dns for the past 1 week with no > luck..If i dig any other website from the local redhat linux machine > where this DNS is configured then it works fine, us...

Re: BIND 8.2.7 master ixfr to 9.2.2 slave #2
Mayer () gis ! Net writes: > Don't use IXFR on BIND 8. It never quite worked right and it got > rewritten > 3 times. It works correctly in BIND 9. > Danny That response is similar to Patient: Doctor, it hurts when I do this. Doctor: Don't do it. I'll admit that their might be bugs in BIND 8's implementation of IXFR, but they shouldn't cause BIND 9 to blow away it's zone information. This smells like a small bug in BIND 8 tickling a large bug in BIND 9. I've diff'd the bin/named/ns_ixfr.c and bin/named/ns_xfr.c code betwee...

Web resources about - Re: Bind 9.2.5 and IPv6 fails with client.c:1325: unexpected error: failed to get request's destination: failure #2 - comp.protocols.dns.bind

Resources last updated: 2/20/2016 9:32:33 AM