f



Kerberos failing pthreads assert when running in php+Apache2? (Mac OS X 10.4.5)

Hello,

I've been using a port of phpkrb5 (PHP3/4) to PHP5 (http:// 
homepages.nyu.edu/~jcw9/phpkrb5php5.tar.gz ~12 K, run `phpize` to  
make all the Makefiles, etc.). This is *REALLY SIMPLE* code.

One of Apple's most recent updates to Tiger seems to have caused  
Kerberos within the Apache2 context to fail a pthreads assertation.  
(However, applications using mod_auth_kerberos for HTTP  
Authentication are working fine still.)

error.log:
[Tue Mar 14 17:49:06 2006] [notice] child pid 24389 exit signal Abort  
trap (6)
.../../../include/fake-addrinfo.h:687: failed assertion
`pthread_equal((&(&krb5int_fac.lock)->os)->owner, pthread_self())'

Apache is and has been using the prefork mpm, not the pthreads one.  
Disabling threads support in kerberos5 yields a different error message:
../../include/k5-thread.h:667: failed assertion `(&m->os)->initialized ==
K5_MUTEX_DEBUG_PARTLY_INITIALIZED'
[Tue Mar 14 18:54:24 2006] [notice] child pid 8617 exit signal Abort  
trap (6)


However, the same code executed within the standalone CLI PHP binary  
works
fine. Perhaps the update broke pthreads? It worked before(tm).

Is there someway I can change the source of phpkrb5 to work better  
within Apache2?

--
Jonathan C. Williams
Web Programmer
Steinhardt School of Education
jonathan.williams@nyu.edu :: 212-998-5308
________________________________________________
Kerberos mailing list           Kerberos@mit.edu
https://mailman.mit.edu/mailman/listinfo/kerberos

0
3/15/2006 4:44:32 PM
comp.protocols.kerberos 5541 articles. 1 followers. jwinius (31) is leader. Post Follow

2 Replies
573 Views

Similar Articles

[PageSpeed] 55

On Mar 15, 2006, at 11:44, Jonathan Williams wrote:
> I've been using a port of phpkrb5 (PHP3/4) to PHP5 (http://
> homepages.nyu.edu/~jcw9/phpkrb5php5.tar.gz ~12 K, run `phpize` to
> make all the Makefiles, etc.). This is *REALLY SIMPLE* code.
>
> One of Apple's most recent updates to Tiger seems to have caused
> Kerberos within the Apache2 context to fail a pthreads assertation.
> (However, applications using mod_auth_kerberos for HTTP
> Authentication are working fine still.)

 From the fact that you mention disabling thread support in Kerberos,  
I assume you're building and installing a copy of krb5 from MIT,  
rather than using the version of KfM included with the operating system?

It occurs to me that the problems you describe could arise if two  
versions of the Kerberos libraries were loaded into the same address  
space, and symbol name resolution pointed some of the MIT functions  
at support symbols provided by the KfM framework.  I.e., we call a  
routine for initializing a mutex, the routine is in one library  
version and initializes that library's copy of the mutex, then we  
directly examine the mutex, but we get pointed to the other copy of  
the mutex in the other library.

If you built krb5 from MIT, I assume you wound up linking static  
libraries into your PHP module rather than linking against dynamic  
libraries, since our last release should only build static libraries  
for the Mac?

Is it possible that both the Kerberos framework and your freshly  
built krb5 library are being loaded into the same process?  (What is  
mod_auth_kerberos using?)  Ideally, that ought to work okay, if  
dynamic objects are loaded in a way that keeps the namespaces  
separated.  But I don't have a convenient apache+php build setup  
lying around to test what might be happening in your case.

Ken
________________________________________________
Kerberos mailing list           Kerberos@mit.edu
https://mailman.mit.edu/mailman/listinfo/kerberos

0
raeburn (375)
3/15/2006 7:40:14 PM
Hi Ken,

Thanks for the helpful email. I think your guess was spot on -- after  
a successful rebuild of both mod_auth_kerberos and my php extension,  
I was in a stage where I am able to get *either* to work in Apache. I  
chucked the

On Mar 15, 2006, at 2:40 PM, Ken Raeburn wrote:

> From the fact that you mention disabling thread support in  
> Kerberos, I assume you're building and installing a copy of krb5  
> from MIT, rather than using the version of KfM included with the  
> operating system?

I was building Apache, Kerberos, PHP etc. using DarwinPorts and had  
assumed that this would prevent these from linking against the system  
Kerberos libraries (http://wiki.opendarwin.org/index.php/ 
DarwinPorts:FAQ).

I tried with MIT/DarwinPorts Kerberos uninstalled and everything  
works again. (I only [thought] I needed the DarwinPorts Kerberos  
while I was testing phpkrb5.)

Hopefully, this will save some other DarwinPorts user from these  
issues. (Sidebar: Does anyone know what the OS X equivalent of  
Linux's `ldd` is?)

Also: If anyone finds my move of phpkrb5 to PHP5 useful, feel free to  
send diffs, etc.

--
Jonathan C. Williams
Web Programmer
Steinhardt School of Education
jonathan.williams@nyu.edu :: 212-998-5308


________________________________________________
Kerberos mailing list           Kerberos@mit.edu
https://mailman.mit.edu/mailman/listinfo/kerberos

0
3/15/2006 9:17:09 PM
Reply:

Similar Artilces:

Kerberos failing pthreads assert when running in php+Apache2? (Mac OS X 10.4.5) #2
Hello, I've been using a port of phpkrb5 (PHP3/4) to PHP5 (http:// homepages.nyu.edu/~jcw9/phpkrb5php5.tar.gz ~12 K, run `phpize` to make all the Makefiles, etc.). This is *REALLY SIMPLE* code. One of Apple's most recent updates to Tiger seems to have caused Kerberos within the Apache2 context to fail a pthreads assertation. (However, applications using mod_auth_kerberos for HTTP Authentication are working fine still.) error.log: [Tue Mar 14 17:49:06 2006] [notice] child pid 24389 exit signal Abort trap (6) .../../../include/fake-addrinfo.h:687: failed assertion `pthread_equal((&(&krb5int_fac.lock)->os)->owner, pthread_self())' Apache is and has been using the prefork mpm, not the pthreads one. Disabling threads support in kerberos5 yields a different error message: ../../include/k5-thread.h:667: failed assertion `(&m->os)->initialized == K5_MUTEX_DEBUG_PARTLY_INITIALIZED' [Tue Mar 14 18:54:24 2006] [notice] child pid 8617 exit signal Abort trap (6) However, the same code executed within the standalone CLI PHP binary works fine. Perhaps the update broke pthreads? It worked before(tm). Is there someway I can change the source of phpkrb5 to work better within Apache2? -- Jonathan C. Williams Web Programmer Steinhardt School of Education jonathan.williams@nyu.edu :: 212-998-5308 ________________________________________________ Kerberos mailing list Kerberos@mit.edu https://mailman.mit.edu/mailman/list...

Mac OS X Kerberos Extras updated for Mac OS X 10.3
-----BEGIN PGP SIGNED MESSAGE----- Just a reminder to coincide with today's release of Mac OS X 10.3 ("Panther"), the MIT Kerberos team has released an updated version of the Mac OS X Kerberos Extras that work with both Mac OS X 10.2 (Jaguar) and Mac OS X 10.3 (Panther). The Mac OS X Kerberos Extras allow CFM-based applications, such as Eudora and Fetch, to work with OS X's built-in Kerberos. Older releases of the OS X Kerberos Extras will not work with Mac OS X 10.3. You must have the latest release (which was released back in June) for it to work with Panther. However, this new release is backwards compatible with Mac OS X 10.2 as well as supporting 10.3. For further information and to download the updated Mac OS X Kerberos Extras, go to: <http://web.mit.edu/macdev/www/osx-kerberos-extras.html> -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.0.7 (SunOS) Comment: Processed by Mailcrypt 3.5.6 and Gnu Privacy Guard <http://www.gnupg.org/> iQCVAwUBP5l9LabDgE/zdoE9AQFqVAP/cQQ/zxvdAG3zxk5MpGCPgRlWbkWfD2Gl KrDXE96oLW8BrCE/aWiFPPoYoaGM5j8Eu3YcDf4TKiTQcXOCTh6+MCE6dsigzLcb GoA3iqq18yufxD8ohA0vlghN/tChFWWLA1+rqbvs6D2mCHoZKjEMznHkL5lWszbK XVEfL/szqa8= =rAbI -----END PGP SIGNATURE----- _______________________________________________ kerberos-announce mailing list kerberos-announce@mit.edu https://mailman.mit.edu/mailman/listinfo/kerberos-announce ________________________________________________ Kerberos mailing list Kerberos@mit.edu http...

Are Mac OS X 10.5.8's iLife programs safe to use in Mac OS X 10.7.x and 10.8.x?
Hi. Someone told me that Mac OS X 10.7.x and 10.8.x do not come with iLife like the older Mac OS X versions (e.g., 10.5.x). I did not know this! Since my client uses iPhoto that came preinstalled on his old 2008 MacBook Pro's Mac OS X 10.5.x (10.5.8 right now), can he use the old one from 10.5.8? Or will he need a third party replacement (needs to import/copy the old image files) or buy a new iPhoto version for his photo(graph)s? I recalled he did not like iPhoto and wonder if the new one is any better. Thank you in advance. :) -- Quote of the Week: "Every ruler...

Kerberos in Mac OS X 10.4?
I just upgraded to Mac OS X 10.4, and have been having problems with its implementation of Kerberos. In OS 10.3, I could access my mail on MIT's POP server using Kerberized POP. Now, in 10.4, whenever I try to access it, I get an error in the Console: "krb_sendauth() failed: error code 255". When I run the Kerberos app hidden in the System directory, I see that while on 10.3 my tickets were listed as "v4/v5", in 10.4 I only see "v5". Could this be why my email isn't working? If so, how do I convince 10.4's Kerberos to get v4 tickets? If not, any idea what the problem actually is? I have a support request in with Apple about this, but I doubt they'll get to it for a while. Also, I'm not on this list, so if you could include me in your replies, I'd appreciate it. Thanks, Alex Valys ________________________________________________ Kerberos mailing list Kerberos@mit.edu https://mailman.mit.edu/mailman/listinfo/kerberos ...

[ace-users] Compilation of ACE 5.5.3 fails on Mac OS X 10.4.8
Compilation of ACE version 5.5..3 (using GNU tools: mkdir build cd build ../configure --enable-static make fails on Mac OS X 10.4.8 (Intel-based). Compilation of ACE.cpp throws many errors that are copied below the problem report form. I can send the complete output when needed. ACE 5.5. compiles and builds without problems on the same machine. PROBLEM REPORT FORM ACE VERSION: 5.5.3 HOST MACHINE and OPERATING SYSTEM: Mac Pro (Intel) OS X 10.4.8 TARGET MACHINE and OPERATING SYSTEM, if different from HOST: COMPILER NAME AND VERSION (AND PATCHLEVEL): i686-apple-darwin8-gcc-4.0.1 (GCC) 4.0.1 (Apple Computer, Inc. build 5363) THE $ACE_ROOT/ace/config.h FILE [if you use a link to a platform- specific file, simply state which one]: GNU build: ../conifgure --enable-static make THE $ACE_ROOT/include/makeinclude/platform_macros.GNU FILE [if you use a link to a platform-specific file, simply state which one (unless this isn't used in this case, e.g., with Microsoft Visual C++)]: CONTENTS OF $ACE_ROOT/bin/MakeProjectCreator/config/ default.features (used by MPC when you generate your own makefiles): AREA/CLASS/EXAMPLE AFFECTED: [What example failed? What module failed to compile?] DOES THE PROBLEM AFFECT: COMPILATION? Yes. LINKING? On Unix systems, did you ru...

Re: Subject: Building ACE 5.3.1 on Mac OS X (Tiger) 10.4.2 was [ace-users] Building ACE on Mac OSX 10.4
Hi Jason, Thanks for using the PRF. >> ACE VERSION: 5.3.1 This version of ACE is ANCIENT. The forthcoming ACE 5.4.8 beta should work "out of the box" for Mac OS X Tiger. If you want a preview, please download the version in our CVS repo at http://cvs.doc.wustl.edu/ take care, Doug >> HOST MACHINE and OPERATING SYSTEM: Mac OS X 10.4.2 >> COMPILER NAME AND VERSION (AND PATCHLEVEL): >> powerpc-apple-darwin8-gcc-4.0.1 >> >> CONTENTS OF $ACE_ROOT/ace/config.h: >> >> /* -*- C++ -*- */ >> // config-macosx.h,v 4.17 2003/01/20 20:02:12 seibel_r Exp >> >> // This configuration file is designed to work with the MacOS X operating >> system. >> >> #ifndef ACE_CONFIG_MACOSX_H >> #define ACE_CONFIG_MACOSX_H >> >> #if ! defined (__ACE_INLINE__) >> #define __ACE_INLINE__ >> #endif /* ! __ACE_INLINE__ */ >> >> #if defined (__GNUG__) >> # include "ace/config-g++-common.h" >> #endif /* __GNUG__ */ >> >> #undef ACE_HAS_EXPLICIT_TEMPLATE_INSTANTIATION >> >> #define ACE_SIZE_T_FORMAT_SPECIFIER ACE_LIB_TEXT ("%lu") >> >> #if defined (ACE_HAS_PENTIUM) >> # undef ACE_HAS_PENTIUM >> #endif /* ACE_HAS_PENTIUM */ >> >> #if !defined (_THREAD_SAFE) >> #define _THREAD_SAFE >&g...

RE: Subject: Building ACE 5.3.1 on Mac OS X (Tiger) 10.4.2 was [ace-users] Building ACE on Mac OSX 10.4 #2
Hi Jason, > > >> ACE VERSION: 5.3.1 > > > > This version of ACE is ANCIENT. The forthcoming ACE 5.4.8 > beta should > > work "out of the box" for Mac OS X Tiger. If you want a preview, > > please download the version in our CVS repo at > > I know it isn't the most recent version available, but this > version is used > extensively across the corporation. Changing the version of > ACE all these > products used will cause the architect's heads to explode ;) ;-) Right - this is where the value of commercial support providers comes into play. DOC's research efforts continue to march on as they should, while commercial product efforts are best served by sticking with a version of ACE over time. Companies such as Riverace can make a 5.3-base version work on Mac OS X Tiger, for instance, as well as make sure that when your product is ready for an upgrade, the new version of ACE won't surprise you. I'd be happy to discuss further how we can help you and your architects - we don't want any heads to explode :-) -Steve -- Steve Huston, Riverace Corporation Helping you succeed with ACE See http://www.riverace.com/support.htm ...

Re: Subject: Building ACE 5.3.1 on Mac OS X (Tiger) 10.4.2 was [ace-users] Building ACE on Mac OSX 10.4 #2
Hi Jason, >> I know it isn't the most recent version available, but this version >> is used extensively across the corporation. Changing the version of >> ACE all these products used will cause the architect's heads to >> explode ;) >> >> Is it your opinion that 5.3.1 is hopeless cause on Tiger? It'll take some work, but companies like Riverace, Remedy, and OCI can help out with this stuff if staying with 5.3.1 is essential. Please see http://www.cs.wustl.edu/~schmidt/commercial-support.html for help with this stuff. >> > http://cvs.doc.wustl.edu/ >> I will try it out, and let you know how it works. Great - if there are any problems please let us know quickly so that we can get the fixes into the x.4.8 beta. Thanks, Doug -- Dr. Douglas C. Schmidt Professor and Associate Chair Electrical Engineering and Computer Science TEL: (615) 343-8197 Institute for Software Integrated Systems WEB: www.dre.vanderbilt.edu/~schmidt Vanderbilt University, Nashville TN, 37203 NET: d.schmidt@vanderbilt.edu ...

Does an app run Mac O X 10.4 when it has been built on Mac OS 10. 3+
Hello. I don't have Mac OS X 10.4 yet, my application is built on Mac OS X 10.3.9, does The application can run properly on Mac OS 10.4 ? Thanks ming --------------------------------------------------------------------- To unsubscribe, e-mail: wx-users-unsubscribe@lists.wxwidgets.org For additional commands, e-mail: wx-users-help@lists.wxwidgets.org Hi Ming, Yes, almost everything should work without modification. I only found one thing in Tiger that worked differently than Panther, and it was easy to fix once I got a complete report of what was going on. HTH,...

Mac OS X 1.0 x86 and Mac OS X 10.4 x86
I wonder of OS X on Intel runs binaries made for Mac OS X Server 1.0 or earlier x86 versions of NEXTSTEP... There should be some interesting error messages to find. I'll try it out with OmniWeb 3 one day... -- Andrew J. Brehm Marx Brothers Fan PowerPC/Macintosh User Supporter of Chicken Sandwiches In article <1gxrpng.qcld42zk38uoN%ajbrehm@gmail.com>, ajbrehm@gmail.com (Andrew J. Brehm) wrote: > I wonder of OS X on Intel runs binaries made for Mac OS X Server 1.0 or > earlier x86 versions of NEXTSTEP... > > There should be some interesting error messages to find. > > I'll try it out with OmniWeb 3 one day... I *really* doubt it. 10.0 PPC doesn't run OS X Server 1.0 PPC binaries, does it? -- "This notion that the United States is getting ready to attack Iran is simply ridiculous. And having said that, all options are on the table." -- George W. Bush in Brussels, Belgium, Feb. 22, 2005 ZnU <znu@fake.invalid> wrote: > In article <1gxrpng.qcld42zk38uoN%ajbrehm@gmail.com>, > ajbrehm@gmail.com (Andrew J. Brehm) wrote: > > > I wonder of OS X on Intel runs binaries made for Mac OS X Server 1.0 or > > earlier x86 versions of NEXTSTEP... > > > > There should be some interesting error messages to find. > > > > I'll try it out with OmniWeb 3 one day... > > I *really* doubt it. 10.0 PPC doesn't run OS X Server 1.0 PPC binaries, > does it? I think i...

mac os x 10.4.4 breaks mathematica 5.2 (again)
it appears mac os x 10.4.4 update breaks 64-bit application Mathematica 5.2, just like 10.4.2 did. i'm surprised that i haven't seen any reports on this yet. last time, wolfram was on the case the same day 10.4.2 was released. Exception: EXC_BAD_ACCESS (0x0001) Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000004 Thread 0 Crashed: 0 com.wolfram.Mathematica 0x000567b4 0x1000 + 350132 1 com.wolfram.Mathematica 0x00087450 0x1000 + 549968 2 com.wolfram.Mathematica 0x0008a220 0x1000 + 561696 3 com.wolfram.Mathematica 0x00088724 0x1000 + 554788 4...

FileMaker Server 5.5 and Mac OS X Server 10.4?
Is FileMaker Server 5.5 compatible with Mac OS X Server 10.4? On 2005-09-02 20:12:20 -0400, "John Cradock" <kananga@gmail.com> said: > Is FileMaker Server 5.5 compatible with Mac OS X Server 10.4? Yes it is. I am currently running FMS 5.5 on an xserve. Thanks for your reply. I actually ended up speaking with FileMaker about this, and they say that FileMaker Server 5.5 is not officially supported on Mac OS X Server 10.3 or 10.4, but that there are many more problems running it on 10.4 Server than 10.3. Apparently most people running it on 10.3 don't have too many p...

Running the Gimp on Mac OS X 10.4.4 / x11 updated
After Mac did its update to OS X (the day of the Mac World Expo?) and I installed it, I found that I couldn't get the gimp to run. I would click on the icon and a white box would appear where the splash screen could normally be found. No graphics or plug-in loading text would appear and the box would just sit there until I did a Force Quit. Not giving up, I looked around for any talk on Mac forums, this forum and elsewhere that might be discussing what I assumed was a common problem. I eventually found something somewhere (long forgotten) that mentioned that release 10.4.4 had added better...

[Q] RB 5.5 or RB 2005 with Mac OS X 10.4?
Hello. I'm under Mac OS X 10.3.9 and I use RB 5.5.4. This couple works well. I'd like to upgrade to Mac OS X 10.4. Do I have to upgrade to RB 2005? Or is RB 5.5.4 fully compatible with Mac OS X 10.4? (I'd like to use my current version of RB 5.5.4 when I upgrade to Mac OS X 10.4, and wait for a next release of RB 2005 more stable before I upgrade to RB 2005.) Thanks in advance, Pascal. Pascal <pascalchiotasso@yahoo.fr> wrote: > Hello. > > I'm under Mac OS X 10.3.9 and I use RB 5.5.4. This couple works well. > I'd like to upgrade t...

XML::RSS Install Fails on Mac OS X 10.6 (Perl 5.10)
After upgrading from Mac OS 10.5 to 10.6, I found as usual that most of my Perl modules were gone; also Apple upgraded to Perl 5.10. So, I reinstalled stuff using cpan, but XML::RSS failed after several tries. It seems to follow the prerequisite tree through DateTime:: and then things start to look bad when it tries to install Params::Validate. Does anyone know what might be wrong? I tried it several times, also tried to install Params::Validate directly but got similar results. Here is the part where it looks like things start to look bad... Creating new 'Build' scri...

Scilab 5.1.1. does not open on iMac G5 running Mac OS X 10.5.6
Hi there, Scilab 5.1.1. (and even 5.1) does not open up. When I double click on scilab 5.1.1 in the Applications folder, the "Scilab bird" appears in the dock, which then soon transforms into a paper with a cup. Nothing happens after that! I have to force quit it. I simply ran scilab-bin under the MacOS of the package. I get the following error message dyld: Library not loaded: /Users/pmarecha/compilation_chain_macosx/ sci_binary/scilab-5.1.1-alpha-1.app/Contents/MacOS/lib/scilab/ libscilab.0.dylib Referenced from: /Applications/scilab-5.1.1-alpha-1.app/Contents/ MacOS/bin/./scilab-bin Reason: image not found I am not sure if the above alone is a problem or if there is an additional problem due to Java. I have Java installed. Running java - version yields java version "1.5.0_16" Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_16- b06-284) Java HotSpot(TM) Client VM (build 1.5.0_16-133, mixed mode, sharing) Any insight would be really helpful! I am running Mac OS X 10.5.6 Thanks in advance best regards Arun In article <a6fbd1c6-69e3-4426-9ad0-199d7a22726d@c18g2000prh.googlegroups.com>, arun.kt@gmail.com <arun.kt@gmail.com> wrote: >Hi there, > >Scilab 5.1.1. (and even 5.1) does not open up. When I double click on >scilab 5.1.1 in the Applications folder, the "Scilab bird" appears in >the dock, which then soon transforms into a paper with a cup. Nothing >...

Kerberos Authentication for OS X 10.4
Has any had experience with Kerberos Authentication on the Mac, ie. authent= icating to a different realm from which the Macs are bound to?=0AWe have 2 = AD domains, one for networking (which the macs are bound to) and a separate= one for Exchange. I would like to script kpasswd for users to be able to c= hange their Exchange passwords. Using OWA does not work all the time becaus= e uses are unable to log in if the password is set to =93user must change p= assword on first log in=94 or the change password time has expired.=0AAny f= eedback welcome.=0A=0AGibc=0A=0A=0A=0A Sick of deleting your inbox? Ya= hoo!7 Mail has free unlimited storage.=0Ahttp://au.docs.yahoo.com/mail/unli= mitedstorage.html=0A ...

Compiling fails on Mac OS X 10.5
Hi! I'm trying to compile on my Macbook with OS X 10.5. I have all updates and Xcode 3.0 installed. I checked python out with: svn checkout http://svn.python.org/projects/python/branches/py3k After that I did "./configure" in the created "py3k" dir. Everything went fine. But make fails with the following error message: ranlib libpython3.0.a gcc -u _PyMac_Error -o python.exe \ Modules/python.o \ libpython3.0.a -ldl make: *** [sharedmods] Error 1 I tried checking out many times. I also tried de 3.0a2 release,gives me the same error. I've heard others have co...

Mac OS X 10.4.5 compatability
After installing Mac OS X 10.4.5 on my Intel iMac, USB overdrive doesn't work. The mouse buttons on my Microsoft Wireless Laser Mouse 6000 respond to the settings in the Keyboard and Mouse control panel, and totally ignore USB Overdrive. Further, on boot, the Microsoft Mouse doesn't work at all unless I plug in a USB mouse; I can then remove the USB mouse and the Microsoft mouse will continue to work, but only as described in the preceding paragraph. -- Stop Mad Cowboy Disease: Impeach the son of a Bush. In article <michelle-AF3D3B.18220214022006@news.west.cox.net>, M...

Print Preview Fails in Mac OS X 10.5
I'm having problems with wxPrintPreview under OS X 10.5. When I start the print preview, I get a dialog that says "Could not start document preview." This seems to be happening in both 2.8.6 and 2.8.7. I don't have a machine with OS X 10.4 to see if it is happening there. I know for sure that this was working on 10.4, the code hasn't changed. You can download the source code here from http://www.xivesoftware.com/Projects/MathPageGen2/Downloads/index.php to test it out. An XCode project file is included and should work with a few config changes (need ...

Discount Mac OS X Leopard 10.5.4
OEM Software! Download <a href=http://community.myfoxatlanta.com/osx_leopard_10.5.4/>Mac OS X Leopard 10.5.4 buy discount software</a> Find Cheap Music Software Discount for buy <a href=http://community.myfoxmemphis.com/osx_leopard_10.5.4/>buy Mac OS X Leopard 10.5.4 low cost</a> Cheap download Purchase Cheap Music Software Online <a href=http://community.myfoxboston.com/osx_leopard_10.5.4/>Mac OS X Leopard 10.5.4 oem software</a> Discount Software to Buy low price <a href=http://community.myfoxchicago.c...

Cheap Mac OS X Leopard 10.5.4
Computer Software to Purchase <a href=http://www.diigo.com/profile/mac_osx_leopard>Cheap Mac OS X Leopard 10.5.4 download</a> Purchase Cheap Music Software Online Download Full version <a href=http://cs.beadandbutton.com/bnbcs/members/Buy-Mac-OS-X-Leopard-10.5.4-cheap.aspx>Where can i buy Mac OS X Leopard 10.5.4</a> buy discount software buy full version <a href=http://dailybooth.com/Mac_OSX_Leopard_10/>Buy cheap Mac OS X Leopard 10.5.4</a> buy oem software compare prices Software Downloads <a href=http://about.me/Mac-OSX-Leopa...

Scilab 5.x cannot get started on my Intel iMac with Mac OS X 10.6.5
Scilab has been working on my various Macs, but Scilab 5.2 and Scilab 5.3 just cannot get started on my Intel iMac with Mac OS X 10.6.5 How can I get Scilab going again? Heinz On 14/11/10 12:35 PM, Znieh Keleiban wrote: > Scilab has been working on my various Macs, but Scilab 5.2 and Scilab > 5.3 just cannot get started on my Intel iMac with Mac OS X 10.6.5 > > How can I get Scilab going again? > > Heinz The specific error messages are shown below (excerpt). Can anybody see what is going wrong? Heinz Process: scilab-bin [1396] Path: /Applications/scilab-5.2.2.app/Contents/MacOS/bin/scilab Identifier: org.scilab.modules.jvm.Scilab Version: ??? (???) Code Type: X86 (Native) Parent Process: sh [1371] Date/Time: 2010-11-14 16:06:49.876 +0100 OS Version: Mac OS X 10.6.5 (10H574) Report Version: 6 Interval Since Last Report: 120544 sec Crashes Since Last Report: 26 Per-App Interval Since Last Report: 40 sec Per-App Crashes Since Last Report: 18 Anonymous UUID: FA59A36E-2928-43F0-B9B1-CD9411CE78EE Exception Type: EXC_BAD_ACCESS (SIGBUS) Exception Codes: KERN_PROTECTION_FAILURE at 0x000000000000000c Crashed Thread: 1 Application Specific Information: Java information: Exception type: Bus Error (0xa) at pc=00000000027b9d52 Java VM: Java HotSpot(TM) Client VM (17.1-b03-307 mixed mode macosx-x86) Current threa...

Installing gnuplot 4.2.2 on Mac G4 under Mac OS X 10.4.11
In attempting to install gnuplot 4.2.2 on a Mac G4 running Mac OS X v. 4.2.2, I got several error messages before the installation failed. The error messages asked that I report these messages to the gnuplot lists, so the excerpt below contains the transcript of the installation. Any suggestions as to how to install gnuplot 4.2.2? Starfighter. Last login: Wed Nov 21 03:22:17 on ttyp1 Welcome to Darwin! dsl092-239-159:/ samueldupree$ tar -xzf gnuplot-4.2.2.tar.gz dsl092-239-159:/ samueldupree$ ls dsl092-239-159:/ samueldupree$ cd gnuplot-4.2.2 dsl092-239-159:/gnuplot-4.2.2 samueldupree$ ./configure --prefix=/usr/ local checking for a BSD-compatible install... /usr/bin/ginstall -c checking whether build environment is sane... yes checking for gawk... gawk checking whether make sets $(MAKE)... yes checking for gcc... gcc checking for C compiler default output file name... a.out checking whether the C compiler works... yes checking whether we are cross compiling... no checking for suffix of executables... checking for suffix of object files... o checking whether we are using the GNU C compiler... yes checking whether gcc accepts -g... yes checking for gcc option to accept ANSI C... none needed checking for style of include used by make... GNU checking dependency style of gcc... gcc3 checking for function prototypes... yes checking how to run the C preprocessor... gcc -E checking for egrep... grep -E checking for ANSI C header files... yes ...

Web resources about - Kerberos failing pthreads assert when running in php+Apache2? (Mac OS X 10.4.5) - comp.protocols.kerberos

Resources last updated: 3/10/2016 2:25:18 PM