f



ssh gssapi-with-mic and "Key table entry not found"

Hi,

I'm trying to get ssh working using gssapi-with-mic authentication.  I have
about 40 machines running CentOS 5.7.  (My bigger goal is to use NFSv4
mounts with "krb5p" security.  All these machines mount the same NFSv4 share
(think home directories) so my users need to be able to forward their TGT
around.)

What I'm ultimately running into is sshd complaining "Key table entry not
found" on *most* of the servers---a random handful work, and I can't figure
out how the working ones are different.

So, here's an example: I'm trying to ssh from "lnxsvr3" to "lnxsvr11" using
gssapi-with-mic authentication.

Here's the output of trying to ssh:
    [matt@lnxsvr3 ~]$ ssh -v -o"PreferredAuthentications
gssapi-with-mic" lnxsvr11
    OpenSSH_4.3p2, OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to lnxsvr11 [192.168.187.67] port 22.
    debug1: Connection established.
    debug1: identity file /mnt/home/matt/.ssh/identity type -1
    debug1: identity file /mnt/home/matt/.ssh/id_rsa type 1
    debug1: identity file /mnt/home/matt/.ssh/id_dsa type -1
    debug1: loaded 3 keys
    debug1: Remote protocol version 2.0, remote software version OpenSSH_4.3
    debug1: match: OpenSSH_4.3 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_4.3
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-md5 none
    debug1: kex: client->server aes128-ctr hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host 'lnxsvr11' is known and matches the RSA host key.
    debug1: Found key in /mnt/home/matt/.ssh/known_hosts:207
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue:
publickey,gssapi-with-mic,password
    debug1: Next authentication method: gssapi-with-mic
    debug1: Delegating credentials
    debug1: Authentications that can continue:
publickey,gssapi-with-mic,password
    debug1: Authentications that can continue:
publickey,gssapi-with-mic,password
    debug1: Authentications that can continue:
publickey,gssapi-with-mic,password
    debug1: No more authentication methods to try.
    Permission denied (publickey,gssapi-with-mic,password).

On the server side, /var/log/secure, with sshd running with LogLevel DEBUG:
    Aug  7 11:53:06 lnxsvr11 sshd[4998]: debug1: rexec start in 4 out
4 newsock 4 pipe 6 sock 7
    Aug  7 11:53:06 lnxsvr11 sshd[4804]: debug1: Forked child 4998.
    Aug  7 11:53:06 lnxsvr11 sshd[4998]: debug1: inetd sockets after
dupping: 3, 3
    Aug  7 11:53:06 lnxsvr11 sshd[4998]: Connection from
192.168.187.61 port 43559
    Aug  7 11:53:06 lnxsvr11 sshd[4998]: debug1: Client protocol
version 2.0; client software version OpenSSH_4.3
    Aug  7 11:53:06 lnxsvr11 sshd[4998]: debug1: match: OpenSSH_4.3 pat OpenSSH*
    Aug  7 11:53:06 lnxsvr11 sshd[4998]: debug1: Enabling
compatibility mode for protocol 2.0
    Aug  7 11:53:06 lnxsvr11 sshd[4998]: debug1: Local version string
SSH-2.0-OpenSSH_4.3
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: debug1: permanently_set_uid: 74/74
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: debug1: list_hostkey_types:
ssh-rsa,ssh-dss
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: debug1: SSH2_MSG_KEXINIT sent
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: debug1: SSH2_MSG_KEXINIT received
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: debug1: kex: client->server
aes128-ctr hmac-md5 none
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: debug1: kex: server->client
aes128-ctr hmac-md5 none
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: debug1:
SSH2_MSG_KEX_DH_GEX_REQUEST received
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: debug1: SSH2_MSG_KEX_DH_GEX_GROUP sent
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: debug1: expecting
SSH2_MSG_KEX_DH_GEX_INIT
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: debug1: SSH2_MSG_KEX_DH_GEX_REPLY sent
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: debug1: SSH2_MSG_NEWKEYS sent
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: debug1: expecting SSH2_MSG_NEWKEYS
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: debug1: SSH2_MSG_NEWKEYS received
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: debug1: KEX done
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: debug1: userauth-request for
user matt service ssh-connection method none
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: debug1: attempt 0 failures 0
    Aug  7 11:53:06 lnxsvr11 sshd[4998]: debug1: PAM: initializing for "matt"
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: debug1: userauth-request for
user matt service ssh-connection method gssapi-with-mic
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: debug1: attempt 1 failures 1
    Aug  7 11:53:06 lnxsvr11 sshd[4998]: debug1: PAM: setting
PAM_RHOST to "lnxsvr3.mydomain.com"
    Aug  7 11:53:06 lnxsvr11 sshd[4998]: debug1: PAM: setting PAM_TTY to "ssh"
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: Postponed gssapi-with-mic for
matt from 192.168.187.61 port 43559 ssh2
    Aug  7 11:53:06 lnxsvr11 sshd[4998]: debug1: Unspecified GSS
failure.  Minor code may provide more information\nKey table entry not
found\n
    Aug  7 11:53:06 lnxsvr11 sshd[4998]: debug1: Got no client credentials
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: debug1: userauth-request for
user matt service ssh-connection method gssapi-with-mic
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: debug1: attempt 2 failures 2
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: debug1: userauth-request for
user matt service ssh-connection method gssapi-with-mic
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: debug1: attempt 3 failures 3
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: Connection closed by 192.168.187.61
    Aug  7 11:53:06 lnxsvr11 sshd[5001]: debug1: do_cleanup
    Aug  7 11:53:06 lnxsvr11 sshd[4998]: debug1: do_cleanup
    Aug  7 11:53:06 lnxsvr11 sshd[4998]: debug1: PAM: cleanup

Based on the web searching I've done for this issue, it seems the most common
culprit is DNS issues.  But as far as I can tell, my /etc/hosts and DNS are
set up correctly and in agreement.  So here is the output of various commands
on lnxsvr11:

    [root@lnxsvr11 ~]# klist -ekt
    Keytab name: FILE:/etc/krb5.keytab
    KVNO Timestamp         Principal
    ---- -----------------
--------------------------------------------------------
       5 08/07/12 11:39:04 host/lnxsvr11.mydomain.com@MYDOMAIN.COM
(DES cbc mode with CRC-32)
       5 08/07/12 11:39:45 nfs/lnxsvr11.mydomain.com@MYDOMAIN.COM (DES
cbc mode with CRC-32)

    [root@lnxsvr11 ~]# hostname
    lnxsvr11.mydomain.com
    [root@lnxsvr11 ~]# hostname
    lnxsvr11
    [root@lnxsvr11 ~]# hostname -s
    lnxsvr11
    [root@lnxsvr11 ~]# hostname -f
    lnxsvr11.mydomain.com

    [root@lnxsvr11 ~]# grep 192.168.187.67 /etc/hosts
    192.168.187.67     lnxsvr11.mydomain.com      lnxsvr11
    [root@lnxsvr11 ~]# grep "lnxsvr11\." /etc/hosts
    192.168.187.67     lnxsvr11.mydomain.com      lnxsvr11
    [root@lnxsvr11 ~]# grep "lnxsvr11$" /etc/hosts
    192.168.187.67     lnxsvr11.mydomain.com      lnxsvr11

    [root@lnxsvr11 ~]# dig -x 192.168.187.67

    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-16.P1.el5 <<>> -x 192.168.187.67
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 13806
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;67.187.168.192.in-addr.arpa.   IN      PTR

    ;; ANSWER SECTION:
    67.187.168.192.in-addr.arpa. 604800 IN  PTR     lnxsvr11.mydomain.com.

    ;; AUTHORITY SECTION:
    187.168.192.in-addr.arpa. 604800 IN     NS      ns1.mydomain.com.

    ;; ADDITIONAL SECTION:
    ns1.mydomain.com. 604800  IN      A       192.168.184.7

    ;; Query time: 1 msec
    ;; SERVER: 192.168.184.7#53(192.168.184.7)
    ;; WHEN: Tue Aug  7 11:59:35 2012
    ;; MSG SIZE  rcvd: 120

Can anyone see anything obvious that I'm missing?

Thanks,
Matt
0
Matt
8/7/2012 5:23:29 PM
comp.protocols.kerberos 5541 articles. 1 followers. jwinius (31) is leader. Post Follow

0 Replies
555 Views

Similar Articles

[PageSpeed] 31

Reply:

Similar Artilces:

"Key table entry not found while verifying ticket for server"
This is an OpenPGP/MIME signed message (RFC 2440 and 3156) --------------enig07FDE7C699B5FF20AD258797 Content-Type: text/plain; charset=ISO-8859-1 Content-Transfer-Encoding: quoted-printable Just added a new system tonight to our Kerberos realm, and was getting the following error when ksu'ing: "ksu: Key table entry not found while verifying ticket for server" Tried Googling for the error to no avail; what is the meaning of this error and how do I clear it? Best Wishes - Peter --=20 Peter_Losher@isc.org | ISC | OpenPGP 0xE8048D08 | "The bits must flow" -----------...

""""""""""""""""""""""ADD ME""""""""""""""""""""
Hi , Hope you are doing great. Please let me take this opportunity to introduce myself, Iam Karthik working with BhanInfo Inc, a NY based company. We have consultants on our bench on various technologies, my request is to add me to your distribution list and kindly do send me the requirements. i have the below list available 1. Mainframe 2. Java 3.. Financial Analyst 4. Data Architect If there is any vendor ship agreement which has to be signed then I would like to take an opportunity to represent my company and expect your cooperation... We look forward to build a ve...

"@" entries and "" entries not transferring
Hi, primary master: $ORIGIN . $TTL 86400 ; 1 day mydomain.tld IN SOA whatever. admin.whatever. ( 2006072506 ; serial 28800 ; refresh (8 hours) 7200 ; retry (2 hours) 604800 ; expire (1 week) 86400 ; minimum (1 day) ) NS whatever. NS whatever. MX 0 whatever. MX 10 whatever. $ORIGIN mydomain.tld. test A 192.168.0.100 @ A 192.168.0.100 www A 192.168.0.100 A 192.168.0.100 After transferring the zone to the secondary "@" and "" is lost: $ORIGIN . $TTL 86400 ; 1 day mydomain.tld IN SOA whatever. admin.whatever. ( 2006072506 ; serial 28800 ; refresh (8 hours) 7200 ; retry (2 hours) 604800 ; expire (1 week) 86400 ; minimum (1 day) ) NS whatever. NS whatever. MX 0 w...

"""""""""ADD ME""""""""""
Hi , Hope you are doing great. Please let me take this opportunity to introduce myself, Iam Karthik working with BhanInfoi Inc, a NY based company. We have consultants on our bench on various technologies, my request is to add me to your distribution list and kindly do send me the requirements. i have the below list available 1. Mainframe 2. Java 3.. Financial Analyst 4. Data Architect If there is any vendor ship agreement which has to be signed then I would like to take an opportunity to represent my company and expect your cooperation... ...

Urgent Requirement in """""""""""""NEW YORK""""""""""""""""
Hello Partners, Please find the requirement below. Please send the updated resume along with rate and contact no. REQ#1: Title : Java Developer ( Rating Project) Duration : 6 months Rate : open Location : NY strong java, WebLogic 9.2, Web Services, Oracle REQ#2: Title : Java Developer Duration : 4 months Rate : open Location : NY Strong java, SQL REQ#3: Title : VB.Net Consultant Location : NY Duration : 4 months Rate : open Primarily looking at someone who has Excel, VB.net and Oracle (good to have). Req #4: Title : Java Developer (MSA Project) Duration : 6+ months Rate : open Location : NY Note : Please send your updated resume along with contact no karthik@bhaninfo.com : No phone calls please. Thanks & Regards Karthik BhanInfo karthik@bhaninfo.com ...

"/a" is not "/a" ?
Hi everybody, while testing a module today I stumbled on something that I can work around but I don't quite understand. >>> a = "a" >>> b = "a" >>> a == b True >>> a is b True >>> c = "/a" >>> d = "/a" >>> c == d True # all good so far >>> c is d False # eeeeek! Why c and d point to two different objects with an identical string content rather than the same object? Manu Emanuele D'Arrigo wrote: >>>> c = "/a" >>>&...

why "::", not "."
Why does the method of modules use a dot, and the constants a double colon? e.g. Math::PI and Math.cos -- Posted via http://www.ruby-forum.com/. On Oct 26, 2010, at 01:48 , Oleg Igor wrote: > Why does the method of modules use a dot, and the constants a double > colon? > e.g. > Math::PI and Math.cos For the same reason why inner-classes/modules use double colon, because = they're constants and that's how you look up via constant namespace. Math::PI and ActiveRecord::Base are the same type of lookup... it is = just that Base is a module and PI is a float....

"out" and "in out"
Hi i found the following explaination: In Ada, "in" parameters are similar to C++ const parameters. They are effectively read-only within the scope of the called subprogram. Ada "in out" parameters have a reliable initial value (that passed in from the calling subprogram) and may be modified within the scope of the called procedure. Ada "out" parameters have no reliable initial value, but are expected to be assigned a value within the called procedure. What does "have no reliable initial value" mean when considering the "out" parameter? By c...

"my" and "our"
Hi, while testing a program, I erroneously declared the same variable twice within a block, the first time with "my", the second time with "our": { my $fz = 'VTX_Link'; .... ( around 200 lines of code, all in the same block) our $fz = 'VTX_Linkset'; ... } So the initial contents of the $fz declared with "my" is lost, because "our" creates a lexical alias for the global $fz, thus overwriting the previous "my" declaration. It was my error, no question. But I wonder why Perl doesn't mention this - even with "use s...

Re: "@" entries and "" entries not transferring
Addendum: Helmut Schneider (jumper99@gmx.de) wrote: >> Are you sure the A record for @ isn't included in the above batch of >> lines? I presume @ = mydomain.tld, so BIND would have put that above. > > root@mx1:/root# nslookup mydomain.org > Server: 192.168.0.80 > Address: 192.168.0.80#53 > > Non-authoritative answer: > *** Can't find mydomain.org: No answer > > root@mx1:/root# nslookup mydomain.org ns1 > Server: ns1 > Address: 192.168.0.90#53 > > Name: mydomain.org > Address: 192.168.0.100 > > root@mx1:/root# The entries are transferred correctly to my ISP as the provide seondaries, too. -- Please do not feed my mailbox, Swen still does his job well ...

"If then; if then;" and "If then; if;"
I have a raw data set which is a hierarchical file: H 321 s. main st P Mary E 21 F P william m 23 M P Susan K 3 F H 324 S. Main St I use the folowing code to read the data to creat one observation per detail(P) record including hearder record(H): data test; infile 'C:\Documents and Settings\retain.txt'; retain Address; input type $1. @; if type='H' then input @3 Address $12.; if type='P' then input @3 Name $10. @13 Age 3. @16 Gender $1.; run; but the output is not what I want: 1 321 s. main H 2 321 s. main P Mary E 21 F 3 321 s...

"or" and "and"
Hi, I'm just getting to discover ruby, but I find it very nice programming language. I just still don't understand how the "or" and "and" in ruby... I was playing with ruby and for example made a def to print Stem and Leaf plot (for those who didn't have a statistics course or slept on it, e.g. http://cnx.org/content/m10157/latest/) Here is the Beta version of it: class Array def n ; self.size ; end def stem_and_leaf(st = 1) # if st != (2 or 5 or 10) then ; st = 1 ; end k = Hash.new(0) self.each {|x| k[x.to_f] += 1 } k = k.sort{|a, b| a[0].to_f <=&g...

about "++" and "--"
why this program snippet display "8,7,7,8,-7,-8" the program is: main() { int i=8; printf("%d\n%d\n%d\n%d\n%d\n%d\n",++i,--i,i++,i--,-i++,-i--); } > why this program snippet display "8,7,7,8,-7,-8" Ask your compiler-vendor because this result is IMHO implementation-defined. Check this out: http://www.parashift.com/c++-faq-lite/misc-technical-issues.html#faq-39.15 http://www.parashift.com/c++-faq-lite/misc-technical-issues.html#faq-39.16 Regards, Irina Marudina fxc123@gmail.com wrote: > why this program snippet display "8,7,7,8,-7,-8&q...

Urgent Requirement for """""""""""""""INFORMATICA DEVELOPER"""""""""""""
Hello Partners, How are you ? Please find the requirements below. Title: Database/ETL Developer Duration: 6 months Location: NY Exp: 7+ Locals preferred Database/ETL requirements (Mandatory) Candidate must have worked with financial instruments, preferably Mutual Funds but, Equities are also ok. PL/SQL - packages, Stored procs, Functions, Aggregate functions, Pipelined Functions Informatica 8.6 - especially complex mappings, complex maplets, complex workflows, transformations Oracle 10g/11g Unix/Linux shell scripting ...

Urgent need """""""""""INFORMATICA DEVELOPER"""""""""""""
Hello Partners, How are you ? Please find the requirements below. Title: Database/ETL Developer Duration: 6 months Location: NY Exp: 7+ Locals preferred Database/ETL requirements (Mandatory) Candidate must have worked with financial instruments, preferably Mutual Funds but, Equities are also ok. PL/SQL - packages, Stored procs, Functions, Aggregate functions, Pipelined Functions Informatica 8.6 - especially complex mappings, complex maplets, complex workflows, transformations Oracle 10g/11g Unix/Linux shell scripting Database/ETL requirements (Optional) Data warehousing experience Threading and job concepts in 10g/11g Cost based Optimizer concepts in 10g/11g Must : Experience with XML files and partitioning concepts in Oracle, Collections, Material Views Note : No phone calls please. : send Resumes to karthik@bhaninfo.com Thanks & Regards Karthik BhanInfo karthik@bhaninfo.com ...

Does it need a ";" at the very after of "if" and "for"
write code like: int main(void) { int a=10; if(a<20) {} } Compiler ok on dev-cpp . don't we have to add a ";" after if statement? marsarden said: > write code like: > > int main(void) > { > int a=10; > if(a<20) > {} > } > > Compiler ok on dev-cpp . don't we have to add a ";" after if > statement? The syntax for 'if' is: if(expression) statement There is no semicolon after the ) but before the statement. The statement is either a normal statement (which can be empty), ending in a semicolon:- if(expr) ...

"In" "Out" and "Trash"
I just bought a new computer and I re-installed Eudora Light on my new computer. But when I open Eudora, the "In", "Out" and "Trash" links are not on the left side of the screen the way they were on my old computer. How can I get these links back on the left side of the screen? Thank you. On 25 Mar 2007 09:49:22 -0700, "abx" <abfunex@yahoo.com> wrote: >I just bought a new computer and I re-installed Eudora Light on my new >computer. But when I open Eudora, the "In", "Out" and "Trash" links >are ...

A problem about "[ ]" "( )" "="
I want to read several images saved in a director,and give them to I1,I2 ,I3....,using the following codes: filelist=dir(['c:\MATLAB701\work\...\*.jpg']); for i=1 :length(filelist) I=imread(fullfile('c:\MATLAB701\work\...',filelist(i).name)); end; but failed. Then I used I(i)=imread... ,still failed. How could I do? "John" <mailofww@126.com> wrote in message news:ef19e12.-1@webx.raydaftYaTP... >I want to read several images saved in a director,and give them to > I1,I2 ,I3....,using the following codes: > filelist=dir(['c:\MATLAB701\work\.....

Errors: "No current record" and "The search Key was not found in any record"
Hi I get the errors 1) No current record 2) The search Key was not found in any record while deleting data from a table it is a simple delete, as: delete from asd where record_time < 39585 or where record time > 39585 and < 39586 They result in the errors above, in the same order. Data is present in the table. What causes this? On May 29, 11:08=A0am, jodleren <sonn...@hot.ee> wrote: > Hi > > I get the errors > 1) No current record > 2) The search Key was not found in any record > > while deleting data from a table > > it is a simple delete, as: ...

ORA-04031: unable to allocate 2097152 bytes of shared memory ("shared pool","unknown object","hash-join subh","QERHJ Hash Table Entries")
We getting the following error in our database: ORA-04031: unable to allocate 2097152 bytes of shared memory ("shared pool","unknown object","hash-join subh","QERHJ Hash Table Entries")" We have already tried the following: 1. Flushing shared pool 2. Bouncing db Bouncing does resolve the problem temporarily but then it comes back again? Size of the shared pool has been same throughtout but problem has started to appear recently. Any clues anyone? On Thu, 30 Aug 2007 05:55:19 -0000, purohitatul@gmail.com wrote: >We getting the following error...

Another variant of "ssh" working interactively, but "ssh cmd" and "scp" failing
hello, world\n I've read the SSH and OpenSSH FAQ (motd/.profile issue), googled left and right and still could not find a solution to the problem. I've got an embedded box named FOO running OpenSSH_3.7.1p1 on Linux 2.4 on PowerPC, the shell is a busybox, but using bash does not change anything. No PAM. This is the situation: ssh root@FOO -- works ssh root@FOO ls -- fails, no output, no matter what command is given scp file root@FOO: -- fails, "lost connection" Here's the debug output for the client and the server. I have also appended the /etc/ssh/sshd_config....

differences among "ssh", "rlogin" and "telnet"
Hi, what are the differences among "ssh", "rlogin" and "telnet"? Which one is better and when are each of these are recommended to use? Thanks. On Thu, 2 Mar 2006, SolarisUser wrote: > what are the differences among "ssh", "rlogin" and "telnet"? Which one > is better and when are each of these are recommended to use? ssh encrypts traffic, the others don't. SSh should always be used, and there's no reason to use the others these days. -- Rich Teer, SCNA, SCSA, OpenSolaris CAB member President, Rite Online Inc. ...

"for" loop inside "ssh"
Hello, I try to use "ssh" command and run "for" loop in remote server. I mean something like: ssh remote_server -l remote_user "for file in `ls *.sql`; do; echo $file; done" Now I get: file: Undefined variable. OS: Sun Solaris Shell: ksh Thank you. On 2014-03-10, shulamitmi3@gmail.com <shulamitmi3@gmail.com> wrote: > Hello, > > I try to use "ssh" command and run "for" loop in remote server. > > I mean something like: > > ssh remote_server -l remote_user "for file in `ls *.sql`; do...

"value" to find a "key"
Is there such a "Map" in java I can easily trace the key by its value, assuming the values are also unique ? John, John wrote: > > Is there such a "Map" in java I can easily trace the key by its value, > assuming the values are also unique ? Not that I know of. You could always use two Maps, one for name-to-phone and the other for phone-to-name. If you happen to know *for certain* that names and numbers are never alike, you could use a single Map and enter each item twice, once as name-and-phone and once as phone-and-name. -- Eric.Sosman@sun.com ...

Web resources about - ssh gssapi-with-mic and "Key table entry not found" - comp.protocols.kerberos

Come on in...: kerberos
skip to main - skip to sidebar Come on in... Developing for MeeGo, Mer, Maemo and other OSS systems Showing posts with label kerberos . Show ...

RFC 2744 - Generic Security Service API Version 2 : C-bindings
Network Working Group J. WrayRequest for Comments: 2744 Iris AssociatesObsoletes: 1509 January 2000Category: Standards Track Generic Security ...

Kerberos and ssh
skip to main - skip to sidebar Come on in... Developing for MeeGo, Mer, Maemo and other OSS systems Saturday, 22 May 2010 Kerberos and ssh So ...

Come on in...
skip to main - skip to sidebar Come on in... Developing for MeeGo, Mer, Maemo and other OSS systems Showing posts with label kerberos . Show ...

Resources last updated: 3/5/2016 10:58:43 PM