f



error: setsockopt SO_KEEPALIVE: Invalid argument

Hi,

I'm running openssh 3.5p1 Protocol 2 on Solaris 2.6. Our users have 
reported problems with trying to ssh to the box eventhough the sshd is 
running (from inetd). It seems to be OK now, but when I checked the log 
in /var/log/messages I found the following error:

Dec  8 11:32:08 smpl98 sshd[1851]: error: setsockopt SO_KEEPALIVE: 
Invalid argument
Dec  8 11:32:31 smpl98 sshd[28492]: error: setsockopt SO_KEEPALIVE: 
Invalid argument
Dec  8 11:34:49 smpl98 sshd[165]: error: setsockopt SO_KEEPALIVE: 
Invalid argument
Dec  8 11:50:48 smpl98 sshd[4126]: error: setsockopt SO_KEEPALIVE: 
Invalid argument

Does anyone know what causes this problem? Is it related to the 
keepalive option in sshd_config?

Thanks for any help.

JS.

0
vervoom (9)
12/8/2003 3:33:11 PM
comp.security.ssh 4228 articles. 0 followers. terra1024 (490) is leader. Post Follow

0 Replies
1805 Views

Similar Articles

[PageSpeed] 1

Reply:

Similar Artilces:

3146 Error, and Invalid Argument Value error
I have recently upsized a client database to SQL Server. The application is used to book people onto courses at a Conference Centre/Adult Study Centre. It was originally an Access FE/BE, all written by my client. While it's not bad as an "amateur" database, it has all the expected failings of the inexperienced developer (poor table design, queries operating on whole tables, macros running hither and yon mixed with code etc.) The FE resides on a server, and all users (about four or five at most) connect to it. The BE resides on a different server. Recently, the users have be...

ipfw 'table' doens't exist? Gives "ipfw: setsockopt(IP_FW_TABLE_ADD): Invalid argument" Error
Hey, I've recently setup ipfw to attempt to block some of the abusers trying to gain access to my web server and have run into a problem. I was originally using add rules like so: add 600 deny log all from 218.0.0.0/8 to any in add 601 deny log all from 202.0.0.0/7 to any in add 602 deny log all from 219.0.0.0/8 to any in But after reading some information from newsgroups I was told it's best to use a table to deny large amounts of people as it improves efficiency, and was told to setup my ipfw.rules like so: ipfw table 666 add 218.0.0.0/8 ipfw table 666 add 202.0.0.0/7 ipfw table 666 add 219.0.0.0/8 ipfw table 666 add 222.0.0.0/8 ipfw table 666 add 124.0.0.0/8 ipfw add 400 deny ip from table(666) to any However when trying to run this, I get a seres of errors that all repeat the same thing: "ipfw: setsockopt(IP_FW_TABLE_ADD): Invalid argument" Not sure how to resolve this and my extensive Google searches have turned up nothing besides C scripting for ipfw. Any help would be greatly appreciated. Thanks in Advance. Inferno wrote: > ipfw table 666 add 218.0.0.0/8 > ipfw table 666 add 202.0.0.0/7 > ipfw table 666 add 219.0.0.0/8 > ipfw table 666 add 222.0.0.0/8 > ipfw table 666 add 124.0.0.0/8 > ipfw add 400 deny ip from table(666) to any > > However when trying to run this, I get a seres of errors that all > repeat the same thing: > > "ipfw: setsockopt(IP_FW_TABLE_ADD...

Phonon error: libv4l2: error getting pixformat: Invalid argument
Here is my code. I'm just trying to play an mp3 that I've clicked in a PyQT listwidget: @pyqtSlot() def item_clicked(self): row = self.listWidget.currentRow() song = musiclist[row] QCoreApplication.setApplicationName("Phonon") output = Phonon.AudioOutput(Phonon.MusicCategory) m_media = Phonon.MediaObject() Phonon.createPath(m_media, output) m_media.setCurrentSource(Phonon.MediaSource(song)) m_media.play() I'm running OpenSUSE Linux 12.3 Any ideas? Looking in /var/log/messages, eve...

Invalid Argument error on boot
I have a SunFire V210 which is spitting out a "Invalid Argument" error during boot. The error occurs immediately following the "normal" error messages you get when loading the volume manager on Solaris 9: WARNING: forceload of misc/md_trans failed WARNING: forceload of misc/md_raid failed WARNING: forceload of misc/md_hotspares failed Invalid Argument: Operation failed I had recently made a bunch of changes to the security configuration of the system. My guess is I fat-fingered something and didn't catch it. Any tips for finding out exactly where this is occuring?...

Invalid argument error in IE
Hi, I have created two javascript classes in the following way. //Script tag starts here function ClassA(textBoxID, objB) { this.textBox = document.getElementById(textBoxID); this.objB = objB; //some other methods } function ClassB() { this.propertyA = "some value"; //some other methods } var objA = null, objB = null; function body_onLoad() { objB = new ClassB(); objA = new ClassA("aTextBoxID", objB); } //Script tag ends here This approach runs as expected in Firefox but in Internet Explorer, I get a script error "Invalid Argument" at a line numb...

Access Query and Invalid Argument Error
Hi, I have very serious problem with query in Access. I have, in my DB, a lot of forms with some buttons that I use to do query. When I press that buttons and query start I have "Invalid Argument" error because memo field lenght is greater than 128 char. If the type field is memo why I have this error? How I make to resolve this problem? Thanks Mara ...

newbie: insertBefore, Invalid Argument error
Hey I'm trying to use javascript to dynamically add text to the web page. It should work like this: The user tryes to click on a link in the web page. The link executes a javascript method, which checks if a hidden html field has a value. If that hidden field has no value then the javascript should display a message (not using alert, but insert a html element into the code) on the web page telling the user that he need to save the form before clicking on that link.. Below is the approach I've tryed to solve this by... I just posted the code I have problem with... the check if ...

Error: Invalid Procedure call or argument
I run a program which read emails from a text file. There is some thing invalid in one or more text file. When program is busy doing parsing it shows that error and process stop. I dont know which text file has that error. Is it possible that i can handle that error during processing some thing i mean ignore line, email so that my process will not be interrupt. Error: Invalid Procedure call or argument Run time error 5 I want to handle this error by means of skip that line, email or any thing but not to stop the parsing. Might help maybe just a little bit if you let us in on a BIG secret...

mmap() ---- Invalid argument(EINVAL) error ..?
Hi I am using mmap() like this my intension is to allocate (mSize)memory with no memory protection and without file descriptor like this: pBase =(Ptr) mmap(0, mSize,PROT_NONE,MAP_ANONYMOUS,0,0); but I am getting an error Invalid argument(EINVAL). Can anybody give the correct way of doing this? I am using gcc in SOLARIS environment. Thanks, Vinu "Vinu" <vinuwarrier@yahoo.com> writes: >Hi > I am using mmap() like this my intension is to allocate (mSize)memory >with no memory protection and without file descriptor like this: > pBase =(Ptr) mmap(0, mSize,PROT_N...

chown gives error: Invalid argument.
I can change the ownership of files and folder in the users home directory. bash# chown -R arn:root /export/arn/Scripts It report no error. Now I mount a windows partition(fat32 filesystem) on bash# mount -F pcfs /dev/dsk/c0d0p0:C /export/arn/winDocs Then try to change ownership of some files and folders inside that drive(currently mounted). bash# chown ar:root /export/arn/winDocs/Documents/The\ Internet\ resources/Sun\ Solaris/RBAC.PDF chown: /export/arn/winDocs/Documents/The Internet resources/Sun Solaris/RBAC.PDF: Invalid argument Happens for every files and folders there... Why is it invalid argument? ...

CompactDatabase fails with Invalid Argument error
Hello. For years I've been using the DBEngine.CompactDatabase code to make backups of backend databases. But now I've struck a baffling problem where I get an Invalid Argument error. This happens on an XPHome machine with both A97 and A2000 installed. I simplified the code and the error still occurs. In the following new test database containing only this procedure, dbSource refers to a brand new database with no objects which is closed. dbDest does not yet exist. On the last line I get the error message 'Invalid Argument'. The same happens if I leave the dbLangGeneral out. ...

Saving figure error (invalid argument)
I've searched through the newsgroup archives for an answer to my question, and I've read through FAQ 4.12, but I still can't find a solution to my particular issue. I'm trying to automate the saving of a figure as .fig. It is in a loop which changes the figure's filename with each iteration of the loop. Here's the relevant portion of code: figname = sprintf('%s_%s_%s\b\b\b\b', EEG.chanlocs(currChan1).labels, EEG.chanlocs(currChan2).labels, currfile); figname = Fz_Cz_STROOP0037 figure; saveas(gcf, figname, 'fig'); ------ Everything w...

F-Secure SSH Server ERROR
Hi, Any hint what can cause the following error message? F-Secure SSH Server ERROR: Unable to load any hostkeys Public & Private keys are available in the installed directory. I will be thankful to you for your help and fast response. Thanks, //Akg Which Version of F-Secure Server do you use? <it.is.alok@gmail.com> schrieb im Newsbeitrag news:1103545108.948709.5800@c13g2000cwb.googlegroups.com... > Hi, > > Any hint what can cause the following error message? > F-Secure SSH Server ERROR: Unable to load any hostkeys > > Public & Private keys are available in the installed directory. > > I will be thankful to you for your help and fast response. > Thanks, > //Akg > Hi Roger, Thanks for your response. My problem was sloved. Perhaps it was somethng to do with F-secure version as you mentioned. The hostfile format was of newer version but the server was old version server. So even the host file was there but server could not recognized the hostfile format . Thanks a lot for your help. Akg it.is.alok@gmail.com wrote: > Hi, > > Any hint what can cause the following error message? > F-Secure SSH Server ERROR: Unable to load any hostkeys > > Public & Private keys are available in the installed directory. > > I will be thankful to you for your help and fast response. > Thanks, > //Akg ...

stty: : Invalid argument Using SSH
In a script, I was using SSH to run a command on a remote server. I got the message "stty : : invalid argument." It took me a while to figure out why. An interactive shell reads commands from user input on a tty. If you're executing ssh inside a script to run a command on another server, ssh logs into the server as a specific user, and executes the command on the server in a non-interactive shell. Command shells in the sh family execute ~/.profile and ~/.bash_profile once at login, and ~/.kshrc and ~/.bashrc when ever a new shell starts. Command shells in the csh family execute ...

ssh->sudo tcgetattr: Invalid argument
I am responsible for backing up close to 250 servers and workstations. For the servers (mostly debian), I use something like this (where rsyncSend contains: /usr/bin/rsync $*): /usr/bin/ssh -pXXXX -q -x -l backup tobe.backedup.com sudo /var/ backups/rsyncSend ... Recently some CentOS boxes have been thrown into the mix. With the above command, I get: Got remote protocol 1868854643 Fatal error (bad version): sudo: sorry, you must have a tty to run sudo Reading the man page of ssh, I figure it makes sense to add -t to create a tty on the remote system: /usr/bin/ssh -t -pXXXX -q -x -l backup tobe.backedup.com sudo /var/ backups/rsyncSend ... I get the same error, so decide it's a good idea to add a second -t since the ssh is not running from a tty on the local host: /usr/bin/ssh -t -t -pXXXX -q -x -l backup tobe.backedup.com sudo /var/ backups/rsyncSend ... Now I get a new error: Got remote protocol 1701274484 Fatal error (bad version): tcgetattr: Invalid argument I'm stuck at this point. This only happens on the CentOS servers. And it only happens if the command is run from a process without a tty, it works from the command line. I've disabled selinux on both ends. Any ideas? Thanks in advance, James daoist wrote: > I am responsible for backing up close to 250 servers and > workstations. For the servers (mostly debian), I use something like > this (where rsyncSend contains: /usr/bin/rsync $*): > > /usr/bin/ssh -pXXXX -q -x -l back...

MiKTeX 'Invalid argument' error
Please does anyone know the meaning of MiKTeX's 'invalid argument' error. M= y file compiles fine but the DVI viewer reports this error and says its a '= MiKTeX problem'. Acrobat viewer doesn't give this error and displays well. = There is no help forthcoming from the MiKTeX mailing list. I can't find any= error list/glossary in the MiKTeX manual. Please is there an alternative to MiKTeX for Windows OS users? On 18/09/2011 22:21, Ahmed Musa wrote: > Please is there an alternative to MiKTeX for Windows OS users? TL2011 works fine on Windows. -- Joseph Wright ...

why error: "accept: Invalid argument"
when doing fork in a loop: [code] while(1) { tmp_sd = accept(sd, (struct sockaddr*)&tmp_sin, &len); if (tmp_sd == -1) { perror("accept"); exit(0); } //check client ip //fork pid = fork(); switch(pid) { case -1: perror("fork"); break; case 0: _exit(0); ...

ioctl program giving invalid argument error
I am trying to successfully run the following program that I downloaded from the net.I have commented some part.The program compiles and executable is formed fine.But when I give the command line arguments on giving -s option I get the error of invalid argument :- #include <stdio.h> #include <sys/param.h> #include <sys/socket.h> #include <netinet/in.h> #include <arpa/inet.h> #include <sys/ioctl.h> #include <errno.h> #include <netdb.h> //#include "nlist.h" #include <net/if.h> #include <netinet/if_ether.h> e...

iptables
Hello everyone, Why does this entry below result in a iptables error message? iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -j MASQUERADE Results in "iptables: invalid argument" And where might I find any documentation on the error messages for iptables? Thanks Luther martin02 wrote: > Why does this entry below result in a iptables error message? > > iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -j MASQUERADE > > Results in "iptables: invalid argument" > > And where might I find any documentation on the error messages for iptables? On...

error message"invalid argument"
my daughter was sending pics of my grandaughters, i right clicked on them and saved them as a screensaver to look at daily(1st twin grandchildren) now i keep getting invalid argument error and can't do it anymore can someone tell me what to do please........ On Mon, 18 Jun 2007 21:49:26 -0700, jjelswick@yahoo.com wrote: >my daughter was sending pics of my grandaughters, i right clicked on >them and saved them as a screensaver to look at daily(1st twin >grandchildren) now i keep getting invalid argument error and can't do >it anymore can someone tell me what to do please....

access2007 create table error
I've got a 2nd MDB with a table (tblPersonalInfo) and I'm trying to create a linked table strsql is the path to that mdb this works Set db = CurrentDb Set tbl = db.CreateTableDef("tblPersonalInfo." & lngEmpCode, _ dbHiddenObject, _ "tblPersonalInfo", _ strSql) but if I use, dbAttachedODBC, I get an error, invalid argument yet if I use the link table manager to link to the table and I display its attribute property it is set...

Error: Invalid procedure call or argument (5)?
I=92m using A2007 (12.0.6334.5000) SP1 Jet 4.0 SP-8 WinXp SP2 I=92m opening/running a Access 2000 FE.mdb with Access 2007 with Custom Menus (no Ribbons) in legacy mode. I have a Custom Menu Bar, when I select: Tools, Compact and Repair Database=85 It runs: CommandBars("Menu Bar"). _ Controls("Tools"). _ Controls("Database Utilities"). _ Controls("Compact and Repair Database..."). _ AccDoDefaultAction I=92m getting the following error: Microsoft Office Access Error: Invalid procedure call or argument (5) OK This same codehas worked OK for years ...

shelve.open() and error 22: invalid argument
Hi everyone I've come across the following problem: on two different linux machines, both running python 2.5 (r25:51908), I have the same file 'd.dat'. The md5 checksums are the same. Now, on one machine the following code works >>> import shelve >>> d=shelve.open('d.dat') >>> while on the other... Traceback (most recent call last): File "<stdin>", line 1, in <module> File "local/lib/python2.5/shelve.py", line 225, in open return DbfilenameShelf(filename, flag, protocol, writeback) File "local/li...

makeconnection errors: "Invalid argument"
Having a problem I could find nothing on using Google. I'm getting a -lot- of the following errors in my maillog: i43ERpEZ018812: makeconnection (xxxx) failed: Invalid argument xxxx being almost every single mail server I try to send mail to. From one sendmail server to another it'll even do this. It'll fail the first try, and on the second try it'll go through. It doesn't do this with mail that stays on the server, but from the best I can tell (and from numerous test messages) it'll do this with every single outgoing message. Anybody know how I can fix this? Mai...

Web resources about - error: setsockopt SO_KEEPALIVE: Invalid argument - comp.security.ssh

Resources last updated: 3/7/2016 2:04:19 PM