f



[ace-bugs] Re: [ace-users] test program failed on running Static library of ACE 5.3.1 on AMD64 Windows platform

Hi,

Please use the PRF form when asking questions, else we can't help. Are you
using for example normal windows, or the 64bit version.

Regards,

Johnny Willemsen
Remedy IT
Leeghwaterstraat 25
2811 DT Reeuwijk
The Netherlands
www.theaceorb.nl / www.remedy.nl 
  

"Meenakshi Vohra" <Meenakshi.Vohra@veritas.com> wrote in message
news:<032B151E55B43D48ACD6B51922A2A277CB7860@svlxchcln6.enterprise.veritas.c
om>...
> Hi,
> 
> I tried building ACE 5.3.1 on an AMD 64 bit Windows platform. After that I
> tried to run the following test program with static ace release library
> (aces.lib).
> The output was always some junk and debugging gave me a hint that as soon
as
> ::set fn. is called the parameter values become, invalid looks like a
stack
> corruption. 
> 
> I verfied that the library did get built successfully on AMD64 platform by
> doing needed build changes.
> 
> Please suggest,
> Thanks,
> Meenakshi
> 
>  
> #include <stdlib.h>
> #include <stdio.h>
> #include <wchar.h>
> #include <ace/INET_Addr.h>
> 
> int main(int argc, char **argv) {
>   ACE_INET_Addr addr;
> 
>  addr.set(2821, "meenakshi.yahoo.com");
> // addr.set("meenakshi.yahoo.com:2821");
> 
>   printf("port=%d host=%s\n", addr.get_port_number(),
addr.get_host_name());
>   return 0;
> }
> 














0
Johnny
11/26/2004 7:10:43 AM
comp.soft-sys.ace 20326 articles. 1 followers. marlow.andrew (167) is leader. Post Follow

0 Replies
736 Views

Similar Articles

[PageSpeed] 54

Reply: